Merge branch 'master' into f20
Conflicts: fence-agents.spec
This commit is contained in:
commit
bab5272584
1
.gitignore
vendored
1
.gitignore
vendored
@ -22,3 +22,4 @@ fence-agents-3.0.14.tar.bz2
|
||||
/fence-agents-4.0.4.tar.xz
|
||||
/fence-agents-4.0.6.tar.xz
|
||||
/fence-agents-4.0.7.tar.xz
|
||||
/fence-agents-4.0.8.tar.xz
|
||||
|
@ -1,27 +0,0 @@
|
||||
From ff12e705744a4f5a525c7a64cd22ca358a43daaa Mon Sep 17 00:00:00 2001
|
||||
From: Marek 'marx' Grac <mgrac@redhat.com>
|
||||
Date: Mon, 17 Feb 2014 16:49:18 +0100
|
||||
Subject: [PATCH] [build] Remove nss/nspr checks from autoconf
|
||||
|
||||
---
|
||||
configure.ac | 4 ----
|
||||
1 files changed, 0 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 510347e..eaef1d8 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -83,10 +83,6 @@ check_lib_no_libs() {
|
||||
LIBS=$ac_check_lib_save_LIBS
|
||||
}
|
||||
|
||||
-# external libs
|
||||
-PKG_CHECK_MODULES([nss],[nss])
|
||||
-PKG_CHECK_MODULES([nspr],[nspr])
|
||||
-
|
||||
# Checks for header files.
|
||||
AC_CHECK_HEADERS([arpa/inet.h fcntl.h libintl.h limits.h netdb.h stddef.h sys/socket.h sys/time.h syslog.h])
|
||||
|
||||
--
|
||||
1.7.7.6
|
||||
|
@ -1,441 +0,0 @@
|
||||
diff -urN fence-agents-4.0.7.orig/configure fence-agents-4.0.7/configure
|
||||
--- fence-agents-4.0.7.orig/configure 2014-02-17 16:25:34.000000000 +0100
|
||||
+++ fence-agents-4.0.7/configure 2014-02-17 17:03:10.000000000 +0100
|
||||
@@ -1,6 +1,6 @@
|
||||
#! /bin/sh
|
||||
# Guess values for system-dependent variables and create Makefiles.
|
||||
-# Generated by GNU Autoconf 2.68 for fence-agents 4.0.7.
|
||||
+# Generated by GNU Autoconf 2.68 for fence-agents 4.0.7.1.
|
||||
#
|
||||
# Report bugs to <linux-cluster@redhat.com>.
|
||||
#
|
||||
@@ -570,8 +570,8 @@
|
||||
# Identity of this package.
|
||||
PACKAGE_NAME='fence-agents'
|
||||
PACKAGE_TARNAME='fence-agents'
|
||||
-PACKAGE_VERSION='4.0.7'
|
||||
-PACKAGE_STRING='fence-agents 4.0.7'
|
||||
+PACKAGE_VERSION='4.0.7.1'
|
||||
+PACKAGE_STRING='fence-agents 4.0.7.1'
|
||||
PACKAGE_BUGREPORT='linux-cluster@redhat.com'
|
||||
PACKAGE_URL=''
|
||||
|
||||
@@ -629,13 +629,6 @@
|
||||
AMTTOOL_PATH
|
||||
IPMITOOL_PATH
|
||||
LIBOBJS
|
||||
-nspr_LIBS
|
||||
-nspr_CFLAGS
|
||||
-nss_LIBS
|
||||
-nss_CFLAGS
|
||||
-PKG_CONFIG_LIBDIR
|
||||
-PKG_CONFIG_PATH
|
||||
-PKG_CONFIG
|
||||
CXXCPP
|
||||
am__fastdepCXX_FALSE
|
||||
am__fastdepCXX_TRUE
|
||||
@@ -781,14 +774,7 @@
|
||||
CXX
|
||||
CXXFLAGS
|
||||
CCC
|
||||
-CXXCPP
|
||||
-PKG_CONFIG
|
||||
-PKG_CONFIG_PATH
|
||||
-PKG_CONFIG_LIBDIR
|
||||
-nss_CFLAGS
|
||||
-nss_LIBS
|
||||
-nspr_CFLAGS
|
||||
-nspr_LIBS'
|
||||
+CXXCPP'
|
||||
|
||||
|
||||
# Initialize some variables set by options.
|
||||
@@ -1331,7 +1317,7 @@
|
||||
# Omit some internal or obsolete options to make the list less imposing.
|
||||
# This message is too long to be a string in the A/UX 3.1 sh.
|
||||
cat <<_ACEOF
|
||||
-\`configure' configures fence-agents 4.0.7 to adapt to many kinds of systems.
|
||||
+\`configure' configures fence-agents 4.0.7.1 to adapt to many kinds of systems.
|
||||
|
||||
Usage: $0 [OPTION]... [VAR=VALUE]...
|
||||
|
||||
@@ -1401,7 +1387,7 @@
|
||||
|
||||
if test -n "$ac_init_help"; then
|
||||
case $ac_init_help in
|
||||
- short | recursive ) echo "Configuration of fence-agents 4.0.7:";;
|
||||
+ short | recursive ) echo "Configuration of fence-agents 4.0.7.1:";;
|
||||
esac
|
||||
cat <<\_ACEOF
|
||||
|
||||
@@ -1449,15 +1435,6 @@
|
||||
CXX C++ compiler command
|
||||
CXXFLAGS C++ compiler flags
|
||||
CXXCPP C++ preprocessor
|
||||
- PKG_CONFIG path to pkg-config utility
|
||||
- PKG_CONFIG_PATH
|
||||
- directories to add to pkg-config's search path
|
||||
- PKG_CONFIG_LIBDIR
|
||||
- path overriding pkg-config's built-in search path
|
||||
- nss_CFLAGS C compiler flags for nss, overriding pkg-config
|
||||
- nss_LIBS linker flags for nss, overriding pkg-config
|
||||
- nspr_CFLAGS C compiler flags for nspr, overriding pkg-config
|
||||
- nspr_LIBS linker flags for nspr, overriding pkg-config
|
||||
|
||||
Use these variables to override the choices made by `configure' or to help
|
||||
it to find libraries and programs with nonstandard names/locations.
|
||||
@@ -1525,7 +1502,7 @@
|
||||
test -n "$ac_init_help" && exit $ac_status
|
||||
if $ac_init_version; then
|
||||
cat <<\_ACEOF
|
||||
-fence-agents configure 4.0.7
|
||||
+fence-agents configure 4.0.7.1
|
||||
generated by GNU Autoconf 2.68
|
||||
|
||||
Copyright (C) 2010 Free Software Foundation, Inc.
|
||||
@@ -2122,7 +2099,7 @@
|
||||
This file contains any messages produced by compilers while
|
||||
running configure, to aid debugging if configure makes a mistake.
|
||||
|
||||
-It was created by fence-agents $as_me 4.0.7, which was
|
||||
+It was created by fence-agents $as_me 4.0.7.1, which was
|
||||
generated by GNU Autoconf 2.68. Invocation command line was
|
||||
|
||||
$ $0 $@
|
||||
@@ -2938,7 +2915,7 @@
|
||||
|
||||
# Define the identity of the package.
|
||||
PACKAGE='fence-agents'
|
||||
- VERSION='4.0.7'
|
||||
+ VERSION='4.0.7.1'
|
||||
|
||||
|
||||
cat >>confdefs.h <<_ACEOF
|
||||
@@ -16182,309 +16159,6 @@
|
||||
LIBS=$ac_check_lib_save_LIBS
|
||||
}
|
||||
|
||||
-# external libs
|
||||
-
|
||||
-
|
||||
-
|
||||
-
|
||||
-
|
||||
-
|
||||
-if test "x$ac_cv_env_PKG_CONFIG_set" != "xset"; then
|
||||
- if test -n "$ac_tool_prefix"; then
|
||||
- # Extract the first word of "${ac_tool_prefix}pkg-config", so it can be a program name with args.
|
||||
-set dummy ${ac_tool_prefix}pkg-config; ac_word=$2
|
||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
|
||||
-$as_echo_n "checking for $ac_word... " >&6; }
|
||||
-if ${ac_cv_path_PKG_CONFIG+:} false; then :
|
||||
- $as_echo_n "(cached) " >&6
|
||||
-else
|
||||
- case $PKG_CONFIG in
|
||||
- [\\/]* | ?:[\\/]*)
|
||||
- ac_cv_path_PKG_CONFIG="$PKG_CONFIG" # Let the user override the test with a path.
|
||||
- ;;
|
||||
- *)
|
||||
- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
|
||||
-for as_dir in $PATH
|
||||
-do
|
||||
- IFS=$as_save_IFS
|
||||
- test -z "$as_dir" && as_dir=.
|
||||
- for ac_exec_ext in '' $ac_executable_extensions; do
|
||||
- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
|
||||
- ac_cv_path_PKG_CONFIG="$as_dir/$ac_word$ac_exec_ext"
|
||||
- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
|
||||
- break 2
|
||||
- fi
|
||||
-done
|
||||
- done
|
||||
-IFS=$as_save_IFS
|
||||
-
|
||||
- ;;
|
||||
-esac
|
||||
-fi
|
||||
-PKG_CONFIG=$ac_cv_path_PKG_CONFIG
|
||||
-if test -n "$PKG_CONFIG"; then
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $PKG_CONFIG" >&5
|
||||
-$as_echo "$PKG_CONFIG" >&6; }
|
||||
-else
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
-$as_echo "no" >&6; }
|
||||
-fi
|
||||
-
|
||||
-
|
||||
-fi
|
||||
-if test -z "$ac_cv_path_PKG_CONFIG"; then
|
||||
- ac_pt_PKG_CONFIG=$PKG_CONFIG
|
||||
- # Extract the first word of "pkg-config", so it can be a program name with args.
|
||||
-set dummy pkg-config; ac_word=$2
|
||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
|
||||
-$as_echo_n "checking for $ac_word... " >&6; }
|
||||
-if ${ac_cv_path_ac_pt_PKG_CONFIG+:} false; then :
|
||||
- $as_echo_n "(cached) " >&6
|
||||
-else
|
||||
- case $ac_pt_PKG_CONFIG in
|
||||
- [\\/]* | ?:[\\/]*)
|
||||
- ac_cv_path_ac_pt_PKG_CONFIG="$ac_pt_PKG_CONFIG" # Let the user override the test with a path.
|
||||
- ;;
|
||||
- *)
|
||||
- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
|
||||
-for as_dir in $PATH
|
||||
-do
|
||||
- IFS=$as_save_IFS
|
||||
- test -z "$as_dir" && as_dir=.
|
||||
- for ac_exec_ext in '' $ac_executable_extensions; do
|
||||
- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
|
||||
- ac_cv_path_ac_pt_PKG_CONFIG="$as_dir/$ac_word$ac_exec_ext"
|
||||
- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
|
||||
- break 2
|
||||
- fi
|
||||
-done
|
||||
- done
|
||||
-IFS=$as_save_IFS
|
||||
-
|
||||
- ;;
|
||||
-esac
|
||||
-fi
|
||||
-ac_pt_PKG_CONFIG=$ac_cv_path_ac_pt_PKG_CONFIG
|
||||
-if test -n "$ac_pt_PKG_CONFIG"; then
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_pt_PKG_CONFIG" >&5
|
||||
-$as_echo "$ac_pt_PKG_CONFIG" >&6; }
|
||||
-else
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
-$as_echo "no" >&6; }
|
||||
-fi
|
||||
-
|
||||
- if test "x$ac_pt_PKG_CONFIG" = x; then
|
||||
- PKG_CONFIG=""
|
||||
- else
|
||||
- case $cross_compiling:$ac_tool_warned in
|
||||
-yes:)
|
||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: using cross tools not prefixed with host triplet" >&5
|
||||
-$as_echo "$as_me: WARNING: using cross tools not prefixed with host triplet" >&2;}
|
||||
-ac_tool_warned=yes ;;
|
||||
-esac
|
||||
- PKG_CONFIG=$ac_pt_PKG_CONFIG
|
||||
- fi
|
||||
-else
|
||||
- PKG_CONFIG="$ac_cv_path_PKG_CONFIG"
|
||||
-fi
|
||||
-
|
||||
-fi
|
||||
-if test -n "$PKG_CONFIG"; then
|
||||
- _pkg_min_version=0.9.0
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking pkg-config is at least version $_pkg_min_version" >&5
|
||||
-$as_echo_n "checking pkg-config is at least version $_pkg_min_version... " >&6; }
|
||||
- if $PKG_CONFIG --atleast-pkgconfig-version $_pkg_min_version; then
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
||||
-$as_echo "yes" >&6; }
|
||||
- else
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
-$as_echo "no" >&6; }
|
||||
- PKG_CONFIG=""
|
||||
- fi
|
||||
-fi
|
||||
-
|
||||
-pkg_failed=no
|
||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for nss" >&5
|
||||
-$as_echo_n "checking for nss... " >&6; }
|
||||
-
|
||||
-if test -n "$nss_CFLAGS"; then
|
||||
- pkg_cv_nss_CFLAGS="$nss_CFLAGS"
|
||||
- elif test -n "$PKG_CONFIG"; then
|
||||
- if test -n "$PKG_CONFIG" && \
|
||||
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"nss\""; } >&5
|
||||
- ($PKG_CONFIG --exists --print-errors "nss") 2>&5
|
||||
- ac_status=$?
|
||||
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
||||
- test $ac_status = 0; }; then
|
||||
- pkg_cv_nss_CFLAGS=`$PKG_CONFIG --cflags "nss" 2>/dev/null`
|
||||
-else
|
||||
- pkg_failed=yes
|
||||
-fi
|
||||
- else
|
||||
- pkg_failed=untried
|
||||
-fi
|
||||
-if test -n "$nss_LIBS"; then
|
||||
- pkg_cv_nss_LIBS="$nss_LIBS"
|
||||
- elif test -n "$PKG_CONFIG"; then
|
||||
- if test -n "$PKG_CONFIG" && \
|
||||
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"nss\""; } >&5
|
||||
- ($PKG_CONFIG --exists --print-errors "nss") 2>&5
|
||||
- ac_status=$?
|
||||
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
||||
- test $ac_status = 0; }; then
|
||||
- pkg_cv_nss_LIBS=`$PKG_CONFIG --libs "nss" 2>/dev/null`
|
||||
-else
|
||||
- pkg_failed=yes
|
||||
-fi
|
||||
- else
|
||||
- pkg_failed=untried
|
||||
-fi
|
||||
-
|
||||
-
|
||||
-
|
||||
-if test $pkg_failed = yes; then
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
-$as_echo "no" >&6; }
|
||||
-
|
||||
-if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
|
||||
- _pkg_short_errors_supported=yes
|
||||
-else
|
||||
- _pkg_short_errors_supported=no
|
||||
-fi
|
||||
- if test $_pkg_short_errors_supported = yes; then
|
||||
- nss_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "nss" 2>&1`
|
||||
- else
|
||||
- nss_PKG_ERRORS=`$PKG_CONFIG --print-errors "nss" 2>&1`
|
||||
- fi
|
||||
- # Put the nasty error message in config.log where it belongs
|
||||
- echo "$nss_PKG_ERRORS" >&5
|
||||
-
|
||||
- as_fn_error $? "Package requirements (nss) were not met:
|
||||
-
|
||||
-$nss_PKG_ERRORS
|
||||
-
|
||||
-Consider adjusting the PKG_CONFIG_PATH environment variable if you
|
||||
-installed software in a non-standard prefix.
|
||||
-
|
||||
-Alternatively, you may set the environment variables nss_CFLAGS
|
||||
-and nss_LIBS to avoid the need to call pkg-config.
|
||||
-See the pkg-config man page for more details." "$LINENO" 5
|
||||
-
|
||||
-elif test $pkg_failed = untried; then
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
-$as_echo "no" >&6; }
|
||||
- { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
|
||||
-$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
|
||||
-as_fn_error $? "The pkg-config script could not be found or is too old. Make sure it
|
||||
-is in your PATH or set the PKG_CONFIG environment variable to the full
|
||||
-path to pkg-config.
|
||||
-
|
||||
-Alternatively, you may set the environment variables nss_CFLAGS
|
||||
-and nss_LIBS to avoid the need to call pkg-config.
|
||||
-See the pkg-config man page for more details.
|
||||
-
|
||||
-To get pkg-config, see <http://pkg-config.freedesktop.org/>.
|
||||
-See \`config.log' for more details" "$LINENO" 5; }
|
||||
-
|
||||
-else
|
||||
- nss_CFLAGS=$pkg_cv_nss_CFLAGS
|
||||
- nss_LIBS=$pkg_cv_nss_LIBS
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
||||
-$as_echo "yes" >&6; }
|
||||
-
|
||||
-fi
|
||||
-
|
||||
-pkg_failed=no
|
||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for nspr" >&5
|
||||
-$as_echo_n "checking for nspr... " >&6; }
|
||||
-
|
||||
-if test -n "$nspr_CFLAGS"; then
|
||||
- pkg_cv_nspr_CFLAGS="$nspr_CFLAGS"
|
||||
- elif test -n "$PKG_CONFIG"; then
|
||||
- if test -n "$PKG_CONFIG" && \
|
||||
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"nspr\""; } >&5
|
||||
- ($PKG_CONFIG --exists --print-errors "nspr") 2>&5
|
||||
- ac_status=$?
|
||||
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
||||
- test $ac_status = 0; }; then
|
||||
- pkg_cv_nspr_CFLAGS=`$PKG_CONFIG --cflags "nspr" 2>/dev/null`
|
||||
-else
|
||||
- pkg_failed=yes
|
||||
-fi
|
||||
- else
|
||||
- pkg_failed=untried
|
||||
-fi
|
||||
-if test -n "$nspr_LIBS"; then
|
||||
- pkg_cv_nspr_LIBS="$nspr_LIBS"
|
||||
- elif test -n "$PKG_CONFIG"; then
|
||||
- if test -n "$PKG_CONFIG" && \
|
||||
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"nspr\""; } >&5
|
||||
- ($PKG_CONFIG --exists --print-errors "nspr") 2>&5
|
||||
- ac_status=$?
|
||||
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
||||
- test $ac_status = 0; }; then
|
||||
- pkg_cv_nspr_LIBS=`$PKG_CONFIG --libs "nspr" 2>/dev/null`
|
||||
-else
|
||||
- pkg_failed=yes
|
||||
-fi
|
||||
- else
|
||||
- pkg_failed=untried
|
||||
-fi
|
||||
-
|
||||
-
|
||||
-
|
||||
-if test $pkg_failed = yes; then
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
-$as_echo "no" >&6; }
|
||||
-
|
||||
-if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
|
||||
- _pkg_short_errors_supported=yes
|
||||
-else
|
||||
- _pkg_short_errors_supported=no
|
||||
-fi
|
||||
- if test $_pkg_short_errors_supported = yes; then
|
||||
- nspr_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "nspr" 2>&1`
|
||||
- else
|
||||
- nspr_PKG_ERRORS=`$PKG_CONFIG --print-errors "nspr" 2>&1`
|
||||
- fi
|
||||
- # Put the nasty error message in config.log where it belongs
|
||||
- echo "$nspr_PKG_ERRORS" >&5
|
||||
-
|
||||
- as_fn_error $? "Package requirements (nspr) were not met:
|
||||
-
|
||||
-$nspr_PKG_ERRORS
|
||||
-
|
||||
-Consider adjusting the PKG_CONFIG_PATH environment variable if you
|
||||
-installed software in a non-standard prefix.
|
||||
-
|
||||
-Alternatively, you may set the environment variables nspr_CFLAGS
|
||||
-and nspr_LIBS to avoid the need to call pkg-config.
|
||||
-See the pkg-config man page for more details." "$LINENO" 5
|
||||
-
|
||||
-elif test $pkg_failed = untried; then
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
-$as_echo "no" >&6; }
|
||||
- { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
|
||||
-$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
|
||||
-as_fn_error $? "The pkg-config script could not be found or is too old. Make sure it
|
||||
-is in your PATH or set the PKG_CONFIG environment variable to the full
|
||||
-path to pkg-config.
|
||||
-
|
||||
-Alternatively, you may set the environment variables nspr_CFLAGS
|
||||
-and nspr_LIBS to avoid the need to call pkg-config.
|
||||
-See the pkg-config man page for more details.
|
||||
-
|
||||
-To get pkg-config, see <http://pkg-config.freedesktop.org/>.
|
||||
-See \`config.log' for more details" "$LINENO" 5; }
|
||||
-
|
||||
-else
|
||||
- nspr_CFLAGS=$pkg_cv_nspr_CFLAGS
|
||||
- nspr_LIBS=$pkg_cv_nspr_LIBS
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
||||
-$as_echo "yes" >&6; }
|
||||
-
|
||||
-fi
|
||||
-
|
||||
# Checks for header files.
|
||||
for ac_header in arpa/inet.h fcntl.h libintl.h limits.h netdb.h stddef.h sys/socket.h sys/time.h syslog.h
|
||||
do :
|
||||
@@ -17743,7 +17417,7 @@
|
||||
# report actual input values of CONFIG_FILES etc. instead of their
|
||||
# values after options handling.
|
||||
ac_log="
|
||||
-This file was extended by fence-agents $as_me 4.0.7, which was
|
||||
+This file was extended by fence-agents $as_me 4.0.7.1, which was
|
||||
generated by GNU Autoconf 2.68. Invocation command line was
|
||||
|
||||
CONFIG_FILES = $CONFIG_FILES
|
||||
@@ -17809,7 +17483,7 @@
|
||||
cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
|
||||
ac_cs_config="`$as_echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`"
|
||||
ac_cs_version="\\
|
||||
-fence-agents config.status 4.0.7
|
||||
+fence-agents config.status 4.0.7.1
|
||||
configured by $0, generated by GNU Autoconf 2.68,
|
||||
with options \\"\$ac_cs_config\\"
|
||||
|
@ -15,27 +15,19 @@
|
||||
|
||||
Name: fence-agents
|
||||
Summary: Fence Agents for Red Hat Cluster
|
||||
Version: 4.0.7
|
||||
Release: 3%{?alphatag:.%{alphatag}}%{?dist}
|
||||
Version: 4.0.8
|
||||
Release: 1%{?alphatag:.%{alphatag}}%{?dist}
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Group: System Environment/Base
|
||||
URL: http://sourceware.org/cluster/wiki/
|
||||
Source0: https://fedorahosted.org/releases/f/e/fence-agents/%{name}-%{version}.tar.xz
|
||||
Patch0: 0001-build-Remove-nss-nspr-checks-from-autoconf.patch
|
||||
Patch1: 0002-autoconf_rebuild.patch
|
||||
|
||||
%if 0%{?fedora}
|
||||
%global supportedagents alom amt apc apc_snmp bladecenter brocade cisco_mds cisco_ucs drac5 eaton_snmp eps hpblade ibmblade ifmib ilo ilo_mp intelmodular ipdu ipmilan kdump ldom lpar netio ovh rhevm rsa rsb scsi vmware_soap wti
|
||||
%global testagents virsh
|
||||
%global testagents virsh raritan
|
||||
%global allfenceagents fence-agents-alom fence-agents-amt fence-agents-apc fence-agents-apc-snmp fence-agents-bladecenter fence-agents-brocade fence-agents-cisco-mds fence-agents-cisco-ucs fence-agents-drac5 fence-agents-eaton-snmp fence-agents-eps fence-agents-hpblade fence-agents-ibmblade fence-agents-ifmib fence-agents-ilo2 fence-agents-ilo-mp fence-agents-intelmodular fence-agents-ipdu fence-agents-ipmilan fence-agents-kdump fence-agents-ldom fence-agents-lpar fence-agents-netio fence-agents-ovh fence-agents-rhevm fence-agents-rsa fence-agents-rsb fence-agents-scsi fence-agents-vmware-soap fence-agents-wti
|
||||
%endif
|
||||
|
||||
%if 0%{?rhel}
|
||||
%global supportedagents apc apc_snmp bladecenter brocade cisco_mds cisco_ucs drac5 eaton_snmp eps hpblade ibmblade ifmib ilo ilo_mp intelmodular ipdu ipmilan kdump rhevm rsb scsi vmware_soap wti
|
||||
%global testagents virsh
|
||||
%global allfenceagents fence-agents-apc fence-agents-apc-snmp fence-agents-bladecenter fence-agents-brocade fence-agents-cisco-mds fence-agents-cisco-ucs fence-agents-drac5 fence-agents-eaton-snmp fence-agents-eps fence-agents-hpblade fence-agents-ibmblade fence-agents-ifmib fence-agents-ilo2 fence-agents-ilo-mp fence-agents-intelmodular fence-agents-ipdu fence-agents-ipmilan fence-agents-kdump fence-agents-rhevm fence-agents-rsb fence-agents-scsi fence-agents-vmware-soap fence-agents-wti
|
||||
%endif
|
||||
|
||||
## Setup/build bits
|
||||
|
||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
@ -47,14 +39,10 @@ BuildRequires: gnutls-utils
|
||||
BuildRequires: libxslt
|
||||
BuildRequires: python pexpect python-pycurl python-suds
|
||||
BuildRequires: perl(Net::Telnet) net-snmp-utils
|
||||
%if 0%{?fedora}
|
||||
BuildRequires: perl(Pod::MinimumVersion)
|
||||
%endif
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}
|
||||
%patch0 -p1 -b .build1
|
||||
%patch1 -p1 -b .build2
|
||||
|
||||
%build
|
||||
%{configure} --with-agents='%{supportedagents} %{testagents}'
|
||||
@ -463,6 +451,19 @@ Red Hat Fence Agent for OVH hosting provider
|
||||
%{_mandir}/man8/fence_ovh.8*
|
||||
%endif
|
||||
|
||||
%package raritan
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Group: System Environment/Base
|
||||
Summary: Fence agent for Raritan Dominion PX
|
||||
Requires: fence-agents-common
|
||||
Obsoletes: fence-agents
|
||||
%description raritan
|
||||
Red Hat Fence Agent for Raritan Dominion PX
|
||||
%files raritan
|
||||
%defattr(-,root,root,-)
|
||||
%{_sbindir}/fence_raritan
|
||||
%{_mandir}/man8/fence_raritan.8*
|
||||
|
||||
%package rhevm
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Group: System Environment/Base
|
||||
@ -579,6 +580,10 @@ The fence-agents-wti package contains a fence agent for WTI network power switch
|
||||
%{_mandir}/man8/fence_wti.8*
|
||||
|
||||
%changelog
|
||||
* Mon Apr 07 2014 Marek Grac <mgrac@redhat.com> - 4.0.8-1
|
||||
- new upstream release
|
||||
- new package fence-agents-raritan
|
||||
|
||||
* Wed Feb 26 2014 Marek Grac <mgrac@redhat.com> - 4.0.7-3
|
||||
- requires a specific version of fence-agents-common
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user