Auto sync2gitlab import of fence-agents-4.2.1-97.el8.src.rpm
This commit is contained in:
parent
0532b6e439
commit
b8bb674d05
30
bz2072421-2-fence_zvmip-connect-error.patch
Normal file
30
bz2072421-2-fence_zvmip-connect-error.patch
Normal file
@ -0,0 +1,30 @@
|
||||
From 6430104318b4bf349425b08636183bf839812e04 Mon Sep 17 00:00:00 2001
|
||||
From: Oyvind Albrigtsen <oalbrigt@redhat.com>
|
||||
Date: Tue, 31 May 2022 08:55:25 +0200
|
||||
Subject: [PATCH] fence_zvmip: show unable to connect error instead of full
|
||||
stacktrace, e.g. when not using --ssl for SSL devices
|
||||
|
||||
---
|
||||
agents/zvm/fence_zvmip.py | 9 +++++++--
|
||||
1 file changed, 7 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/agents/zvm/fence_zvmip.py b/agents/zvm/fence_zvmip.py
|
||||
index 90ca95d45..4f538e10d 100644
|
||||
--- a/agents/zvm/fence_zvmip.py
|
||||
+++ b/agents/zvm/fence_zvmip.py
|
||||
@@ -127,8 +127,13 @@ def get_list_of_images(options, command, data_as_plug):
|
||||
|
||||
conn.send(packet)
|
||||
|
||||
- request_id = struct.unpack("!i", conn.recv(INT4))[0]
|
||||
- (output_len, request_id, return_code, reason_code) = struct.unpack("!iiii", conn.recv(INT4 * 4))
|
||||
+ try:
|
||||
+ request_id = struct.unpack("!i", conn.recv(INT4))[0]
|
||||
+ (output_len, request_id, return_code, reason_code) = struct.unpack("!iiii", conn.recv(INT4 * 4))
|
||||
+ except struct.error:
|
||||
+ logging.debug(sys.exc_info())
|
||||
+ fail_usage("Failed: Unable to connect to {} port: {} SSL: {} \n".format(options["--ip"], options["--ipport"], bool("--ssl" in options)))
|
||||
+
|
||||
images = set()
|
||||
|
||||
if output_len > 3*INT4:
|
62
bz2091826-fence_ibm_vpc-add-proxy-support.patch
Normal file
62
bz2091826-fence_ibm_vpc-add-proxy-support.patch
Normal file
@ -0,0 +1,62 @@
|
||||
From be409554bbc99df2bba22cb01e8a6df634af896d Mon Sep 17 00:00:00 2001
|
||||
From: Oyvind Albrigtsen <oalbrigt@redhat.com>
|
||||
Date: Tue, 31 May 2022 15:46:40 +0200
|
||||
Subject: [PATCH] fence_ibm_vpc: add proxy support
|
||||
|
||||
---
|
||||
agents/ibm_vpc/fence_ibm_vpc.py | 11 +++++++++++
|
||||
tests/data/metadata/fence_ibm_vpc.xml | 5 +++++
|
||||
2 files changed, 16 insertions(+)
|
||||
|
||||
diff --git a/agents/ibm_vpc/fence_ibm_vpc.py b/agents/ibm_vpc/fence_ibm_vpc.py
|
||||
index 9e38e8301..3da3ce056 100755
|
||||
--- a/agents/ibm_vpc/fence_ibm_vpc.py
|
||||
+++ b/agents/ibm_vpc/fence_ibm_vpc.py
|
||||
@@ -88,6 +88,7 @@ def connect(opt):
|
||||
conn.setopt(pycurl.TIMEOUT, int(opt["--shell-timeout"]))
|
||||
conn.setopt(pycurl.SSL_VERIFYPEER, 1)
|
||||
conn.setopt(pycurl.SSL_VERIFYHOST, 2)
|
||||
+ conn.setopt(pycurl.PROXY, "{}".format(opt["--proxy"]))
|
||||
|
||||
# get bearer token
|
||||
bearer_token = get_bearer_token(conn, opt)
|
||||
@@ -169,6 +170,15 @@ def define_new_opts():
|
||||
"shortdesc" : "Region",
|
||||
"order" : 0
|
||||
}
|
||||
+ all_opt["proxy"] = {
|
||||
+ "getopt" : ":",
|
||||
+ "longopt" : "proxy",
|
||||
+ "help" : "--proxy=[http://<URL>:<PORT>] Proxy: 'http://<URL>:<PORT>'",
|
||||
+ "required" : "0",
|
||||
+ "default": "",
|
||||
+ "shortdesc" : "Network proxy",
|
||||
+ "order" : 0
|
||||
+ }
|
||||
all_opt["limit"] = {
|
||||
"getopt" : ":",
|
||||
"longopt" : "limit",
|
||||
@@ -185,6 +195,7 @@ def main():
|
||||
"apikey",
|
||||
"region",
|
||||
"limit",
|
||||
+ "proxy",
|
||||
"port",
|
||||
"no_password",
|
||||
]
|
||||
diff --git a/tests/data/metadata/fence_ibm_vpc.xml b/tests/data/metadata/fence_ibm_vpc.xml
|
||||
index ee7151673..09da0e303 100644
|
||||
--- a/tests/data/metadata/fence_ibm_vpc.xml
|
||||
+++ b/tests/data/metadata/fence_ibm_vpc.xml
|
||||
@@ -13,6 +13,11 @@
|
||||
<content type="string" default="50" />
|
||||
<shortdesc lang="en">Number of nodes returned by API</shortdesc>
|
||||
</parameter>
|
||||
+ <parameter name="proxy" unique="0" required="0">
|
||||
+ <getopt mixed="--proxy=[http://<URL>:<PORT>]" />
|
||||
+ <content type="string" default="" />
|
||||
+ <shortdesc lang="en">Network proxy</shortdesc>
|
||||
+ </parameter>
|
||||
<parameter name="region" unique="0" required="1">
|
||||
<getopt mixed="--region=[region]" />
|
||||
<content type="string" />
|
@ -87,7 +87,7 @@
|
||||
Name: fence-agents
|
||||
Summary: Set of unified programs capable of host isolation ("fencing")
|
||||
Version: 4.2.1
|
||||
Release: 95%{?alphatag:.%{alphatag}}%{?dist}
|
||||
Release: 97%{?alphatag:.%{alphatag}}%{?dist}
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Group: System Environment/Base
|
||||
URL: https://github.com/ClusterLabs/fence-agents
|
||||
@ -283,11 +283,13 @@ Patch108: bz2048857-fence_aws-botocore-bundled.patch
|
||||
Patch109: bz1886074-1-fencing-source_env.patch
|
||||
Patch110: bz1886074-2-fence_openstack.patch
|
||||
Patch111: bz1886074-3-fence_openstack-bundled.patch
|
||||
Patch112: bz2072421-all-agents-unify-ssl-parameters.patch
|
||||
Patch112: bz2072421-1-all-agents-unify-ssl-parameters.patch
|
||||
Patch113: bz2078244-fence_gce-update.patch
|
||||
Patch114: bz2080994-fence_ibm_vpc-fix-parameters.patch
|
||||
Patch115: bz2080729-1-fence_apc-fence_ilo_moonshot-import-logging.patch
|
||||
Patch116: bz2080729-2-fence_lpar-fix-import-fail_usage.patch
|
||||
Patch117: bz2072421-2-fence_zvmip-connect-error.patch
|
||||
Patch118: bz2091826-fence_ibm_vpc-add-proxy-support.patch
|
||||
|
||||
%if 0%{?fedora} || 0%{?rhel} > 7
|
||||
%global supportedagents amt_ws apc apc_snmp bladecenter brocade cisco_mds cisco_ucs compute drac5 eaton_snmp emerson eps evacuate hds_cb hpblade ibmblade ibm_powervs ibm_vpc ifmib ilo ilo_moonshot ilo_mp ilo_ssh intelmodular ipdu ipmilan kdump kubevirt lpar mpath redfish rhevm rsa rsb sbd scsi vmware_rest vmware_soap wti
|
||||
@ -482,6 +484,8 @@ BuildRequires: python3-google-api-client python3-pip python3-wheel python3-jinja
|
||||
%patch114 -p1
|
||||
%patch115 -p1
|
||||
%patch116 -p1
|
||||
%patch117 -p1
|
||||
%patch118 -p1
|
||||
|
||||
# prevent compilation of something that won't get used anyway
|
||||
sed -i.orig 's|FENCE_ZVM=1|FENCE_ZVM=0|' configure.ac
|
||||
@ -1506,6 +1510,15 @@ Fence agent for IBM z/VM over IP.
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Jun 1 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.2.1-97
|
||||
- fence_ibm_vpc: add proxy support
|
||||
Resolves: rhbz#2091826
|
||||
|
||||
* Tue May 31 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.2.1-96
|
||||
- all agents: unify ssl parameters to avoid having to use --ssl when
|
||||
using --ssl-secure/--ssl-insecure for some agents
|
||||
Resolves: rhbz#2072421
|
||||
|
||||
* Tue May 17 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.2.1-95
|
||||
- fence_apc/fence_ilo_moonshot/fence_lpar: add missing "import logging"
|
||||
Resolves: rhbz#2080729
|
||||
@ -1516,9 +1529,6 @@ Fence agent for IBM z/VM over IP.
|
||||
Resolves: rhbz#2080994
|
||||
|
||||
* Thu Apr 28 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.2.1-93
|
||||
- all agents: unify ssl parameters to avoid having to use --ssl when
|
||||
using --ssl-secure/--ssl-insecure for some agents
|
||||
Resolves: rhbz#2072421
|
||||
- fence_gce: update fence agent
|
||||
Resolves: rhbz#2078244
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user