- fence_azure_arm: add Stack Hub support
Resolves: rhbz#2211460
This commit is contained in:
parent
370371f084
commit
a3675e4fcd
@ -0,0 +1,17 @@
|
||||
--- a/lib/azure_fence.py.py 2023-06-20 16:16:38.525301510 +0200
|
||||
+++ b/lib/azure_fence.py.py 2023-06-20 16:15:52.336508620 +0200
|
||||
@@ -317,12 +317,11 @@
|
||||
from azure.mgmt.compute import ComputeManagementClient
|
||||
|
||||
cloud_environment = get_azure_cloud_environment(config)
|
||||
+ if (config.Cloud.lower() == "stack") and not config.MetadataEndpoint:
|
||||
+ fail_usage("metadata-endpoint not specified")
|
||||
credentials = get_azure_credentials(config)
|
||||
|
||||
if cloud_environment:
|
||||
- if (config.Cloud.lower() == "stack") and not config.MetadataEndpoint:
|
||||
- fail_usage("metadata-endpoint not specified")
|
||||
-
|
||||
compute_client = ComputeManagementClient(
|
||||
credentials,
|
||||
config.SubscriptionId,
|
@ -87,7 +87,7 @@
|
||||
Name: fence-agents
|
||||
Summary: Set of unified programs capable of host isolation ("fencing")
|
||||
Version: 4.2.1
|
||||
Release: 116%{?alphatag:.%{alphatag}}%{?dist}
|
||||
Release: 117%{?alphatag:.%{alphatag}}%{?dist}
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Group: System Environment/Base
|
||||
URL: https://github.com/ClusterLabs/fence-agents
|
||||
@ -271,7 +271,8 @@ Patch128: bz2183158-fence_aws-1-add-skip-race-check-parameter.patch
|
||||
Patch129: bz2183158-fence_aws-2-fail-when-power-action-request-fails.patch
|
||||
Patch130: bz2187329-fence_scsi-1-detect-devices-in-shared-vgs.patch
|
||||
Patch131: bz2187329-fence_scsi-2-support-space-separated-devices.patch
|
||||
Patch132: bz2211460-fence_azure-arm-stack-hub-support.patch
|
||||
Patch132: bz2211460-fence_azure-arm-1-stack-hub-support.patch
|
||||
Patch133: bz2211460-fence_azure-arm-2-metadata-endpoint-error-message.patch
|
||||
|
||||
%if 0%{?fedora} || 0%{?rhel} > 7
|
||||
%global supportedagents amt_ws apc apc_snmp bladecenter brocade cisco_mds cisco_ucs compute drac5 eaton_snmp emerson eps evacuate hds_cb hpblade ibmblade ibm_powervs ibm_vpc ifmib ilo ilo_moonshot ilo_mp ilo_ssh intelmodular ipdu ipmilan kdump kubevirt lpar mpath redfish rhevm rsa rsb sbd scsi vmware_rest vmware_soap wti
|
||||
@ -482,6 +483,7 @@ BuildRequires: python3-google-api-client python3-pip python3-wheel python3-jinja
|
||||
%patch130 -p1
|
||||
%patch131 -p1
|
||||
%patch132 -p1
|
||||
%patch133 -p1
|
||||
|
||||
# prevent compilation of something that won't get used anyway
|
||||
sed -i.orig 's|FENCE_ZVM=1|FENCE_ZVM=0|' configure.ac
|
||||
@ -1479,7 +1481,7 @@ Fence agent for IBM z/VM over IP.
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Jun 20 2023 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.2.1-116
|
||||
* Tue Jun 20 2023 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.2.1-117
|
||||
- fence_azure_arm: add Stack Hub support
|
||||
Resolves: rhbz#2211460
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user