Auto sync2gitlab import of fence-agents-4.2.1-101.el8.src.rpm
This commit is contained in:
parent
ca50c9cc1a
commit
762f3be205
@ -0,0 +1,22 @@
|
||||
From fbca33a536413565108374dd4ed3237b6f7896bd Mon Sep 17 00:00:00 2001
|
||||
From: Oyvind Albrigtsen <oalbrigt@redhat.com>
|
||||
Date: Mon, 15 Aug 2022 10:40:19 +0200
|
||||
Subject: [PATCH] fencing: source_env(): dont process empty lines
|
||||
|
||||
---
|
||||
lib/fencing.py.py | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/lib/fencing.py.py b/lib/fencing.py.py
|
||||
index fc3679e33..940bd01d1 100644
|
||||
--- a/lib/fencing.py.py
|
||||
+++ b/lib/fencing.py.py
|
||||
@@ -1264,7 +1264,7 @@ def source_env(env_file):
|
||||
executable="/bin/sh")
|
||||
# replace env
|
||||
os.environ.clear()
|
||||
- os.environ.update(line.partition('=')[::2] for line in output.decode("utf-8").split('\0'))
|
||||
+ os.environ.update(line.partition('=')[::2] for line in output.decode("utf-8").split('\0') if not re.match("^\s*$", line))
|
||||
|
||||
# Convert array of format [[key1, value1], [key2, value2], ... [keyN, valueN]] to dict, where key is
|
||||
# in format a.b.c.d...z and returned dict has key only z
|
@ -87,7 +87,7 @@
|
||||
Name: fence-agents
|
||||
Summary: Set of unified programs capable of host isolation ("fencing")
|
||||
Version: 4.2.1
|
||||
Release: 100%{?alphatag:.%{alphatag}}%{?dist}
|
||||
Release: 101%{?alphatag:.%{alphatag}}%{?dist}
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Group: System Environment/Base
|
||||
URL: https://github.com/ClusterLabs/fence-agents
|
||||
@ -292,6 +292,7 @@ Patch117: bz2072421-2-fence_zvmip-connect-error.patch
|
||||
Patch118: bz2091826-fence_ibm_vpc-add-proxy-support.patch
|
||||
Patch119: bz2092921-fence_ibm_powervs-proxy-private-api-servers.patch
|
||||
Patch120: bz2033671-fence_sbd-improve-error-handling.patch
|
||||
Patch121: bz1886074-4-fencing-source_env-dont-process-empty-lines.patch
|
||||
|
||||
%if 0%{?fedora} || 0%{?rhel} > 7
|
||||
%global supportedagents amt_ws apc apc_snmp bladecenter brocade cisco_mds cisco_ucs compute drac5 eaton_snmp emerson eps evacuate hds_cb hpblade ibmblade ibm_powervs ibm_vpc ifmib ilo ilo_moonshot ilo_mp ilo_ssh intelmodular ipdu ipmilan kdump kubevirt lpar mpath redfish rhevm rsa rsb sbd scsi vmware_rest vmware_soap wti
|
||||
@ -490,6 +491,7 @@ BuildRequires: python3-google-api-client python3-pip python3-wheel python3-jinja
|
||||
%patch118 -p1
|
||||
%patch119 -p1
|
||||
%patch120 -p1
|
||||
%patch121 -p1
|
||||
|
||||
# prevent compilation of something that won't get used anyway
|
||||
sed -i.orig 's|FENCE_ZVM=1|FENCE_ZVM=0|' configure.ac
|
||||
@ -1514,6 +1516,10 @@ Fence agent for IBM z/VM over IP.
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Aug 15 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.2.1-101
|
||||
- fence_openstack: new fence agent
|
||||
Resolves: rhbz#1886074
|
||||
|
||||
* Mon Aug 1 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.2.1-100
|
||||
- fence_sbd: improve error handling
|
||||
Resolves: rhbz#2033671
|
||||
@ -1549,10 +1555,6 @@ Fence agent for IBM z/VM over IP.
|
||||
- fence_ibm_vpc: new fence agent
|
||||
Resolves: rhbz#1728203
|
||||
|
||||
* Mon Apr 25 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.2.1-91
|
||||
- fence_openstack: new fence agent
|
||||
Resolves: rhbz#1886074
|
||||
|
||||
* Fri Feb 11 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.2.1-88
|
||||
- fence_aws: upgrade botocore to fix IMDSv2 support
|
||||
Resolves: rhbz#2048857
|
||||
|
Loading…
Reference in New Issue
Block a user