Auto sync2gitlab import of fence-agents-4.2.1-111.el8.src.rpm
This commit is contained in:
parent
cc10e2594f
commit
70ebc5b08c
74
bz2152105-fencing-1-add-plug_separator.patch
Normal file
74
bz2152105-fencing-1-add-plug_separator.patch
Normal file
@ -0,0 +1,74 @@
|
||||
From 90ea995038e560222f9345310f31a79b595a5219 Mon Sep 17 00:00:00 2001
|
||||
From: Oyvind Albrigtsen <oalbrigt@redhat.com>
|
||||
Date: Thu, 24 Nov 2022 10:19:29 +0100
|
||||
Subject: [PATCH 1/2] fencing: add plug_separator parameter to be able to
|
||||
specify one that isnt part of the plug name(s)
|
||||
|
||||
---
|
||||
lib/fencing.py.py | 9 ++++++++-
|
||||
1 file changed, 8 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/lib/fencing.py.py b/lib/fencing.py.py
|
||||
index 940bd01d1..cf1c48e78 100644
|
||||
--- a/lib/fencing.py.py
|
||||
+++ b/lib/fencing.py.py
|
||||
@@ -322,6 +322,13 @@
|
||||
"help" : "-6, --inet6-only Forces agent to use IPv6 addresses only",
|
||||
"required" : "0",
|
||||
"order" : 1},
|
||||
+ "plug_separator" : {
|
||||
+ "getopt" : ":",
|
||||
+ "longopt" : "plug-separator",
|
||||
+ "help" : "--plug-separator=[char] Separator for plug parameter when specifying more than 1 plug",
|
||||
+ "default" : ",",
|
||||
+ "required" : "0",
|
||||
+ "order" : 100},
|
||||
"separator" : {
|
||||
"getopt" : "C:",
|
||||
"longopt" : "separator",
|
||||
@@ -934,7 +941,7 @@ def fence_action(connection, options, set_power_fn, get_power_fn, get_outlet_lis
|
||||
|
||||
try:
|
||||
if "--plug" in options:
|
||||
- options["--plugs"] = options["--plug"].split(",")
|
||||
+ options["--plugs"] = options["--plug"].split(options["--plug-separator"])
|
||||
|
||||
## Process options that manipulate fencing device
|
||||
#####
|
||||
|
||||
From 55e2a56b81ed2188dedfce07cc3155e2175183cd Mon Sep 17 00:00:00 2001
|
||||
From: Oyvind Albrigtsen <oalbrigt@redhat.com>
|
||||
Date: Mon, 28 Nov 2022 12:40:00 +0100
|
||||
Subject: [PATCH 2/2] fence_wti: increase login timeout to avoid random
|
||||
timeouts
|
||||
|
||||
---
|
||||
agents/wti/fence_wti.py | 1 +
|
||||
tests/data/metadata/fence_wti.xml | 2 +-
|
||||
2 files changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/agents/wti/fence_wti.py b/agents/wti/fence_wti.py
|
||||
index 68640ae65..97cc66de2 100644
|
||||
--- a/agents/wti/fence_wti.py
|
||||
+++ b/agents/wti/fence_wti.py
|
||||
@@ -178,6 +178,7 @@ def main():
|
||||
atexit.register(atexit_handler)
|
||||
|
||||
all_opt["cmd_prompt"]["default"] = ["RSM>", "MPC>", "IPS>", "TPS>", "NBB>", "NPS>", "VMR>"]
|
||||
+ all_opt["login_timeout"]["default"] = "10"
|
||||
|
||||
options = check_input(device_opt, process_input(device_opt))
|
||||
|
||||
diff --git a/tests/data/metadata/fence_wti.xml b/tests/data/metadata/fence_wti.xml
|
||||
index 6bdccd2dc..8e15f4852 100644
|
||||
--- a/tests/data/metadata/fence_wti.xml
|
||||
+++ b/tests/data/metadata/fence_wti.xml
|
||||
@@ -153,7 +153,7 @@
|
||||
</parameter>
|
||||
<parameter name="login_timeout" unique="0" required="0">
|
||||
<getopt mixed="--login-timeout=[seconds]" />
|
||||
- <content type="second" default="5" />
|
||||
+ <content type="second" default="10" />
|
||||
<shortdesc lang="en">Wait X seconds for cmd prompt after login</shortdesc>
|
||||
</parameter>
|
||||
<parameter name="power_timeout" unique="0" required="0">
|
1212
bz2152105-fencing-2-update-DEPENDENCY_OPT.patch
Normal file
1212
bz2152105-fencing-2-update-DEPENDENCY_OPT.patch
Normal file
File diff suppressed because it is too large
Load Diff
@ -87,7 +87,7 @@
|
||||
Name: fence-agents
|
||||
Summary: Set of unified programs capable of host isolation ("fencing")
|
||||
Version: 4.2.1
|
||||
Release: 110%{?alphatag:.%{alphatag}}%{?dist}
|
||||
Release: 111%{?alphatag:.%{alphatag}}%{?dist}
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Group: System Environment/Base
|
||||
URL: https://github.com/ClusterLabs/fence-agents
|
||||
@ -265,6 +265,8 @@ Patch122: bz2102024-fence_ibm_vpc-add-token-cache-support.patch
|
||||
Patch123: bz2134017-fence_lpar-only-output-additional-info-on-debug.patch
|
||||
Patch124: bz2136076-fence_ibm_powervs-improve-defaults.patch
|
||||
Patch125: bz2160478-fence_scsi-fix-validate-all.patch
|
||||
Patch126: bz2152105-fencing-1-add-plug_separator.patch
|
||||
Patch127: bz2152105-fencing-2-update-DEPENDENCY_OPT.patch
|
||||
|
||||
%if 0%{?fedora} || 0%{?rhel} > 7
|
||||
%global supportedagents amt_ws apc apc_snmp bladecenter brocade cisco_mds cisco_ucs compute drac5 eaton_snmp emerson eps evacuate hds_cb hpblade ibmblade ibm_powervs ibm_vpc ifmib ilo ilo_moonshot ilo_mp ilo_ssh intelmodular ipdu ipmilan kdump kubevirt lpar mpath redfish rhevm rsa rsb sbd scsi vmware_rest vmware_soap wti
|
||||
@ -468,6 +470,8 @@ BuildRequires: python3-google-api-client python3-pip python3-wheel python3-jinja
|
||||
%patch123 -p1
|
||||
%patch124 -p1
|
||||
%patch125 -p1
|
||||
%patch126 -p1
|
||||
%patch127 -p1
|
||||
|
||||
# prevent compilation of something that won't get used anyway
|
||||
sed -i.orig 's|FENCE_ZVM=1|FENCE_ZVM=0|' configure.ac
|
||||
@ -1465,6 +1469,11 @@ Fence agent for IBM z/VM over IP.
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Jan 25 2023 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.2.1-111
|
||||
- fencing/fence_wti: add --plug-separator to be able to avoid
|
||||
characters that are in node name(s)
|
||||
Resolves: rhbz#2152105
|
||||
|
||||
* Fri Jan 13 2023 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.2.1-110
|
||||
- fence_scsi: skip key generation during validate-all action
|
||||
Resolves: rhbz#2160478
|
||||
|
Loading…
Reference in New Issue
Block a user