Auto sync2gitlab import of fence-agents-4.2.1-107.el8.src.rpm
This commit is contained in:
parent
67972e79e5
commit
2f6448fc93
@ -0,0 +1,33 @@
|
|||||||
|
From 46f94d4dbad868afc70b96bd612323221991d06e Mon Sep 17 00:00:00 2001
|
||||||
|
From: Oyvind Albrigtsen <oalbrigt@redhat.com>
|
||||||
|
Date: Tue, 11 Oct 2022 09:51:24 +0200
|
||||||
|
Subject: [PATCH] fence_lpar: only output additional error output on DEBUG
|
||||||
|
level
|
||||||
|
|
||||||
|
Without this patch we get ERROR logged with trace info when doing
|
||||||
|
status-action for nodes that doesnt exist.
|
||||||
|
---
|
||||||
|
agents/lpar/fence_lpar.py | 3 ++-
|
||||||
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/agents/lpar/fence_lpar.py b/agents/lpar/fence_lpar.py
|
||||||
|
index 2046b0e4e..975971a57 100644
|
||||||
|
--- a/agents/lpar/fence_lpar.py
|
||||||
|
+++ b/agents/lpar/fence_lpar.py
|
||||||
|
@@ -12,6 +12,7 @@
|
||||||
|
|
||||||
|
import sys, re
|
||||||
|
import atexit
|
||||||
|
+import logging
|
||||||
|
sys.path.append("@FENCEAGENTSLIBDIR@")
|
||||||
|
from fencing import *
|
||||||
|
from fencing import fail, fail_usage, EC_STATUS_HMC
|
||||||
|
@@ -48,7 +49,7 @@ def get_power_status(conn, options):
|
||||||
|
elif options["--hmc-version"] in ["4", "IVM"]:
|
||||||
|
status = re.compile(",state=(.*?),", re.IGNORECASE).search(conn.before).group(1)
|
||||||
|
except AttributeError as e:
|
||||||
|
- fail_usage("Command on HMC failed: {}\n{}".format(command, str(e)), False)
|
||||||
|
+ logging.debug("Command on HMC failed: {}\n{}".format(command, str(e)))
|
||||||
|
fail(EC_STATUS_HMC)
|
||||||
|
|
||||||
|
return _normalize_status(status)
|
@ -87,7 +87,7 @@
|
|||||||
Name: fence-agents
|
Name: fence-agents
|
||||||
Summary: Set of unified programs capable of host isolation ("fencing")
|
Summary: Set of unified programs capable of host isolation ("fencing")
|
||||||
Version: 4.2.1
|
Version: 4.2.1
|
||||||
Release: 106%{?alphatag:.%{alphatag}}%{?dist}
|
Release: 107%{?alphatag:.%{alphatag}}%{?dist}
|
||||||
License: GPLv2+ and LGPLv2+
|
License: GPLv2+ and LGPLv2+
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
URL: https://github.com/ClusterLabs/fence-agents
|
URL: https://github.com/ClusterLabs/fence-agents
|
||||||
@ -261,6 +261,7 @@ Patch118: bz2092921-fence_ibm_powervs-proxy-private-api-servers.patch
|
|||||||
Patch119: bz1886074-4-fencing-source_env-dont-process-empty-lines.patch
|
Patch119: bz1886074-4-fencing-source_env-dont-process-empty-lines.patch
|
||||||
Patch120: bz1787178-fence_vmware_soap-set-timeout-cleanup-tmp-dirs.patch
|
Patch120: bz1787178-fence_vmware_soap-set-timeout-cleanup-tmp-dirs.patch
|
||||||
Patch121: bz2102024-fence_ibm_vpc-add-token-cache-support.patch
|
Patch121: bz2102024-fence_ibm_vpc-add-token-cache-support.patch
|
||||||
|
Patch122: bz2134017-fence_lpar-only-output-additional-info-on-debug.patch
|
||||||
|
|
||||||
%if 0%{?fedora} || 0%{?rhel} > 7
|
%if 0%{?fedora} || 0%{?rhel} > 7
|
||||||
%global supportedagents amt_ws apc apc_snmp bladecenter brocade cisco_mds cisco_ucs compute drac5 eaton_snmp emerson eps evacuate hds_cb hpblade ibmblade ibm_powervs ibm_vpc ifmib ilo ilo_moonshot ilo_mp ilo_ssh intelmodular ipdu ipmilan kdump kubevirt lpar mpath redfish rhevm rsa rsb sbd scsi vmware_rest vmware_soap wti
|
%global supportedagents amt_ws apc apc_snmp bladecenter brocade cisco_mds cisco_ucs compute drac5 eaton_snmp emerson eps evacuate hds_cb hpblade ibmblade ibm_powervs ibm_vpc ifmib ilo ilo_moonshot ilo_mp ilo_ssh intelmodular ipdu ipmilan kdump kubevirt lpar mpath redfish rhevm rsa rsb sbd scsi vmware_rest vmware_soap wti
|
||||||
@ -460,6 +461,7 @@ BuildRequires: python3-google-api-client python3-pip python3-wheel python3-jinja
|
|||||||
%patch119 -p1
|
%patch119 -p1
|
||||||
%patch120 -p1
|
%patch120 -p1
|
||||||
%patch121 -p1 -F2
|
%patch121 -p1 -F2
|
||||||
|
%patch122 -p1
|
||||||
|
|
||||||
# prevent compilation of something that won't get used anyway
|
# prevent compilation of something that won't get used anyway
|
||||||
sed -i.orig 's|FENCE_ZVM=1|FENCE_ZVM=0|' configure.ac
|
sed -i.orig 's|FENCE_ZVM=1|FENCE_ZVM=0|' configure.ac
|
||||||
@ -1457,6 +1459,10 @@ Fence agent for IBM z/VM over IP.
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Oct 12 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.2.1-107
|
||||||
|
- fence_lpar: only output additional output info on DEBUG level
|
||||||
|
Resolves: rhbz#2134017
|
||||||
|
|
||||||
* Mon Sep 5 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.2.1-106
|
* Mon Sep 5 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.2.1-106
|
||||||
- fence_vmware_soap: set timeout, which should help cleanup tmp dirs
|
- fence_vmware_soap: set timeout, which should help cleanup tmp dirs
|
||||||
Resolves: rhbz#1787178
|
Resolves: rhbz#1787178
|
||||||
|
Loading…
Reference in New Issue
Block a user