import fence-agents-4.2.1-109.el8

This commit is contained in:
CentOS Sources 2022-11-15 04:12:12 +00:00 committed by Stepan Oksanichenko
parent 7d42761f55
commit 1692c51af9
3 changed files with 36 additions and 9 deletions

View File

@ -0,0 +1,23 @@
From 8f71784c66e812f31fdc3e2523bd9abcc5d7cdcb Mon Sep 17 00:00:00 2001
From: Oyvind Albrigtsen <oalbrigt@redhat.com>
Date: Fri, 11 Nov 2022 13:53:24 +0100
Subject: [PATCH] fence_vmware_soap: set default login timeout less than
Pacemakers default timeout to remove tmp dirs
---
agents/vmware_soap/fence_vmware_soap.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/agents/vmware_soap/fence_vmware_soap.py b/agents/vmware_soap/fence_vmware_soap.py
index 51fb0f147..b1d27a9fb 100644
--- a/agents/vmware_soap/fence_vmware_soap.py
+++ b/agents/vmware_soap/fence_vmware_soap.py
@@ -57,7 +57,7 @@ def soap_login(options):
try:
headers = {"Content-Type" : "text/xml;charset=UTF-8", "SOAPAction" : "vim25"}
- login_timeout = int(options["--login-timeout"]) or 60
+ login_timeout = int(options["--login-timeout"]) or 50
conn = Client(url + "/vimService.wsdl", location=url, transport=RequestsTransport(verify=verify), headers=headers, timeout=login_timeout)
mo_ServiceInstance = Property('ServiceInstance')

View File

@ -87,7 +87,7 @@
Name: fence-agents
Summary: Set of unified programs capable of host isolation ("fencing")
Version: 4.2.1
Release: 108%{?alphatag:.%{alphatag}}%{?dist}
Release: 109%{?alphatag:.%{alphatag}}%{?dist}
License: GPLv2+ and LGPLv2+
Group: System Environment/Base
URL: https://github.com/ClusterLabs/fence-agents
@ -259,10 +259,11 @@ Patch116: bz2072421-2-fence_zvmip-connect-error.patch
Patch117: bz2091826-fence_ibm_vpc-add-proxy-support.patch
Patch118: bz2092921-fence_ibm_powervs-proxy-private-api-servers.patch
Patch119: bz1886074-4-fencing-source_env-dont-process-empty-lines.patch
Patch120: bz1787178-fence_vmware_soap-set-timeout-cleanup-tmp-dirs.patch
Patch121: bz2102024-fence_ibm_vpc-add-token-cache-support.patch
Patch122: bz2134017-fence_lpar-only-output-additional-info-on-debug.patch
Patch123: bz2136076-fence_ibm_powervs-improve-defaults.patch
Patch120: bz1787178-1-fence_vmware_soap-set-timeout-cleanup-tmp-dirs.patch
Patch121: bz1787178-2-fence_vmware_soap-login-timeout-50s.patch
Patch122: bz2102024-fence_ibm_vpc-add-token-cache-support.patch
Patch123: bz2134017-fence_lpar-only-output-additional-info-on-debug.patch
Patch124: bz2136076-fence_ibm_powervs-improve-defaults.patch
%if 0%{?fedora} || 0%{?rhel} > 7
%global supportedagents amt_ws apc apc_snmp bladecenter brocade cisco_mds cisco_ucs compute drac5 eaton_snmp emerson eps evacuate hds_cb hpblade ibmblade ibm_powervs ibm_vpc ifmib ilo ilo_moonshot ilo_mp ilo_ssh intelmodular ipdu ipmilan kdump kubevirt lpar mpath redfish rhevm rsa rsb sbd scsi vmware_rest vmware_soap wti
@ -461,9 +462,10 @@ BuildRequires: python3-google-api-client python3-pip python3-wheel python3-jinja
%patch118 -p1
%patch119 -p1
%patch120 -p1
%patch121 -p1 -F2
%patch122 -p1
%patch121 -p1
%patch122 -p1 -F2
%patch123 -p1
%patch124 -p1
# prevent compilation of something that won't get used anyway
sed -i.orig 's|FENCE_ZVM=1|FENCE_ZVM=0|' configure.ac
@ -1461,6 +1463,10 @@ Fence agent for IBM z/VM over IP.
%endif
%changelog
* Fri Nov 11 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.2.1-109
- fence_vmware_soap: set timeout, which should help cleanup tmp dirs
Resolves: rhbz#1787178
* Thu Oct 27 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.2.1-108
- fence_ibm_powervs: improve defaults
Resolves: rhbz#2136076
@ -1470,8 +1476,6 @@ Fence agent for IBM z/VM over IP.
Resolves: rhbz#2134017
* Mon Sep 5 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.2.1-106
- fence_vmware_soap: set timeout, which should help cleanup tmp dirs
Resolves: rhbz#1787178
- fence_ibm_vpc: add token cache support
Resolves: rhbz#2102024