- new upstream release
- new package fence-agents-amt-ws - new package fence-agents-compute - new package fence-agents-drac - new package fence-agents-hds-cb - new package fence-agents-mpath - new package fence-agents-sanbox2 - new package fence-agents-sbd - new package fence-agents-vbox - new package fence-agents-vmware - new package fence-agents-xenapi
This commit is contained in:
parent
fe9396adfe
commit
15ba3df6a7
1
.gitignore
vendored
1
.gitignore
vendored
@ -30,3 +30,4 @@ fence-agents-3.0.14.tar.bz2
|
||||
/fence-agents-4.0.15.tar.xz
|
||||
/fence-agents-4.0.16.tar.xz
|
||||
/fence-agents-4.0.20.tar.xz
|
||||
/fence-agents-4.0.23.tar.xz
|
||||
|
45
0001-Fix-install-issue-for-symlinked-agents.patch
Normal file
45
0001-Fix-install-issue-for-symlinked-agents.patch
Normal file
@ -0,0 +1,45 @@
|
||||
From df5492f2dea1ff880308f6daf7043f3159aa4a89 Mon Sep 17 00:00:00 2001
|
||||
From: Oyvind Albrigtsen <oalbrigt@redhat.com>
|
||||
Date: Tue, 5 Jul 2016 14:33:43 +0200
|
||||
Subject: [PATCH] Fix install issue for symlinked agents
|
||||
|
||||
---
|
||||
make/fencebuild.mk | 25 +++++++++++++++++++++++++
|
||||
1 file changed, 25 insertions(+)
|
||||
|
||||
diff --git a/make/fencebuild.mk b/make/fencebuild.mk
|
||||
index 1d50398..f11aa8a 100644
|
||||
--- a/make/fencebuild.mk
|
||||
+++ b/make/fencebuild.mk
|
||||
@@ -47,3 +47,28 @@ clean: clean-man
|
||||
fi
|
||||
|
||||
clean-local: clean
|
||||
+
|
||||
+install-exec-hook: $(TARGET)
|
||||
+ if [ -n "$(man8dir)" ]; then \
|
||||
+ echo " $(MKDIR_P) '$(DESTDIR)$(man8dir)'"; \
|
||||
+ $(MKDIR_P) "$(DESTDIR)$(man8dir)" || exit 1; \
|
||||
+ fi
|
||||
+ for p in $(TARGET); do \
|
||||
+ dir=`dirname $$p`; \
|
||||
+ for x in `PYTHONPATH=$(abs_srcdir)/lib:$(abs_builddir)/lib $(PYTHON) $$p -o metadata | grep symlink | sed -e "s/.*\(fence.*\)\" .*/\1/g"`; do \
|
||||
+ echo " $(INSTALL_SCRIPT) $$dir/$$x '$(DESTDIR)$(sbindir)'"; \
|
||||
+ $(INSTALL_SCRIPT) $$dir/$$x "$(DESTDIR)$(sbindir)" || exit $$?; \
|
||||
+ echo " $(INSTALL_DATA) '$$dir/$$x.8' '$(DESTDIR)$(man8dir)'"; \
|
||||
+ $(INSTALL_DATA) "$$dir/$$x.8" "$(DESTDIR)$(man8dir)" || exit $$?; \
|
||||
+ done; \
|
||||
+ done
|
||||
+
|
||||
+uninstall-hook: $(TARGET)
|
||||
+ files=`for p in $(TARGET); do \
|
||||
+ for x in \`PYTHONPATH=$(abs_srcdir)/lib:$(abs_builddir)/lib $(PYTHON) $$p -o metadata | grep symlink | sed -e "s/.*\(fence.*\)\" .*/\1/g"\`; do \
|
||||
+ echo " rm -f '$(DESTDIR)$(sbindir)/$$x'"; \
|
||||
+ rm -f "$(DESTDIR)$(sbindir)/$$x"; \
|
||||
+ echo " rm -f '$(DESTDIR)$(man8dir)/$$x.8'"; \
|
||||
+ rm -f "$(DESTDIR)$(man8dir)/$$x.8"; \
|
||||
+ done; \
|
||||
+ done`
|
||||
--
|
||||
2.7.4
|
||||
|
@ -15,17 +15,17 @@
|
||||
|
||||
Name: fence-agents
|
||||
Summary: Fence Agents for Red Hat Cluster
|
||||
Version: 4.0.20
|
||||
Release: 2%{?alphatag:.%{alphatag}}%{?dist}
|
||||
Version: 4.0.23
|
||||
Release: 1%{?alphatag:.%{alphatag}}%{?dist}
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Group: System Environment/Base
|
||||
URL: http://sourceware.org/cluster/wiki/
|
||||
Source0: https://fedorahosted.org/releases/f/e/fence-agents/%{name}-%{version}.tar.xz
|
||||
Patch1: 0001-Fix-install-issue-for-symlinked-agents.patch
|
||||
|
||||
%if 0%{?fedora}
|
||||
%global supportedagents alom amt apc apc_snmp bladecenter brocade cisco_mds cisco_ucs docker drac5 eaton_snmp emerson eps hpblade ibmblade ifmib ilo ilo_mp ilo_ssh ilo_moonshot intelmodular ipdu ipmilan kdump ldom lpar netio ovh pve rhevm rsa rsb scsi vmware_soap wti
|
||||
%global testagents zvm virsh raritan rcd_serial
|
||||
%global allfenceagents fence-agents-alom fence-agents-amt fence-agents-apc fence-agents-apc-snmp fence-agents-bladecenter fence-agents-brocade fence-agents-cisco-mds fence-agents-cisco-ucs fence-agents-docker fence-agents-drac5 fence-agents-eaton-snmp fence-agents-eps fence-agents-hpblade fence-agents-ibmblade fence-agents-ifmib fence-agents-ilo2 fence-agents-ilo-mp fence-agents-ilo-ssh fence-agents-ilo-moonshot fence-agents-intelmodular fence-agents-ipdu fence-agents-ipmilan fence-agents-kdump fence-agents-ldom fence-agents-lpar fence-agents-netio fence-agents-ovh fence-agents-rhevm fence-agents-rsa fence-agents-rsb fence-agents-scsi fence-agents-vmware-soap fence-agents-wti fence-agents-zvm fence-agents-emerson
|
||||
%global allfenceagents fence-agents-alom fence-agents-amt fence-agents-amt-ws fence-agents-apc fence-agents-apc-snmp fence-agents-bladecenter fence-agents-brocade fence-agents-cisco-mds fence-agents-cisco-ucs fence-agents-compute fence-agents-docker fence-agents-drac fence-agents-drac5 fence-agents-eaton-snmp fence-agents-emerson fence-agents-eps fence-agents-hds-cb fence-agents-hpblade fence-agents-ibmblade fence-agents-ifmib fence-agents-ilo2 fence-agents-ilo-mp fence-agents-ilo-ssh fence-agents-ilo-moonshot fence-agents-mpath fence-agents-intelmodular fence-agents-ipdu fence-agents-ipmilan fence-agents-kdump fence-agents-ldom fence-agents-lpar fence-agents-netio fence-agents-ovh fence-agents-rhevm fence-agents-rsa fence-agents-rsb fence-agents-sanbox2 fence-agents-sbd fence-agents-scsi fence-agents-vbox fence-agents-vmware fence-agents-vmware-soap fence-agents-wti fence-agents-xenapi fence-agents-zvm
|
||||
%endif
|
||||
|
||||
## Setup/build bits
|
||||
@ -36,15 +36,16 @@ BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: gnutls-utils
|
||||
BuildRequires: libxslt
|
||||
BuildRequires: python pexpect python-pycurl python-suds python-requests
|
||||
BuildRequires: python-pexpect python-pycurl python-suds python-requests openwsman-python
|
||||
BuildRequires: autoconf automake libtool
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}
|
||||
%autopatch -p1
|
||||
|
||||
%build
|
||||
./autogen.sh
|
||||
%{configure} --with-agents='%{supportedagents} %{testagents}'
|
||||
%{configure}
|
||||
CFLAGS="$(echo '%{optflags}')" make %{_smp_mflags}
|
||||
|
||||
%install
|
||||
@ -71,7 +72,7 @@ power management for several devices.
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Group: System Environment/Base
|
||||
Summary: Common utilities for fence agents
|
||||
Requires: python pexpect
|
||||
Requires: python-pexpect
|
||||
%description common
|
||||
Red Hat Fence Agents is a collection of scripts and libraries to handle remote power management for various devices.
|
||||
%files common
|
||||
@ -81,9 +82,15 @@ Red Hat Fence Agents is a collection of scripts and libraries to handle remote p
|
||||
%{_datadir}/cluster
|
||||
%{_datadir}/fence/fencing.py
|
||||
%{_datadir}/fence/fencing_snmp.py
|
||||
%exclude %{_sbindir}/fence_ack_manual
|
||||
%exclude %{_mandir}/man8/fence_ack_manual.8*
|
||||
%exclude %{_sbindir}/fence_dummy
|
||||
%exclude %{_mandir}/man8/fence_dummy.8*
|
||||
%exclude %{_sbindir}/fence_zvm
|
||||
|
||||
|
||||
%package all
|
||||
License: GPLv2+ and LGPLv2+
|
||||
License: GPLv2+, LGPLv2+ and ASL 2.0
|
||||
Group: System Environment/Base
|
||||
Summary: Fence agents
|
||||
Requires: %{allfenceagents}
|
||||
@ -153,6 +160,19 @@ The fence-agents-amt package contains a fence agent for AMT compatibile devices
|
||||
%{_sbindir}/fence_amt
|
||||
%{_mandir}/man8/fence_amt.8*
|
||||
|
||||
%package amt-ws
|
||||
License: ASL 2.0
|
||||
Group: System Environment/Base
|
||||
Summary: Fence agent for Intel AMT (WS-Man) devices
|
||||
Requires: fence-agents-common >= %{version}-%{release}
|
||||
Requires: openwsman-python
|
||||
Obsoletes: fence-agents
|
||||
%description amt-ws
|
||||
The fence-agents-amt-ws package contains a fence agent for AMT (WS-Man) devices.
|
||||
%files amt-ws
|
||||
%defattr(-,root,root,-)
|
||||
%{_sbindir}/fence_amt_ws
|
||||
%{_mandir}/man8/fence_amt_ws.8*
|
||||
|
||||
%package bladecenter
|
||||
License: GPLv2+ and LGPLv2+
|
||||
@ -200,7 +220,7 @@ The fence-agents-cisco-mds package contains a fence agent for Cisco MDS 9000 ser
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Group: System Environment/Base
|
||||
Summary: Fence agent for Cisco UCS series
|
||||
Requires: pycurl
|
||||
Requires: python-pycurl
|
||||
Requires: fence-agents-common = %{version}-%{release}
|
||||
Obsoletes: fence-agents
|
||||
%description cisco-ucs
|
||||
@ -210,11 +230,25 @@ The fence-agents-cisco-ucs package contains a fence agent for Cisco UCS series d
|
||||
%{_sbindir}/fence_cisco_ucs
|
||||
%{_mandir}/man8/fence_cisco_ucs.8*
|
||||
|
||||
%package compute
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Group: System Environment/Base
|
||||
Summary: Fence agent for Nova compute nodes
|
||||
Requires: python-requests
|
||||
Requires: fence-agents-common = %{version}-%{release}
|
||||
Obsoletes: fence-agents
|
||||
%description compute
|
||||
The fence-agents-compute package contains a fence agent for Nova compute nodes.
|
||||
%files compute
|
||||
%defattr(-,root,root,-)
|
||||
%{_sbindir}/fence_compute
|
||||
%{_mandir}/man8/fence_compute.8*
|
||||
|
||||
%package docker
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Group: System Environment/Base
|
||||
Summary: Fence agent for Docker
|
||||
Requires: pycurl
|
||||
Requires: python-pycurl
|
||||
Requires: fence-agents-common = %{version}-%{release}
|
||||
Obsoletes: fence-agents
|
||||
%description docker
|
||||
@ -224,6 +258,22 @@ The fence-agents-docker package contains a fence agent for Docker images that ar
|
||||
%{_sbindir}/fence_docker
|
||||
%{_mandir}/man8/fence_docker.8*
|
||||
|
||||
%if 0%{?fedora}
|
||||
%package drac
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Group: System Environment/Base
|
||||
Summary: Fence agent for Dell DRAC
|
||||
Requires: telnet
|
||||
Requires: fence-agents-common = %{version}-%{release}
|
||||
Obsoletes: fence-agents
|
||||
%description drac
|
||||
The fence-agents-drac package contains a fence agent for Dell DRAC IV series devices that are accessed via telnet.
|
||||
%files drac
|
||||
%defattr(-,root,root,-)
|
||||
%{_sbindir}/fence_drac
|
||||
%{_mandir}/man8/fence_drac.8*
|
||||
%endif
|
||||
|
||||
%package drac5
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Group: System Environment/Base
|
||||
@ -292,6 +342,22 @@ The fence-agents-hpblade package contains a fence agent for HP BladeSystem devic
|
||||
%{_sbindir}/fence_hpblade
|
||||
%{_mandir}/man8/fence_hpblade.8*
|
||||
|
||||
%if 0%{?fedora}
|
||||
%package hds-cb
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Group: System Environment/Base
|
||||
Summary: Fence agent for Hitachi Compute Blade systems
|
||||
Requires: telnet
|
||||
Requires: fence-agents-common = %{version}-%{release}
|
||||
Obsoletes: fence-agents
|
||||
%description hds-cb
|
||||
The fence-agents-hds-cb package contains a fence agent for Hitachi Compute Blades that are accessed via telnet.
|
||||
%files hds-cb
|
||||
%defattr(-,root,root,-)
|
||||
%{_sbindir}/fence_hds_cb
|
||||
%{_mandir}/man8/fence_hds_cb.8*
|
||||
%endif
|
||||
|
||||
%package ibmblade
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Group: System Environment/Base
|
||||
@ -479,6 +545,20 @@ The fence-agents-lpar package contains a fence agent for IBM LPAR devices that a
|
||||
%{_mandir}/man8/fence_lpar.8*
|
||||
%endif
|
||||
|
||||
%package mpath
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Group: System Environment/Base
|
||||
Summary: Fence agent for reservations over Device Mapper Multipath
|
||||
Requires: device-mapper-multipath
|
||||
Requires: fence-agents-common = %{version}-%{release}
|
||||
Obsoletes: fence-agents
|
||||
%description mpath
|
||||
The fence-agents-mpath package contains fence agent for SCSI persisent reservation over Device Mapper Multipath
|
||||
%files mpath
|
||||
%defattr(-,root,root,-)
|
||||
%{_sbindir}/fence_mpath
|
||||
%{_mandir}/man8/fence_mpath.8*
|
||||
|
||||
%if 0%{?fedora}
|
||||
%package netio
|
||||
License: GPLv2+ and LGPLv2+
|
||||
@ -595,7 +675,7 @@ The fence-agents-rsb package contains a fence agent for Fujitsu RSB devices that
|
||||
%{_sbindir}/fence_rsb
|
||||
%{_mandir}/man8/fence_rsb.8*
|
||||
|
||||
%if 0
|
||||
%if 0%{?fedora}
|
||||
%package sanbox2
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Group: System Environment/Base
|
||||
@ -611,6 +691,22 @@ The fence-agents-sanbox2 package contains a fence agent for QLogic SANBox2 switc
|
||||
%{_mandir}/man8/fence_sanbox2.8*
|
||||
%endif
|
||||
|
||||
%if 0%{?fedora}
|
||||
%package sbd
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Group: System Environment/Base
|
||||
Summary: Fence agent for SBD (storage-based death)
|
||||
Requires: sbd
|
||||
Requires: fence-agents-common = %{version}-%{release}
|
||||
Obsoletes: fence-agents
|
||||
%description sbd
|
||||
The fence-agents-sbd package contains a fence agent for SBD (storage-based death).
|
||||
%files sbd
|
||||
%defattr(-,root,root,-)
|
||||
%{_sbindir}/fence_sbd
|
||||
%{_mandir}/man8/fence_sbd.8*
|
||||
%endif
|
||||
|
||||
%package scsi
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Group: System Environment/Base
|
||||
@ -625,6 +721,22 @@ The fence-agents-scsi package contains fence agent for SCSI persisent reservatio
|
||||
%{_datadir}/cluster/fence_scsi_check
|
||||
%{_mandir}/man8/fence_scsi.8*
|
||||
|
||||
%if 0%{?fedora}
|
||||
%package vbox
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Group: System Environment/Base
|
||||
Summary: Fence agent for VirtualBox
|
||||
Requires: openssh-clients
|
||||
Requires: fence-agents-common = %{version}-%{release}
|
||||
Obsoletes: fence-agents
|
||||
%description vbox
|
||||
The fence-agents-vbox package contains a fence agent for VirtualBox dom0 accessed via SSH.
|
||||
%files vbox
|
||||
%defattr(-,root,root,-)
|
||||
%{_sbindir}/fence_vbox
|
||||
%{_mandir}/man8/fence_vbox.8*
|
||||
%endif
|
||||
|
||||
%package virsh
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Group: System Environment/Base
|
||||
@ -639,6 +751,22 @@ The fence-agents-virsh package contains a fence agent for virtual machines that
|
||||
%{_sbindir}/fence_virsh
|
||||
%{_mandir}/man8/fence_virsh.8*
|
||||
|
||||
%if 0%{?fedora}
|
||||
%package vmware
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Group: System Environment/Base
|
||||
Summary: Fence agent for VMWare with VI Perl Toolkit or vmrun
|
||||
Requires: python-pexpect
|
||||
Requires: fence-agents-common = %{version}-%{release}
|
||||
Obsoletes: fence-agents
|
||||
%description vmware
|
||||
The fence-agents-vmware package contains a fence agent for VMWare accessed with VI Perl Toolkit or vmrun.
|
||||
%files vmware
|
||||
%defattr(-,root,root,-)
|
||||
%{_sbindir}/fence_vmware
|
||||
%{_mandir}/man8/fence_vmware.8*
|
||||
%endif
|
||||
|
||||
%package vmware-soap
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Group: System Environment/Base
|
||||
@ -667,6 +795,22 @@ The fence-agents-wti package contains a fence agent for WTI network power switch
|
||||
%{_sbindir}/fence_wti
|
||||
%{_mandir}/man8/fence_wti.8*
|
||||
|
||||
%if 0%{?fedora}
|
||||
%package xenapi
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Group: System Environment/Base
|
||||
Summary: Fence agent for Citrix XenServer over XenAPI
|
||||
Requires: python-pexpect
|
||||
Requires: fence-agents-common = %{version}-%{release}
|
||||
Obsoletes: fence-agents
|
||||
%description xenapi
|
||||
The fence-agents-xenapi package contains a fence agent for Citrix XenServer accessed over XenAPI.
|
||||
%files xenapi
|
||||
%defattr(-,root,root,-)
|
||||
%{_sbindir}/fence_xenapi
|
||||
%{_mandir}/man8/fence_xenapi.8*
|
||||
%endif
|
||||
|
||||
%package zvm
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Group: System Environment/Base
|
||||
@ -681,10 +825,14 @@ The fence-agents-zvm package contains a fence agent for IBM z/VM over IP.
|
||||
%{_mandir}/man8/fence_zvmip.8*
|
||||
|
||||
%changelog
|
||||
* Thu Jun 30 2016 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.0.23-1
|
||||
- new upstream release
|
||||
- new package fence-agents-amt-ws
|
||||
|
||||
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.20-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Thu Aug 11 2015 Marek Grac <mgrac@redhat.com> - 4.0.20-1
|
||||
* Tue Aug 11 2015 Marek Grac <mgrac@redhat.com> - 4.0.20-1
|
||||
- new upstream release
|
||||
- new package fence-agents-rcd-serial
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user