- fence_vmware_soap: set timeout, which should help cleanup tmp dirs
Resolves: rhbz#2122944
This commit is contained in:
parent
d9b26bb6c4
commit
1466cc3ffa
23
bz2122944-2-fence_vmware_soap-login-timeout-50s.patch
Normal file
23
bz2122944-2-fence_vmware_soap-login-timeout-50s.patch
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
From 8f71784c66e812f31fdc3e2523bd9abcc5d7cdcb Mon Sep 17 00:00:00 2001
|
||||||
|
From: Oyvind Albrigtsen <oalbrigt@redhat.com>
|
||||||
|
Date: Fri, 11 Nov 2022 13:53:24 +0100
|
||||||
|
Subject: [PATCH] fence_vmware_soap: set default login timeout less than
|
||||||
|
Pacemakers default timeout to remove tmp dirs
|
||||||
|
|
||||||
|
---
|
||||||
|
agents/vmware_soap/fence_vmware_soap.py | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/agents/vmware_soap/fence_vmware_soap.py b/agents/vmware_soap/fence_vmware_soap.py
|
||||||
|
index 51fb0f147..b1d27a9fb 100644
|
||||||
|
--- a/agents/vmware_soap/fence_vmware_soap.py
|
||||||
|
+++ b/agents/vmware_soap/fence_vmware_soap.py
|
||||||
|
@@ -57,7 +57,7 @@ def soap_login(options):
|
||||||
|
|
||||||
|
try:
|
||||||
|
headers = {"Content-Type" : "text/xml;charset=UTF-8", "SOAPAction" : "vim25"}
|
||||||
|
- login_timeout = int(options["--login-timeout"]) or 60
|
||||||
|
+ login_timeout = int(options["--login-timeout"]) or 50
|
||||||
|
conn = Client(url + "/vimService.wsdl", location=url, transport=RequestsTransport(verify=verify), headers=headers, timeout=login_timeout)
|
||||||
|
|
||||||
|
mo_ServiceInstance = Property('ServiceInstance')
|
@ -60,7 +60,7 @@
|
|||||||
Name: fence-agents
|
Name: fence-agents
|
||||||
Summary: Set of unified programs capable of host isolation ("fencing")
|
Summary: Set of unified programs capable of host isolation ("fencing")
|
||||||
Version: 4.10.0
|
Version: 4.10.0
|
||||||
Release: 37%{?alphatag:.%{alphatag}}%{?dist}
|
Release: 38%{?alphatag:.%{alphatag}}%{?dist}
|
||||||
License: GPLv2+ and LGPLv2+
|
License: GPLv2+ and LGPLv2+
|
||||||
URL: https://github.com/ClusterLabs/fence-agents
|
URL: https://github.com/ClusterLabs/fence-agents
|
||||||
Source0: https://fedorahosted.org/releases/f/e/fence-agents/%{name}-%{version}.tar.gz
|
Source0: https://fedorahosted.org/releases/f/e/fence-agents/%{name}-%{version}.tar.gz
|
||||||
@ -219,12 +219,13 @@ Patch24: bz2072420-2-fence_zvmip-connect-error.patch
|
|||||||
Patch25: bz2092385-fence_ibm_vpc-add-proxy-support.patch
|
Patch25: bz2092385-fence_ibm_vpc-add-proxy-support.patch
|
||||||
Patch26: bz2093216-fence_ibm_powervs-proxy-private-api-servers.patch
|
Patch26: bz2093216-fence_ibm_powervs-proxy-private-api-servers.patch
|
||||||
Patch27: bz2041933-bz2041935-3-fencing-source_env-dont-process-empty-lines.patch
|
Patch27: bz2041933-bz2041935-3-fencing-source_env-dont-process-empty-lines.patch
|
||||||
Patch28: bz2122944-fence_vmware_soap-set-timeout-cleanup-tmp-dirs.patch
|
Patch28: bz2122944-1-fence_vmware_soap-set-timeout-cleanup-tmp-dirs.patch
|
||||||
Patch29: bz2111998-fence_ibm_vpc-add-token-cache-support.patch
|
Patch29: bz2122944-2-fence_vmware_soap-login-timeout-50s.patch
|
||||||
Patch30: bz2132008-fence_virt-add-note-reboot-action.patch
|
Patch30: bz2111998-fence_ibm_vpc-add-token-cache-support.patch
|
||||||
Patch31: bz2134015-fence_lpar-only-output-additional-info-on-debug.patch
|
Patch31: bz2132008-fence_virt-add-note-reboot-action.patch
|
||||||
Patch32: bz2136191-fence_ibm_powervs-improve-defaults.patch
|
Patch32: bz2134015-fence_lpar-only-output-additional-info-on-debug.patch
|
||||||
Patch33: bz2138823-fence_virtd-update-manpage.patch
|
Patch33: bz2136191-fence_ibm_powervs-improve-defaults.patch
|
||||||
|
Patch34: bz2138823-fence_virtd-update-manpage.patch
|
||||||
|
|
||||||
%global supportedagents amt_ws apc apc_snmp bladecenter brocade cisco_mds cisco_ucs compute drac5 eaton_snmp emerson eps evacuate hpblade ibmblade ibm_powervs ibm_vpc ifmib ilo ilo_moonshot ilo_mp ilo_ssh intelmodular ipdu ipmilan kdump kubevirt lpar mpath redfish rhevm rsa rsb sbd scsi vmware_rest vmware_soap wti
|
%global supportedagents amt_ws apc apc_snmp bladecenter brocade cisco_mds cisco_ucs compute drac5 eaton_snmp emerson eps evacuate hpblade ibmblade ibm_powervs ibm_vpc ifmib ilo ilo_moonshot ilo_mp ilo_ssh intelmodular ipdu ipmilan kdump kubevirt lpar mpath redfish rhevm rsa rsb sbd scsi vmware_rest vmware_soap wti
|
||||||
%ifarch x86_64
|
%ifarch x86_64
|
||||||
@ -369,6 +370,7 @@ BuildRequires: %{systemd_units}
|
|||||||
%patch31 -p1
|
%patch31 -p1
|
||||||
%patch32 -p1
|
%patch32 -p1
|
||||||
%patch33 -p1
|
%patch33 -p1
|
||||||
|
%patch34 -p1
|
||||||
|
|
||||||
# prevent compilation of something that won't get used anyway
|
# prevent compilation of something that won't get used anyway
|
||||||
sed -i.orig 's|FENCE_ZVM=1|FENCE_ZVM=0|' configure.ac
|
sed -i.orig 's|FENCE_ZVM=1|FENCE_ZVM=0|' configure.ac
|
||||||
@ -1435,6 +1437,10 @@ are located on corosync cluster nodes.
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Nov 11 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.10.0-38
|
||||||
|
- fence_vmware_soap: set timeout, which should help cleanup tmp dirs
|
||||||
|
Resolves: rhbz#2122944
|
||||||
|
|
||||||
* Tue Nov 8 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.10.0-37
|
* Tue Nov 8 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.10.0-37
|
||||||
- Upgrade bundled python-oauthlib
|
- Upgrade bundled python-oauthlib
|
||||||
Resolves: rhbz#2128564
|
Resolves: rhbz#2128564
|
||||||
@ -1462,8 +1468,6 @@ are located on corosync cluster nodes.
|
|||||||
Resolves: rhbz#2121546
|
Resolves: rhbz#2121546
|
||||||
|
|
||||||
* Tue Aug 16 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.10.0-31
|
* Tue Aug 16 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.10.0-31
|
||||||
- fence_vmware_soap: set timeout, which should help cleanup tmp dirs
|
|
||||||
Resolves: rhbz#2122944
|
|
||||||
- fence_ibm_vpc: add token cache support
|
- fence_ibm_vpc: add token cache support
|
||||||
Resolves: rhbz#2111998
|
Resolves: rhbz#2111998
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user