import fence-agents-4.2.1-75.el8_5.2
This commit is contained in:
parent
f22138bf39
commit
0f3c18702a
@ -1,5 +1,19 @@
|
||||
0a56f6d9ed2014a363486d33b63eca094379be06 SOURCES/aliyun-python-sdk-core-2.13.1.tar.gz
|
||||
c2a98b9a1562d223a76514f05028488ca000c395 SOURCES/aliyun-python-sdk-ecs-4.9.3.tar.gz
|
||||
f14647a4d37a9a254c4e711b95a7654fc418e41e SOURCES/aliyun-python-sdk-vpc-3.0.2.tar.gz
|
||||
2512ff4ef016cad0b916006f6acf2a309f908c4d SOURCES/botocore-1.23.46.tar.gz
|
||||
b13e22d55867e2ca5f92e5289cfdc21ba6e343aa SOURCES/certifi-2021.10.8.tar.gz
|
||||
2384f6cfba4685d901262e073a4455d4cf76d102 SOURCES/chardet-4.0.0.tar.gz
|
||||
865df92e66e5dc7b940144cbad8115c07dc8784f SOURCES/charset-normalizer-2.0.7.tar.gz
|
||||
e2561df8e7ff9113dab118a651371dd88dab0142 SOURCES/fence-agents-4.2.1.tar.gz
|
||||
08c0449533fc94462f78652dea209099754d9ee4 SOURCES/idna-3.3.tar.gz
|
||||
356c48dfea2214dd9e7e2b222a99dddfe9c0d05c SOURCES/jmespath-0.10.0.tar.gz
|
||||
bccbc1bf76a9db46998eb8e1ffa2f2a2baf9237a SOURCES/packaging-21.2-py3-none-any.whl
|
||||
326a73f58a62ebee00c11a12cfdd838b196e0e8e SOURCES/pycryptodome-3.6.4.tar.gz
|
||||
c8307f47e3b75a2d02af72982a2dfefa3f56e407 SOURCES/pyparsing-2.4.7-py2.py3-none-any.whl
|
||||
c2ba10c775b7a52a4b57cac4d4110a0c0f812a82 SOURCES/python-dateutil-2.8.2.tar.gz
|
||||
8c7a89d183d3e9b70bf91ba5b75eccf7111b9d8d SOURCES/requests-2.26.0.tar.gz
|
||||
a4f02fddae697614e356cadfddb6241cc7737f38 SOURCES/setuptools_scm-6.3.2.tar.gz
|
||||
06fa0bb50f2a4e2917fd14c21e9d2d5508ce0163 SOURCES/six-1.16.0.tar.gz
|
||||
b42b7960047441db7dc021cc20e14279bd836f8d SOURCES/tomli-1.0.1.tar.gz
|
||||
eb35c3fd8b0867ae988a15917d6b80e8bdf60222 SOURCES/urllib3-1.26.7.tar.gz
|
||||
|
14
.gitignore
vendored
14
.gitignore
vendored
@ -1,5 +1,19 @@
|
||||
SOURCES/aliyun-python-sdk-core-2.13.1.tar.gz
|
||||
SOURCES/aliyun-python-sdk-ecs-4.9.3.tar.gz
|
||||
SOURCES/aliyun-python-sdk-vpc-3.0.2.tar.gz
|
||||
SOURCES/botocore-1.23.46.tar.gz
|
||||
SOURCES/certifi-2021.10.8.tar.gz
|
||||
SOURCES/chardet-4.0.0.tar.gz
|
||||
SOURCES/charset-normalizer-2.0.7.tar.gz
|
||||
SOURCES/fence-agents-4.2.1.tar.gz
|
||||
SOURCES/idna-3.3.tar.gz
|
||||
SOURCES/jmespath-0.10.0.tar.gz
|
||||
SOURCES/packaging-21.2-py3-none-any.whl
|
||||
SOURCES/pycryptodome-3.6.4.tar.gz
|
||||
SOURCES/pyparsing-2.4.7-py2.py3-none-any.whl
|
||||
SOURCES/python-dateutil-2.8.2.tar.gz
|
||||
SOURCES/requests-2.26.0.tar.gz
|
||||
SOURCES/setuptools_scm-6.3.2.tar.gz
|
||||
SOURCES/six-1.16.0.tar.gz
|
||||
SOURCES/tomli-1.0.1.tar.gz
|
||||
SOURCES/urllib3-1.26.7.tar.gz
|
||||
|
11
SOURCES/bz2052627-fence_aws-botocore-bundled.patch
Normal file
11
SOURCES/bz2052627-fence_aws-botocore-bundled.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- a/agents/aws/fence_aws.py 2022-02-09 10:51:19.579385154 +0100
|
||||
+++ b/agents/aws/fence_aws.py 2022-02-09 10:51:47.148478185 +0100
|
||||
@@ -7,6 +7,8 @@
|
||||
from fencing import *
|
||||
from fencing import fail, fail_usage, run_delay, EC_STATUS, SyslogLibHandler
|
||||
|
||||
+sys.path.insert(0, '/usr/lib/fence-agents/bundled/aws')
|
||||
+
|
||||
import requests
|
||||
import boto3
|
||||
from requests import HTTPError
|
@ -25,11 +25,32 @@
|
||||
%global aliyunsdkvpc aliyun-python-sdk-vpc
|
||||
%global aliyunsdkvpc_version 3.0.2
|
||||
%global aliyunsdkvpc_dir %{bundled_lib_dir}/aliyun/%{aliyunsdkvpc}
|
||||
# aws
|
||||
%global botocore botocore
|
||||
%global botocore_version 1.23.46
|
||||
%global urllib3 urllib3
|
||||
%global urllib3_version 1.26.7
|
||||
%global requests requests
|
||||
%global requests_version 2.26.0
|
||||
%global certifi certifi
|
||||
%global certifi_version 2021.10.8
|
||||
%global chrstnormalizer charset-normalizer
|
||||
%global chrstnormalizer_version 2.0.7
|
||||
%global idna idna
|
||||
%global idna_version 3.3
|
||||
%global chardet chardet
|
||||
%global chardet_version 4.0.0
|
||||
%global dateutil dateutil
|
||||
%global dateutil_version 2.8.2
|
||||
%global six six
|
||||
%global six_version 1.16.0
|
||||
%global jmespath jmespath
|
||||
%global jmespath_version 0.10.0
|
||||
|
||||
Name: fence-agents
|
||||
Summary: Set of unified programs capable of host isolation ("fencing")
|
||||
Version: 4.2.1
|
||||
Release: 75%{?alphatag:.%{alphatag}}%{?dist}
|
||||
Release: 75%{?alphatag:.%{alphatag}}%{?dist}.2
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Group: System Environment/Base
|
||||
URL: https://github.com/ClusterLabs/fence-agents
|
||||
@ -38,6 +59,22 @@ Source1: %{pycryptodome}-%{pycryptodome_version}.tar.gz
|
||||
Source2: %{aliyunsdkcore}-%{aliyunsdkcore_version}.tar.gz
|
||||
Source3: %{aliyunsdkecs}-%{aliyunsdkecs_version}.tar.gz
|
||||
Source4: %{aliyunsdkvpc}-%{aliyunsdkvpc_version}.tar.gz
|
||||
# aws
|
||||
Source5: %{botocore}-%{botocore_version}.tar.gz
|
||||
Source6: %{urllib3}-%{urllib3_version}.tar.gz
|
||||
Source7: %{requests}-%{requests_version}.tar.gz
|
||||
Source8: %{certifi}-%{certifi_version}.tar.gz
|
||||
Source9: %{chrstnormalizer}-%{chrstnormalizer_version}.tar.gz
|
||||
Source10: %{idna}-%{idna_version}.tar.gz
|
||||
Source11: %{chardet}-%{chardet_version}.tar.gz
|
||||
Source12: python-%{dateutil}-%{dateutil_version}.tar.gz
|
||||
Source13: %{six}-%{six_version}.tar.gz
|
||||
Source14: %{jmespath}-%{jmespath_version}.tar.gz
|
||||
## for build process only
|
||||
Source15: setuptools_scm-6.3.2.tar.gz
|
||||
Source16: packaging-21.2-py3-none-any.whl
|
||||
Source17: pyparsing-2.4.7-py2.py3-none-any.whl
|
||||
Source18: tomli-1.0.1.tar.gz
|
||||
Patch0: fence_impilan-fence_ilo_ssh-add-ilo5-support.patch
|
||||
Patch1: fence_mpath-watchdog-support.patch
|
||||
Patch2: fence_ilo3-fence_ipmilan-show-correct-default-method.patch
|
||||
@ -132,6 +169,7 @@ Patch90: bz1920947-fence_redfish-2-add-diag-action-logic.patch
|
||||
Patch91: bz1920947-fence_redfish-3-fix-typo.patch
|
||||
Patch92: bz1922437-fence_mpath-watchdog-retry-support.patch
|
||||
Patch93: bz1685814-fence_gce-add-serviceaccount-file-support.patch
|
||||
Patch94: bz2052627-fence_aws-botocore-bundled.patch
|
||||
|
||||
%if 0%{?fedora} || 0%{?rhel} > 7
|
||||
%global supportedagents amt_ws apc apc_snmp bladecenter brocade cisco_mds cisco_ucs compute drac5 eaton_snmp emerson eps evacuate hds_cb hpblade ibmblade ifmib ilo ilo_moonshot ilo_mp ilo_ssh intelmodular ipdu ipmilan kdump lpar mpath redfish rhevm rsa rsb sbd scsi vmware_rest vmware_soap wti
|
||||
@ -200,7 +238,7 @@ BuildRequires: gnutls-utils
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: python3-pexpect python3-pycurl python3-requests
|
||||
BuildRequires: python3-suds openwsman-python3 python3-boto3
|
||||
BuildRequires: python3-google-api-client
|
||||
BuildRequires: python3-google-api-client python3-pip
|
||||
|
||||
# turn off the brp-python-bytecompile script
|
||||
# (for F28+ or equivalent, the latter is the preferred form)
|
||||
@ -303,6 +341,7 @@ BuildRequires: python3-google-api-client
|
||||
%patch91 -p1
|
||||
%patch92 -p1
|
||||
%patch93 -p1
|
||||
%patch94 -p1
|
||||
|
||||
# prevent compilation of something that won't get used anyway
|
||||
sed -i.orig 's|FENCE_ZVM=1|FENCE_ZVM=0|' configure.ac
|
||||
@ -388,6 +427,14 @@ pushd %{aliyunsdkvpc_dir}
|
||||
popd
|
||||
%endif
|
||||
|
||||
# aws
|
||||
%ifarch x86_64
|
||||
%{__python3} -m pip install --user --no-index --find-links %{_sourcedir} setuptools-scm
|
||||
%{__python3} -m pip install --user --no-index --find-links %{_sourcedir} jmespath
|
||||
%{__python3} -m pip install --target %{buildroot}/usr/lib/fence-agents/%{bundled_lib_dir}/aws --no-index --find-links %{_sourcedir} botocore
|
||||
%{__python3} -m pip install --target %{buildroot}/usr/lib/fence-agents/%{bundled_lib_dir}/aws --no-index --find-links %{_sourcedir} requests
|
||||
%endif
|
||||
|
||||
## tree fix up
|
||||
# fix libfence permissions
|
||||
chmod 0755 %{buildroot}%{_datadir}/fence/*.py
|
||||
@ -538,6 +585,16 @@ Group: System Environment/Base
|
||||
Summary: Fence agent for Amazon AWS
|
||||
Requires: fence-agents-common >= %{version}-%{release}
|
||||
Requires: python3-boto3
|
||||
Provides: bundled(python3-%{botocore}) = %{botocore_version}
|
||||
Provides: bundled(python3-%{urllib3}) = %{urllib3_version}
|
||||
Provides: bundled(python3-%{requests}) = %{requests_version}
|
||||
Provides: bundled(python3-%{certifi}) = %{certifi_version}
|
||||
Provides: bundled(python3-%{chrstnormalizer}) = %{chrstnormalizer_version}
|
||||
Provides: bundled(python3-%{idna}) = %{idna_version}
|
||||
Provides: bundled(python3-%{chardet}) = %{chardet_version}
|
||||
Provides: bundled(python3-%{dateutil}) = %{dateutil_version}
|
||||
Provides: bundled(python3-%{six}) = %{six_version}
|
||||
Provides: bundled(python3-%{jmespath}) = %{jmespath_version}
|
||||
Obsoletes: %{name} < %{version}-%{release}
|
||||
BuildArch: noarch
|
||||
%description aws
|
||||
@ -545,6 +602,8 @@ Fence agent for Amazon AWS instances.
|
||||
%files aws
|
||||
%{_sbindir}/fence_aws
|
||||
%{_mandir}/man8/fence_aws.8*
|
||||
# bundled libraries
|
||||
/usr/lib/fence-agents/%{bundled_lib_dir}/aws
|
||||
%endif
|
||||
|
||||
%ifarch x86_64
|
||||
@ -1175,6 +1234,10 @@ Fence agent for IBM z/VM over IP.
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Feb 11 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.2.1-75.2
|
||||
- fence_aws: upgrade botocore to fix IMDSv2 support
|
||||
Resolves: rhbz#2052627
|
||||
|
||||
* Wed Aug 11 2021 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.2.1-75
|
||||
- fence_gce: add serviceaccount JSON file support
|
||||
Resolves: rhbz#1685814
|
||||
|
Loading…
Reference in New Issue
Block a user