import felix-osgi-compendium-1.4.0-26.module+el8+2598+06babf2e
This commit is contained in:
commit
2d43a62a93
1
.felix-osgi-compendium.metadata
Normal file
1
.felix-osgi-compendium.metadata
Normal file
@ -0,0 +1 @@
|
||||
be5620b1e693dc730802e942de6066d47655c6f2 SOURCES/org.osgi.compendium-1.4.0-project.tar.gz
|
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/org.osgi.compendium-1.4.0-project.tar.gz
|
27
SOURCES/0001-Fix-servlet-api-dependency.patch
Normal file
27
SOURCES/0001-Fix-servlet-api-dependency.patch
Normal file
@ -0,0 +1,27 @@
|
||||
From 3a7cfc3cf5cadca0e25854ccb85c65f46fd15737 Mon Sep 17 00:00:00 2001
|
||||
From: Stanislav Ochotnicky <sochotnicky@redhat.com>
|
||||
Date: Wed, 2 Feb 2011 14:17:20 +0100
|
||||
Subject: [PATCH 1/2] Fix servlet api dependency
|
||||
|
||||
---
|
||||
pom.xml | 4 ++--
|
||||
1 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/pom.xml b/pom.xml
|
||||
index d53eaa9..f45d162 100644
|
||||
--- a/pom.xml
|
||||
+++ b/pom.xml
|
||||
@@ -38,8 +38,8 @@
|
||||
<version>1.4.0</version>
|
||||
</dependency>
|
||||
<dependency>
|
||||
- <groupId>${pom.groupId}</groupId>
|
||||
- <artifactId>javax.servlet</artifactId>
|
||||
+ <groupId>javax.servlet</groupId>
|
||||
+ <artifactId>javax.servlet-api</artifactId>
|
||||
<version>1.0.0</version>
|
||||
</dependency>
|
||||
<dependency>
|
||||
--
|
||||
1.7.3.5
|
||||
|
32
SOURCES/0002-Fix-compile-target.patch
Normal file
32
SOURCES/0002-Fix-compile-target.patch
Normal file
@ -0,0 +1,32 @@
|
||||
From 5b80abcb5b2dbead332e1c77fa615d6f93fe2218 Mon Sep 17 00:00:00 2001
|
||||
From: Stanislav Ochotnicky <sochotnicky@redhat.com>
|
||||
Date: Wed, 2 Feb 2011 14:50:17 +0100
|
||||
Subject: [PATCH 2/2] Fix compile target
|
||||
|
||||
---
|
||||
pom.xml | 9 +++++++++
|
||||
1 files changed, 9 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/pom.xml b/pom.xml
|
||||
index f45d162..2c1a7a9 100644
|
||||
--- a/pom.xml
|
||||
+++ b/pom.xml
|
||||
@@ -67,6 +67,15 @@
|
||||
</instructions>
|
||||
</configuration>
|
||||
</plugin>
|
||||
+ <plugin>
|
||||
+ <groupId>org.apache.maven.plugins</groupId>
|
||||
+ <artifactId>maven-compiler-plugin</artifactId>
|
||||
+ <version>2.3.2</version>
|
||||
+ <configuration>
|
||||
+ <source>1.5</source>
|
||||
+ <target>1.5</target>
|
||||
+ </configuration>
|
||||
+ </plugin>
|
||||
</plugins>
|
||||
</build>
|
||||
|
||||
--
|
||||
1.7.3.5
|
||||
|
@ -0,0 +1,37 @@
|
||||
From ec6885545fb6889ed9a5522647b9780a53c6fd93 Mon Sep 17 00:00:00 2001
|
||||
From: Marek Goldmann <goldmann@fedoraproject.org>
|
||||
Date: Fri, 15 Jun 2012 11:25:12 +0200
|
||||
Subject: [PATCH 3/3] Add CM_LOCATION_CHANGED property to ConfigurationEvent.
|
||||
|
||||
---
|
||||
.../java/org/osgi/service/cm/ConfigurationEvent.java | 14 ++++++++++++++
|
||||
1 file changed, 14 insertions(+)
|
||||
|
||||
diff --git a/src/main/java/org/osgi/service/cm/ConfigurationEvent.java b/src/main/java/org/osgi/service/cm/ConfigurationEvent.java
|
||||
index f17007f..e98f3ac 100644
|
||||
--- a/src/main/java/org/osgi/service/cm/ConfigurationEvent.java
|
||||
+++ b/src/main/java/org/osgi/service/cm/ConfigurationEvent.java
|
||||
@@ -79,6 +79,20 @@ public class ConfigurationEvent {
|
||||
*/
|
||||
public static final int CM_DELETED = 2;
|
||||
/**
|
||||
+ * The location of a {@code Configuration} has been changed.
|
||||
+ *
|
||||
+ * <p>
|
||||
+ * This {@code ConfigurationEvent} type that indicates that the location of
|
||||
+ * a {@code Configuration} object has been changed.
|
||||
+ *
|
||||
+ * An event is fired when a call to
|
||||
+ * {@link Configuration#setBundleLocation(String)} successfully changes the
|
||||
+ * location.
|
||||
+ *
|
||||
+ * @since 1.4
|
||||
+ */
|
||||
+ public static final int CM_LOCATION_CHANGED = 3;
|
||||
+ /**
|
||||
* Type of this event.
|
||||
*
|
||||
* @see #getType
|
||||
--
|
||||
1.7.10.2
|
||||
|
@ -0,0 +1,31 @@
|
||||
From 88616a67fcdcf3bbc201ed1736b31a61da7f609e Mon Sep 17 00:00:00 2001
|
||||
From: Marek Goldmann <goldmann@fedoraproject.org>
|
||||
Date: Fri, 15 Jun 2012 11:32:27 +0200
|
||||
Subject: [PATCH 4/4] Add TARGET property to ConfigurationPermission
|
||||
|
||||
---
|
||||
src/main/java/org/osgi/service/cm/ConfigurationPermission.java | 8 ++++++++
|
||||
1 file changed, 8 insertions(+)
|
||||
|
||||
diff --git a/src/main/java/org/osgi/service/cm/ConfigurationPermission.java b/src/main/java/org/osgi/service/cm/ConfigurationPermission.java
|
||||
index 3af9088..7b8f3e3 100644
|
||||
--- a/src/main/java/org/osgi/service/cm/ConfigurationPermission.java
|
||||
+++ b/src/main/java/org/osgi/service/cm/ConfigurationPermission.java
|
||||
@@ -40,6 +40,14 @@ public final class ConfigurationPermission extends BasicPermission {
|
||||
public final static String CONFIGURE = "configure";
|
||||
|
||||
/**
|
||||
+ * The permission to be updated, that is, act as a Managed Service or
|
||||
+ * Managed Service Factory. The action string {@value #TARGET}.
|
||||
+ *
|
||||
+ * @since 1.4
|
||||
+ */
|
||||
+ public final static String TARGET = "target";
|
||||
+
|
||||
+ /**
|
||||
* Create a new ConfigurationPermission.
|
||||
*
|
||||
* @param name Name must be "*".
|
||||
--
|
||||
1.7.10.2
|
||||
|
@ -0,0 +1,28 @@
|
||||
From d9df4679129efdc654b44213fb33abd7ac042e81 Mon Sep 17 00:00:00 2001
|
||||
From: Marek Goldmann <goldmann@fedoraproject.org>
|
||||
Date: Tue, 3 Jul 2012 18:43:17 +0200
|
||||
Subject: [PATCH 5/5] Add getResourceURL method to make jbosgi-framework
|
||||
happy...
|
||||
|
||||
---
|
||||
src/main/java/org/osgi/util/xml/XMLParserActivator.java | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/src/main/java/org/osgi/util/xml/XMLParserActivator.java b/src/main/java/org/osgi/util/xml/XMLParserActivator.java
|
||||
index 963c092..85f9f56 100644
|
||||
--- a/src/main/java/org/osgi/util/xml/XMLParserActivator.java
|
||||
+++ b/src/main/java/org/osgi/util/xml/XMLParserActivator.java
|
||||
@@ -165,6 +165,10 @@ public class XMLParserActivator implements BundleActivator, ServiceFactory {
|
||||
.getResource(DOMCLASSFILE)));
|
||||
}
|
||||
|
||||
+ protected URL getResourceURL(Bundle parserBundle, String resname) {
|
||||
+ return parserBundle.getResource(resname);
|
||||
+ }
|
||||
+
|
||||
/**
|
||||
* This method has nothing to do as all active service registrations will
|
||||
* automatically get unregistered when the bundle stops.
|
||||
--
|
||||
1.7.10.4
|
||||
|
150
SPECS/felix-osgi-compendium.spec
Normal file
150
SPECS/felix-osgi-compendium.spec
Normal file
@ -0,0 +1,150 @@
|
||||
%global bundle org.osgi.compendium
|
||||
|
||||
Name: felix-osgi-compendium
|
||||
Version: 1.4.0
|
||||
Release: 26%{?dist}
|
||||
Summary: Felix OSGi R4 Compendium Bundle
|
||||
License: ASL 2.0
|
||||
URL: http://felix.apache.org
|
||||
BuildArch: noarch
|
||||
|
||||
Source0: http://www.apache.org/dist/felix/%{bundle}-%{version}-project.tar.gz
|
||||
|
||||
Patch0: 0001-Fix-servlet-api-dependency.patch
|
||||
Patch1: 0002-Fix-compile-target.patch
|
||||
Patch2: 0003-Add-CM_LOCATION_CHANGED-property-to-ConfigurationEve.patch
|
||||
Patch3: 0004-Add-TARGET-property-to-ConfigurationPermission.patch
|
||||
# This is an ugly patch that adds getResourceURL method. This prevents jbosgi-framework
|
||||
# package from bundling osgi files. Once the jbosgi-framework will be updated
|
||||
# to a new version without the need for this patch, REMOVE it!
|
||||
Patch4: 0005-Add-getResourceURL-method-to-make-jbosgi-framework-h.patch
|
||||
|
||||
BuildRequires: maven-local
|
||||
BuildRequires: mvn(javax.servlet:javax.servlet-api)
|
||||
BuildRequires: mvn(org.apache.felix:felix-parent:pom:)
|
||||
BuildRequires: mvn(org.apache.felix:maven-bundle-plugin)
|
||||
BuildRequires: mvn(org.apache.felix:org.osgi.core)
|
||||
BuildRequires: mvn(org.apache.felix:org.osgi.foundation)
|
||||
|
||||
%description
|
||||
OSGi Service Platform Release 4 Compendium Interfaces and Classes.
|
||||
|
||||
%package javadoc
|
||||
Summary: API documentation for %{name}
|
||||
|
||||
%description javadoc
|
||||
This package contains API documentation for %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{bundle}-%{version}
|
||||
|
||||
# fix servlet api properly
|
||||
%patch0 -p1
|
||||
# fix compile source/target
|
||||
%patch1 -p1
|
||||
# add CM_LOCATION_CHANGED property
|
||||
%patch2 -p1
|
||||
# add TARGET property
|
||||
%patch3 -p1
|
||||
# add getResourceURL method
|
||||
%patch4 -p1
|
||||
|
||||
%mvn_file :%{bundle} "felix/%{bundle}"
|
||||
%mvn_alias "org.apache.felix:%{bundle}" "org.osgi:%{bundle}"
|
||||
|
||||
%build
|
||||
%mvn_build -- -Drat.numUnapprovedLicenses=100
|
||||
|
||||
%install
|
||||
%mvn_install
|
||||
|
||||
%files -f .mfiles
|
||||
%license LICENSE NOTICE
|
||||
|
||||
%files javadoc -f .mfiles-javadoc
|
||||
%license LICENSE NOTICE
|
||||
|
||||
%changelog
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-26
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-25
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-24
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Thu Jun 16 2016 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.4.0-23
|
||||
- Regenerate build-requires
|
||||
- Update to current packaging guidelines
|
||||
|
||||
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-22
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.0-21
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.0-20
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Thu Jun 5 2014 Alexander Kurtakov <akurtako@redhat.com> 1.4.0-19
|
||||
- Switch to mvn style BR for servlet api.
|
||||
|
||||
* Mon May 26 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.4.0-18
|
||||
- Remove BuildRequires on maven-surefire-provider-junit4
|
||||
|
||||
* Tue Mar 04 2014 Stanislav Ochotnicky <sochotnicky@redhat.com> - 1.4.0-17
|
||||
- Use Requires: java-headless rebuild (#1067528)
|
||||
|
||||
* Mon Aug 05 2013 Mat Booth <fedora@matbooth.co.uk> - 1.4.0-16
|
||||
- Update for latest guidelines
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.0-15
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.0-14
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Wed Feb 06 2013 Java SIG <java-devel@lists.fedoraproject.org> - 1.4.0-13
|
||||
- Update for https://fedoraproject.org/wiki/Fedora_19_Maven_Rebuild
|
||||
- Replace maven BuildRequires with maven-local
|
||||
|
||||
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.0-12
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Tue Jul 03 2012 Marek Goldmann <mgoldman@redhat.com> 1.4.0-11
|
||||
- Add getResourceURL method to XMLParserActivator
|
||||
|
||||
* Fri Jun 15 2012 Marek Goldmann <mgoldman@redhat.com> 1.4.0-10
|
||||
- Add CM_LOCATION_CHANGED property to ConfigurationEvent
|
||||
- Add TARGET property to ConfigurationPermission
|
||||
|
||||
* Wed Mar 21 2012 Alexander Kurtakov <akurtako@redhat.com> 1.4.0-9
|
||||
- Move to tomcat 7.x servlet api.
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.0-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Thu Sep 22 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 1.4.0-7
|
||||
- Add org.osgi groupId to depmap
|
||||
- Packaging fixes
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.0-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Wed Feb 2 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 1.4.0-5
|
||||
- Fix servlet api in pom
|
||||
|
||||
* Mon Dec 27 2010 Mat Booth <fedora@matbooth.co.uk> 1.4.0-4
|
||||
- Fix POM names RHBZ #655800.
|
||||
- Versionless jars/docs, update maven plug-in BRs.
|
||||
- Other misc guideline compliances.
|
||||
|
||||
* Mon Jul 12 2010 Victor G. Vasilyev <victor.vasilyev@sun.com> 1.4.0-3
|
||||
- Avoid owning the %%{_javadir}/%%{project} directory
|
||||
|
||||
* Wed Jul 07 2010 Victor G. Vasilyev <victor.vasilyev@sun.com> 1.4.0-2
|
||||
- Use maven instead of ant
|
||||
|
||||
* Tue Jun 22 2010 Victor G. Vasilyev <victor.vasilyev@sun.com> 1.4.0-1
|
||||
- Release 1.4.0
|
Loading…
Reference in New Issue
Block a user