9a79b1c7b8
BuildRoot and ExcludeArch cleanup
23 lines
1.0 KiB
Diff
23 lines
1.0 KiB
Diff
--- fcoe-utils-1.0.17/Makefile.am 2011-01-15 01:28:10.000000000 +0100
|
|
+++ fcoe-utils-1.0.17/Makefile.am.new 2011-02-04 10:59:25.579483545 +0100
|
|
@@ -2,7 +2,7 @@
|
|
sbin_PROGRAMS = fcoeadm fcoemon fcping fipvlan fcnsq fcrls
|
|
|
|
## all targets should look for headers in the include directory
|
|
-AM_CPPFLAGS = -I${srcdir}/include -I${builddir}/include
|
|
+AM_CPPFLAGS = -I${srcdir}/include -I${builddir}/include -I/lib/modules/`rpm -q --list kernel | grep "^/lib/modules/.*/build$$" | cut -f4 -d"/" | sort -r | head -1`/build/include
|
|
## pass the sysconfdir into the C proprocessor
|
|
AM_CPPFLAGS += -DSYSCONFDIR="\"${sysconfdir}\""
|
|
AM_CFLAGS = -Wall
|
|
--- fcoe-utils-1.0.17/Makefile.am 2011-02-04 11:06:42.253483139 +0100
|
|
+++ fcoe-utils-1.0.17/Makefile.am.new 2011-02-04 11:06:59.956483271 +0100
|
|
@@ -65,8 +65,3 @@
|
|
init_d_SCRIPTS = etc/initd/fcoe
|
|
|
|
dist_noinst_DATA = README COPYING INSTALL fcoe-utils.spec etc/config
|
|
-
|
|
-install-data-hook:
|
|
- if [ ! -f ${DESTDIR}${fcoe_configdir}/config ] ; then \
|
|
- cp ${srcdir}/etc/config ${DESTDIR}${fcoe_configdir}/config; \
|
|
- fi
|