Fix format strings to compile on i386 too
This commit is contained in:
parent
efccaad723
commit
deea7f9098
@ -1,13 +0,0 @@
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index c412de5..149df47 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -4,6 +4,8 @@ AM_INIT_AUTOMAKE([-Wall -Werror foreign])
|
||||
AC_PROG_CC
|
||||
AM_PROG_CC_C_O
|
||||
AC_PROG_RANLIB
|
||||
+m4_pattern_allow([AM_PROG_AR])
|
||||
+AM_PROG_AR
|
||||
|
||||
PKG_CHECK_MODULES([HBAAPI], [HBAAPI])
|
||||
AC_SUBST([HBAAPI_CFLAGS])
|
63
fcoe-utils-1.0.28-format-strings.patch
Normal file
63
fcoe-utils-1.0.28-format-strings.patch
Normal file
@ -0,0 +1,63 @@
|
||||
diff --git a/fcoeadm_display.c b/fcoeadm_display.c
|
||||
index e1cbd48..a6cf7a3 100644
|
||||
--- a/fcoeadm_display.c
|
||||
+++ b/fcoeadm_display.c
|
||||
@@ -1426,8 +1426,8 @@ void print_fcoe_fcf_device(void *ep, void *arg)
|
||||
if (!buf)
|
||||
buf = temp;
|
||||
printf(" Connection Mode: %s\n", buf);
|
||||
- printf(" Fabric Name: 0x%016lx\n", fcf->fabric_name);
|
||||
- printf(" Switch Name 0x%016lx\n", fcf->switch_name);
|
||||
+ printf(" Fabric Name: 0x%016" PRIx64 "\n", fcf->fabric_name);
|
||||
+ printf(" Switch Name 0x%016" PRIx64 "\n", fcf->switch_name);
|
||||
mac2str(fcf->mac, mac, MAX_STR_LEN);
|
||||
printf(" MAC Address: %s\n", mac);
|
||||
printf(" FCF Priority: %u\n", fcf->priority);
|
||||
diff --git a/fcoemon.c b/fcoemon.c
|
||||
index 80360fd..23fae9e 100644
|
||||
--- a/fcoemon.c
|
||||
+++ b/fcoemon.c
|
||||
@@ -2640,7 +2640,7 @@ static void fcm_dcbd_get_oper(struct fcm_netif *ff, char *resp, char *cp)
|
||||
|
||||
if (ep) {
|
||||
FCM_LOG_DEV(ff, "Invalid get oper response "
|
||||
- "parse error byte %ld, resp %s", ep - cp, cp);
|
||||
+ "parse error byte %td, resp %s", ep - cp, cp);
|
||||
fcm_dcbd_state_set(ff, FCD_ERROR);
|
||||
} else {
|
||||
if (val && fcoe_config.debug)
|
||||
diff --git a/fcping.c b/fcping.c
|
||||
index bc51d5f..f92516f 100644
|
||||
--- a/fcping.c
|
||||
+++ b/fcping.c
|
||||
@@ -25,6 +25,7 @@
|
||||
#include <stddef.h>
|
||||
#include <stdarg.h>
|
||||
#include <unistd.h>
|
||||
+#include <inttypes.h>
|
||||
#include <errno.h>
|
||||
#include <string.h>
|
||||
#include <time.h>
|
||||
@@ -812,17 +813,17 @@ static void fp_check_data_len()
|
||||
printf("Maximum ECHO data allowed by the Fabric (0x%06x) : %d bytes.\n"
|
||||
"Maximum ECHO data allowed by the Source (0x%06x) : %d bytes.\n"
|
||||
"Maximum ECHO data allowed by the Target (0x%06x) : %d bytes.\n"
|
||||
- "Maximum ECHO data requested from user input (-s) : %lu "
|
||||
+ "Maximum ECHO data requested from user input (-s) : %" PRIu32 " "
|
||||
"(default %d) bytes.\n",
|
||||
FC_WKA_FABRIC_CONTROLLER, flen, sid, slen, fp_did, dlen,
|
||||
- fp_len - FP_LEN_ECHO, FP_LEN_DEF);
|
||||
+ (uint32_t)(fp_len - FP_LEN_ECHO), FP_LEN_DEF);
|
||||
|
||||
/* fp_len is the total payload, including 4 bytes for ECHO command */
|
||||
fp_len = MIN(fp_len, plen + FP_LEN_ECHO);
|
||||
- printf("Actual FC ELS ECHO data size used : %lu bytes.\n"
|
||||
+ printf("Actual FC ELS ECHO data size used : %" PRIu32 " bytes.\n"
|
||||
"Actual FC ELS ECHO payload size used : %d bytes "
|
||||
- "(including %ld bytes ECHO command).\n",
|
||||
- fp_len - FP_LEN_ECHO, fp_len, FP_LEN_ECHO);
|
||||
+ "(including %zu bytes ECHO command).\n",
|
||||
+ (uint32_t)(fp_len - FP_LEN_ECHO), fp_len, FP_LEN_ECHO);
|
||||
}
|
||||
|
||||
/*
|
@ -18,6 +18,7 @@ ExcludeArch: ppc s390 s390x
|
||||
Patch1: fcoe-utils-1.0.28-make.patch
|
||||
Patch2: fcoe-utils-1.0.18-help.patch
|
||||
Patch3: fcoe-utils-1.0.18-config.patch
|
||||
Patch4: fcoe-utils-1.0.28-format-strings.patch
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake
|
||||
BuildRequires: libhbaapi-devel >= 2.2-12
|
||||
@ -44,6 +45,7 @@ cp -v %{SOURCE1} quickstart.txt
|
||||
%patch1 -p1 -b .make
|
||||
%patch2 -p1 -b .help
|
||||
%patch3 -p1 -b .config
|
||||
%patch4 -p1 -b .format-strings
|
||||
|
||||
%build
|
||||
./bootstrap.sh
|
||||
|
Loading…
Reference in New Issue
Block a user