fix vn2vn mode from fcoeadm
This commit is contained in:
parent
81c0139d2a
commit
d188efb2e8
@ -1,25 +0,0 @@
|
||||
diff --git a/doc/fcoemon.8 b/doc/fcoemon.8
|
||||
index e9a045b..020394e 100644
|
||||
--- a/doc/fcoemon.8
|
||||
+++ b/doc/fcoemon.8
|
||||
@@ -358,7 +358,7 @@ indicates whether a FIP responder should be activated on this device to support
|
||||
Note that the attached Ethernet peer device (e\&.g\&. FCoE capable switch port) must have compatible settings For DCB and FCoE to function properly\&.
|
||||
.SS "/etc/init\&.d/fcoe"
|
||||
.sp
|
||||
-This is the \fBfcoe\fR system service script\&. This script is invoked by the init process or by the service command to start and stop the \fBfcoemon\fR\&.
|
||||
+This is the \fBfcoe\fR system service script\&. This script is invoked by the init process or by the service command to start and stop the \fBfcoemon\fR\&. On systemd-enabled systems, \fBfcoemon\fR is controlled via the \fBfcoe.service\fR unit.
|
||||
.SH "VLAN NAMING CONVENTIONS"
|
||||
.sp
|
||||
If a new VLAN device is created (see the description of the \fIAUTO_VLAN\fR setting above), it will have the name \fIdev\fR\&.\fIvlan\fR\-fcoe; where \fIdev\fR is the name of the Ethernet parent device and \fIvlan\fR is the discovered VLAN ID number\&.
|
||||
diff --git a/doc/fcoemon.txt b/doc/fcoemon.txt
|
||||
index ec15197..09ee5a2 100644
|
||||
--- a/doc/fcoemon.txt
|
||||
+++ b/doc/fcoemon.txt
|
||||
@@ -214,6 +214,7 @@ must have compatible settings For DCB and FCoE to function properly.
|
||||
~~~~~~~~~~~~~~~~
|
||||
This is the *fcoe* system service script. This script is invoked by the
|
||||
init process or by the service command to start and stop the *fcoemon*.
|
||||
+On systemd-enabled systems, *fcoemon* is controlled via the *fcoe.service* unit.
|
||||
|
||||
VLAN NAMING CONVENTIONS
|
||||
-----------------------
|
@ -1,10 +0,0 @@
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 73c140f..bb1385b 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1,5 +1,4 @@
|
||||
AC_INIT([fcoe-utils], [1.0.29], [fcoe-devel@open-fcoe.org])
|
||||
-AM_INIT_AUTOMAKE([foreign])
|
||||
|
||||
m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
|
||||
AM_INIT_AUTOMAKE([foreign])
|
@ -0,0 +1,45 @@
|
||||
From 50e1aaa1b8b6856a890ae3f036ae9439b24c40c3 Mon Sep 17 00:00:00 2001
|
||||
From: Chris Leech <cleech@redhat.com>
|
||||
Date: Fri, 24 Oct 2014 14:36:53 -0700
|
||||
Subject: [PATCH] pass flags to fcoemon to enable vn2vn mode
|
||||
|
||||
---
|
||||
fcoeadm.c | 8 +++-----
|
||||
1 file changed, 3 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/fcoeadm.c b/fcoeadm.c
|
||||
index 07ff690..776b4e3 100644
|
||||
--- a/fcoeadm.c
|
||||
+++ b/fcoeadm.c
|
||||
@@ -286,7 +286,7 @@ int main(int argc, char *argv[])
|
||||
}
|
||||
|
||||
ifname = argv[optind];
|
||||
- rc = fcoeadm_action(cmd, ifname, CLIF_FLAGS_NONE);
|
||||
+ rc = fcoeadm_action(cmd, ifname, flags);
|
||||
break;
|
||||
case 'r':
|
||||
cmd = CLIF_RESET_CMD;
|
||||
@@ -303,8 +303,7 @@ int main(int argc, char *argv[])
|
||||
ifname = argv[optind];
|
||||
rc = fcoe_validate_fcoe_conn(ifname);
|
||||
if (!rc)
|
||||
- rc = fcoeadm_action(cmd, ifname,
|
||||
- CLIF_FLAGS_NONE);
|
||||
+ rc = fcoeadm_action(cmd, ifname, flags);
|
||||
break;
|
||||
|
||||
case 'i':
|
||||
@@ -405,8 +404,7 @@ int main(int argc, char *argv[])
|
||||
rc = display_port_stats(ifname, stat_interval);
|
||||
break;
|
||||
case 'p':
|
||||
- rc = fcoeadm_action(CLIF_PID_CMD, NULL,
|
||||
- CLIF_FLAGS_NONE);
|
||||
+ rc = fcoeadm_action(CLIF_PID_CMD, NULL, flags);
|
||||
break;
|
||||
|
||||
case 'b':
|
||||
--
|
||||
1.9.3
|
||||
|
@ -1,9 +1,11 @@
|
||||
# https://fedoraproject.org/wiki/Packaging:Guidelines#Compiler_flags
|
||||
%define _hardened_build 1
|
||||
%global _hardened_build 1
|
||||
|
||||
%global checkout 9267509
|
||||
|
||||
Name: fcoe-utils
|
||||
Version: 1.0.29
|
||||
Release: 6%{?dist}
|
||||
Release: 7.git%{checkout}%{?dist}
|
||||
Summary: Fibre Channel over Ethernet utilities
|
||||
Group: Applications/System
|
||||
License: GPLv2
|
||||
@ -15,6 +17,7 @@ Source2: fcoe.service
|
||||
Source3: fcoe.config
|
||||
ExcludeArch: ppc s390 s390x
|
||||
Patch1: fcoe-utils-1.0.29-29-g9267509.patch
|
||||
Patch2: fcoe-utils-1.0.29-pass-flags-to-fcoemon-to-enable-vn2vn-mode.patch
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake
|
||||
BuildRequires: libhbaapi-devel >= 2.2.9-6
|
||||
@ -39,6 +42,7 @@ fcoemon - service to configure DCB Ethernet QOS filters, works with lldpad
|
||||
%setup -q
|
||||
cp -v %{SOURCE1} quickstart.txt
|
||||
%patch1 -p1 -b .v1_0_29-29
|
||||
%patch2 -p1 -b .vn2vn
|
||||
|
||||
%build
|
||||
./bootstrap.sh
|
||||
@ -82,6 +86,9 @@ rm -f %{buildroot}/%{_sysconfdir}/fcoe/config
|
||||
%{_libexecdir}/fcoe/
|
||||
|
||||
%changelog
|
||||
* Fri Oct 24 2014 Chris Leech <cleech@redhat.com> - 1.0.29-7
|
||||
- enable vn2vn mode in fcoeadm
|
||||
|
||||
* Tue Oct 07 2014 Chris Leech <cleech@redhat.com> - 1.0.29-6
|
||||
- update to upstream v1.0.29-29-g9267509
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user