- Disable fatal diagnostics from gcc-11 for fipvlan
This commit is contained in:
parent
375a864686
commit
b9c42614a4
15
fcoe-utils-gcc11.patch
Normal file
15
fcoe-utils-gcc11.patch
Normal file
@ -0,0 +1,15 @@
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index 2f323e4..d6bc3c3 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -25,6 +25,10 @@ fcping_CFLAGS = $(AM_CFLAGS)
|
||||
## rules for building fipvlan
|
||||
fipvlan_SOURCES = fipvlan.c
|
||||
fipvlan_LDADD = lib/libutil.a
|
||||
+# These look like valid warnings, but the code may be fine in practice. Someone
|
||||
+# with a deeper understanding of the source needs to chime in
|
||||
+fipvlan_CFLAGS = $(AM_CFLAGS) -Wno-error=array-bounds -Wno-error=stringop-overread
|
||||
+
|
||||
|
||||
AUTOMAKE_OPTIONS=subdir-objects
|
||||
noinst_LIBRARIES = lib/libutil.a libopenfcoe.a
|
@ -7,7 +7,7 @@
|
||||
|
||||
Name: fcoe-utils
|
||||
Version: 1.0.33
|
||||
Release: 0.git%{shortcommit0}%{?dist}
|
||||
Release: 1.git%{shortcommit0}%{?dist}
|
||||
Summary: Fibre Channel over Ethernet utilities
|
||||
License: GPLv2
|
||||
URL: http://www.open-fcoe.org
|
||||
@ -18,6 +18,7 @@ Source3: fcoe.config
|
||||
ExcludeArch: ppc s390
|
||||
Patch1: 0001-21-string-op-truncation-format-truncation-and-format.patch
|
||||
Patch2: 0002-use-of-uninitialized-values-detected-during-LTO.patch
|
||||
Patch3: %{name}-gcc11.patch
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake
|
||||
BuildRequires: libpciaccess-devel
|
||||
@ -83,6 +84,9 @@ rm -f %{buildroot}/%{_sysconfdir}/fcoe/config
|
||||
%{_libexecdir}/fcoe/
|
||||
|
||||
%changelog
|
||||
* Wed Oct 28 2020 Jeff Law <aw@redhat.com> - 1.0.33-1.gitfe376de
|
||||
- Disable fatal diagnostics from gcc-11 for fipvlan
|
||||
|
||||
* Mon Sep 21 2020 Chris Leech <cleech@redhat.com> - 1.0.33-0.gitfe376de
|
||||
- FTBFS: fix gcc 10.2 truncation and overflow errors
|
||||
- rebase to 1.0.33+ from new upstream location
|
||||
|
Loading…
Reference in New Issue
Block a user