import fcoe-utils-1.0.32-6.el8
This commit is contained in:
commit
5b058697f7
1
.fcoe-utils.metadata
Normal file
1
.fcoe-utils.metadata
Normal file
@ -0,0 +1 @@
|
||||
af94ad7bd13d0828be6246f46f04b3b7d6a1ad0a SOURCES/fcoe-utils-1.0.32.tar.gz
|
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/fcoe-utils-1.0.32.tar.gz
|
53
SOURCES/fcoe-utils-gcc7-fmt-truc-err.patch
Normal file
53
SOURCES/fcoe-utils-gcc7-fmt-truc-err.patch
Normal file
@ -0,0 +1,53 @@
|
||||
diff --git a/fipvlan.c b/fipvlan.c
|
||||
index 7c00c7c..065b742 100644
|
||||
--- a/fipvlan.c
|
||||
+++ b/fipvlan.c
|
||||
@@ -621,8 +621,10 @@ create_and_start_vlan(struct fcf *fcf, bool vn2vn)
|
||||
real_dev->ifname, fcf->vlan, vlan->ifname);
|
||||
rc = 0;
|
||||
} else {
|
||||
- snprintf(vlan_name, IFNAMSIZ, "%s.%d%s",
|
||||
- real_dev->ifname, fcf->vlan, config.suffix);
|
||||
+ rc = snprintf(vlan_name, IFNAMSIZ, "%s.%d%s",
|
||||
+ real_dev->ifname, fcf->vlan, config.suffix);
|
||||
+ if (rc >= IFNAMSIZ)
|
||||
+ return -E2BIG;
|
||||
rc = vlan_create(fcf->ifindex, fcf->vlan, vlan_name);
|
||||
if (rc < 0)
|
||||
printf("Failed to create VLAN device %s\n\t%s\n",
|
||||
diff --git a/libopenfcoe.c b/libopenfcoe.c
|
||||
index 07090d5..98fb975 100644
|
||||
--- a/libopenfcoe.c
|
||||
+++ b/libopenfcoe.c
|
||||
@@ -59,6 +59,7 @@ static int add_fcoe_fcf_device(struct dirent *dp, void *arg)
|
||||
{
|
||||
struct fcoe_ctlr_device *ctlr = (struct fcoe_ctlr_device *)arg;
|
||||
struct fcoe_fcf_device *fcf;
|
||||
+ int rc;
|
||||
|
||||
if (!strstr(dp->d_name, "fcf") ||
|
||||
(!strcmp(dp->d_name, "fcf_dev_loss_tmo")))
|
||||
@@ -71,8 +72,10 @@ static int add_fcoe_fcf_device(struct dirent *dp, void *arg)
|
||||
memset(fcf, 0, sizeof(struct fcoe_fcf_device));
|
||||
|
||||
/* Save the path */
|
||||
- snprintf(fcf->path, sizeof(fcf->path),
|
||||
- "%s/%s", ctlr->path, dp->d_name);
|
||||
+ rc = snprintf(fcf->path, sizeof(fcf->path),
|
||||
+ "%s/%s", ctlr->path, dp->d_name);
|
||||
+ if (rc >= sizeof(fcf->path))
|
||||
+ goto fail;
|
||||
|
||||
/* Use the index from the logical enumeration */
|
||||
fcf->index = atoi(dp->d_name + sizeof("fcf_") - 1);
|
||||
@@ -198,7 +201,9 @@ static int read_fcoe_ctlr_device(struct dirent *dp, void *arg)
|
||||
sa_sys_read_line(ctlr->path, "mode", buf, sizeof(buf));
|
||||
sa_enum_encode(fip_conn_type_table, buf, &ctlr->mode);
|
||||
|
||||
- snprintf(lesb_path, sizeof(lesb_path), "%s/lesb/", ctlr->path);
|
||||
+ rc = snprintf(lesb_path, sizeof(lesb_path), "%s/lesb/", ctlr->path);
|
||||
+ if (rc >= sizeof(lesb_path))
|
||||
+ goto fail;
|
||||
|
||||
/* Get LESB statistics */
|
||||
sa_sys_read_u32(lesb_path, "link_fail",
|
119
SOURCES/fcoe-utils-gcc8-fmt-truc-err.patch
Normal file
119
SOURCES/fcoe-utils-gcc8-fmt-truc-err.patch
Normal file
@ -0,0 +1,119 @@
|
||||
From: Chris Leech <cleech@redhat.com>
|
||||
Subject: fix build warnings/errors with GCC format-truncation checks
|
||||
|
||||
diff --git a/fcoeadm_display.c b/fcoeadm_display.c
|
||||
index 120c6084b7ca..f10cfb53d454 100644
|
||||
--- a/fcoeadm_display.c
|
||||
+++ b/fcoeadm_display.c
|
||||
@@ -254,6 +254,7 @@ static void show_full_lun_info(unsigned int hba, unsigned int port,
|
||||
struct dirent *dp;
|
||||
struct port_attributes *rport_attrs;
|
||||
struct port_attributes *port_attrs;
|
||||
+ int rc;
|
||||
|
||||
snprintf(path, sizeof(path),
|
||||
"/sys/class/scsi_device/%u:%u:%u:%u",
|
||||
@@ -287,10 +288,18 @@ static void show_full_lun_info(unsigned int hba, unsigned int port,
|
||||
|
||||
osname = dp->d_name;
|
||||
|
||||
- snprintf(npath, sizeof(npath), "%s/%s/", path, osname);
|
||||
+ rc = snprintf(npath, sizeof(npath), "%s/%s/", path, osname);
|
||||
+ if (rc < 0 || rc >= sizeof(npath)) {
|
||||
+ /* error or truncation, bailing out */
|
||||
+ return;
|
||||
+ }
|
||||
sa_sys_read_u64(npath, "size", &lba);
|
||||
|
||||
- snprintf(npath, sizeof(npath), "%s/%s/queue/", path, osname);
|
||||
+ rc = snprintf(npath, sizeof(npath), "%s/%s/queue/", path, osname);
|
||||
+ if (rc < 0 || rc >= sizeof(npath)) {
|
||||
+ /* error or truncation, bailing out */
|
||||
+ return;
|
||||
+ }
|
||||
sa_sys_read_u32(npath, "hw_sector_size", &blksize);
|
||||
}
|
||||
|
||||
@@ -340,6 +349,7 @@ static void show_short_lun_info(unsigned int hba, unsigned int port,
|
||||
char *capstr = "Unknown";
|
||||
char *osname = "Unknown";
|
||||
uint64_t size;
|
||||
+ int rc;
|
||||
|
||||
snprintf(path, sizeof(path),
|
||||
"/sys/class/scsi_device/%u:%u:%u:%u/device/",
|
||||
@@ -363,10 +373,18 @@ static void show_short_lun_info(unsigned int hba, unsigned int port,
|
||||
|
||||
osname = dp->d_name;
|
||||
|
||||
- snprintf(npath, sizeof(npath), "%s/%s/", path, osname);
|
||||
+ rc = snprintf(npath, sizeof(npath), "%s/%s/", path, osname);
|
||||
+ if (rc < 0 || rc >= sizeof(npath)) {
|
||||
+ /* error or truncation, bailing out */
|
||||
+ return;
|
||||
+ }
|
||||
sa_sys_read_u64(npath, "size", &size);
|
||||
|
||||
- snprintf(npath, sizeof(npath), "%s/%s/queue/", path, osname);
|
||||
+ rc = snprintf(npath, sizeof(npath), "%s/%s/queue/", path, osname);
|
||||
+ if (rc < 0 || rc >= sizeof(npath)) {
|
||||
+ /* error or truncation, bailing out */
|
||||
+ return;
|
||||
+ }
|
||||
sa_sys_read_u32(npath, "hw_sector_size", &blksize);
|
||||
}
|
||||
|
||||
diff --git a/fcoemon.c b/fcoemon.c
|
||||
index 9a400c56b72a..bf73a0d4c89e 100644
|
||||
--- a/fcoemon.c
|
||||
+++ b/fcoemon.c
|
||||
@@ -939,6 +939,7 @@ static struct fcoe_port *fcm_new_vlan(int ifindex, int vid, bool vn2vn)
|
||||
[false] = CLIF_FLAGS_FABRIC,
|
||||
[true] = CLIF_FLAGS_VN2VN,
|
||||
};
|
||||
+ int rc;
|
||||
|
||||
if (vn2vn)
|
||||
FCM_LOG_DBG("Auto VLAN found vn2vn on VID %d\n", vid);
|
||||
@@ -947,8 +948,15 @@ static struct fcoe_port *fcm_new_vlan(int ifindex, int vid, bool vn2vn)
|
||||
|
||||
if (rtnl_find_vlan(ifindex, vid, vlan_name)) {
|
||||
rtnl_get_linkname(ifindex, real_name);
|
||||
- snprintf(vlan_name, sizeof(vlan_name), FCOE_VLAN_FORMAT,
|
||||
- real_name, vid);
|
||||
+ rc = snprintf(vlan_name, sizeof(vlan_name), FCOE_VLAN_FORMAT,
|
||||
+ real_name, vid);
|
||||
+ if (rc >= sizeof(vlan_name)) {
|
||||
+ FCM_LOG("Warning: Generating FCoE VLAN device name for"
|
||||
+ "interface %s VLAN %d: format resulted in a"
|
||||
+ "name larger than IFNAMSIZ\n", real_name, vid);
|
||||
+ vlan_name[sizeof(vlan_name) - 1] = 0;
|
||||
+ FCM_LOG("\tTruncating VLAN name to %s\n", vlan_name);
|
||||
+ }
|
||||
vlan_create(ifindex, vid, vlan_name);
|
||||
}
|
||||
rtnl_set_iff_up(0, vlan_name);
|
||||
@@ -3549,7 +3557,7 @@ static void fcm_srv_receive(void *arg)
|
||||
}
|
||||
|
||||
cmd = data->cmd;
|
||||
- strncpy(ifname, data->ifname, sizeof(data->ifname));
|
||||
+ strncpy(ifname, data->ifname, sizeof(ifname) - 1);
|
||||
ifname[sizeof(data->ifname)] = 0;
|
||||
|
||||
if (cmd != CLIF_PID_CMD) {
|
||||
diff --git a/libopenfcoe.c b/libopenfcoe.c
|
||||
index 07090d5a09aa..c1190adc2328 100644
|
||||
--- a/libopenfcoe.c
|
||||
+++ b/libopenfcoe.c
|
||||
@@ -179,7 +179,9 @@ static int read_fcoe_ctlr_device(struct dirent *dp, void *arg)
|
||||
if (!rc)
|
||||
goto fail;
|
||||
|
||||
- sprintf(hpath, "%s/%s/", SYSFS_FCHOST, fchost);
|
||||
+ rc = snprintf(hpath, MAX_STR_LEN, "%s/%s/", SYSFS_FCHOST, fchost);
|
||||
+ if (rc < 0 || rc >= MAX_STR_LEN)
|
||||
+ goto fail;
|
||||
|
||||
rc = sa_sys_read_line(hpath, "symbolic_name", buf, sizeof(buf));
|
||||
|
25
SOURCES/fcoe-utils-set-default-DCB_REQUIRED-to-no.patch
Normal file
25
SOURCES/fcoe-utils-set-default-DCB_REQUIRED-to-no.patch
Normal file
@ -0,0 +1,25 @@
|
||||
From db650524cb395827cf0d5a43bd07f77396513cd7 Mon Sep 17 00:00:00 2001
|
||||
From: rpm-build <rpm-build>
|
||||
Date: Tue, 7 Aug 2018 21:23:38 -0700
|
||||
Subject: [PATCH 1/1] set default DCB_REQUIRED to 'no'
|
||||
|
||||
---
|
||||
etc/cfg-ethx | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/etc/cfg-ethx b/etc/cfg-ethx
|
||||
index c5aaf36b4625..e2eb3309ccc7 100644
|
||||
--- a/etc/cfg-ethx
|
||||
+++ b/etc/cfg-ethx
|
||||
@@ -8,7 +8,7 @@ FCOE_ENABLE="yes"
|
||||
## Default: no
|
||||
# Indicate if DCB service is required at the Ethernet port
|
||||
# Normally set to "yes"
|
||||
-DCB_REQUIRED="yes"
|
||||
+DCB_REQUIRED="no"
|
||||
|
||||
## Type: yes/no
|
||||
## Default: no
|
||||
--
|
||||
2.14.4
|
||||
|
@ -0,0 +1,34 @@
|
||||
From f369a89e914eb1f14b26d6e84fa32fdf8a591cfc Mon Sep 17 00:00:00 2001
|
||||
From: Andrey Grafin <Andrey.Grafin@acronis.com>
|
||||
Date: Mon, 18 Sep 2017 17:35:08 +0300
|
||||
Subject: [PATCH 1/1] fcoe-utils: Fix get_ctlr_num() for large ctlr_* indices
|
||||
|
||||
Each creation of a FCoE device increases counter which is used as a suffix
|
||||
in a FCoE device name in sysfs (i.e. /sys/bus/fcoe/devices/ctlr_1).
|
||||
Once this counter reaches the value of two digits (10 and larger),
|
||||
get_ctlr_num() stopped working properly and a command like `fcoeadm -i`
|
||||
which depends on get_ctlr_num() call doesn't show anything.
|
||||
This patch solves this problem.
|
||||
|
||||
Signed-off-by: Andrey Grafin <Andrey.Grafin@acronis.com>
|
||||
Signed-off-by: Johannes Thumshirn <jthumshirn@suse.de>
|
||||
---
|
||||
lib/sysfs_hba.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/lib/sysfs_hba.c b/lib/sysfs_hba.c
|
||||
index 5cb7fd3fa5d5..786215440bac 100644
|
||||
--- a/lib/sysfs_hba.c
|
||||
+++ b/lib/sysfs_hba.c
|
||||
@@ -606,7 +606,7 @@ static int get_ctlr_num(const char *netdev)
|
||||
if (!ctlr)
|
||||
continue;
|
||||
|
||||
- ctlr_num = atoi(&ctlr[strlen(ctlr) - 1]);
|
||||
+ ctlr_num = atoi(&ctlr[sizeof("ctlr_") - 1]);
|
||||
break;
|
||||
}
|
||||
|
||||
--
|
||||
2.14.4
|
||||
|
5
SOURCES/fcoe.config
Normal file
5
SOURCES/fcoe.config
Normal file
@ -0,0 +1,5 @@
|
||||
# All supported drivers listed here are loaded when service starts
|
||||
SUPPORTED_DRIVERS="libfc bnx2fc qedf"
|
||||
|
||||
# Add --debug to enable debug messages
|
||||
FCOEMON_OPTS="--syslog"
|
12
SOURCES/fcoe.service
Normal file
12
SOURCES/fcoe.service
Normal file
@ -0,0 +1,12 @@
|
||||
[Unit]
|
||||
Description=Open-FCoE Inititator.
|
||||
After=syslog.target network.target lldpad.service
|
||||
|
||||
[Service]
|
||||
Type=forking
|
||||
EnvironmentFile=/etc/sysconfig/fcoe
|
||||
ExecStartPre=/sbin/modprobe -qa $SUPPORTED_DRIVERS
|
||||
ExecStart=/usr/sbin/fcoemon $FCOEMON_OPTS
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
25
SOURCES/quickstart.txt
Normal file
25
SOURCES/quickstart.txt
Normal file
@ -0,0 +1,25 @@
|
||||
Quick Start guide for Open-FCoE
|
||||
===============================
|
||||
|
||||
1. Install fcoe-utils package. This should also install dcbd, libhbaapi and
|
||||
libhbalinux as dependencies.
|
||||
|
||||
2. Rename /etc/fcoe/cfg-ethx so it corresponds with name of your network
|
||||
interface (e.g. /etc/fcoe/cfg-eth0). Copy and rename this file accordingly
|
||||
if you have more interfaces, which should be fcoe-enabled
|
||||
|
||||
3. Modify configuration files to enable FCoE. Set FCOE_ENABLE="yes" and
|
||||
DCB_REQUIRED="yes".
|
||||
|
||||
3. Run 'systemctl enable fcoe.service' to start FCoE per run level. This
|
||||
will setup FCoE to start on reboot.
|
||||
|
||||
4. Run 'systemctl enable lldpad.service' to start LLDP agent per run
|
||||
level. This will setup DCB to start on reboot.
|
||||
|
||||
5. Run 'systemctl start lldpad.service' to start LLDP agent.
|
||||
|
||||
6. Run 'dcbtool sc ethX dcb on; dcbtool sc ethX app:0 e:1;' for each fcoe-enabled
|
||||
interface to setup DCB for FCoE.
|
||||
|
||||
7. Run 'systemctl start fcoe.sertvice' to start FCoE.
|
326
SPECS/fcoe-utils.spec
Normal file
326
SPECS/fcoe-utils.spec
Normal file
@ -0,0 +1,326 @@
|
||||
# https://fedoraproject.org/wiki/Packaging:Guidelines#Compiler_flags
|
||||
%global _hardened_build 1
|
||||
|
||||
%global checkout f5cbb9a
|
||||
|
||||
Name: fcoe-utils
|
||||
Version: 1.0.32
|
||||
Release: 6%{?dist}
|
||||
Summary: Fibre Channel over Ethernet utilities
|
||||
Group: Applications/System
|
||||
License: GPLv2
|
||||
URL: http://www.open-fcoe.org
|
||||
# git://open-fcoe.org/fcoe/fcoe-utils.git
|
||||
Source0: https://github.com/morbidrsa/fcoe-utils/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
|
||||
Source1: quickstart.txt
|
||||
Source2: fcoe.service
|
||||
Source3: fcoe.config
|
||||
ExcludeArch: ppc s390
|
||||
Patch0: fcoe-utils-gcc7-fmt-truc-err.patch
|
||||
Patch1: fcoe-utils-gcc8-fmt-truc-err.patch
|
||||
Patch2: fcoe-utils-v1.0.32-1-fcoe-utils-Fix-get_ctlr_num-for-large-ctlr_-indices.patch
|
||||
Patch3: fcoe-utils-set-default-DCB_REQUIRED-to-no.patch
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake
|
||||
BuildRequires: libpciaccess-devel
|
||||
BuildRequires: libtool
|
||||
BuildRequires: lldpad-devel >= 0.9.43
|
||||
BuildRequires: systemd
|
||||
Requires: lldpad >= 0.9.43
|
||||
Requires: iproute
|
||||
Requires: device-mapper-multipath
|
||||
Requires(post): systemd
|
||||
Requires(preun): systemd
|
||||
Requires(postun): systemd
|
||||
|
||||
%description
|
||||
Fibre Channel over Ethernet utilities
|
||||
fcoeadm - command line tool for configuring FCoE interfaces
|
||||
fcoemon - service to configure DCB Ethernet QOS filters, works with lldpad
|
||||
|
||||
%prep
|
||||
%autosetup -p1
|
||||
cp -v %{SOURCE1} quickstart.txt
|
||||
|
||||
%build
|
||||
./bootstrap.sh
|
||||
%configure
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
make install DESTDIR=%{buildroot}
|
||||
rm -rf %{buildroot}/etc/init.d
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/sysconfig %{buildroot}%{_unitdir}
|
||||
rm -f %{buildroot}%{_unitdir}/*
|
||||
install -m 644 %{SOURCE2} %{buildroot}%{_unitdir}
|
||||
install -m 644 %{SOURCE3} %{buildroot}%{_sysconfdir}/sysconfig/fcoe
|
||||
mkdir -p %{buildroot}%{_libexecdir}/fcoe
|
||||
for file in \
|
||||
contrib/*.sh \
|
||||
debug/*sh
|
||||
do install -m 755 ${file} %{buildroot}%{_libexecdir}/fcoe/
|
||||
done
|
||||
# We supply our own config for fcoe.service
|
||||
rm -f %{buildroot}/%{_sysconfdir}/fcoe/config
|
||||
|
||||
%post
|
||||
%systemd_post fcoe.service
|
||||
|
||||
%preun
|
||||
%systemd_preun fcoe.service
|
||||
|
||||
%postun
|
||||
%systemd_postun_with_restart fcoe.service
|
||||
|
||||
%files
|
||||
%doc README COPYING QUICKSTART quickstart.txt
|
||||
%{_sbindir}/*
|
||||
%{_mandir}/man8/*
|
||||
%{_unitdir}/fcoe.service
|
||||
%{_sysconfdir}/fcoe/
|
||||
%config(noreplace) %{_sysconfdir}/fcoe/cfg-ethx
|
||||
%config(noreplace) %{_sysconfdir}/sysconfig/fcoe
|
||||
%{_sysconfdir}/bash_completion.d/*
|
||||
%{_libexecdir}/fcoe/
|
||||
|
||||
%changelog
|
||||
* Tue Aug 07 2018 Chris Leech <cleech@redhat.com> - 1.0.32-6
|
||||
- remove fcoe from SUPPORTED_DRIVERS in /etc/sysconfig/fcoe
|
||||
- add qedf to SUPPORTED_DRIVERS in /etc/sysconf/fcoe
|
||||
- added upstream fix for large fcoe ctrl numbers
|
||||
|
||||
* Fri Mar 16 2018 Chris Leech <cleech@redhat.com> - 1.0.32-5
|
||||
- fix some newer gcc 8 truncation format errors
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.32-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.32-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.32-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Thu Feb 09 2017 Chris Leech <cleech@redhat.com> - 1.0.32-1
|
||||
- update to 1.0.32
|
||||
|
||||
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.30-5.git91c0c8c
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Mon Feb 01 2016 Chris Leech <cleech@redhat.com> - 1.0.30-4.git91c0c8c
|
||||
- 1303433 package should not attempt to own /etc/bash_completion.d
|
||||
|
||||
* Mon Jul 06 2015 Chris Leech <cleech@redhat.com> - 1.0.30-2
|
||||
- fix display when libhbalinux includes hosts without a serial number
|
||||
|
||||
* Tue Jun 16 2015 Chris Leech <cleech@redhat.com> - 1.0.30-1
|
||||
- rebase to upstream v1.0.30-2-g91c0c8c
|
||||
|
||||
* Fri Oct 24 2014 Chris Leech <cleech@redhat.com> - 1.0.29-7
|
||||
- enable vn2vn mode in fcoeadm
|
||||
|
||||
* Tue Oct 07 2014 Chris Leech <cleech@redhat.com> - 1.0.29-6
|
||||
- update to upstream v1.0.29-29-g9267509
|
||||
|
||||
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.29-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.29-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Thu Nov 07 2013 Petr Šabata <contyk@redhat.com> - 1.0.29-3
|
||||
- Fix configure.ac for automake 1.14
|
||||
|
||||
* Thu Nov 07 2013 Petr Šabata <contyk@redhat.com> - 1.0.29-2
|
||||
- Don't install the old configuration file alongside the new one
|
||||
- Add bnx2fc to the SUPPORTED_DRIVERS for consistency with previous configuration
|
||||
|
||||
* Thu Aug 29 2013 Petr Šabata <contyk@redhat.com> - 1.0.29-1
|
||||
- 1.0.29 bump
|
||||
|
||||
* Wed Jul 31 2013 Petr Šabata <contyk@redhat.com> - 1.0.28-4
|
||||
- Drop the initscript-specific config patch
|
||||
|
||||
* Wed Jul 31 2013 Petr Šabata <contyk@redhat.com> - 1.0.28-3
|
||||
- Require just 'systemd' instead of 'systemd-units'
|
||||
- Patch the fcoemon manpage with a note for systemd users
|
||||
|
||||
* Mon Jun 10 2013 Petr Šabata <contyk@redhat.com> - 1.0.28-2
|
||||
- Enhance the format strings patch to fix ppc64 build failures too
|
||||
|
||||
* Tue Jun 04 2013 Petr Šabata <contyk@redhat.com> - 1.0.28-1
|
||||
- 1.0.28 bump
|
||||
|
||||
* Wed Mar 06 2013 Petr Šabata <contyk@redhat.com> - 1.0.27-1
|
||||
- 1.0.27 bump
|
||||
|
||||
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.25-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Wed Jan 09 2013 Petr Šabata <contyk@redhat.com> - 1.0.25-2
|
||||
- Don't build for s390x since it's not supported by kernel either
|
||||
|
||||
* Tue Nov 27 2012 Petr Šabata <contyk@redhat.com> - 1.0.25-1
|
||||
- 1.0.25 (with latest fixes)
|
||||
- Simplify the spec a bit
|
||||
- Fix bogus dates in changelog
|
||||
|
||||
* Thu Nov 01 2012 Petr Šabata <contyk@redhat.com> - 1.0.25-1
|
||||
|
||||
* Tue Aug 28 2012 Petr Šabata <contyk@redhat.com> - 1.0.24-2
|
||||
- Migrate to systemd scriptlets (#850104)
|
||||
|
||||
* Wed Aug 15 2012 Petr Šabata <contyk@redhat.com> - 1.0.24-1
|
||||
- 1.0.24 bump
|
||||
|
||||
* Mon Jul 23 2012 Petr Šabata <contyk@redhat.com> - 1.0.23-3
|
||||
- Don't exclude s390x.
|
||||
- Add AM_PROG_AR to configure.ac.
|
||||
|
||||
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.23-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Mon Jun 25 2012 Petr Šabata <contyk@redhat.com> - 1.0.23-1
|
||||
- Update to 1.0.23
|
||||
- Re-introduce ExcludeArch to be in line with EL.
|
||||
|
||||
* Thu Feb 16 2012 Petr Šabata <contyk@redhat.com> - 1.0.22-2
|
||||
- Fix the incorrect libhbalinux runtime dependency
|
||||
|
||||
* Mon Jan 23 2012 Petr Šabata <contyk@redhat.com> - 1.0.22-1
|
||||
- 1.0.22 bump
|
||||
- Remove dcbd from Description
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.21-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Thu Nov 24 2011 Petr Šabata <contyk@redhat.com> - 1.0.21-1
|
||||
- 1.0.21 bump
|
||||
|
||||
* Mon Oct 31 2011 Petr Sabata <contyk@redhat.com> - 1.0.20-5
|
||||
- Remove useless PIDFile from fcoe.service unit file
|
||||
|
||||
* Thu Oct 06 2011 Petr Sabata <contyk@redhat.com> - 1.0.20-4
|
||||
- Do not enable fcoemon by default (#701999)
|
||||
- Silence systemctl output
|
||||
|
||||
* Fri Sep 23 2011 Petr Sabata <contyk@redhat.com> - 1.0.20-3
|
||||
- Enable hardened build
|
||||
|
||||
* Mon Jul 18 2011 Petr Sabata <contyk@redhat.com> - 1.0.20-2
|
||||
- Drop SysV support in favor of systemd (#714683)
|
||||
- Remove ancient scriptlets (pre-1.0.7 era)
|
||||
- Update quickstart.txt to reflect new changes
|
||||
|
||||
* Thu Jul 07 2011 Petr Sabata <contyk@redhat.com> - 1.0.20-1
|
||||
- 1.0.20 bump
|
||||
|
||||
* Thu Jun 02 2011 Petr Sabata <contyk@redhat.com> - 1.0.19-1
|
||||
- 1.0.19 bump
|
||||
|
||||
* Tue May 3 2011 Petr Sabata <psabata@redhat.com> - 1.0.18-2
|
||||
- fcoemon: Do not create a world and group writable PID file
|
||||
|
||||
* Wed Apr 20 2011 Petr Sabata <psabata@redhat.com> - 1.0.18-1
|
||||
- 1.0.18 bump with latest bugfixes
|
||||
- Removing ExcludeArch completely; not related for Fedora
|
||||
- Buildroot cleanup
|
||||
|
||||
* Tue Apr 19 2011 Karsten Hopp <karsten@redhat.com> 1.0.17-1.1
|
||||
- remove excludearch ppc, required by anaconda.ppc
|
||||
|
||||
* Thu Feb 24 2011 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.0.17-1
|
||||
- Pull in new upstream release (required to build)
|
||||
- Fix git clone URL in comments
|
||||
- Drop fcoe-utils-1.0.7-init.patch, fcoe-utils-1.0.7-init-condrestart.patch
|
||||
and fcoe-utils-1.0.8-init-LSB.patch that are now upstream
|
||||
- Drop fcoe-utils-1.0.8-includes.patch and use a copy of kernel headers
|
||||
for all architectures (rename fcoe-sparc.patch to fcoe-include-headers.patch)
|
||||
Upstream added detection to avoid inclusion of kernel headers in the build
|
||||
and it expects to find the userland headers installed. Those have not
|
||||
yet propagated in Fedora.
|
||||
Use temporary this workaround, since fcoe is a requiment for anaconda
|
||||
and it failed to build for a while
|
||||
- Drop BuildRequires on kernel-devel
|
||||
- Add BuildRequires on autoconf (it is used and not installed by default
|
||||
on all build chroots)
|
||||
|
||||
* Wed Feb 23 2011 Dennis Gilmore <dennis@ausil.us> - 1.0.14-5
|
||||
- patch in headers used from kernel-devel on 32 bit sparc
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.14-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Tue Nov 30 2010 Petr Sabata <psabata@redhat.com> - 1.0.14-3
|
||||
- Removing dependency on vconfig, rhbz#658525
|
||||
|
||||
* Mon Jun 28 2010 Jan Zeleny <jzeleny@redhat.com> - 1.0.14-2
|
||||
- added device-mapper-multipath to requires (#603242)
|
||||
- added missing man pages for fcrls, fcnsq and fcping
|
||||
- update of init script - added condrestart, try-restart
|
||||
and force-reload options
|
||||
- added vconfig to requires (#589608)
|
||||
|
||||
* Mon May 24 2010 Jan Zeleny <jzeleny@redhat.com> - 1.0.14-1
|
||||
- rebased to 1.0.14, see bug #593824 for complete changelog
|
||||
|
||||
* Mon Apr 12 2010 Jan Zeleny <jzeleny@redhat.com> - 1.0.13-1
|
||||
- rebased to v1.0.13, some bugfixes, new fcoe related scripts
|
||||
|
||||
* Tue Mar 30 2010 Jan Zeleny <jzeleny@redhat.com> - 1.0.12-2.20100323git
|
||||
- some upstream updates
|
||||
- better fipvlan support
|
||||
- added fcoe_edd.sh script
|
||||
|
||||
* Tue Mar 16 2010 Jan Zeleny <jzeleny@redhat.com> - 1.0.12-1
|
||||
- rebased to version 1.0.12, improved functionality with lldpad
|
||||
and dcbd
|
||||
- removed /etc/fcoe/scripts/fcoeplumb
|
||||
|
||||
* Thu Dec 10 2009 Jan Zeleny <jzeleny@redhat.com> - 1.0.9-2.20091204git
|
||||
- excluded s390 and ppc
|
||||
|
||||
* Fri Dec 04 2009 Jan Zeleny <jzeleny@redhat.com> - 1.0.9-1.20091204git
|
||||
- rebase to latest version of fcoe-utils
|
||||
|
||||
* Mon Sep 14 2009 Jan Zeleny <jzeleny@redhat.com> - 1.0.8-3
|
||||
- update of init script to be LSB-compliant
|
||||
|
||||
* Fri Jul 31 2009 Jan Zeleny <jzeleny@redhat.com> - 1.0.8-2
|
||||
- patch for clean compilation without usage of upstream's ugly hack
|
||||
|
||||
* Thu Jul 30 2009 Jan Zeleny <jzeleny@redhat.com> - 1.0.8-1
|
||||
- rebase of fcoe-utils to 1.0.8, adjusted spec file
|
||||
|
||||
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.7-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Tue Jun 9 2009 Jan Zeleny <jzeleny@redhat.com> - 1.0.7-7
|
||||
- added quickstart file to doc (#500759)
|
||||
|
||||
* Thu May 14 2009 Jan Zeleny <jzeleny@redhat.com> - 1.0.7-6
|
||||
- renamed init script to fcoe, changed lock filename to fcoe
|
||||
(#497604)
|
||||
- init script modified to do condrestart properly
|
||||
- some modifications in spec file to apply previous change
|
||||
to older versions od init script during update
|
||||
- fixed issue with accepting long options (#498551)
|
||||
|
||||
* Mon May 4 2009 Jan Zeleny <jzeleny@redhat.com> - 1.0.7-5
|
||||
- fixed SIGSEGV when fcoe module isn't loaded (#498550)
|
||||
|
||||
* Mon Apr 27 2009 Jan Zeleny <jzeleny@redhat.com> - 1.0.7-4
|
||||
- added libhbalinux to Requires (#497605)
|
||||
- correction of spec file (_initddir -> _initrddir)
|
||||
|
||||
* Wed Apr 8 2009 Jan Zeleny <jzeleny@redhat.com> - 1.0.7-3
|
||||
- more minor corrections in spec file
|
||||
|
||||
* Thu Apr 2 2009 Jan Zeleny <jzeleny@redhat.com> - 1.0.7-2
|
||||
- minor corrections in spec file
|
||||
- moved init script to correct location
|
||||
- correction in the init script (chkconfig directives)
|
||||
|
||||
* Mon Mar 2 2009 Chris Leech <christopher.leech@intel.com> - 1.0.7-1
|
||||
- initial rpm build of fcoe tools
|
||||
|
Loading…
Reference in New Issue
Block a user