- fixed SIGSEGV when fcoe module isn't loaded (#498550)
- removed make patch, which was previously imported, but it's useless
This commit is contained in:
parent
47a58f52c0
commit
5af7502deb
12
fcoe-utils-1.0.7-free.patch
Normal file
12
fcoe-utils-1.0.7-free.patch
Normal file
@ -0,0 +1,12 @@
|
||||
--- fcoe-utils-1.0.7/fcoeadm.c 2009-03-27 21:40:22.000000000 +0100
|
||||
+++ fcoe-utils-1.0.7/fcoeadm.c.free 2009-05-04 11:29:00.000000000 +0200
|
||||
@@ -250,8 +250,8 @@ fcoeadm_find_fchost(char *ifname, char *
|
||||
}
|
||||
free(namelist[n]);
|
||||
}
|
||||
+ free(namelist);
|
||||
}
|
||||
- free(namelist);
|
||||
|
||||
return found;
|
||||
}
|
@ -1,22 +0,0 @@
|
||||
--- fcoe-utils-1.0.7/Makefile.am 2009-03-27 21:40:22.000000000 +0100
|
||||
+++ fcoe-utils-1.0.7/Makefile.am.initdir 2009-04-02 15:35:34.000000000 +0200
|
||||
@@ -56,7 +56,7 @@ etc/initd/fcoe:
|
||||
ln -s ${abs_srcdir}/etc/initd/initd.fcoe $@; \
|
||||
fi
|
||||
|
||||
-init_ddir = ${sysconfdir}/init.d
|
||||
+init_ddir = ${sysconfdir}/rc.d/init.d
|
||||
init_d_SCRIPTS = etc/initd/fcoe
|
||||
|
||||
dist_noinst_DATA = README COPYING INSTALL fcoe-utils.spec
|
||||
--- fcoe-utils-1.0.7/Makefile.in 2009-03-27 21:44:40.000000000 +0100
|
||||
+++ fcoe-utils-1.0.7/Makefile.in.initdir 2009-04-02 15:35:19.000000000 +0200
|
||||
@@ -211,7 +211,7 @@ fcoe_scripts_SCRIPTS = fcoeplumb
|
||||
dist_man_MANS = doc/fcoeadm.8 $(am__append_2)
|
||||
dist_noinst_SCRIPTS = etc/initd/initd.fcoe etc/initd/initd.suse etc/initd/initd.fedora
|
||||
CLEANFILES = etc/initd/fcoe
|
||||
-init_ddir = ${sysconfdir}/init.d
|
||||
+init_ddir = ${sysconfdir}/rc.d/init.d
|
||||
init_d_SCRIPTS = etc/initd/fcoe
|
||||
dist_noinst_DATA = README COPYING INSTALL fcoe-utils.spec
|
||||
all: all-am
|
@ -1,6 +1,6 @@
|
||||
Name: fcoe-utils
|
||||
Version: 1.0.7
|
||||
Release: 4%{?dist}
|
||||
Release: 5%{?dist}
|
||||
Summary: Fibre Channel over Ethernet utilities
|
||||
|
||||
Group: Applications/System
|
||||
@ -8,6 +8,7 @@ License: GPLv2
|
||||
URL: http://www.open-fcoe.org
|
||||
Source0: http://www.open-fcoe.org/openfc/downloads/%{name}-%{version}.tar.gz
|
||||
Patch0: fcoe-utils-1.0.7-init.patch
|
||||
Patch1: fcoe-utils-1.0.7-free.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildRequires: libhbaapi-devel dcbd-devel
|
||||
@ -24,6 +25,7 @@ fcoemon - service to configure DCB Ethernet QOS filters, works with dcbd
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .initPatch
|
||||
%patch1 -p1 -b .freePatch
|
||||
|
||||
|
||||
%build
|
||||
@ -72,6 +74,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed May 4 2009 Jan Zeleny <jzeleny@redhat.com> - 1.0.7-5
|
||||
- fixed SIGSEGV when fcoe module isn't loaded (#498550)
|
||||
|
||||
* Wed Apr 27 2009 Jan Zeleny <jzeleny@redhat.com> - 1.0.7-4
|
||||
- added libhbalinux to Requires (#497605)
|
||||
- correction of spec file (_initddir -> _initrddir)
|
||||
|
Loading…
Reference in New Issue
Block a user