Disable fatal diagnostic from gcc-11 for fping
This commit is contained in:
parent
fe12778cd2
commit
4962fcf0f9
@ -13,3 +13,16 @@ index 2f323e4..d6bc3c3 100644
|
||||
|
||||
AUTOMAKE_OPTIONS=subdir-objects
|
||||
noinst_LIBRARIES = lib/libutil.a libopenfcoe.a
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index 11262ec..08bc207 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -20,7 +20,7 @@ fcoemon_CFLAGS = $(AM_CFLAGS) $(DCBD_CFLAGS)
|
||||
## rules for building fcping
|
||||
fcping_SOURCES = fcping.c
|
||||
fcping_LDADD = lib/libutil.a libopenfcoe.a $(PCIACCESS_LIBS) -lrt
|
||||
-fcping_CFLAGS = $(AM_CFLAGS)
|
||||
+fcping_CFLAGS = $(AM_CFLAGS) -Wno-error=stringop-overflow
|
||||
|
||||
## rules for building fipvlan
|
||||
fipvlan_SOURCES = fipvlan.c
|
||||
|
@ -7,7 +7,7 @@
|
||||
|
||||
Name: fcoe-utils
|
||||
Version: 1.0.33
|
||||
Release: 1.git%{shortcommit0}%{?dist}
|
||||
Release: 2.git%{shortcommit0}%{?dist}
|
||||
Summary: Fibre Channel over Ethernet utilities
|
||||
License: GPLv2
|
||||
URL: http://www.open-fcoe.org
|
||||
@ -84,7 +84,10 @@ rm -f %{buildroot}/%{_sysconfdir}/fcoe/config
|
||||
%{_libexecdir}/fcoe/
|
||||
|
||||
%changelog
|
||||
* Wed Oct 28 2020 Jeff Law <aw@redhat.com> - 1.0.33-1.gitfe376de
|
||||
* Sat Nov 14 2020 Jeff Law <law@redhat.com> - 1.0.33-2.gitfe376de
|
||||
- Disable fatal diagnostic from gcc-11 for fping
|
||||
|
||||
* Wed Oct 28 2020 Jeff Law <law@redhat.com> - 1.0.33-1.gitfe376de
|
||||
- Disable fatal diagnostics from gcc-11 for fipvlan
|
||||
|
||||
* Mon Sep 21 2020 Chris Leech <cleech@redhat.com> - 1.0.33-0.gitfe376de
|
||||
|
Loading…
Reference in New Issue
Block a user