rebased to version 1.0.12 (improved functionality with lldpad and dcbd)
This commit is contained in:
parent
b5de791ef5
commit
34acd0925d
@ -1 +1 @@
|
|||||||
fcoe-utils-1.0.9.tar.gz
|
fcoe-utils-1.0.12.tar.gz
|
||||||
|
11
fcoe-utils-1.0.12-makefile-data-hook.patch
Normal file
11
fcoe-utils-1.0.12-makefile-data-hook.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- fcoe-utils-1.0.12/Makefile.am.orig 2010-03-15 17:02:19.000000000 +0100
|
||||||
|
+++ fcoe-utils-1.0.12/Makefile.am 2010-03-15 17:02:34.000000000 +0100
|
||||||
|
@@ -69,8 +69,3 @@
|
||||||
|
init_d_SCRIPTS = etc/initd/fcoe
|
||||||
|
|
||||||
|
dist_noinst_DATA = README COPYING INSTALL fcoe-utils.spec
|
||||||
|
-
|
||||||
|
-install-data-hook:
|
||||||
|
- if [ ! -f ${fcoe_configdir}/config ] ; then \
|
||||||
|
- cp etc/config ${fcoe_configdir}/config; \
|
||||||
|
- fi
|
@ -1,20 +1,20 @@
|
|||||||
--- fcoe-utils-1.0.7/etc/initd/initd.fedora 2009-03-27 21:40:22.000000000 +0100
|
--- fcoe-utils-1.0.7/etc/initd/initd.fedora 2009-03-27 21:40:22.000000000 +0100
|
||||||
+++ fcoe-utils-1.0.7/etc/initd/initd.fedora.update 2009-04-03 09:54:39.000000000 +0200
|
+++ fcoe-utils-1.0.7/etc/initd/initd.fedora.update 2009-04-03 09:54:39.000000000 +0200
|
||||||
service_status()
|
service_status()
|
||||||
@@ -245,6 +245,8 @@ service_status()
|
@@ -109,6 +109,8 @@ service_status()
|
||||||
else
|
else
|
||||||
echo "Created interfaces: $IF_LIST"
|
echo "Created interfaces: $interfaces"
|
||||||
fi
|
fi
|
||||||
+ test -f /var/lock/subsys/fcoe
|
+ test -f /var/lock/subsys/fcoe
|
||||||
+ return $@
|
+ return $@
|
||||||
}
|
}
|
||||||
|
|
||||||
case "$1" in
|
case "$1" in
|
||||||
@@ -284,6 +286,7 @@ case "$1" in
|
@@ -137,6 +139,7 @@ case "$1" in
|
||||||
;;
|
|
||||||
status)
|
status)
|
||||||
service_status
|
status
|
||||||
+ exit $?
|
+ exit $?
|
||||||
;;
|
;;
|
||||||
|
|
||||||
*)
|
*)
|
||||||
echo "Usage: $0 {start|stop|status|try-restart|restart|force-reload|reload}"
|
|
||||||
|
@ -16,25 +16,25 @@
|
|||||||
-# Default-Stop: 3 5
|
-# Default-Stop: 3 5
|
||||||
+# Default-Start:
|
+# Default-Start:
|
||||||
+# Default-Stop:
|
+# Default-Stop:
|
||||||
+# Short-Description: Open-FCoE SAN Setup
|
+# Short-Description: Open-FCoE Initiator
|
||||||
# Description: Open-FCoE SAN Setup
|
# Description: Open-FCoE Initiator
|
||||||
### END INIT INFO
|
### END INIT INFO
|
||||||
|
|
||||||
@@ -185,6 +187,9 @@ service_start()
|
@@ -69,6 +72,9 @@ service_start()
|
||||||
|
|
||||||
daemon --pidfile ${PID_FILE} ${FCOEMON} ${FCOEMON_OPTS}
|
daemon --pidfile ${PID_FILE} ${FCOEMON} ${FCOEMON_OPTS}
|
||||||
fi
|
|
||||||
|
|
||||||
+ echo
|
+ echo
|
||||||
+ touch /var/lock/subsys/fcoe
|
+ touch /var/lock/subsys/fcoe
|
||||||
+
|
+
|
||||||
return
|
echo
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -220,6 +226,7 @@ service_stop()
|
@@ -80,6 +86,7 @@ service_stop()
|
||||||
done
|
|
||||||
rm -f /var/run/fcoemon.*
|
rm -f /var/run/fcoemon.*
|
||||||
rm -f /tmp/fcoemon.dcbd.*
|
rm -f /tmp/fcoemon.dcbd.*
|
||||||
+ rm -f /var/lock/subsys/fcoe
|
+ rm -f /var/lock/subsys/fcoe
|
||||||
}
|
|
||||||
|
|
||||||
service_status()
|
echo
|
||||||
|
}
|
||||||
|
@ -1,8 +1,8 @@
|
|||||||
--- fcoe-utils-1.0.8/etc/initd/initd.fedora.orig 2009-09-14 09:40:57.000000000 +0200
|
--- fcoe-utils-1.0.8/etc/initd/initd.fedora.orig 2009-09-14 09:40:57.000000000 +0200
|
||||||
+++ fcoe-utils-1.0.8/etc/initd/initd.fedora 2009-09-14 11:06:34.000000000 +0200
|
+++ fcoe-utils-1.0.8/etc/initd/initd.fedora 2009-09-14 11:06:34.000000000 +0200
|
||||||
@@ -231,11 +231,13 @@
|
@@ -93,11 +93,13 @@
|
||||||
|
|
||||||
service_status()
|
status()
|
||||||
{
|
{
|
||||||
+ status=0
|
+ status=0
|
||||||
pidof $FCOEMON
|
pidof $FCOEMON
|
||||||
@ -12,12 +12,12 @@
|
|||||||
echo "$FCOEMON -- UNUSED"
|
echo "$FCOEMON -- UNUSED"
|
||||||
+ status=3
|
+ status=3
|
||||||
fi
|
fi
|
||||||
IF_LIST=`$FCOEADM -i 2>&1 | \
|
|
||||||
awk '/Symbolic Name:/{print $6}' | \
|
interfaces=`$FCOEADM -i 2>&1 | \
|
||||||
@@ -244,9 +246,15 @@
|
@@ -244,9 +246,15 @@
|
||||||
echo "No interfaces created."
|
echo "No interfaces created."
|
||||||
else
|
else
|
||||||
echo "Created interfaces: $IF_LIST"
|
echo "Created interfaces: $interfaces"
|
||||||
+ status=0
|
+ status=0
|
||||||
fi
|
fi
|
||||||
- test -f /var/lock/subsys/fcoe
|
- test -f /var/lock/subsys/fcoe
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
Name: fcoe-utils
|
Name: fcoe-utils
|
||||||
Version: 1.0.9
|
Version: 1.0.12
|
||||||
Release: 2.20091204git%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Fibre Channel over Ethernet utilities
|
Summary: Fibre Channel over Ethernet utilities
|
||||||
|
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
@ -17,11 +17,12 @@ Patch0: fcoe-utils-1.0.7-init.patch
|
|||||||
Patch1: fcoe-utils-1.0.7-init-condrestart.patch
|
Patch1: fcoe-utils-1.0.7-init-condrestart.patch
|
||||||
Patch2: fcoe-utils-1.0.8-includes.patch
|
Patch2: fcoe-utils-1.0.8-includes.patch
|
||||||
Patch3: fcoe-utils-1.0.8-init-LSB.patch
|
Patch3: fcoe-utils-1.0.8-init-LSB.patch
|
||||||
|
Patch4: fcoe-utils-1.0.12-makefile-data-hook.patch
|
||||||
BuildRoot: 1{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: 1{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
ExcludeArch: s390 ppc
|
ExcludeArch: s390 ppc
|
||||||
|
|
||||||
BuildRequires: libhbaapi-devel dcbd-devel libtool automake kernel-devel
|
BuildRequires: libhbaapi-devel lldpad-devel libtool automake kernel-devel
|
||||||
Requires: dcbd libhbalinux >= 1.0.8
|
Requires: lldpad libhbalinux >= 1.0.8
|
||||||
Requires(post): chkconfig
|
Requires(post): chkconfig
|
||||||
Requires(preun): chkconfig initscripts
|
Requires(preun): chkconfig initscripts
|
||||||
Requires(postun): initscripts
|
Requires(postun): initscripts
|
||||||
@ -29,7 +30,7 @@ Requires(postun): initscripts
|
|||||||
%description
|
%description
|
||||||
Fibre Channel over Ethernet utilities
|
Fibre Channel over Ethernet utilities
|
||||||
fcoeadm - command line tool for configuring FCoE interfaces
|
fcoeadm - command line tool for configuring FCoE interfaces
|
||||||
fcoemon - service to configure DCB Ethernet QOS filters, works with dcbd
|
fcoemon - service to configure DCB Ethernet QOS filters, works with dcbd or lldpad
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
@ -37,6 +38,7 @@ fcoemon - service to configure DCB Ethernet QOS filters, works with dcbd
|
|||||||
%patch1 -p1 -b .condrestartPatch
|
%patch1 -p1 -b .condrestartPatch
|
||||||
%patch2 -p1 -b .includes-fix
|
%patch2 -p1 -b .includes-fix
|
||||||
%patch3 -p1 -b .initLSB
|
%patch3 -p1 -b .initLSB
|
||||||
|
%patch4 -p1 -b .data-hook
|
||||||
|
|
||||||
%build
|
%build
|
||||||
./bootstrap.sh
|
./bootstrap.sh
|
||||||
@ -51,6 +53,8 @@ mkdir -p $RPM_BUILD_ROOT%{_initrddir}
|
|||||||
mv $RPM_BUILD_ROOT/etc/init.d/fcoe $RPM_BUILD_ROOT%{_initrddir}/fcoe
|
mv $RPM_BUILD_ROOT/etc/init.d/fcoe $RPM_BUILD_ROOT%{_initrddir}/fcoe
|
||||||
rm -rf $RPM_BUILD_ROOT/etc/init.d
|
rm -rf $RPM_BUILD_ROOT/etc/init.d
|
||||||
install -m 644 %SOURCE1 quickstart.txt
|
install -m 644 %SOURCE1 quickstart.txt
|
||||||
|
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/fcoe/
|
||||||
|
cp etc/config $RPM_BUILD_ROOT%{_sysconfdir}/fcoe/config
|
||||||
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
@ -99,6 +103,10 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Mar 16 2010 Jan Zeleny <jzeleny@redhat.com> - 1.0.12-1
|
||||||
|
- rebased to version 1.0.12, improved functionality with lldpad
|
||||||
|
and dcbd
|
||||||
|
|
||||||
* Thu Dec 10 2009 Jan Zeleny <jzeleny@redhat.com> - 1.0.9-2.20091204git
|
* Thu Dec 10 2009 Jan Zeleny <jzeleny@redhat.com> - 1.0.9-2.20091204git
|
||||||
- excluded s390 and ppc
|
- excluded s390 and ppc
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user