rebased to version 1.0.12 (improved functionality with lldpad and dcbd)

This commit is contained in:
Jan Zeleny 2010-03-16 08:52:46 +00:00
parent b5de791ef5
commit 34acd0925d
7 changed files with 56 additions and 37 deletions

View File

@ -1 +1 @@
fcoe-utils-1.0.9.tar.gz
fcoe-utils-1.0.12.tar.gz

View File

@ -0,0 +1,11 @@
--- fcoe-utils-1.0.12/Makefile.am.orig 2010-03-15 17:02:19.000000000 +0100
+++ fcoe-utils-1.0.12/Makefile.am 2010-03-15 17:02:34.000000000 +0100
@@ -69,8 +69,3 @@
init_d_SCRIPTS = etc/initd/fcoe
dist_noinst_DATA = README COPYING INSTALL fcoe-utils.spec
-
-install-data-hook:
- if [ ! -f ${fcoe_configdir}/config ] ; then \
- cp etc/config ${fcoe_configdir}/config; \
- fi

View File

@ -1,20 +1,20 @@
--- fcoe-utils-1.0.7/etc/initd/initd.fedora 2009-03-27 21:40:22.000000000 +0100
+++ fcoe-utils-1.0.7/etc/initd/initd.fedora.update 2009-04-03 09:54:39.000000000 +0200
service_status()
@@ -245,6 +245,8 @@ service_status()
@@ -109,6 +109,8 @@ service_status()
else
echo "Created interfaces: $IF_LIST"
echo "Created interfaces: $interfaces"
fi
+ test -f /var/lock/subsys/fcoe
+ return $@
}
case "$1" in
@@ -284,6 +286,7 @@ case "$1" in
;;
@@ -137,6 +139,7 @@ case "$1" in
status)
service_status
status
+ exit $?
;;
*)
echo "Usage: $0 {start|stop|status|try-restart|restart|force-reload|reload}"

View File

@ -16,25 +16,25 @@
-# Default-Stop: 3 5
+# Default-Start:
+# Default-Stop:
+# Short-Description: Open-FCoE SAN Setup
# Description: Open-FCoE SAN Setup
+# Short-Description: Open-FCoE Initiator
# Description: Open-FCoE Initiator
### END INIT INFO
@@ -185,6 +187,9 @@ service_start()
daemon --pidfile ${PID_FILE} ${FCOEMON} ${FCOEMON_OPTS}
fi
@@ -69,6 +72,9 @@ service_start()
+ echo
+ touch /var/lock/subsys/fcoe
daemon --pidfile ${PID_FILE} ${FCOEMON} ${FCOEMON_OPTS}
+ echo
+ touch /var/lock/subsys/fcoe
+
return
echo
}
@@ -220,6 +226,7 @@ service_stop()
done
@@ -80,6 +86,7 @@ service_stop()
rm -f /var/run/fcoemon.*
rm -f /tmp/fcoemon.dcbd.*
+ rm -f /var/lock/subsys/fcoe
}
+ rm -f /var/lock/subsys/fcoe
service_status()
echo
}

View File

@ -1,8 +1,8 @@
--- fcoe-utils-1.0.8/etc/initd/initd.fedora.orig 2009-09-14 09:40:57.000000000 +0200
+++ fcoe-utils-1.0.8/etc/initd/initd.fedora 2009-09-14 11:06:34.000000000 +0200
@@ -231,11 +231,13 @@
@@ -93,11 +93,13 @@
service_status()
status()
{
+ status=0
pidof $FCOEMON
@ -12,22 +12,22 @@
echo "$FCOEMON -- UNUSED"
+ status=3
fi
IF_LIST=`$FCOEADM -i 2>&1 | \
awk '/Symbolic Name:/{print $6}' | \
interfaces=`$FCOEADM -i 2>&1 | \
@@ -244,9 +246,15 @@
echo "No interfaces created."
else
echo "Created interfaces: $IF_LIST"
echo "Created interfaces: $interfaces"
+ status=0
fi
- test -f /var/lock/subsys/fcoe
- return $@
+ if [ -f /var/lock/subsys/fcoe -a $status -eq 3 ]; then
+ status=2
+ fi
+ if [ -f /var/run/fcoe.pid -a $status -eq 3 ]; then
+ status=1
+ fi
+ if [ -f /var/lock/subsys/fcoe -a $status -eq 3 ]; then
+ status=2
+ fi
+ if [ -f /var/run/fcoe.pid -a $status -eq 3 ]; then
+ status=1
+ fi
+ return $status
}

View File

@ -1,6 +1,6 @@
Name: fcoe-utils
Version: 1.0.9
Release: 2.20091204git%{?dist}
Version: 1.0.12
Release: 1%{?dist}
Summary: Fibre Channel over Ethernet utilities
Group: Applications/System
@ -17,11 +17,12 @@ Patch0: fcoe-utils-1.0.7-init.patch
Patch1: fcoe-utils-1.0.7-init-condrestart.patch
Patch2: fcoe-utils-1.0.8-includes.patch
Patch3: fcoe-utils-1.0.8-init-LSB.patch
Patch4: fcoe-utils-1.0.12-makefile-data-hook.patch
BuildRoot: 1{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
ExcludeArch: s390 ppc
BuildRequires: libhbaapi-devel dcbd-devel libtool automake kernel-devel
Requires: dcbd libhbalinux >= 1.0.8
BuildRequires: libhbaapi-devel lldpad-devel libtool automake kernel-devel
Requires: lldpad libhbalinux >= 1.0.8
Requires(post): chkconfig
Requires(preun): chkconfig initscripts
Requires(postun): initscripts
@ -29,7 +30,7 @@ Requires(postun): initscripts
%description
Fibre Channel over Ethernet utilities
fcoeadm - command line tool for configuring FCoE interfaces
fcoemon - service to configure DCB Ethernet QOS filters, works with dcbd
fcoemon - service to configure DCB Ethernet QOS filters, works with dcbd or lldpad
%prep
%setup -q
@ -37,6 +38,7 @@ fcoemon - service to configure DCB Ethernet QOS filters, works with dcbd
%patch1 -p1 -b .condrestartPatch
%patch2 -p1 -b .includes-fix
%patch3 -p1 -b .initLSB
%patch4 -p1 -b .data-hook
%build
./bootstrap.sh
@ -51,6 +53,8 @@ mkdir -p $RPM_BUILD_ROOT%{_initrddir}
mv $RPM_BUILD_ROOT/etc/init.d/fcoe $RPM_BUILD_ROOT%{_initrddir}/fcoe
rm -rf $RPM_BUILD_ROOT/etc/init.d
install -m 644 %SOURCE1 quickstart.txt
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/fcoe/
cp etc/config $RPM_BUILD_ROOT%{_sysconfdir}/fcoe/config
%clean
@ -99,6 +103,10 @@ fi
%changelog
* Tue Mar 16 2010 Jan Zeleny <jzeleny@redhat.com> - 1.0.12-1
- rebased to version 1.0.12, improved functionality with lldpad
and dcbd
* Thu Dec 10 2009 Jan Zeleny <jzeleny@redhat.com> - 1.0.9-2.20091204git
- excluded s390 and ppc

View File

@ -1 +1 @@
7a60e3063c3888cabcb40421a4525100 fcoe-utils-1.0.9.tar.gz
bd64197b18f9d743120846c03b66dcf5 fcoe-utils-1.0.12.tar.gz