upstream 1.0.34

drop gcc11 warning disabling patch, warnings have been addressed upstream
This commit is contained in:
Chris Leech 2021-04-14 11:10:12 -07:00
parent 40a726740a
commit 278397fbf4
3 changed files with 9 additions and 34 deletions

View File

@ -1,28 +0,0 @@
diff --git a/Makefile.am b/Makefile.am
index 2f323e4..d6bc3c3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,6 +25,10 @@ fcping_CFLAGS = $(AM_CFLAGS)
## rules for building fipvlan
fipvlan_SOURCES = fipvlan.c
fipvlan_LDADD = lib/libutil.a
+# These look like valid warnings, but the code may be fine in practice. Someone
+# with a deeper understanding of the source needs to chime in
+fipvlan_CFLAGS = $(AM_CFLAGS) -Wno-error=array-bounds -Wno-stringop-overread
+
AUTOMAKE_OPTIONS=subdir-objects
noinst_LIBRARIES = lib/libutil.a libopenfcoe.a
diff --git a/Makefile.am b/Makefile.am
index 11262ec..08bc207 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,7 +20,7 @@ fcoemon_CFLAGS = $(AM_CFLAGS) $(DCBD_CFLAGS)
## rules for building fcping
fcping_SOURCES = fcping.c
fcping_LDADD = lib/libutil.a libopenfcoe.a $(PCIACCESS_LIBS) -lrt
-fcping_CFLAGS = $(AM_CFLAGS)
+fcping_CFLAGS = $(AM_CFLAGS) -Wno-error=stringop-overflow
## rules for building fipvlan
fipvlan_SOURCES = fipvlan.c

View File

@ -1,19 +1,18 @@
# https://fedoraproject.org/wiki/Packaging:Guidelines#Compiler_flags # https://fedoraproject.org/wiki/Packaging:Guidelines#Compiler_flags
%global _hardened_build 1 %global _hardened_build 1
# v1.0.33-9-g848bcc6ba8c # v1.0.34
%global commit0 848bcc6ba8cda1f344663b4e73f1bc4857bcb4e3 %global commit0 14ef0d24c0657e56c68360afcfe64034d37323e0
%global shortcommit0 %(c=%{commit0}; echo ${c:0:7}) %global shortcommit0 %(c=%{commit0}; echo ${c:0:7})
Name: fcoe-utils Name: fcoe-utils
Version: 1.0.33 Version: 1.0.34
Release: 6.git%{shortcommit0}%{?dist} Release: 0.git%{shortcommit0}%{?dist}
Summary: Fibre Channel over Ethernet utilities Summary: Fibre Channel over Ethernet utilities
License: GPLv2 License: GPLv2
URL: http://www.open-fcoe.org URL: http://www.open-fcoe.org
Source0: https://github.com/openSUSE/fcoe-utils/archive/%{commit0}.tar.gz#/%{name}-%{version}-%{shortcommit0}.tar.gz Source0: https://github.com/openSUSE/fcoe-utils/archive/%{commit0}.tar.gz#/%{name}-%{version}-%{shortcommit0}.tar.gz
ExcludeArch: ppc s390 ExcludeArch: ppc s390
Patch3: %{name}-gcc11.patch
BuildRequires: autoconf BuildRequires: autoconf
BuildRequires: automake BuildRequires: automake
BuildRequires: libtool BuildRequires: libtool
@ -79,6 +78,10 @@ done
%{_libexecdir}/fcoe/ %{_libexecdir}/fcoe/
%changelog %changelog
* Wed Apr 14 2021 Chris Leech <cleech@redhat.com> - 1.0.34-0.git14ef0d2
- upstream 1.0.34
- drop gcc11 warning disabling patch, warnings have been addressed upstream
* Tue Mar 02 2021 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 1.0.33-6.git848bcc6 * Tue Mar 02 2021 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 1.0.33-6.git848bcc6
- Rebuilt for updated systemd-rpm-macros - Rebuilt for updated systemd-rpm-macros
See https://pagure.io/fesco/issue/2583. See https://pagure.io/fesco/issue/2583.

View File

@ -1 +1 @@
SHA512 (fcoe-utils-1.0.33-848bcc6.tar.gz) = 1f591d4b950032f015399a56233510146791d6c0ac510c1c384ce430273445f4be94aaaeb144469b856830401f2089bb951ec3ee253b425ec9e02fbd8d639bda SHA512 (fcoe-utils-1.0.34-14ef0d2.tar.gz) = bc58aa0e60eaae156e4ac8c6cbbca621abb52da8acd685d4839f15727c067b0ee99a483057c33449b87eef034971a98e3cb3ea6d24093d5239dedf27391dabae