Auto sync2gitlab import of fcoe-utils-1.0.33-4.git848bcc6.el8.src.rpm
This commit is contained in:
parent
1b0a48a648
commit
233028faaa
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
/fcoe-utils-1.0.33-848bcc6.tar.gz
|
115
0001-Revert-fcoemon-Correctly-handle-options-in-the-servi.patch
Normal file
115
0001-Revert-fcoemon-Correctly-handle-options-in-the-servi.patch
Normal file
@ -0,0 +1,115 @@
|
||||
From 729135eea0ed39b3dfd57b7ea15f284e67af532f Mon Sep 17 00:00:00 2001
|
||||
From: Chris Leech <cleech@redhat.com>
|
||||
Date: Mon, 18 Jan 2021 13:37:39 -0800
|
||||
Subject: [PATCH 1/1] Revert "fcoemon: Correctly handle options in the service
|
||||
file"
|
||||
|
||||
This reverts commit b06c3df0f0b06c1ad37b3bbf8bd602b24318aae6.
|
||||
---
|
||||
doc/fcoemon.txt | 6 +++---
|
||||
etc/systemd/fcoe.service | 4 ++--
|
||||
fcoemon.c | 24 +++++++++---------------
|
||||
3 files changed, 14 insertions(+), 20 deletions(-)
|
||||
|
||||
diff --git a/doc/fcoemon.txt b/doc/fcoemon.txt
|
||||
index ba70478d141..3bfb3581a1b 100644
|
||||
--- a/doc/fcoemon.txt
|
||||
+++ b/doc/fcoemon.txt
|
||||
@@ -53,13 +53,13 @@ OPTIONS
|
||||
-------
|
||||
*-f*, *--foreground*::
|
||||
Run *fcoemon* in the foreground.
|
||||
-*-d*, *--debug=yes|no*::
|
||||
- Enable or disable debugging messages.
|
||||
+*-d*, *--debug*::
|
||||
+ Enable debugging messages.
|
||||
*-l*, *--legacy*::
|
||||
Force fcoemon to use the legacy /sys/module/libfcoe/parameters/
|
||||
interface. The default is to use the newer /sys/bus/fcoe/ interfaces
|
||||
if they are available.
|
||||
-*-s*, *--syslog=yes|no*::
|
||||
+*-s*, *--syslog*::
|
||||
Use syslogd for logging. The default behavior is to log to stdout
|
||||
and stderr.
|
||||
*-h*, *--help*::
|
||||
diff --git a/etc/systemd/fcoe.service b/etc/systemd/fcoe.service
|
||||
index b1d95671573..5e5c8a2b67b 100644
|
||||
--- a/etc/systemd/fcoe.service
|
||||
+++ b/etc/systemd/fcoe.service
|
||||
@@ -4,9 +4,9 @@ After=syslog.target network.target
|
||||
|
||||
[Service]
|
||||
Type=simple
|
||||
-EnvironmentFile=/etc/fcoe/config
|
||||
+EnvironmentFile=/etc/sysconfig/fcoe
|
||||
ExecStartPre=/sbin/modprobe -qa $SUPPORTED_DRIVERS
|
||||
-ExecStart=/usr/sbin/fcoemon --foreground --debug=$DEBUG --syslog=$SYSLOG
|
||||
+ExecStart=/usr/sbin/fcoemon $FCOEMON_OPTS
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
||||
diff --git a/fcoemon.c b/fcoemon.c
|
||||
index 8c08bc5a032..0cc36fec304 100644
|
||||
--- a/fcoemon.c
|
||||
+++ b/fcoemon.c
|
||||
@@ -335,9 +335,9 @@ static int fcoe_vid_from_ifname(const char *ifname);
|
||||
* Table for getopt_long(3).
|
||||
*/
|
||||
static struct option fcm_options[] = {
|
||||
- {"debug", 1, NULL, 'd'},
|
||||
+ {"debug", 0, NULL, 'd'},
|
||||
{"legacy", 0, NULL, 'l'},
|
||||
- {"syslog", 1, NULL, 's'},
|
||||
+ {"syslog", 0, NULL, 's'},
|
||||
{"exec", 1, NULL, 'e'},
|
||||
{"foreground", 0, NULL, 'f'},
|
||||
{"version", 0, NULL, 'v'},
|
||||
@@ -3271,9 +3271,9 @@ static void fcm_usage(void)
|
||||
{
|
||||
printf("Usage: %s\n"
|
||||
"\t [-f|--foreground]\n"
|
||||
- "\t [-d|--debug=yes|no]\n"
|
||||
+ "\t [-d|--debug]\n"
|
||||
"\t [-l|--legacy]\n"
|
||||
- "\t [-s|--syslog=yes|no]\n"
|
||||
+ "\t [-s|--syslog]\n"
|
||||
"\t [-v|--version]\n"
|
||||
"\t [-h|--help]\n\n", progname);
|
||||
exit(1);
|
||||
@@ -3729,28 +3729,22 @@ int main(int argc, char **argv)
|
||||
sa_log_flags = 0;
|
||||
openlog(sa_log_prefix, LOG_CONS, LOG_DAEMON);
|
||||
|
||||
- while ((c = getopt_long(argc, argv, "fd:hls:v",
|
||||
+ while ((c = getopt_long(argc, argv, "fdhlsv",
|
||||
fcm_options, NULL)) != -1) {
|
||||
switch (c) {
|
||||
case 'f':
|
||||
fcm_fg = 1;
|
||||
break;
|
||||
case 'd':
|
||||
- if (!strncmp(optarg, "yes", 3) ||
|
||||
- !strncmp(optarg, "YES", 3)) {
|
||||
- fcoe_config.debug = 1;
|
||||
- enable_debug_log(1);
|
||||
- }
|
||||
+ fcoe_config.debug = 1;
|
||||
+ enable_debug_log(1);
|
||||
break;
|
||||
case 'l':
|
||||
force_legacy = true;
|
||||
break;
|
||||
case 's':
|
||||
- if (!strncmp(optarg, "yes", 3) ||
|
||||
- !strncmp(optarg, "YES", 3)) {
|
||||
- fcoe_config.use_syslog = 1;
|
||||
- enable_syslog(1);
|
||||
- }
|
||||
+ fcoe_config.use_syslog = 1;
|
||||
+ enable_syslog(1);
|
||||
break;
|
||||
case 'v':
|
||||
printf("%s\n", FCOE_UTILS_VERSION);
|
||||
--
|
||||
2.26.2
|
||||
|
@ -0,0 +1,78 @@
|
||||
From 1e6837c8ce063399eeb9580104da33f807e15443 Mon Sep 17 00:00:00 2001
|
||||
From: Chris Leech <cleech@redhat.com>
|
||||
Date: Tue, 23 Mar 2021 11:16:06 -0700
|
||||
Subject: [PATCH 2/5] Revert "Make gcc compiler happy about ifname string
|
||||
truncation."
|
||||
|
||||
This change dropped the "." from between the physical interface name and
|
||||
the vlan number, making fipvlan created vlan names incompatible with
|
||||
fcoeadm commands that ended up calling get_pci_dev_from_netdev in
|
||||
lib/sysfs_hba.c (fcoeadm -i). That requirement should be fixed, but for
|
||||
now lets deal with the fipvlan naming regression.
|
||||
|
||||
safe_makevlan_name isn't doing anything that can't be handled by
|
||||
checking the return from snprintf
|
||||
|
||||
This reverts commit eee875e6526786031ec916274deec92148677c38.
|
||||
|
||||
Signed-off-by: Chris Leech <cleech@redhat.com>
|
||||
---
|
||||
fipvlan.c | 34 +---------------------------------
|
||||
1 file changed, 1 insertion(+), 33 deletions(-)
|
||||
|
||||
diff --git a/fipvlan.c b/fipvlan.c
|
||||
index c8a07339314..fe8d7955cc5 100644
|
||||
--- a/fipvlan.c
|
||||
+++ b/fipvlan.c
|
||||
@@ -595,36 +595,6 @@ static int rtnl_listener_handler(struct nlmsghdr *nh, UNUSED void *arg)
|
||||
return -1;
|
||||
}
|
||||
|
||||
-static int
|
||||
-safe_makevlan_name(char *vlan_name, size_t vsz,
|
||||
- char *ifname, int vlan_num, char *suffix)
|
||||
-{
|
||||
- size_t ifsz = strlen(ifname);
|
||||
- size_t susz = strlen(suffix); /* should never be NULL */
|
||||
- int nusz;
|
||||
- char numbuf[16];
|
||||
- char *cp = vlan_name;
|
||||
-
|
||||
- nusz = snprintf(numbuf, sizeof(numbuf), "%d", vlan_num);
|
||||
-
|
||||
- if ((ifsz + susz + nusz + 2) > vsz) {
|
||||
- FIP_LOG_ERR(EINVAL,
|
||||
- "Cannot make VLAN name from ifname=\"%s\", vlan %d, and suffix=\"%s\"\n",
|
||||
- ifname, vlan_num, suffix);
|
||||
- return -EINVAL;
|
||||
- }
|
||||
- memcpy(cp, ifname, ifsz);
|
||||
- cp += ifsz;
|
||||
- memcpy(cp, numbuf, nusz);
|
||||
- cp += nusz;
|
||||
- if (susz > 0) {
|
||||
- memcpy(cp, suffix, susz);
|
||||
- cp += susz;
|
||||
- }
|
||||
- *cp = '\0';
|
||||
- return 0;
|
||||
-}
|
||||
-
|
||||
static int
|
||||
create_and_start_vlan(struct fcf *fcf, bool vn2vn)
|
||||
{
|
||||
@@ -654,10 +624,8 @@ create_and_start_vlan(struct fcf *fcf, bool vn2vn)
|
||||
real_dev->ifname, fcf->vlan, vlan->ifname);
|
||||
rc = 0;
|
||||
} else {
|
||||
- rc = safe_makevlan_name(vlan_name, sizeof(vlan_name),
|
||||
+ snprintf(vlan_name, IFNAMSIZ, "%s.%d%s",
|
||||
real_dev->ifname, fcf->vlan, config.suffix);
|
||||
- if (rc < 0)
|
||||
- return rc;
|
||||
rc = vlan_create(fcf->ifindex, fcf->vlan, vlan_name);
|
||||
if (rc < 0)
|
||||
printf("Failed to create VLAN device %s\n\t%s\n",
|
||||
--
|
||||
2.26.2
|
||||
|
38
0003-fix-VLAN-device-name-overflow-check.patch
Normal file
38
0003-fix-VLAN-device-name-overflow-check.patch
Normal file
@ -0,0 +1,38 @@
|
||||
From b9885692cb283a674e04528486984fb61f92a190 Mon Sep 17 00:00:00 2001
|
||||
From: Chris Leech <cleech@redhat.com>
|
||||
Date: Tue, 23 Mar 2021 11:21:17 -0700
|
||||
Subject: [PATCH 3/5] fix VLAN device name overflow check
|
||||
|
||||
check snprintf return for truncation
|
||||
|
||||
Signed-off-by: Chris Leech <cleech@redhat.com>
|
||||
---
|
||||
fipvlan.c | 12 ++++++++++--
|
||||
1 file changed, 10 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/fipvlan.c b/fipvlan.c
|
||||
index fe8d7955cc5..3ce913d5eaf 100644
|
||||
--- a/fipvlan.c
|
||||
+++ b/fipvlan.c
|
||||
@@ -624,8 +624,16 @@ create_and_start_vlan(struct fcf *fcf, bool vn2vn)
|
||||
real_dev->ifname, fcf->vlan, vlan->ifname);
|
||||
rc = 0;
|
||||
} else {
|
||||
- snprintf(vlan_name, IFNAMSIZ, "%s.%d%s",
|
||||
- real_dev->ifname, fcf->vlan, config.suffix);
|
||||
+ rc = snprintf(vlan_name, IFNAMSIZ, "%s.%d%s",
|
||||
+ real_dev->ifname, fcf->vlan,
|
||||
+ config.suffix);
|
||||
+ if (rc < 0 || rc >= IFNAMSIZ) {
|
||||
+ printf("Failed to create VLAN device "
|
||||
+ "(name %s.%d%s is too long)\n",
|
||||
+ real_dev->ifname, fcf->vlan,
|
||||
+ config.suffix);
|
||||
+ return -EINVAL;
|
||||
+ }
|
||||
rc = vlan_create(fcf->ifindex, fcf->vlan, vlan_name);
|
||||
if (rc < 0)
|
||||
printf("Failed to create VLAN device %s\n\t%s\n",
|
||||
--
|
||||
2.26.2
|
||||
|
@ -0,0 +1,35 @@
|
||||
From 108387a2aa986a8107faa7548f3f9e9c084749d2 Mon Sep 17 00:00:00 2001
|
||||
From: Chris Leech <cleech@redhat.com>
|
||||
Date: Wed, 24 Mar 2021 09:50:51 -0700
|
||||
Subject: [PATCH 4/5] fix regressions caused by safe_makepath change in
|
||||
libopenfcoe.c
|
||||
|
||||
This needs to use strlen(dname) not sizeof(dname) or the directory path
|
||||
is truncated. On a 64-bit arch an 8 byte truncation kind of looks like
|
||||
a valid path '/sys/bus' which is sort of funny unless you're debugging
|
||||
it.
|
||||
|
||||
This caused fcoeadm --fcf to fail to read in FCF info, and fcoeadm
|
||||
--lesb to fail to find the link error status block counters.
|
||||
|
||||
Signed-off-by: Chris Leech <cleech@redhat.com>
|
||||
---
|
||||
libopenfcoe.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/libopenfcoe.c b/libopenfcoe.c
|
||||
index 452ee803e63..cd35c868eee 100644
|
||||
--- a/libopenfcoe.c
|
||||
+++ b/libopenfcoe.c
|
||||
@@ -58,7 +58,7 @@ out_err:
|
||||
static char *safe_makepath(char *path, size_t path_sz,
|
||||
char *dname, char *fname)
|
||||
{
|
||||
- size_t dsz = sizeof(dname);
|
||||
+ size_t dsz = strlen(dname);
|
||||
size_t fsz = strlen(fname);
|
||||
char *cp = path;
|
||||
|
||||
--
|
||||
2.26.2
|
||||
|
35
0005-minor-fcoeadm-output-issues.patch
Normal file
35
0005-minor-fcoeadm-output-issues.patch
Normal file
@ -0,0 +1,35 @@
|
||||
From c4fe62dd3d26b30fdcf94c94f74bc0b9f7034c17 Mon Sep 17 00:00:00 2001
|
||||
From: Chris Leech <cleech@redhat.com>
|
||||
Date: Wed, 24 Mar 2021 10:17:52 -0700
|
||||
Subject: [PATCH 5/5] minor fcoeadm output issues
|
||||
|
||||
Signed-off-by: Chris Leech <cleech@redhat.com>
|
||||
---
|
||||
fcoeadm_display.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/fcoeadm_display.c b/fcoeadm_display.c
|
||||
index 585ecfae54e..c2ef33b82cf 100644
|
||||
--- a/fcoeadm_display.c
|
||||
+++ b/fcoeadm_display.c
|
||||
@@ -132,7 +132,7 @@ static void show_port_info(struct port_attributes *lp_info)
|
||||
printf(" Port Name: %s\n",
|
||||
lp_info->port_name);
|
||||
|
||||
- printf(" Fabric Name: %s\n",
|
||||
+ printf(" Fabric Name: %s\n",
|
||||
lp_info->fabric_name);
|
||||
|
||||
printf(" Speed: %s\n",
|
||||
@@ -853,7 +853,7 @@ static void print_fcoe_fcf_device(void *ep, UNUSED void *arg)
|
||||
buf = temp;
|
||||
printf(" Connection Mode: %s\n", buf);
|
||||
printf(" Fabric Name: 0x%016" PRIx64 "\n", fcf->fabric_name);
|
||||
- printf(" Switch Name 0x%016" PRIx64 "\n", fcf->switch_name);
|
||||
+ printf(" Switch Name: 0x%016" PRIx64 "\n", fcf->switch_name);
|
||||
mac2str(fcf->mac, mac, MAX_STR_LEN);
|
||||
printf(" MAC Address: %s\n", mac);
|
||||
printf(" FCF Priority: %u\n", fcf->priority);
|
||||
--
|
||||
2.26.2
|
||||
|
25
fcoe-utils-set-default-DCB_REQUIRED-to-no.patch
Normal file
25
fcoe-utils-set-default-DCB_REQUIRED-to-no.patch
Normal file
@ -0,0 +1,25 @@
|
||||
From db650524cb395827cf0d5a43bd07f77396513cd7 Mon Sep 17 00:00:00 2001
|
||||
From: rpm-build <rpm-build>
|
||||
Date: Tue, 7 Aug 2018 21:23:38 -0700
|
||||
Subject: [PATCH 1/1] set default DCB_REQUIRED to 'no'
|
||||
|
||||
---
|
||||
etc/cfg-ethx | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/etc/cfg-ethx b/etc/cfg-ethx
|
||||
index c5aaf36b4625..e2eb3309ccc7 100644
|
||||
--- a/etc/cfg-ethx
|
||||
+++ b/etc/cfg-ethx
|
||||
@@ -8,7 +8,7 @@ FCOE_ENABLE="yes"
|
||||
## Default: no
|
||||
# Indicate if DCB service is required at the Ethernet port
|
||||
# Normally set to "yes"
|
||||
-DCB_REQUIRED="yes"
|
||||
+DCB_REQUIRED="no"
|
||||
|
||||
## Type: yes/no
|
||||
## Default: no
|
||||
--
|
||||
2.14.4
|
||||
|
348
fcoe-utils.spec
Normal file
348
fcoe-utils.spec
Normal file
@ -0,0 +1,348 @@
|
||||
# https://fedoraproject.org/wiki/Packaging:Guidelines#Compiler_flags
|
||||
%global _hardened_build 1
|
||||
|
||||
# v1.0.33-9-g848bcc6ba8c
|
||||
%global commit0 848bcc6ba8cda1f344663b4e73f1bc4857bcb4e3
|
||||
%global shortcommit0 %(c=%{commit0}; echo ${c:0:7})
|
||||
|
||||
Name: fcoe-utils
|
||||
Version: 1.0.33
|
||||
Release: 4.git%{shortcommit0}%{?dist}
|
||||
Summary: Fibre Channel over Ethernet utilities
|
||||
Group: Applications/System
|
||||
License: GPLv2
|
||||
URL: http://www.open-fcoe.org
|
||||
Source0: https://github.com/openSUSE/fcoe-utils/archive/%{commit0}.tar.gz#/%{name}-%{version}-%{shortcommit0}.tar.gz
|
||||
Source1: quickstart.txt
|
||||
Source2: fcoe.service
|
||||
Source3: fcoe.config
|
||||
ExcludeArch: ppc s390
|
||||
Patch0: fcoe-utils-set-default-DCB_REQUIRED-to-no.patch
|
||||
Patch1: 0001-Revert-fcoemon-Correctly-handle-options-in-the-servi.patch
|
||||
Patch2: 0002-Revert-Make-gcc-compiler-happy-about-ifname-string-t.patch
|
||||
Patch3: 0003-fix-VLAN-device-name-overflow-check.patch
|
||||
Patch4: 0004-fix-regressions-caused-by-safe_makepath-change-in-li.patch
|
||||
Patch5: 0005-minor-fcoeadm-output-issues.patch
|
||||
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake
|
||||
BuildRequires: libpciaccess-devel
|
||||
BuildRequires: libtool
|
||||
BuildRequires: lldpad-devel >= 0.9.43
|
||||
BuildRequires: systemd
|
||||
Requires: lldpad >= 0.9.43
|
||||
Requires: iproute
|
||||
Requires: device-mapper-multipath
|
||||
Requires(post): systemd
|
||||
Requires(preun): systemd
|
||||
Requires(postun): systemd
|
||||
|
||||
%description
|
||||
Fibre Channel over Ethernet utilities
|
||||
fcoeadm - command line tool for configuring FCoE interfaces
|
||||
fcoemon - service to configure DCB Ethernet QOS filters, works with lldpad
|
||||
|
||||
%prep
|
||||
%autosetup -p1 -n fcoe-utils-%{commit0}
|
||||
cp -v %{SOURCE1} quickstart.txt
|
||||
|
||||
%build
|
||||
./bootstrap.sh
|
||||
%configure
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
make install DESTDIR=%{buildroot}
|
||||
rm -rf %{buildroot}/etc/init.d
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/sysconfig %{buildroot}%{_unitdir}
|
||||
rm -f %{buildroot}%{_unitdir}/*
|
||||
install -m 644 %{SOURCE2} %{buildroot}%{_unitdir}
|
||||
install -m 644 %{SOURCE3} %{buildroot}%{_sysconfdir}/sysconfig/fcoe
|
||||
mkdir -p %{buildroot}%{_libexecdir}/fcoe
|
||||
for file in \
|
||||
contrib/*.sh \
|
||||
debug/*sh
|
||||
do install -m 755 ${file} %{buildroot}%{_libexecdir}/fcoe/
|
||||
done
|
||||
# We supply our own config for fcoe.service
|
||||
rm -f %{buildroot}/%{_sysconfdir}/fcoe/config
|
||||
|
||||
%post
|
||||
%systemd_post fcoe.service
|
||||
|
||||
%preun
|
||||
%systemd_preun fcoe.service
|
||||
|
||||
%postun
|
||||
%systemd_postun_with_restart fcoe.service
|
||||
|
||||
%files
|
||||
%doc README COPYING QUICKSTART quickstart.txt
|
||||
%{_sbindir}/*
|
||||
%{_mandir}/man8/*
|
||||
%{_unitdir}/fcoe.service
|
||||
%{_sysconfdir}/fcoe/
|
||||
%config(noreplace) %{_sysconfdir}/fcoe/cfg-ethx
|
||||
%config(noreplace) %{_sysconfdir}/sysconfig/fcoe
|
||||
%{_datadir}/bash-completion/completions/*
|
||||
%{_libexecdir}/fcoe/
|
||||
|
||||
%changelog
|
||||
* Thu Jun 10 2021 Chris Leech <cleech@redhat.com> - 1.0.33-4.git848bcc6
|
||||
- rebuilt for 8.5
|
||||
|
||||
* Tue Mar 23 2021 Chris Leech <cleech@redhat.com> - 1.0.33-3.git848bcc6
|
||||
- 1918561 regression in fipvlan VLAN name generation and fcoeadm commands
|
||||
|
||||
* Mon Jan 18 2021 Chris Leech <cleech@redhat.com> - 1.0.33-2.git848bcc6
|
||||
- 1897503 revert breaking upstream change to command line options
|
||||
|
||||
* Tue Nov 03 2020 Chris Leech <cleech@redhat.com> - 1.0.33-1.git848bcc6
|
||||
- 1889536 add back default change of DCB_REQUIRED="no" for RHEL 8
|
||||
|
||||
* Tue Nov 03 2020 Chris Leech <cleech@redhat.com> - 1.0.33-0.git848bcc6
|
||||
- 1889536 new version
|
||||
|
||||
* Fri Dec 06 2019 Chris Leech <cleech@redhat.com> - 1.0.32-7
|
||||
- 1776492 fcoemon: fix ignored devices from recv buffer resize bug
|
||||
|
||||
* Tue Aug 07 2018 Chris Leech <cleech@redhat.com> - 1.0.32-6
|
||||
- remove fcoe from SUPPORTED_DRIVERS in /etc/sysconfig/fcoe
|
||||
- add qedf to SUPPORTED_DRIVERS in /etc/sysconf/fcoe
|
||||
- added upstream fix for large fcoe ctrl numbers
|
||||
|
||||
* Fri Mar 16 2018 Chris Leech <cleech@redhat.com> - 1.0.32-5
|
||||
- fix some newer gcc 8 truncation format errors
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.32-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.32-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.32-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Thu Feb 09 2017 Chris Leech <cleech@redhat.com> - 1.0.32-1
|
||||
- update to 1.0.32
|
||||
|
||||
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.30-5.git91c0c8c
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Mon Feb 01 2016 Chris Leech <cleech@redhat.com> - 1.0.30-4.git91c0c8c
|
||||
- 1303433 package should not attempt to own /etc/bash_completion.d
|
||||
|
||||
* Mon Jul 06 2015 Chris Leech <cleech@redhat.com> - 1.0.30-2
|
||||
- fix display when libhbalinux includes hosts without a serial number
|
||||
|
||||
* Tue Jun 16 2015 Chris Leech <cleech@redhat.com> - 1.0.30-1
|
||||
- rebase to upstream v1.0.30-2-g91c0c8c
|
||||
|
||||
* Fri Oct 24 2014 Chris Leech <cleech@redhat.com> - 1.0.29-7
|
||||
- enable vn2vn mode in fcoeadm
|
||||
|
||||
* Tue Oct 07 2014 Chris Leech <cleech@redhat.com> - 1.0.29-6
|
||||
- update to upstream v1.0.29-29-g9267509
|
||||
|
||||
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.29-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.29-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Thu Nov 07 2013 Petr Šabata <contyk@redhat.com> - 1.0.29-3
|
||||
- Fix configure.ac for automake 1.14
|
||||
|
||||
* Thu Nov 07 2013 Petr Šabata <contyk@redhat.com> - 1.0.29-2
|
||||
- Don't install the old configuration file alongside the new one
|
||||
- Add bnx2fc to the SUPPORTED_DRIVERS for consistency with previous configuration
|
||||
|
||||
* Thu Aug 29 2013 Petr Šabata <contyk@redhat.com> - 1.0.29-1
|
||||
- 1.0.29 bump
|
||||
|
||||
* Wed Jul 31 2013 Petr Šabata <contyk@redhat.com> - 1.0.28-4
|
||||
- Drop the initscript-specific config patch
|
||||
|
||||
* Wed Jul 31 2013 Petr Šabata <contyk@redhat.com> - 1.0.28-3
|
||||
- Require just 'systemd' instead of 'systemd-units'
|
||||
- Patch the fcoemon manpage with a note for systemd users
|
||||
|
||||
* Mon Jun 10 2013 Petr Šabata <contyk@redhat.com> - 1.0.28-2
|
||||
- Enhance the format strings patch to fix ppc64 build failures too
|
||||
|
||||
* Tue Jun 04 2013 Petr Šabata <contyk@redhat.com> - 1.0.28-1
|
||||
- 1.0.28 bump
|
||||
|
||||
* Wed Mar 06 2013 Petr Šabata <contyk@redhat.com> - 1.0.27-1
|
||||
- 1.0.27 bump
|
||||
|
||||
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.25-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Wed Jan 09 2013 Petr Šabata <contyk@redhat.com> - 1.0.25-2
|
||||
- Don't build for s390x since it's not supported by kernel either
|
||||
|
||||
* Tue Nov 27 2012 Petr Šabata <contyk@redhat.com> - 1.0.25-1
|
||||
- 1.0.25 (with latest fixes)
|
||||
- Simplify the spec a bit
|
||||
- Fix bogus dates in changelog
|
||||
|
||||
* Thu Nov 01 2012 Petr Šabata <contyk@redhat.com> - 1.0.25-1
|
||||
|
||||
* Tue Aug 28 2012 Petr Šabata <contyk@redhat.com> - 1.0.24-2
|
||||
- Migrate to systemd scriptlets (#850104)
|
||||
|
||||
* Wed Aug 15 2012 Petr Šabata <contyk@redhat.com> - 1.0.24-1
|
||||
- 1.0.24 bump
|
||||
|
||||
* Mon Jul 23 2012 Petr Šabata <contyk@redhat.com> - 1.0.23-3
|
||||
- Don't exclude s390x.
|
||||
- Add AM_PROG_AR to configure.ac.
|
||||
|
||||
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.23-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Mon Jun 25 2012 Petr Šabata <contyk@redhat.com> - 1.0.23-1
|
||||
- Update to 1.0.23
|
||||
- Re-introduce ExcludeArch to be in line with EL.
|
||||
|
||||
* Thu Feb 16 2012 Petr Šabata <contyk@redhat.com> - 1.0.22-2
|
||||
- Fix the incorrect libhbalinux runtime dependency
|
||||
|
||||
* Mon Jan 23 2012 Petr Šabata <contyk@redhat.com> - 1.0.22-1
|
||||
- 1.0.22 bump
|
||||
- Remove dcbd from Description
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.21-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Thu Nov 24 2011 Petr Šabata <contyk@redhat.com> - 1.0.21-1
|
||||
- 1.0.21 bump
|
||||
|
||||
* Mon Oct 31 2011 Petr Sabata <contyk@redhat.com> - 1.0.20-5
|
||||
- Remove useless PIDFile from fcoe.service unit file
|
||||
|
||||
* Thu Oct 06 2011 Petr Sabata <contyk@redhat.com> - 1.0.20-4
|
||||
- Do not enable fcoemon by default (#701999)
|
||||
- Silence systemctl output
|
||||
|
||||
* Fri Sep 23 2011 Petr Sabata <contyk@redhat.com> - 1.0.20-3
|
||||
- Enable hardened build
|
||||
|
||||
* Mon Jul 18 2011 Petr Sabata <contyk@redhat.com> - 1.0.20-2
|
||||
- Drop SysV support in favor of systemd (#714683)
|
||||
- Remove ancient scriptlets (pre-1.0.7 era)
|
||||
- Update quickstart.txt to reflect new changes
|
||||
|
||||
* Thu Jul 07 2011 Petr Sabata <contyk@redhat.com> - 1.0.20-1
|
||||
- 1.0.20 bump
|
||||
|
||||
* Thu Jun 02 2011 Petr Sabata <contyk@redhat.com> - 1.0.19-1
|
||||
- 1.0.19 bump
|
||||
|
||||
* Tue May 3 2011 Petr Sabata <psabata@redhat.com> - 1.0.18-2
|
||||
- fcoemon: Do not create a world and group writable PID file
|
||||
|
||||
* Wed Apr 20 2011 Petr Sabata <psabata@redhat.com> - 1.0.18-1
|
||||
- 1.0.18 bump with latest bugfixes
|
||||
- Removing ExcludeArch completely; not related for Fedora
|
||||
- Buildroot cleanup
|
||||
|
||||
* Tue Apr 19 2011 Karsten Hopp <karsten@redhat.com> 1.0.17-1.1
|
||||
- remove excludearch ppc, required by anaconda.ppc
|
||||
|
||||
* Thu Feb 24 2011 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.0.17-1
|
||||
- Pull in new upstream release (required to build)
|
||||
- Fix git clone URL in comments
|
||||
- Drop fcoe-utils-1.0.7-init.patch, fcoe-utils-1.0.7-init-condrestart.patch
|
||||
and fcoe-utils-1.0.8-init-LSB.patch that are now upstream
|
||||
- Drop fcoe-utils-1.0.8-includes.patch and use a copy of kernel headers
|
||||
for all architectures (rename fcoe-sparc.patch to fcoe-include-headers.patch)
|
||||
Upstream added detection to avoid inclusion of kernel headers in the build
|
||||
and it expects to find the userland headers installed. Those have not
|
||||
yet propagated in Fedora.
|
||||
Use temporary this workaround, since fcoe is a requiment for anaconda
|
||||
and it failed to build for a while
|
||||
- Drop BuildRequires on kernel-devel
|
||||
- Add BuildRequires on autoconf (it is used and not installed by default
|
||||
on all build chroots)
|
||||
|
||||
* Wed Feb 23 2011 Dennis Gilmore <dennis@ausil.us> - 1.0.14-5
|
||||
- patch in headers used from kernel-devel on 32 bit sparc
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.14-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Tue Nov 30 2010 Petr Sabata <psabata@redhat.com> - 1.0.14-3
|
||||
- Removing dependency on vconfig, rhbz#658525
|
||||
|
||||
* Mon Jun 28 2010 Jan Zeleny <jzeleny@redhat.com> - 1.0.14-2
|
||||
- added device-mapper-multipath to requires (#603242)
|
||||
- added missing man pages for fcrls, fcnsq and fcping
|
||||
- update of init script - added condrestart, try-restart
|
||||
and force-reload options
|
||||
- added vconfig to requires (#589608)
|
||||
|
||||
* Mon May 24 2010 Jan Zeleny <jzeleny@redhat.com> - 1.0.14-1
|
||||
- rebased to 1.0.14, see bug #593824 for complete changelog
|
||||
|
||||
* Mon Apr 12 2010 Jan Zeleny <jzeleny@redhat.com> - 1.0.13-1
|
||||
- rebased to v1.0.13, some bugfixes, new fcoe related scripts
|
||||
|
||||
* Tue Mar 30 2010 Jan Zeleny <jzeleny@redhat.com> - 1.0.12-2.20100323git
|
||||
- some upstream updates
|
||||
- better fipvlan support
|
||||
- added fcoe_edd.sh script
|
||||
|
||||
* Tue Mar 16 2010 Jan Zeleny <jzeleny@redhat.com> - 1.0.12-1
|
||||
- rebased to version 1.0.12, improved functionality with lldpad
|
||||
and dcbd
|
||||
- removed /etc/fcoe/scripts/fcoeplumb
|
||||
|
||||
* Thu Dec 10 2009 Jan Zeleny <jzeleny@redhat.com> - 1.0.9-2.20091204git
|
||||
- excluded s390 and ppc
|
||||
|
||||
* Fri Dec 04 2009 Jan Zeleny <jzeleny@redhat.com> - 1.0.9-1.20091204git
|
||||
- rebase to latest version of fcoe-utils
|
||||
|
||||
* Mon Sep 14 2009 Jan Zeleny <jzeleny@redhat.com> - 1.0.8-3
|
||||
- update of init script to be LSB-compliant
|
||||
|
||||
* Fri Jul 31 2009 Jan Zeleny <jzeleny@redhat.com> - 1.0.8-2
|
||||
- patch for clean compilation without usage of upstream's ugly hack
|
||||
|
||||
* Thu Jul 30 2009 Jan Zeleny <jzeleny@redhat.com> - 1.0.8-1
|
||||
- rebase of fcoe-utils to 1.0.8, adjusted spec file
|
||||
|
||||
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.7-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Tue Jun 9 2009 Jan Zeleny <jzeleny@redhat.com> - 1.0.7-7
|
||||
- added quickstart file to doc (#500759)
|
||||
|
||||
* Thu May 14 2009 Jan Zeleny <jzeleny@redhat.com> - 1.0.7-6
|
||||
- renamed init script to fcoe, changed lock filename to fcoe
|
||||
(#497604)
|
||||
- init script modified to do condrestart properly
|
||||
- some modifications in spec file to apply previous change
|
||||
to older versions od init script during update
|
||||
- fixed issue with accepting long options (#498551)
|
||||
|
||||
* Mon May 4 2009 Jan Zeleny <jzeleny@redhat.com> - 1.0.7-5
|
||||
- fixed SIGSEGV when fcoe module isn't loaded (#498550)
|
||||
|
||||
* Mon Apr 27 2009 Jan Zeleny <jzeleny@redhat.com> - 1.0.7-4
|
||||
- added libhbalinux to Requires (#497605)
|
||||
- correction of spec file (_initddir -> _initrddir)
|
||||
|
||||
* Wed Apr 8 2009 Jan Zeleny <jzeleny@redhat.com> - 1.0.7-3
|
||||
- more minor corrections in spec file
|
||||
|
||||
* Thu Apr 2 2009 Jan Zeleny <jzeleny@redhat.com> - 1.0.7-2
|
||||
- minor corrections in spec file
|
||||
- moved init script to correct location
|
||||
- correction in the init script (chkconfig directives)
|
||||
|
||||
* Mon Mar 2 2009 Chris Leech <christopher.leech@intel.com> - 1.0.7-1
|
||||
- initial rpm build of fcoe tools
|
||||
|
5
fcoe.config
Normal file
5
fcoe.config
Normal file
@ -0,0 +1,5 @@
|
||||
# All supported drivers listed here are loaded when service starts
|
||||
SUPPORTED_DRIVERS="libfc bnx2fc qedf"
|
||||
|
||||
# Add --debug to enable debug messages
|
||||
FCOEMON_OPTS="--syslog"
|
12
fcoe.service
Normal file
12
fcoe.service
Normal file
@ -0,0 +1,12 @@
|
||||
[Unit]
|
||||
Description=Open-FCoE Inititator.
|
||||
After=syslog.target network.target lldpad.service
|
||||
|
||||
[Service]
|
||||
Type=forking
|
||||
EnvironmentFile=/etc/sysconfig/fcoe
|
||||
ExecStartPre=/sbin/modprobe -qa $SUPPORTED_DRIVERS
|
||||
ExecStart=/usr/sbin/fcoemon $FCOEMON_OPTS
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
25
quickstart.txt
Normal file
25
quickstart.txt
Normal file
@ -0,0 +1,25 @@
|
||||
Quick Start guide for Open-FCoE
|
||||
===============================
|
||||
|
||||
1. Install fcoe-utils package. This should also install dcbd, libhbaapi and
|
||||
libhbalinux as dependencies.
|
||||
|
||||
2. Rename /etc/fcoe/cfg-ethx so it corresponds with name of your network
|
||||
interface (e.g. /etc/fcoe/cfg-eth0). Copy and rename this file accordingly
|
||||
if you have more interfaces, which should be fcoe-enabled
|
||||
|
||||
3. Modify configuration files to enable FCoE. Set FCOE_ENABLE="yes" and
|
||||
DCB_REQUIRED="yes".
|
||||
|
||||
3. Run 'systemctl enable fcoe.service' to start FCoE per run level. This
|
||||
will setup FCoE to start on reboot.
|
||||
|
||||
4. Run 'systemctl enable lldpad.service' to start LLDP agent per run
|
||||
level. This will setup DCB to start on reboot.
|
||||
|
||||
5. Run 'systemctl start lldpad.service' to start LLDP agent.
|
||||
|
||||
6. Run 'dcbtool sc ethX dcb on; dcbtool sc ethX app:0 e:1;' for each fcoe-enabled
|
||||
interface to setup DCB for FCoE.
|
||||
|
||||
7. Run 'systemctl start fcoe.sertvice' to start FCoE.
|
Loading…
Reference in New Issue
Block a user