import fabtests-1.9.0rc1-1.el8

This commit is contained in:
CentOS Sources 2020-01-21 15:44:08 -05:00 committed by Andrew Lukoshko
commit 65ded0e50f
5 changed files with 144 additions and 0 deletions

1
.fabtests.metadata Normal file
View File

@ -0,0 +1 @@
0d968b928074c6e9a578fed5c80c7712d6369371 SOURCES/fabtests-1.9.0rc1.tar.bz2

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
SOURCES/fabtests-1.9.0rc1.tar.bz2

View File

@ -0,0 +1,20 @@
diff --git a/fabtests/scripts/rft_yaml_to_junit_xml b/fabtests/scripts/rft_yaml_to_junit_xml
index feb646366..2d3b3a30c 100755
--- a/fabtests/scripts/rft_yaml_to_junit_xml
+++ b/fabtests/scripts/rft_yaml_to_junit_xml
@@ -1,4 +1,4 @@
-#!/usr/bin/env ruby
+#!/usr/bin/ruby
# Copyright (c) 2015 Cisco Systems, Inc. All rights reserved.
#
diff --git a/fabtests/scripts/runfabtests.sh b/fabtests/scripts/runfabtests.sh
index aba23be6f..73f55d07b 100755
--- a/fabtests/scripts/runfabtests.sh
+++ b/fabtests/scripts/runfabtests.sh
@@ -1,4 +1,4 @@
-#!/usr/bin/env bash
+#!/bin/bash
#
# Copyright (c) 2017-2019, Intel Corporation. All rights reserved.

View File

@ -0,0 +1,19 @@
diff --git a/fabtests/scripts/runfabtests.sh b/fabtests/scripts/runfabtests.sh
index aba23be6f..70f86a749 100755
--- a/fabtests/scripts/runfabtests.sh
+++ b/fabtests/scripts/runfabtests.sh
@@ -72,11 +72,11 @@ declare -i fail_count=0
declare -i total_failures=0
if [[ "$(uname)" == "FreeBSD" ]]; then
- declare -ri FI_ENODATA=$(python -c 'import errno; print(errno.ENOMSG)')
+ declare -ri FI_ENODATA=$(python3 -c 'import errno; print(errno.ENOMSG)')
else
- declare -ri FI_ENODATA=$(python -c 'import errno; print(errno.ENODATA)')
+ declare -ri FI_ENODATA=$(python3 -c 'import errno; print(errno.ENODATA)')
fi
-declare -ri FI_ENOSYS=$(python -c 'import errno; print(errno.ENOSYS)')
+declare -ri FI_ENOSYS=$(python3 -c 'import errno; print(errno.ENOSYS)')
neg_unit_tests=(
"fi_dgram g00n13s"

103
SPECS/fabtests.spec Normal file
View File

@ -0,0 +1,103 @@
Name: fabtests
Version: 1.9.0rc1
Release: 1%{?dist}
Summary: Test suite for libfabric API
# include/jsmn.h and common/jsmn.c are licensed under MIT.
# All other source files permit distribution under BSD. Some of them
# additionaly expressly allow the option to be licensed under GPLv2.
# See the license headers in individual source files to see which those are.
License: BSD and (BSD or GPLv2) and MIT
Url: https://github.com/ofiwg/libfabric
Source: https://github.com/ofiwg/libfabric/releases/download/v%{version}/%{name}-%{version}.tar.bz2
Patch0: 0001-adjust-shebang-lines-in-rft_yaml_to_junit_xml-and-ru.patch
Patch1: runfabtests-python3.patch
BuildRequires: libfabric-devel >= %{version}
%ifarch %{valgrind_arches}
BuildRequires: valgrind-devel
%endif
BuildRequires: gcc
%description
Fabtests provides a set of examples that uses libfabric - a high-performance
fabric software library.
%prep
%setup -q
%patch0 -p2
%patch1 -p2
%build
%configure \
%ifarch %{valgrind_arches}
--with-valgrind \
%endif
make %{?_smp_mflags} V=1
%install
%make_install
# remove unpackaged files from the buildroot
rm -f %{buildroot}%{_libdir}/*.la
%files
%{_datadir}/%{name}/
%{_bindir}/*
%{_mandir}/man1/*
%{_mandir}/man7/*
%doc AUTHORS README
%license COPYING
%changelog
* Mon Nov 11 2019 Honggang Li <honli@redhat.com> - 1.9.0rc1-1
- Rebase to upstream release v1.9.0rc1
- Resolves: bz1770650
* Mon Jul 1 2019 Honggang Li <honli@redhat.com> - 1.8.0-1
- Rebase to upstream release v1.8.0
- Resolves: bz1710870
* Mon Dec 10 2018 Honggang Li <honli@redhat.com> - 1.6.2-1
- Rebase to upstream release v1.6.2
- Resolves: bz1654871
* Sat Aug 4 2018 Florian Weimer <fweimer@redhat.com> - 1.6.1-3
- Fix shell syntax error in %%build
* Fri Aug 3 2018 Florian Weimer <fweimer@redhat.com> - 1.6.1-2
- Honor %%{valgrind_arches}
* Fri Jun 22 2018 Honggang Li <honli@redhat.com> - 1.6.1-1
- Rebase to upstream release v1.6.1
- Resolves: bz1448975
* Thu May 10 2018 Honggang Li <honli@redhat.com> - 1.6.0-1
- Rebase to upstream release v1.6.0
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Tue Apr 11 2017 Honggang Li <honli@redhat.com> - 1.4.1-1
- Rebase to latest upstream release.
- Resolves: bz1428619
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Tue Nov 8 2016 Honggang Li <honli@redhat.com> - 1.4.0-1
- Rebase to latest upstream release.
* Tue Apr 19 2016 Honggang Li <honli@redhat.com> - 1.3.0-3
- Provide precise license information.
* Thu Apr 14 2016 Honggang Li <honli@redhat.com> - 1.3.0-2
- Remove license comment in file section.
- Merge duplicated file entries.
* Thu Apr 14 2016 Honggang Li <honli@redhat.com> - 1.3.0-1
- Import fabtests for Fedora.