Import ezstream-0.6.0-12

This commit is contained in:
Sofia Boldyreva 2024-10-31 18:26:41 +01:00
parent 833e84c915
commit 432a9351a8
5 changed files with 80 additions and 182 deletions

View File

@ -1 +1 @@
8b1cda0f5d7c4df24b847691f98065aab51020d2 SOURCES/ezstream-1.0.2.tar.gz
7817942031411cddf8e4f6d3dd0682a71fc1a592 SOURCES/ezstream-0.6.0.tar.gz

2
.gitignore vendored
View File

@ -1 +1 @@
SOURCES/ezstream-1.0.2.tar.gz
SOURCES/ezstream-0.6.0.tar.gz

View File

@ -0,0 +1,41 @@
From e95150836e332a2522b90382c8a1d4b56ac3ce26 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
Date: Tue, 21 Jul 2015 16:15:07 +0200
Subject: [PATCH] Check for undefined stream format
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
format element is mandatory but the server will crash if it does not
exist in the configuration file. This patch handle the case
gracefully.
It does not raise an error on unsupported value because documentation
allows it.
<https://bugzilla.redhat.com/show_bug.cgi?id=1244481>
Signed-off-by: Petr Písař <ppisar@redhat.com>
---
src/util.c | 5 +++++
1 file changed, 5 insertions(+)
diff --git a/src/util.c b/src/util.c
index 9ecd430..20c2acc 100644
--- a/src/util.c
+++ b/src/util.c
@@ -135,6 +135,11 @@ stream_setup(const char *host, unsigned short port, const char *mount)
return (NULL);
}
+ if (NULL == pezConfig->format) {
+ printf("%s: stream format is missing\n", __progname);
+ shout_free(shout);
+ return (NULL);
+ }
if (!strcmp(pezConfig->format, MP3_FORMAT) &&
shout_set_format(shout, SHOUT_FORMAT_MP3) != SHOUTERR_SUCCESS) {
printf("%s: shout_set_format(MP3): %s\n",
--
2.4.3

View File

@ -1,29 +0,0 @@
From 9a195628f12f65cc949bc6b1801895c48a58893a Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
Date: Mon, 24 Feb 2020 11:27:53 +0100
Subject: [PATCH] doc: Link to distribution OpenSSL certificate bundle
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Petr Písař <ppisar@redhat.com>
---
examples/ezstream-full.xml | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/examples/ezstream-full.xml b/examples/ezstream-full.xml
index 0987124..6042b91 100644
--- a/examples/ezstream-full.xml
+++ b/examples/ezstream-full.xml
@@ -67,7 +67,7 @@
One of the <ca_dir /> or <ca_file /> settings must be enabled for
certificate verification to succeed.
-->
- <!-- <ca_file>/etc/ssl/certs/ca-certificates.crt</ca_file> -->
+ <!-- <ca_file>/etc/ssl/certs/ca-bundle.crt</ca_file> -->
<!--
X.503 client certificate, in PEM format, containing both certificate
--
2.21.1

View File

@ -1,121 +1,56 @@
Name: ezstream
Version: 1.0.2
Release: 9%{?dist}
Version: 0.6.0
Release: 12%{?dist}
Summary: Command line source client for Icecast media streaming servers
## Not installed files:
# aclocal.m4: FSFULLR
# build-aux/compile: GPLv2+ with Autoconf exception
# build-aux/config.guess: GPLv3+ with Autoconf exception
# build-aux/config.rpath: FSFULLR
# build-aux/config.sub: GPLv3+ with Autoconf exception
# build-aux/depcomp: GPLv2+ with Autoconf exception
# build-aux/install-sh: MIT and Public Domain
# build-aux/ltmain.sh: GPLv3+ and
# GPLv3+ with Libtool exception and
# GPLv2+ with Libtool exception
# build-aux/missing: GPLv2+ with Autoconf exception
# build-aux/test-driver: GPLv2+ with Autoconf exception
# compat/getopt.c: MIT and BSD
# compat/reallocarray.c: MIT
# configure: GPLv2+ with Libtool exception and FSFUL
# doc/Makefile.in: FSFULLR
# examples/Makefile.in: FSFULLR
# INSTALL: FSFUL
# m4/attribute.m4: MIT
# m4/ccflags.m4: MIT
# m4/libshout.m4: MIT
# m4/libtool.m4: GPLv2+ with Libtool exception and FSFULLR and FSFUL
# m4/libxml2.m4: MIT
# m4/ltoptions.m4: FSFULLR
# m4/ltsugar.m4: FSFULLR
# m4/ltversion.m4: FSFULLR
# m4/Makefile.in: FSFULLR
# examples/Makefile.in: FSFULLR
# build-aux/config.rpath: FSFULLR
# build-aux/config.guess: GPLv2+ with Autoconf exception
# build-aux/install-sh: MIT and Public Domain
# m4/tree.m4: MIT
# Makefile.in: FSFULLR
# src/Makefile.in: FSFULLR
# tests/Makefile.in: FSFULLR
# win32/tfile.cpp: LGPLv2
# win32/shout/shout.h: LGPLv2+
# compat/sys/tree.3: BSD
# compat/sys/tree.h: BSD (not used if --enable-debug is not specified)
## Installed files:
# compat/strlcat.c: MIT
# compat/strlcpy.c: MIT
# compat/strtonum.c: MIT
# COPYING: GPLv2
# doc/ezstream-cfgmigrate.1.in.in: MIT
# doc/ezstream-file.sh.1*: MIT
# doc/ezstream.1*: GPLv2
# src/cfg.c: MIT
# src/cfg.h: MIT
# src/cfg_decoder.c: MIT
# src/cfg_decoder.h: MIT
# src/cfg_encoder.c: MIT
# src/cfg_encoder.h: MIT
# src/cfg_intake.c: MIT
# src/cfg_intake.h: MIT
# src/cfg_private.h: MIT
# src/cfg_server.c: MIT
# src/cfg_server.h: MIT
# src/cfg_stream.c: MIT
# src/cfg_stream.h: MIT
# src/cfgfile_xml.c: MIT
# src/cfgfile_xml.h: MIT
# src/cmdline.c: MIT
# src/cmdline.h: MIT
# src/ezconfig0.c: GPLv2
# src/ezconfig0.h: GPLv2
# COPYING: GPLv2
# src/metadata.c: MIT
# src/configfile.c: GPLv2
# src/ezstream.c: GPLv2
# src/ezstream.h: MIT
# src/ezstream-cfgmigrate.c: MIT
# src/ezstream-file.sh.in: MIT
# src/log.c: MIT
# src/log.h: MIT
# src/mdata.c: MIT
# src/mdata.h: MIT
# src/playlist.c: MIT
# src/playlist.h: MIT
# src/stream.c: MIT
# src/stream.h: MIT
# src/util.c: GPLv2
# src/util.h: GPLv2
# src/xalloc.c: MIT
# src/xalloc.h: MIT
License: GPLv2 and MIT
URL: https://www.icecast.org/%{name}/
Source0: https://downloads.xiph.org/releases/%{name}/%{name}-%{version}.tar.gz
# Link to distribution-wide certificate store, not upsreamable
Patch0: ezstream-1.0.1-doc-Link-to-distribution-OpenSSL-certificate-bundle.patch
BuildRequires: autoconf >= 2.61
BuildRequires: automake >= 1.10
# src/getopt.c: MIT and BSD
License: GPLv2 and BSD and MIT
URL: http://www.icecast.org/%{name}/
Source0: http://downloads.xiph.org/releases/%{name}/%{name}-%{version}.tar.gz
# Fix a crash on configuration without format, bug #1244481,
# <https://trac.xiph.org/ticket/2208>
Patch0: ezstream-0.6.0-Check-for-undefined-stream-format.patch
BuildRequires: coreutils
BuildRequires: gcc
# gettext-devel for AM_ICONV macro
BuildRequires: gettext-devel
BuildRequires: libtool
BuildRequires: make
BuildRequires: pkgconfig(check) >= 0.9.4
BuildRequires: pkgconfig(libxml-2.0) >= 2
BuildRequires: pkgconfig(shout) >= 2.2
BuildRequires: pkgconfig(taglib_c) >= 1.4
%description
Ezstream is a command line source client for media streams, primarily for
streaming to Icecast servers.
Ezstream is a command line source client for Icecast media streaming servers.
It allows the creation of media streams based on input from files or standard
input that is piped through an optional external decoder and encoder. As every
part of this chain is highly configurable, ezstream can be useful in a large
number of streaming setups.
In its basic mode of operation, it streams media files or data from standard
input without reencoding and thus requires only very little CPU resources. It
can also use various external decoders and encoders to reencode from one format
to another, and stream the result to an Icecast server. Additional features
include scriptable playlist and metadata handling. All of its features make
ezstream a very flexible source client.
Supported media containers for streaming are MP3, Ogg, Theora, WebM, and
Matroska. Supported transport protocols are HTTP, ICY, and RoarAudio.
Metadata support is provided by TagLib library.
Supported media formats for streaming are MP3, Ogg Vorbis and Ogg Theora.
Native metadata support includes MP3 (ID3v1 only) and Ogg Vorbis, and many
more formats understood by TagLib library.
%prep
%setup -q
%patch -P0 -p1
# Regenerate a build script
autoreconf -fi
# Remove bundled code
rm compat/{getopt,reallocarray}.c
# Copy examples for a documention
%patch0 -p1
mkdir __examples
cp -a examples __examples/examples
rm -f __examples/examples/Makefile*
@ -123,73 +58,24 @@ chmod a-x __examples/examples/*
%build
%configure \
--without-asan \
--enable-largefile \
--disable-maintainer-mode \
--disable-rpath \
--enable-shared \
--disable-static
--disable-debug
# --with-taglib actually inhibits the taglib support
%{make_build}
%check
make %{?_smp_mflags} check
make %{?_smp_mflags}
%install
%{make_install}
make install DESTDIR=$RPM_BUILD_ROOT
rm -rf $RPM_BUILD_ROOT%{_docdir} $RPM_BUILD_ROOT%{_datadir}/examples
%files
%license COPYING
%doc ChangeLog NEWS README.md __examples/examples
%doc NEWS README __examples/examples
%{_bindir}/ezstream
%{_bindir}/ezstream-cfgmigrate
%{_bindir}/ezstream-file.sh
%{_mandir}/man1/ezstream.1*
%{_mandir}/man1/ezstream-cfgmigrate.1*
%{_mandir}/man1/ezstream-file.sh.1*
%{_mandir}/man1/ezstream.1.gz
%{_mandir}/man1/ezstream-file.sh.1.gz
%changelog
* Wed Jul 17 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.2-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
* Wed Jan 24 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.2-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Fri Jan 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.2-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Wed Jul 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.2-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.2-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.2-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.2-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Wed Jul 21 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Fri Feb 19 2021 Petr Pisar <ppisar@redhat.com> - 1.0.2-1
- 1.0.2 bump
- Perform tests at build time
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Mon Feb 24 2020 Petr Pisar <ppisar@redhat.com> - 1.0.1-1
- 1.0.1 bump
* Thu Jan 30 2020 Petr Pisar <ppisar@redhat.com> - 1.0.0-1
- 1.0.0 bump
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.0-12
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild