expect/expect-5.43.0-tcl8.5.patch
Miloslav Trmac 047c03f265 - Update to build with Tcl 8.5
- Drop static libraries
- Ship more documentation
- Use %%check for (make test), remove the conditional
2007-02-03 00:19:07 +00:00

66 lines
2.3 KiB
Diff

--- expect-5.43/exp_command.h.tcl8.5 2007-02-03 01:00:05.000000000 +0100
+++ expect-5.43/exp_command.h 2007-02-03 01:02:18.000000000 +0100
@@ -23,7 +23,12 @@
# undef panic
#endif
-#include <tclPort.h>
+#include "tcl.h"
+#if TCL_MAJOR_VERSION < 8 || TCL_MINOR_VERSION < 5
+# include <tclPort.h>
+#else
+# include <tclInt.h>
+#endif
#define EXP_CHANNELNAMELEN (16 + TCL_INTEGER_SPACE)
--- expect-5.43/aclocal.m4.tcl8.5 2002-02-12 03:00:55.000000000 +0100
+++ expect-5.43/aclocal.m4 2007-02-03 01:00:05.000000000 +0100
@@ -150,11 +150,20 @@
TCLHDIRDASHI=""
TCL_LIBRARY=""
else
- AC_MSG_RESULT([found in ${ac_cv_c_tclh}])
+ dirs=${ac_cv_c_tclh}
+ stem=${dirs%/generic}
+ if test x"${dirs}" != x"$stem" && test -d "$stem/unix"; then
+ dirs="$dirs $stem/unix"
+ fi
+ dashi=''
+ for dir in $dirs; do
+ dashi="$dashi -I$dir"
+ done
+ AC_MSG_RESULT([found in ${dirs}])
# this hack is cause the TCLHDIR won't print if there is a "-I" in it.
- TCLHDIR="${ac_cv_c_tclh}"
- TCLHDIRDASHI="-I${ac_cv_c_tclh}"
- TCL_LIBRARY=`echo $TCLHDIR | sed -e 's/generic//'`library
+ TCLHDIR="${dirs}"
+ TCLHDIRDASHI="${dashi# }"
+ TCL_LIBRARY=`echo ${dirs% *} | sed -e 's/generic//'`library
fi
fi
--- expect-5.43/Dbg.c.tcl8.5 2002-03-23 05:11:54.000000000 +0100
+++ expect-5.43/Dbg.c 2007-02-03 01:00:05.000000000 +0100
@@ -11,6 +11,7 @@
#include <stdio.h>
#include "tcldbgcf.h"
+#include "expect_cf.h"
#if 0
/* tclInt.h drags in stdlib. By claiming no-stdlib, force it to drag in */
/* Tcl's compat version. This avoids having to test for its presence */
--- expect-5.43/configure.in.tcl8.5 2007-02-03 01:00:05.000000000 +0100
+++ expect-5.43/configure.in 2007-02-03 01:00:05.000000000 +0100
@@ -368,7 +368,8 @@
cp ${srcdir}/Dbgconfigure ${srcdir}/tcldbg.h ${srcdir}/tcldbgcf.h.in ${srcdir}/install-sh ${tmpdir}
cp $srcdir/DbgMkfl.in ${tmpdir}/Makefile.in
cp $srcdir/DbgpkgInd.in ${tmpdir}/pkgIndex.in
-(cd $tmpdir; ${CONFIG_SHELL-/bin/sh} Dbgconfigure --with-tclinclude=$TCLHDIR $dbg_config_flags)
+# Drop .../unix from tclinclude if present, CY_AC_PATH_TCLH will add it again.
+(cd $tmpdir; ${CONFIG_SHELL-/bin/sh} Dbgconfigure --with-tclinclude=${TCLHDIR%% *} $dbg_config_flags)
cp ${tmpdir}/tcldbgcf.h .
rm -rf $tmpdir
test -n "$verbose" && echo "configured Tcl debugger"