expect/expect-5.43.0-pkgIndex-x.patch
Miloslav Trmac c91b438d11 - s/%%{buildroot}/"$RPM_BUILD_ROOT"/g
- s,/usr/share/man,%%{_mandir},g
- Use the Fedora-specified Buildroot:
- Remove BuildRequires: libX11-devel
- Don't install pkgIndex.tcl as an executable file
- Drop the incorrect expect-5.32.2-fixcat.patch
- Remove comments from *.h.in because they confuse config.status; this
    makes the workaround expect-5.43.0-cfg-setpgrp.patch unnecesary.
2007-02-08 04:39:05 +00:00

12 lines
508 B
Diff

--- expect-5.43/Makefile.in.pkgIndex-x 2007-02-07 15:21:14.000000000 +0100
+++ expect-5.43/Makefile.in 2007-02-07 15:21:55.000000000 +0100
@@ -368,7 +368,7 @@
else true; fi
if [ -s $(EXP_SHARED_LIB_FILE) ] ; then \
$(INSTALL_PROGRAM) $(EXP_SHARED_LIB_FILE) $(tcl_libdir)/$(EXP_SHARED_LIB_FILE) ; \
- $(INSTALL_PROGRAM) pkgIndex $(libdir)/pkgIndex.tcl ; \
+ $(INSTALL_DATA) pkgIndex $(libdir)/pkgIndex.tcl ; \
else true; fi
expect_installed: exp_main_exp.o $(EXP_LIB_FILE) install_shared_lib