Use Tcl 8.4 channel type (GCC 14 compatibility)
Related to: <https://fedoraproject.org/wiki/Changes/PortingToModernC> <https://fedoraproject.org/wiki/Toolchain/PortingToModernC>
This commit is contained in:
parent
07dc210689
commit
f86e28420e
24
expect-c99.patch
Normal file
24
expect-c99.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
Adjustments for compatibility with the currrent (Tcl 8.4.0+) channel
|
||||||
|
implementation.
|
||||||
|
|
||||||
|
diff --git a/exp_chan.c b/exp_chan.c
|
||||||
|
index c92e26b6fbd02305..944200a63b102672 100644
|
||||||
|
--- a/exp_chan.c
|
||||||
|
+++ b/exp_chan.c
|
||||||
|
@@ -60,7 +60,7 @@ void exp_background_channelhandler _ANSI_ARGS_((ClientData,
|
||||||
|
|
||||||
|
Tcl_ChannelType expChannelType = {
|
||||||
|
"exp", /* Type name. */
|
||||||
|
- ExpBlockModeProc, /* Set blocking/nonblocking mode.*/
|
||||||
|
+ TCL_CHANNEL_VERSION_2,
|
||||||
|
ExpCloseProc, /* Close proc. */
|
||||||
|
ExpInputProc, /* Input proc. */
|
||||||
|
ExpOutputProc, /* Output proc. */
|
||||||
|
@@ -70,6 +70,7 @@ Tcl_ChannelType expChannelType = {
|
||||||
|
ExpWatchProc, /* Initialize notifier. */
|
||||||
|
ExpGetHandleProc, /* Get OS handles out of channel. */
|
||||||
|
NULL, /* Close2 proc */
|
||||||
|
+ ExpBlockModeProc, /* Set blocking/nonblocking mode.*/
|
||||||
|
};
|
||||||
|
|
||||||
|
typedef struct ThreadSpecificData {
|
@ -5,7 +5,7 @@
|
|||||||
Summary: A program-script interaction and testing utility
|
Summary: A program-script interaction and testing utility
|
||||||
Name: expect
|
Name: expect
|
||||||
Version: %{majorver}
|
Version: %{majorver}
|
||||||
Release: 20%{?dist}
|
Release: 21%{?dist}
|
||||||
License: LicenseRef-Fedora-Public-Domain
|
License: LicenseRef-Fedora-Public-Domain
|
||||||
URL: https://core.tcl.tk/expect/index
|
URL: https://core.tcl.tk/expect/index
|
||||||
Source: http://downloads.sourceforge.net/%{name}/%{name}%{version}.tar.gz
|
Source: http://downloads.sourceforge.net/%{name}/%{name}%{version}.tar.gz
|
||||||
@ -47,6 +47,7 @@ Patch104: expect-5.45-mkpasswd-man.patch
|
|||||||
# Patch105: Fix error with -Werror=format-security
|
# Patch105: Fix error with -Werror=format-security
|
||||||
Patch105: expect-5.45-format-security.patch
|
Patch105: expect-5.45-format-security.patch
|
||||||
Patch106: expect-configure-c99.patch
|
Patch106: expect-configure-c99.patch
|
||||||
|
Patch107: expect-c99.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Expect is a tcl application for automating and testing
|
Expect is a tcl application for automating and testing
|
||||||
@ -104,6 +105,7 @@ of expectk.
|
|||||||
%patch104 -p1 -b .mkpasswd-man
|
%patch104 -p1 -b .mkpasswd-man
|
||||||
%patch105 -p0 -b .format-security
|
%patch105 -p0 -b .format-security
|
||||||
%patch106 -p1 -b .configure-c99
|
%patch106 -p1 -b .configure-c99
|
||||||
|
%patch -P 107 -p1
|
||||||
# -pkgpath.patch touch configure.in
|
# -pkgpath.patch touch configure.in
|
||||||
aclocal
|
aclocal
|
||||||
autoconf
|
autoconf
|
||||||
@ -186,6 +188,9 @@ chrpath --delete $RPM_BUILD_ROOT%{_libdir}/libexpect%{version}.so
|
|||||||
%{_mandir}/man1/tknewsbiff.1*
|
%{_mandir}/man1/tknewsbiff.1*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jan 17 2024 Florian Weimer <fweimer@redhat.com> - 5.45.4-21
|
||||||
|
- Use Tcl 8.4 channel type (GCC 14 compatibility)
|
||||||
|
|
||||||
* Wed Jul 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 5.45.4-20
|
* Wed Jul 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 5.45.4-20
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user