- s/%%{buildroot}/"$RPM_BUILD_ROOT"/g

- s,/usr/share/man,%%{_mandir},g
- Use the Fedora-specified Buildroot:
- Remove BuildRequires: libX11-devel
- Don't install pkgIndex.tcl as an executable file
- Drop the incorrect expect-5.32.2-fixcat.patch
- Remove comments from *.h.in because they confuse config.status; this
    makes the workaround expect-5.43.0-cfg-setpgrp.patch unnecesary.
This commit is contained in:
Miloslav Trmac 2007-02-08 04:39:05 +00:00
parent 047c03f265
commit c91b438d11
3 changed files with 124 additions and 32 deletions

View File

@ -0,0 +1,72 @@
--- expect-5.43/expect_cf.h.in.h-comments 2007-02-08 05:11:43.000000000 +0100
+++ expect-5.43/expect_cf.h.in 2007-02-08 05:14:05.000000000 +0100
@@ -4,7 +4,8 @@
#ifndef __EXPECT_CF_H__
#define __EXPECT_CF_H__
-#undef NO_STDLIB_H /* Tcl requires this name */
+/* Tcl requires this name */
+#undef NO_STDLIB_H
#undef NO_UNION_WAIT
#undef HAVE_STDARG_H
#undef HAVE_VARARGS_H
@@ -12,12 +13,18 @@
#undef HAVE_SYSCONF_H
#undef HAVE_SYS_FCNTL_H
#undef HAVE_SYS_WAIT_H
-#undef HAVE_SYS_BSDTYPES_H /* nice ISC special */
-#undef HAVE_SYS_SELECT_H /* nice ISC special */
-#undef HAVE_SYS_TIME_H /* nice ISC special */
-#undef HAVE_SYS_PTEM_H /* SCO needs this for window size */
-#undef HAVE_STRREDIR_H /* Solaris needs this for console redir */
-#undef HAVE_STRPTY_H /* old-style Dynix ptys need this */
+/* nice ISC special */
+#undef HAVE_SYS_BSDTYPES_H
+/* nice ISC special */
+#undef HAVE_SYS_SELECT_H
+/* nice ISC special */
+#undef HAVE_SYS_TIME_H
+/* SCO needs this for window size */
+#undef HAVE_SYS_PTEM_H
+/* Solaris needs this for console redir */
+#undef HAVE_STRREDIR_H
+/* old-style Dynix ptys need this */
+#undef HAVE_STRPTY_H
#undef HAVE_UNISTD_H
#undef HAVE_SYSMACROS_H
#undef HAVE_INTTYPES_H
@@ -26,8 +33,10 @@
#undef pid_t
#undef RETSIGTYPE
-#undef TIME_WITH_SYS_TIME /* ok to include both time.h and sys/time.h */
-#undef SETPGRP_VOID /* if setpgrp takes 0 args */
+/* ok to include both time.h and sys/time.h */
+#undef TIME_WITH_SYS_TIME
+/* if setpgrp takes 0 args */
+#undef SETPGRP_VOID
/*
* This section is for compile macros needed by
@@ -42,7 +51,8 @@
#undef SIMPLE_EVENT
#undef HAVE_STRFTIME
#undef HAVE_MEMMOVE
-#undef HAVE_TIMEZONE /* timezone() a la Pyramid */
+/* timezone() a la Pyramid */
+#undef HAVE_TIMEZONE
#undef HAVE_SIGLONGJMP
#undef HAVE_STRCHR
--- expect-5.43/tcldbgcf.h.in.h-comments 2007-02-08 05:11:43.000000000 +0100
+++ expect-5.43/tcldbgcf.h.in 2007-02-08 05:12:17.000000000 +0100
@@ -7,7 +7,8 @@
#ifndef __NIST_DBG_CF_H__
#define __NIST_DBG_CF_H__
-#undef NO_STDLIB_H /* Tcl requires this name */
+/* Tcl requires this name */
+#undef NO_STDLIB_H
/*
* Check for functions

View File

@ -0,0 +1,11 @@
--- expect-5.43/Makefile.in.pkgIndex-x 2007-02-07 15:21:14.000000000 +0100
+++ expect-5.43/Makefile.in 2007-02-07 15:21:55.000000000 +0100
@@ -368,7 +368,7 @@
else true; fi
if [ -s $(EXP_SHARED_LIB_FILE) ] ; then \
$(INSTALL_PROGRAM) $(EXP_SHARED_LIB_FILE) $(tcl_libdir)/$(EXP_SHARED_LIB_FILE) ; \
- $(INSTALL_PROGRAM) pkgIndex $(libdir)/pkgIndex.tcl ; \
+ $(INSTALL_DATA) pkgIndex $(libdir)/pkgIndex.tcl ; \
else true; fi
expect_installed: exp_main_exp.o $(EXP_LIB_FILE) install_shared_lib

View File

@ -3,23 +3,23 @@
Summary: A program-script interaction and testing utility Summary: A program-script interaction and testing utility
Name: expect Name: expect
Version: %{majorver}.0 Version: %{majorver}.0
Release: 6 Release: 7
License: Public Domain License: Public Domain
Group: Development/Languages Group: Development/Languages
URL: http://expect.nist.gov/ URL: http://expect.nist.gov/
Source: http://expect.nist.gov/src/%{name}-%{version}.tar.gz Source: http://expect.nist.gov/src/%{name}-%{version}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Buildrequires: tcl-devel tk-devel autoconf automake libX11-devel Buildrequires: tcl-devel tk-devel autoconf automake
Patch0: expect-5.38.0-spawn-43310.patch Patch0: expect-5.38.0-spawn-43310.patch
Patch1: expect-5.43.0-cfg-setpgrp.patch Patch1: expect-5.43.0-h-comments.patch
Patch2: expect-5.38.0-lib-spec.patch Patch2: expect-5.38.0-lib-spec.patch
Patch3: expect-5.39.0-libdir.patch Patch3: expect-5.39.0-libdir.patch
Patch4: expect-5.43.0-log_file.patch Patch4: expect-5.43.0-log_file.patch
Patch5: expect-5.43.0-tcl8.5.patch Patch5: expect-5.43.0-tcl8.5.patch
Patch6: expect-5.43.0-pkgIndex-x.patch
# examples patches # examples patches
Patch100: expect-5.32.2-random.patch Patch100: expect-5.32.2-random.patch
Patch101: expect-5.32.2-fixcat.patch Patch101: unbuffer-child-flush-143963.patch
Patch102: unbuffer-child-flush-143963.patch
%description %description
Expect is a tcl application for automating and testing Expect is a tcl application for automating and testing
@ -57,17 +57,17 @@ This package contains expectk and some scripts that use it.
%prep %prep
%setup -q -n expect-%{majorver} %setup -q -n expect-%{majorver}
%patch0 -p2 -b .6-spawn %patch0 -p2 -b .spawn
%patch1 -p1 -b .8-pgrp %patch1 -p1 -b .h-comments
%patch2 -p1 -b .10-libspec %patch2 -p1 -b .lib-spec
%patch3 -p1 -b .11-libdir %patch3 -p1 -b .libdir
%patch4 -p1 -b .12-log_file %patch4 -p1 -b .log_file
%patch5 -p1 -b .tcl8.5 %patch5 -p1 -b .tcl8.5
%patch6 -p1 -b .pkgIndex-x
# examples fixes # examples fixes
%patch100 -p1 -b .100 %patch100 -p1 -b .random
%patch101 -p1 -b .101 %patch101 -p1 -b .unbuffer
%patch102 -p1 -b .102 # *-lib-spec.patch and *-tcl8.5.patch touch configure.in
# *-cfg-setpgrp.patch, *-lib-spec.patch and *-tcl8.5.patch touch configure.in
aclocal aclocal
autoconf autoconf
( cd testsuite ( cd testsuite
@ -82,19 +82,19 @@ make %{?_smp_mflags}
make test make test
%install %install
rm -rf $RPM_BUILD_ROOT rm -rf "$RPM_BUILD_ROOT"
make install INSTALL_ROOT=%{buildroot} make install INSTALL_ROOT="$RPM_BUILD_ROOT"
# for linking with -lexpect # for linking with -lexpect
ln -s libexpect%{majorver}.so %{buildroot}%{_libdir}/libexpect.so ln -s libexpect%{majorver}.so "$RPM_BUILD_ROOT"%{_libdir}/libexpect.so
# remove cryptdir/decryptdir, as Linux has no crypt command (bug 6668). # remove cryptdir/decryptdir, as Linux has no crypt command (bug 6668).
rm -f %{buildroot}%{_bindir}/{cryptdir,decryptdir} rm -f "$RPM_BUILD_ROOT"%{_bindir}/{cryptdir,decryptdir}
rm -f %{buildroot}%{_mandir}/man1/{cryptdir,decryptdir}.1* rm -f "$RPM_BUILD_ROOT"%{_mandir}/man1/{cryptdir,decryptdir}.1*
rm -f %{buildroot}%{_bindir}/autopasswd rm -f "$RPM_BUILD_ROOT"%{_bindir}/autopasswd
%clean %clean
rm -rf $RPM_BUILD_ROOT rm -rf "$RPM_BUILD_ROOT"
%files %files
@ -116,18 +116,17 @@ rm -rf $RPM_BUILD_ROOT
%{_bindir}/weather %{_bindir}/weather
%{_bindir}/xkibitz %{_bindir}/xkibitz
%dir %{_libdir}/expect%{majorver} %dir %{_libdir}/expect%{majorver}
%{_libdir}/expect%{majorver}/cat-buffers
%{_libdir}/expect%{majorver}/pkgIndex.tcl %{_libdir}/expect%{majorver}/pkgIndex.tcl
%{_libdir}/libexpect%{majorver}.so %{_libdir}/libexpect%{majorver}.so
/usr/share/man/man1/autoexpect.1.gz %{_mandir}/man1/autoexpect.1.gz
/usr/share/man/man1/dislocate.1.gz %{_mandir}/man1/dislocate.1.gz
/usr/share/man/man1/expect.1.gz %{_mandir}/man1/expect.1.gz
/usr/share/man/man1/kibitz.1.gz %{_mandir}/man1/kibitz.1.gz
/usr/share/man/man1/mkpasswd.1.gz %{_mandir}/man1/mkpasswd.1.gz
/usr/share/man/man1/passmass.1.gz %{_mandir}/man1/passmass.1.gz
/usr/share/man/man1/tknewsbiff.1.gz %{_mandir}/man1/tknewsbiff.1.gz
/usr/share/man/man1/unbuffer.1.gz %{_mandir}/man1/unbuffer.1.gz
/usr/share/man/man1/xkibitz.1.gz %{_mandir}/man1/xkibitz.1.gz
%files devel %files devel
%defattr(-,root,root,-) %defattr(-,root,root,-)
@ -149,6 +148,16 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man1/tknewsbiff.1* %{_mandir}/man1/tknewsbiff.1*
%changelog %changelog
* Thu Feb 8 2007 Miloslav Trmac <mitr@redhat.com> - 5.43.0-7
- s/%%{buildroot}/"$RPM_BUILD_ROOT"/g
- s,/usr/share/man,%%{_mandir},g
- Use the Fedora-specified Buildroot:
- Remove BuildRequires: libX11-devel
- Don't install pkgIndex.tcl as an executable file
- Drop the incorrect expect-5.32.2-fixcat.patch
- Remove comments from *.h.in because they confuse config.status; this makes
the workaround expect-5.43.0-cfg-setpgrp.patch unnecesary.
* Sat Feb 3 2007 Miloslav Trmac <mitr@redhat.com> - 5.43.0-6 * Sat Feb 3 2007 Miloslav Trmac <mitr@redhat.com> - 5.43.0-6
- Update to build with Tcl 8.5 - Update to build with Tcl 8.5
- Drop static libraries - Drop static libraries