- fix flushing of unbuffer script (Charles Sullivan, #143963) with

unbuffer-child-flush-143963.patch (Don Libes)
- separate the examples scripts patches from the rest
This commit is contained in:
Jens Petersen 2005-05-31 02:20:40 +00:00
parent e1ec90051c
commit 42f6009802
2 changed files with 40 additions and 10 deletions

View File

@ -3,21 +3,24 @@
Summary: A program-script interaction and testing utility
Name: expect
Version: %{majorver}.0
Release: 1
Release: 2
License: Public Domain
Group: Development/Languages
URL: http://expect.nist.gov/
Source: http://expect.nist.gov/src/%{name}-%{version}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
Buildrequires: tcl-devel tk-devel autoconf automake
Patch0: expect-5.32.2-random.patch
Patch3: expect-5.32.2-fixcat.patch
# submitted to author
Patch6: expect-5.38.0-spawn-43310.patch
# submitted to author
Patch8: expect-5.43.0-cfg-setpgrp.patch
Patch10: expect-5.38.0-lib-spec.patch
Patch11: expect-5.39.0-libdir.patch
# examples patches
Patch100: expect-5.32.2-random.patch
Patch101: expect-5.32.2-fixcat.patch
Patch102: unbuffer-child-flush-143963.patch
%description
Expect is a tcl application for automating and testing
@ -55,12 +58,14 @@ This package contains expectk and some scripts that use it.
%prep
%setup -q -n expect-%{majorver}
%patch0 -p1 -b .random
%patch3 -p1 -b .fixcat
%patch6 -p2 -b .spawn
%patch8 -p1 -b .pgrp
%patch10 -p1 -b .libspec
%patch11 -p1 -b .libdir
%patch6 -p2 -b .6-spawn
%patch8 -p1 -b .8-pgrp
%patch10 -p1 -b .10-libspec
%patch11 -p1 -b .11-libdir
# examples fixes
%patch100 -p1 -b .100
%patch101 -p1 -b .101
%patch102 -p1 -b .102
# patch8 and patch10 touch configure.in
aclocal
autoconf
@ -147,9 +152,12 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man1/tknewsbiff.1*
%changelog
* Mon May 23 2005 Jens Petersen <petersen@redhat.com>
* Tue May 31 2005 Jens Petersen <petersen@redhat.com> - 5.43.0-2
- fix flushing of unbuffer script (Charles Sullivan, #143963)
with unbuffer-child-flush-143963.patch (Don Libes)
- make autoconf include parent dir in testsuite to avoid error
(Robert Scheck, 150369)
- separate the examples scripts patches from the rest
* Mon Mar 7 2005 Jens Petersen <petersen@redhat.com>
- replace expect-5.32.2-setpgrp.patch by expect-5.43.0-cfg-setpgrp.patch

View File

@ -0,0 +1,22 @@
--- expect-5.43/example/unbuffer.orig 2004-01-25 10:37:49.000000000 +0900
+++ expect-5.43/example/unbuffer 2005-05-31 10:37:19.000000000 +0900
@@ -6,10 +6,17 @@
# pipeline
set stty_init "-echo"
eval spawn -noecho [lrange $argv 1 end]
- interact
+ close_on_eof -i $user_spawn_id 0
+ interact {
+ eof {
+ # flush remaining output from child
+ expect -timeout 1 -re .+
+ return
+ }
+ }
} else {
set stty_init "-opost"
- eval spawn -noecho $argv
set timeout -1
+ eval spawn -noecho $argv
expect
}