Rediff all patches to work with patch --fuzz=0
This commit is contained in:
parent
c50a710156
commit
2723ecb764
@ -1,6 +1,7 @@
|
||||
--- expect5.32/example/mkpasswd.random Mon Jul 23 10:42:04 2001
|
||||
+++ expect5.32/example/mkpasswd Mon Jul 23 11:50:56 2001
|
||||
@@ -92,7 +92,14 @@
|
||||
diff -up expect-5.43/example/mkpasswd.random expect-5.43/example/mkpasswd
|
||||
--- expect-5.43/example/mkpasswd.random 2004-12-07 00:38:21.000000000 +0100
|
||||
+++ expect-5.43/example/mkpasswd 2008-09-25 12:27:19.000000000 +0200
|
||||
@@ -92,7 +92,14 @@ proc insert {pvar char} {
|
||||
}
|
||||
|
||||
proc rand {m} {
|
||||
|
@ -1,6 +1,7 @@
|
||||
--- expect-5.38/configure.in.orig 2002-07-19 00:51:06.000000000 +0900
|
||||
+++ expect-5.38/configure.in 2002-12-05 18:28:05.000000000 +0900
|
||||
@@ -1132,7 +1132,7 @@
|
||||
diff -up expect-5.43/configure.in.lib-spec expect-5.43/configure.in
|
||||
--- expect-5.43/configure.in.lib-spec 2005-02-08 02:45:06.000000000 +0100
|
||||
+++ expect-5.43/configure.in 2008-09-25 12:23:26.000000000 +0200
|
||||
@@ -1141,7 +1141,7 @@ if test $ac_cv_sys_long_file_names = no;
|
||||
fi
|
||||
|
||||
EXP_BUILD_LIB_SPEC="-L`pwd` -lexpect${EXP_LIB_VERSION}${DBGX}"
|
||||
|
@ -1,6 +1,7 @@
|
||||
--- tcltk-8.3.1/expect5.31/exp_chan.c.read Fri Nov 16 00:14:15 2001
|
||||
+++ tcltk-8.3.1/expect5.31/exp_chan.c Fri Nov 16 00:14:15 2001
|
||||
@@ -519,6 +519,7 @@ expCreateChannel(interp,fdin,fdout,pid)
|
||||
diff -up expect-5.43/exp_chan.c.spawn expect-5.43/exp_chan.c
|
||||
--- expect-5.43/exp_chan.c.spawn 2005-02-08 03:01:20.000000000 +0100
|
||||
+++ expect-5.43/exp_chan.c 2008-09-25 12:22:14.000000000 +0200
|
||||
@@ -622,6 +622,7 @@ expCreateChannel(interp,fdin,fdout,pid)
|
||||
esPtr->buffer = Tcl_NewStringObj("",0);
|
||||
Tcl_IncrRefCount(esPtr->buffer);
|
||||
esPtr->umsize = exp_default_match_max;
|
||||
@ -8,17 +9,18 @@
|
||||
/* this will reallocate object with an appropriate sized buffer */
|
||||
expAdjust(esPtr);
|
||||
|
||||
--- tcltk-8.3.1/expect5.31/exp_command.h.read Fri Nov 16 00:14:15 2001
|
||||
+++ tcltk-8.3.1/expect5.31/exp_command.h Fri Nov 16 00:14:15 2001
|
||||
@@ -25,6 +25,7 @@ would appreciate credit if this program
|
||||
diff -up expect-5.43/exp_command.h.spawn expect-5.43/exp_command.h
|
||||
--- expect-5.43/exp_command.h.spawn 2004-07-30 17:35:28.000000000 +0200
|
||||
+++ expect-5.43/exp_command.h 2008-09-25 12:22:14.000000000 +0200
|
||||
@@ -30,6 +30,7 @@ would appreciate credit if this program
|
||||
EXTERN char * exp_get_var _ANSI_ARGS_((Tcl_Interp *,char *));
|
||||
|
||||
EXTERN int exp_default_match_max;
|
||||
+EXTERN int exp_default_match_max_changed;
|
||||
EXTERN int exp_default_parity;
|
||||
EXTERN int exp_default_rm_nulls;
|
||||
|
||||
@@ -97,6 +98,7 @@ typedef struct ExpState {
|
||||
EXTERN int exp_default_close_on_eof;
|
||||
@@ -103,6 +104,7 @@ typedef struct ExpState {
|
||||
int msize; /* # of bytes that buffer can hold (max) */
|
||||
int umsize; /* # of bytes (min) that is guaranteed to match */
|
||||
/* this comes from match_max command */
|
||||
@ -26,8 +28,9 @@
|
||||
int printed; /* # of bytes written to stdout (if logging on) */
|
||||
/* but not actually returned via a match yet */
|
||||
int echoed; /* additional # of bytes (beyond "printed" above) */
|
||||
--- tcltk-8.3.1/expect5.31/expect.c.read Fri Nov 16 00:14:15 2001
|
||||
+++ tcltk-8.3.1/expect5.31/expect.c Fri Nov 16 11:09:59 2001
|
||||
diff -up expect-5.43/expect.c.spawn expect-5.43/expect.c
|
||||
--- expect-5.43/expect.c.spawn 2004-07-07 01:26:02.000000000 +0200
|
||||
+++ expect-5.43/expect.c 2008-09-25 12:22:14.000000000 +0200
|
||||
@@ -41,8 +41,17 @@ would appreciate credit if this program
|
||||
#include "tcldbg.h"
|
||||
#endif
|
||||
@ -47,8 +50,8 @@
|
||||
#define INIT_EXPECT_TIMEOUT_LIT "10" /* seconds */
|
||||
#define INIT_EXPECT_TIMEOUT 10 /* seconds */
|
||||
int exp_default_parity = TRUE;
|
||||
@@ -1557,6 +1566,76 @@ expNullStrip(obj,offsetBytes)
|
||||
Tcl_SetObjLength(obj,offsetBytes + (dest - src2));
|
||||
@@ -1619,6 +1628,76 @@ expNullStrip(obj,offsetBytes)
|
||||
return newsize;
|
||||
}
|
||||
|
||||
+/* returns # of bytes until we see a newline at the end or EOF. */
|
||||
@ -124,7 +127,7 @@
|
||||
/* returns # of bytes read or (non-positive) error of form EXP_XXX */
|
||||
/* returns 0 for end of file */
|
||||
/* If timeout is non-zero, set an alarm before doing the read, else assume */
|
||||
@@ -1571,6 +1650,8 @@ int save_flags;
|
||||
@@ -1633,6 +1712,8 @@ int save_flags;
|
||||
{
|
||||
int cc = EXP_TIMEOUT;
|
||||
int size = expSizeGet(esPtr);
|
||||
@ -133,7 +136,7 @@
|
||||
|
||||
if (size + TCL_UTF_MAX >= esPtr->msize)
|
||||
exp_buffer_shuffle(interp,esPtr,save_flags,EXPECT_OUT,"expect");
|
||||
@@ -1587,11 +1668,43 @@ int save_flags;
|
||||
@@ -1649,11 +1730,43 @@ int save_flags;
|
||||
}
|
||||
#endif
|
||||
|
||||
@ -181,7 +184,7 @@
|
||||
i_read_errno = errno;
|
||||
|
||||
#ifdef SIMPLE_EVENT
|
||||
@@ -1612,7 +1725,7 @@ int save_flags;
|
||||
@@ -1674,7 +1787,7 @@ int save_flags;
|
||||
}
|
||||
}
|
||||
#endif
|
||||
@ -190,7 +193,7 @@
|
||||
}
|
||||
|
||||
/*
|
||||
@@ -2667,8 +2780,14 @@ char **argv;
|
||||
@@ -2751,8 +2864,14 @@ char **argv;
|
||||
return(TCL_ERROR);
|
||||
}
|
||||
|
||||
|
@ -1,6 +1,7 @@
|
||||
--- expect-5.39/Makefile.in.libdir 2003-07-30 00:46:51.000000000 +0200
|
||||
+++ expect-5.39/Makefile.in 2003-11-17 17:54:52.000000000 +0100
|
||||
@@ -316,7 +316,7 @@
|
||||
diff -up expect-5.43/Makefile.in.libdir expect-5.43/Makefile.in
|
||||
--- expect-5.43/Makefile.in.libdir 2004-05-07 20:10:30.000000000 +0200
|
||||
+++ expect-5.43/Makefile.in 2008-09-25 12:24:08.000000000 +0200
|
||||
@@ -317,7 +317,7 @@ EXP_AND_TK_LIBS = $(LDFLAGS) @EXP_AND_TK
|
||||
CFLAGS_INT = $(MH_CFLAGS) $(CPPFLAGS) $(XCFLAGS)
|
||||
|
||||
LIB_INSTALL_DIR = $(tcl_libdir)
|
||||
|
@ -1,5 +1,6 @@
|
||||
--- expect-5.43/expect_cf.h.in.h-comments 2007-02-08 05:11:43.000000000 +0100
|
||||
+++ expect-5.43/expect_cf.h.in 2007-02-08 05:14:05.000000000 +0100
|
||||
diff -up expect-5.43/expect_cf.h.in.h-comments expect-5.43/expect_cf.h.in
|
||||
--- expect-5.43/expect_cf.h.in.h-comments 2004-05-07 19:48:02.000000000 +0200
|
||||
+++ expect-5.43/expect_cf.h.in 2008-09-25 12:22:37.000000000 +0200
|
||||
@@ -4,7 +4,8 @@
|
||||
#ifndef __EXPECT_CF_H__
|
||||
#define __EXPECT_CF_H__
|
||||
@ -58,8 +59,9 @@
|
||||
#undef HAVE_SIGLONGJMP
|
||||
#undef HAVE_STRCHR
|
||||
|
||||
--- expect-5.43/tcldbgcf.h.in.h-comments 2007-02-08 05:11:43.000000000 +0100
|
||||
+++ expect-5.43/tcldbgcf.h.in 2007-02-08 05:12:17.000000000 +0100
|
||||
diff -up expect-5.43/tcldbgcf.h.in.h-comments expect-5.43/tcldbgcf.h.in
|
||||
--- expect-5.43/tcldbgcf.h.in.h-comments 2002-02-12 03:00:56.000000000 +0100
|
||||
+++ expect-5.43/tcldbgcf.h.in 2008-09-25 12:22:37.000000000 +0200
|
||||
@@ -7,7 +7,8 @@
|
||||
#ifndef __NIST_DBG_CF_H__
|
||||
#define __NIST_DBG_CF_H__
|
||||
|
@ -1,6 +1,7 @@
|
||||
--- expect-5.43/exp_log.c.log_file 2004-08-18 16:54:35.000000000 -0400
|
||||
+++ expect-5.43/exp_log.c 2006-02-24 12:39:58.000000000 -0500
|
||||
@@ -471,7 +471,7 @@
|
||||
diff -up expect-5.43/exp_log.c.log_file expect-5.43/exp_log.c
|
||||
--- expect-5.43/exp_log.c.log_file 2004-08-18 22:54:35.000000000 +0200
|
||||
+++ expect-5.43/exp_log.c 2008-09-25 12:24:42.000000000 +0200
|
||||
@@ -471,7 +471,7 @@ expLogChannelOpen(interp,filename,append
|
||||
Tcl_DStringAppend(&tsdPtr->logFilename,filename,-1);
|
||||
}
|
||||
|
||||
|
@ -1,6 +1,7 @@
|
||||
--- expect-5.43/Makefile.in.pkgIndex-x 2007-02-07 15:21:14.000000000 +0100
|
||||
+++ expect-5.43/Makefile.in 2007-02-07 15:21:55.000000000 +0100
|
||||
@@ -368,7 +368,7 @@
|
||||
diff -up expect-5.43/Makefile.in.pkgIndex-x expect-5.43/Makefile.in
|
||||
--- expect-5.43/Makefile.in.pkgIndex-x 2008-09-25 12:26:26.000000000 +0200
|
||||
+++ expect-5.43/Makefile.in 2008-09-25 12:26:26.000000000 +0200
|
||||
@@ -368,7 +368,7 @@ install_shared_lib: $(EXP_LIB_FILES)
|
||||
else true; fi
|
||||
if [ -s $(EXP_SHARED_LIB_FILE) ] ; then \
|
||||
$(INSTALL_PROGRAM) $(EXP_SHARED_LIB_FILE) $(tcl_libdir)/$(EXP_SHARED_LIB_FILE) ; \
|
||||
|
@ -1,14 +1,7 @@
|
||||
--- pkgIndex.in.orig 2007-02-10 21:07:34.000000000 -0800
|
||||
+++ pkgIndex.in 2007-02-10 21:07:43.000000000 -0800
|
||||
@@ -7,4 +7,4 @@
|
||||
# script is sourced, the variable $dir must contain the
|
||||
# full path name of this file's directory.
|
||||
|
||||
-package ifneeded Expect @EXP_VERSION_FULL@ [list load [file join $dir .. @EXP_SHARED_LIB_FILE@]]
|
||||
+package ifneeded Expect @EXP_VERSION_FULL@ [list load [file join $dir .. .. @EXP_SHARED_LIB_FILE@]]
|
||||
--- configure.in.orig 2007-02-10 21:30:13.000000000 -0800
|
||||
+++ configure.in 2007-02-10 21:30:23.000000000 -0800
|
||||
@@ -1260,6 +1260,7 @@
|
||||
diff -up expect-5.43/configure.in.pkgpath expect-5.43/configure.in
|
||||
--- expect-5.43/configure.in.pkgpath 2008-09-25 12:28:28.000000000 +0200
|
||||
+++ expect-5.43/configure.in 2008-09-25 12:28:28.000000000 +0200
|
||||
@@ -1260,6 +1260,7 @@ AC_SUBST(SETUID)
|
||||
AC_SUBST(UNSHARED_RANLIB)
|
||||
AC_SUBST(DEFAULT_STTY_ARGS)
|
||||
AC_SUBST(STTY_BIN)
|
||||
@ -16,9 +9,10 @@
|
||||
AC_OUTPUT([Makefile \
|
||||
pkgIndex],
|
||||
chmod +x ${srcdir}/install-sh ${srcdir}/mkinstalldirs)
|
||||
--- Makefile.in.orig 2007-02-10 21:34:28.000000000 -0800
|
||||
+++ Makefile.in 2007-02-10 22:23:14.000000000 -0800
|
||||
@@ -173,8 +173,8 @@
|
||||
diff -up expect-5.43/Makefile.in.pkgpath expect-5.43/Makefile.in
|
||||
--- expect-5.43/Makefile.in.pkgpath 2008-09-25 12:28:28.000000000 +0200
|
||||
+++ expect-5.43/Makefile.in 2008-09-25 12:28:28.000000000 +0200
|
||||
@@ -173,8 +173,8 @@ STTY = -DDFLT_STTY="\"@DEFAULT_STTY_ARGS
|
||||
bindir = $(INSTALL_ROOT)@bindir@
|
||||
bindir_arch_indep = $(INSTALL_ROOT)$(prefix)/bin
|
||||
tcl_libdir = $(INSTALL_ROOT)@libdir@
|
||||
@ -29,3 +23,12 @@
|
||||
|
||||
mandir = $(INSTALL_ROOT)@mandir@
|
||||
man1dir = $(mandir)/man1
|
||||
diff -up expect-5.43/pkgIndex.in.pkgpath expect-5.43/pkgIndex.in
|
||||
--- expect-5.43/pkgIndex.in.pkgpath 2002-02-12 03:00:56.000000000 +0100
|
||||
+++ expect-5.43/pkgIndex.in 2008-09-25 12:28:28.000000000 +0200
|
||||
@@ -7,4 +7,4 @@
|
||||
# script is sourced, the variable $dir must contain the
|
||||
# full path name of this file's directory.
|
||||
|
||||
-package ifneeded Expect @EXP_VERSION_FULL@ [list load [file join $dir .. @EXP_SHARED_LIB_FILE@]]
|
||||
+package ifneeded Expect @EXP_VERSION_FULL@ [list load [file join $dir .. .. @EXP_SHARED_LIB_FILE@]]
|
||||
|
@ -1,7 +1,6 @@
|
||||
diff -up expect-5.43/tests/all.tcl expect-5.43/tests/all
|
||||
diff -up expect-5.43/Dbg.c.tcl expect-5.43/Dbg.c
|
||||
--- expect-5.43/Dbg.c.tcl 2008-01-04 19:25:02.000000000 +0100
|
||||
+++ expect-5.43/Dbg.c 2008-01-04 19:25:25.000000000 +0100
|
||||
diff -up expect-5.43/Dbg.c.tcl8.5 expect-5.43/Dbg.c
|
||||
--- expect-5.43/Dbg.c.tcl8.5 2002-03-23 05:11:54.000000000 +0100
|
||||
+++ expect-5.43/Dbg.c 2008-09-25 12:25:40.000000000 +0200
|
||||
@@ -10,6 +10,7 @@ would appreciate credit if this program
|
||||
|
||||
#include <stdio.h>
|
||||
@ -10,9 +9,9 @@ diff -up expect-5.43/Dbg.c.tcl expect-5.43/Dbg.c
|
||||
#include "tcldbgcf.h"
|
||||
#if 0
|
||||
/* tclInt.h drags in stdlib. By claiming no-stdlib, force it to drag in */
|
||||
diff -up expect-5.43/exp_inter.c.tcl expect-5.43/exp_inter.c
|
||||
--- expect-5.43/exp_inter.c.tcl 2008-01-04 19:23:47.000000000 +0100
|
||||
+++ expect-5.43/exp_inter.c 2008-01-04 19:24:24.000000000 +0100
|
||||
diff -up expect-5.43/exp_inter.c.tcl8.5 expect-5.43/exp_inter.c
|
||||
--- expect-5.43/exp_inter.c.tcl8.5 2004-08-18 04:03:00.000000000 +0200
|
||||
+++ expect-5.43/exp_inter.c 2008-09-25 12:25:40.000000000 +0200
|
||||
@@ -36,6 +36,7 @@ would appreciate credit if this program
|
||||
#include <ctype.h>
|
||||
|
||||
|
@ -5,7 +5,7 @@
|
||||
Summary: A program-script interaction and testing utility
|
||||
Name: expect
|
||||
Version: %{majorver}.0
|
||||
Release: 14%{?dist}
|
||||
Release: 15%{?dist}
|
||||
License: Public Domain
|
||||
Group: Development/Languages
|
||||
URL: http://expect.nist.gov/
|
||||
@ -62,7 +62,7 @@ This package contains expectk and some scripts that use it.
|
||||
|
||||
%prep
|
||||
%setup -q -n expect-%{majorver}
|
||||
%patch0 -p2 -b .spawn
|
||||
%patch0 -p1 -b .spawn
|
||||
%patch1 -p1 -b .h-comments
|
||||
%patch2 -p1 -b .lib-spec
|
||||
%patch3 -p1 -b .libdir
|
||||
@ -72,7 +72,7 @@ This package contains expectk and some scripts that use it.
|
||||
# examples fixes
|
||||
%patch100 -p1 -b .random
|
||||
%patch101 -p1 -b .unbuffer
|
||||
%patch200 -p0 -b .pkgpath
|
||||
%patch200 -p1 -b .pkgpath
|
||||
# *-lib-spec.patch and *-tcl8.5.patch and -pkgpath.patch touch configure.in
|
||||
aclocal
|
||||
autoconf
|
||||
@ -155,6 +155,9 @@ rm -rf "$RPM_BUILD_ROOT"
|
||||
%{_mandir}/man1/tknewsbiff.1*
|
||||
|
||||
%changelog
|
||||
* Thu Sep 25 2008 Vitezslav Crhonek <vcrhonek@redhat.com> - 5:43.0-15
|
||||
- Rediff all patches to work with patch --fuzz=0
|
||||
|
||||
* Mon Jun 9 2008 Vitezslav Crhonek <vcrhonek@redhat.com> - 5:43.0-14
|
||||
- Use latest config.sub file for package build
|
||||
Resolves: #449560
|
||||
|
@ -1,6 +1,7 @@
|
||||
--- expect-5.43/example/unbuffer.orig 2004-01-25 10:37:49.000000000 +0900
|
||||
+++ expect-5.43/example/unbuffer 2005-05-31 10:37:19.000000000 +0900
|
||||
@@ -6,10 +6,17 @@
|
||||
diff -up expect-5.43/example/unbuffer.unbuffer expect-5.43/example/unbuffer
|
||||
--- expect-5.43/example/unbuffer.unbuffer 2004-01-25 02:37:49.000000000 +0100
|
||||
+++ expect-5.43/example/unbuffer 2008-09-25 12:27:48.000000000 +0200
|
||||
@@ -6,10 +6,17 @@ if {[string compare [lindex $argv 0] "-p
|
||||
# pipeline
|
||||
set stty_init "-echo"
|
||||
eval spawn -noecho [lrange $argv 1 end]
|
||||
|
Loading…
Reference in New Issue
Block a user