- Update to build with Tcl 8.5
- Drop static libraries - Ship more documentation - Use %%check for (make test), remove the conditional
This commit is contained in:
parent
959ad3c077
commit
047c03f265
65
expect-5.43.0-tcl8.5.patch
Normal file
65
expect-5.43.0-tcl8.5.patch
Normal file
@ -0,0 +1,65 @@
|
|||||||
|
--- expect-5.43/exp_command.h.tcl8.5 2007-02-03 01:00:05.000000000 +0100
|
||||||
|
+++ expect-5.43/exp_command.h 2007-02-03 01:02:18.000000000 +0100
|
||||||
|
@@ -23,7 +23,12 @@
|
||||||
|
# undef panic
|
||||||
|
#endif
|
||||||
|
|
||||||
|
-#include <tclPort.h>
|
||||||
|
+#include "tcl.h"
|
||||||
|
+#if TCL_MAJOR_VERSION < 8 || TCL_MINOR_VERSION < 5
|
||||||
|
+# include <tclPort.h>
|
||||||
|
+#else
|
||||||
|
+# include <tclInt.h>
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
#define EXP_CHANNELNAMELEN (16 + TCL_INTEGER_SPACE)
|
||||||
|
|
||||||
|
--- expect-5.43/aclocal.m4.tcl8.5 2002-02-12 03:00:55.000000000 +0100
|
||||||
|
+++ expect-5.43/aclocal.m4 2007-02-03 01:00:05.000000000 +0100
|
||||||
|
@@ -150,11 +150,20 @@
|
||||||
|
TCLHDIRDASHI=""
|
||||||
|
TCL_LIBRARY=""
|
||||||
|
else
|
||||||
|
- AC_MSG_RESULT([found in ${ac_cv_c_tclh}])
|
||||||
|
+ dirs=${ac_cv_c_tclh}
|
||||||
|
+ stem=${dirs%/generic}
|
||||||
|
+ if test x"${dirs}" != x"$stem" && test -d "$stem/unix"; then
|
||||||
|
+ dirs="$dirs $stem/unix"
|
||||||
|
+ fi
|
||||||
|
+ dashi=''
|
||||||
|
+ for dir in $dirs; do
|
||||||
|
+ dashi="$dashi -I$dir"
|
||||||
|
+ done
|
||||||
|
+ AC_MSG_RESULT([found in ${dirs}])
|
||||||
|
# this hack is cause the TCLHDIR won't print if there is a "-I" in it.
|
||||||
|
- TCLHDIR="${ac_cv_c_tclh}"
|
||||||
|
- TCLHDIRDASHI="-I${ac_cv_c_tclh}"
|
||||||
|
- TCL_LIBRARY=`echo $TCLHDIR | sed -e 's/generic//'`library
|
||||||
|
+ TCLHDIR="${dirs}"
|
||||||
|
+ TCLHDIRDASHI="${dashi# }"
|
||||||
|
+ TCL_LIBRARY=`echo ${dirs% *} | sed -e 's/generic//'`library
|
||||||
|
fi
|
||||||
|
fi
|
||||||
|
|
||||||
|
--- expect-5.43/Dbg.c.tcl8.5 2002-03-23 05:11:54.000000000 +0100
|
||||||
|
+++ expect-5.43/Dbg.c 2007-02-03 01:00:05.000000000 +0100
|
||||||
|
@@ -11,6 +11,7 @@
|
||||||
|
#include <stdio.h>
|
||||||
|
|
||||||
|
#include "tcldbgcf.h"
|
||||||
|
+#include "expect_cf.h"
|
||||||
|
#if 0
|
||||||
|
/* tclInt.h drags in stdlib. By claiming no-stdlib, force it to drag in */
|
||||||
|
/* Tcl's compat version. This avoids having to test for its presence */
|
||||||
|
--- expect-5.43/configure.in.tcl8.5 2007-02-03 01:00:05.000000000 +0100
|
||||||
|
+++ expect-5.43/configure.in 2007-02-03 01:00:05.000000000 +0100
|
||||||
|
@@ -368,7 +368,8 @@
|
||||||
|
cp ${srcdir}/Dbgconfigure ${srcdir}/tcldbg.h ${srcdir}/tcldbgcf.h.in ${srcdir}/install-sh ${tmpdir}
|
||||||
|
cp $srcdir/DbgMkfl.in ${tmpdir}/Makefile.in
|
||||||
|
cp $srcdir/DbgpkgInd.in ${tmpdir}/pkgIndex.in
|
||||||
|
-(cd $tmpdir; ${CONFIG_SHELL-/bin/sh} Dbgconfigure --with-tclinclude=$TCLHDIR $dbg_config_flags)
|
||||||
|
+# Drop .../unix from tclinclude if present, CY_AC_PATH_TCLH will add it again.
|
||||||
|
+(cd $tmpdir; ${CONFIG_SHELL-/bin/sh} Dbgconfigure --with-tclinclude=${TCLHDIR%% *} $dbg_config_flags)
|
||||||
|
cp ${tmpdir}/tcldbgcf.h .
|
||||||
|
rm -rf $tmpdir
|
||||||
|
test -n "$verbose" && echo "configured Tcl debugger"
|
52
expect.spec
52
expect.spec
@ -3,20 +3,19 @@
|
|||||||
Summary: A program-script interaction and testing utility
|
Summary: A program-script interaction and testing utility
|
||||||
Name: expect
|
Name: expect
|
||||||
Version: %{majorver}.0
|
Version: %{majorver}.0
|
||||||
Release: 5.1
|
Release: 6
|
||||||
License: Public Domain
|
License: Public Domain
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
URL: http://expect.nist.gov/
|
URL: http://expect.nist.gov/
|
||||||
Source: http://expect.nist.gov/src/%{name}-%{version}.tar.gz
|
Source: http://expect.nist.gov/src/%{name}-%{version}.tar.gz
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||||
Buildrequires: tcl-devel tk-devel autoconf automake libX11-devel
|
Buildrequires: tcl-devel tk-devel autoconf automake libX11-devel
|
||||||
|
Patch0: expect-5.38.0-spawn-43310.patch
|
||||||
Patch6: expect-5.38.0-spawn-43310.patch
|
Patch1: expect-5.43.0-cfg-setpgrp.patch
|
||||||
Patch8: expect-5.43.0-cfg-setpgrp.patch
|
Patch2: expect-5.38.0-lib-spec.patch
|
||||||
Patch10: expect-5.38.0-lib-spec.patch
|
Patch3: expect-5.39.0-libdir.patch
|
||||||
Patch11: expect-5.39.0-libdir.patch
|
Patch4: expect-5.43.0-log_file.patch
|
||||||
Patch12: expect-5.43.0-log_file.patch
|
Patch5: expect-5.43.0-tcl8.5.patch
|
||||||
|
|
||||||
# examples patches
|
# examples patches
|
||||||
Patch100: expect-5.32.2-random.patch
|
Patch100: expect-5.32.2-random.patch
|
||||||
Patch101: expect-5.32.2-fixcat.patch
|
Patch101: expect-5.32.2-fixcat.patch
|
||||||
@ -58,32 +57,29 @@ This package contains expectk and some scripts that use it.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n expect-%{majorver}
|
%setup -q -n expect-%{majorver}
|
||||||
%patch6 -p2 -b .6-spawn
|
%patch0 -p2 -b .6-spawn
|
||||||
%patch8 -p1 -b .8-pgrp
|
%patch1 -p1 -b .8-pgrp
|
||||||
%patch10 -p1 -b .10-libspec
|
%patch2 -p1 -b .10-libspec
|
||||||
%patch11 -p1 -b .11-libdir
|
%patch3 -p1 -b .11-libdir
|
||||||
%patch12 -p1 -b .12-log_file
|
%patch4 -p1 -b .12-log_file
|
||||||
|
%patch5 -p1 -b .tcl8.5
|
||||||
# examples fixes
|
# examples fixes
|
||||||
%patch100 -p1 -b .100
|
%patch100 -p1 -b .100
|
||||||
%patch101 -p1 -b .101
|
%patch101 -p1 -b .101
|
||||||
%patch102 -p1 -b .102
|
%patch102 -p1 -b .102
|
||||||
# patch8 and patch10 touch configure.in
|
# *-cfg-setpgrp.patch, *-lib-spec.patch and *-tcl8.5.patch touch configure.in
|
||||||
aclocal
|
aclocal
|
||||||
autoconf
|
autoconf
|
||||||
( cd testsuite
|
( cd testsuite
|
||||||
autoconf -I.. )
|
autoconf -I.. )
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --with-tcl=%{_libdir} --with-tk=%{_libdir} --enable-shared --with-tclinclude=%{_includedir}/tcl-private
|
%configure --with-tcl=%{_libdir} --with-tk=%{_libdir} --enable-shared \
|
||||||
|
--with-tclinclude=%{_includedir}/tcl-private
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
# run "make test" by default
|
%check
|
||||||
%{?_without_check: %define _without_check 1}
|
make test
|
||||||
%{!?_without_check: %define _without_check 0}
|
|
||||||
|
|
||||||
%if ! %{_without_check}
|
|
||||||
make test
|
|
||||||
%endif
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
@ -103,7 +99,7 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%doc
|
%doc FAQ HISTORY NEWS README
|
||||||
%{_bindir}/expect
|
%{_bindir}/expect
|
||||||
%{_bindir}/autoexpect
|
%{_bindir}/autoexpect
|
||||||
%{_bindir}/dislocate
|
%{_bindir}/dislocate
|
||||||
@ -135,8 +131,8 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%{_libdir}/expect%{majorver}/libexpect%{majorver}.a
|
%exclude %{_libdir}/expect%{majorver}/libexpect%{majorver}.a
|
||||||
%{_libdir}/libexpect%{majorver}.a
|
%exclude %{_libdir}/libexpect%{majorver}.a
|
||||||
%{_libdir}/libexpect.so
|
%{_libdir}/libexpect.so
|
||||||
%{_mandir}/man3/libexpect.3*
|
%{_mandir}/man3/libexpect.3*
|
||||||
%{_includedir}/*
|
%{_includedir}/*
|
||||||
@ -153,6 +149,12 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_mandir}/man1/tknewsbiff.1*
|
%{_mandir}/man1/tknewsbiff.1*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Feb 3 2007 Miloslav Trmac <mitr@redhat.com> - 5.43.0-6
|
||||||
|
- Update to build with Tcl 8.5
|
||||||
|
- Drop static libraries
|
||||||
|
- Ship more documentation
|
||||||
|
- Use %%check for (make test), remove the conditional
|
||||||
|
|
||||||
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 5.43.0-5.1
|
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 5.43.0-5.1
|
||||||
- rebuild
|
- rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user