parent
3aab9d4c61
commit
fd671807c6
@ -1 +1 @@
|
||||
exiv2-0.18.tar.gz
|
||||
exiv2-0.18.1.tar.gz
|
||||
|
@ -1,62 +0,0 @@
|
||||
diff -up exiv2-0.16/xmpsdk/src/XMPCore_Impl.hpp.gcc43 exiv2-0.16/xmpsdk/src/XMPCore_Impl.hpp
|
||||
--- exiv2-0.16/xmpsdk/src/XMPCore_Impl.hpp.gcc43 2007-12-08 10:52:25.000000000 -0600
|
||||
+++ exiv2-0.16/xmpsdk/src/XMPCore_Impl.hpp 2008-02-11 08:12:25.000000000 -0600
|
||||
@@ -20,6 +20,7 @@
|
||||
#include "client-glue/WXMPMeta.hpp"
|
||||
|
||||
#include <vector>
|
||||
+#include <cstring>
|
||||
#include <string>
|
||||
#include <map>
|
||||
|
||||
diff -up exiv2-0.16/xmpsdk/src/XMPMeta-Serialize.cpp.gcc43 exiv2-0.16/xmpsdk/src/XMPMeta-Serialize.cpp
|
||||
--- exiv2-0.16/xmpsdk/src/XMPMeta-Serialize.cpp.gcc43 2007-10-05 23:46:22.000000000 -0500
|
||||
+++ exiv2-0.16/xmpsdk/src/XMPMeta-Serialize.cpp 2008-02-11 07:45:25.000000000 -0600
|
||||
@@ -22,8 +22,11 @@
|
||||
#include <iostream>
|
||||
#endif
|
||||
|
||||
+#include <cstring>
|
||||
+
|
||||
using namespace std;
|
||||
|
||||
+
|
||||
#if XMP_WinBuild
|
||||
#pragma warning ( disable : 4533 ) // initialization of '...' is skipped by 'goto ...'
|
||||
#pragma warning ( disable : 4702 ) // unreachable code
|
||||
diff -up exiv2-0.16/xmpsdk/src/XMPMeta.cpp.gcc43 exiv2-0.16/xmpsdk/src/XMPMeta.cpp
|
||||
--- exiv2-0.16/xmpsdk/src/XMPMeta.cpp.gcc43 2007-10-06 03:11:52.000000000 -0500
|
||||
+++ exiv2-0.16/xmpsdk/src/XMPMeta.cpp 2008-02-11 07:43:12.000000000 -0600
|
||||
@@ -24,6 +24,8 @@
|
||||
#include <iostream>
|
||||
#endif
|
||||
|
||||
+#include <cstring>
|
||||
+
|
||||
using namespace std;
|
||||
|
||||
#if XMP_WinBuild
|
||||
diff -up exiv2-0.16/xmpsdk/src/XMPMeta-GetSet.cpp.gcc43 exiv2-0.16/xmpsdk/src/XMPMeta-GetSet.cpp
|
||||
--- exiv2-0.16/xmpsdk/src/XMPMeta-GetSet.cpp.gcc43 2007-10-01 12:59:06.000000000 -0500
|
||||
+++ exiv2-0.16/xmpsdk/src/XMPMeta-GetSet.cpp 2008-02-11 07:48:01.000000000 -0600
|
||||
@@ -25,6 +25,8 @@
|
||||
#include <iostream>
|
||||
#endif
|
||||
|
||||
+#include <cstring>
|
||||
+
|
||||
using namespace std;
|
||||
|
||||
#if XMP_WinBuild
|
||||
diff -up exiv2-0.16/xmpsdk/src/XMPMeta-Parse.cpp.gcc43 exiv2-0.16/xmpsdk/src/XMPMeta-Parse.cpp
|
||||
--- exiv2-0.16/xmpsdk/src/XMPMeta-Parse.cpp.gcc43 2008-02-11 07:46:47.000000000 -0600
|
||||
+++ exiv2-0.16/xmpsdk/src/XMPMeta-Parse.cpp 2008-02-11 07:47:00.000000000 -0600
|
||||
@@ -23,6 +23,8 @@
|
||||
#include <iostream>
|
||||
#endif
|
||||
|
||||
+#include <cstring>
|
||||
+
|
||||
using namespace std;
|
||||
|
||||
#if XMP_WinBuild
|
27
exiv2-0.18.1-visibility.patch
Normal file
27
exiv2-0.18.1-visibility.patch
Normal file
@ -0,0 +1,27 @@
|
||||
diff -up exiv2-0.18.1/config/configure.ac.visibility exiv2-0.18.1/config/configure.ac
|
||||
--- exiv2-0.18.1/config/configure.ac.visibility 2009-04-03 10:52:50.000000000 -0500
|
||||
+++ exiv2-0.18.1/config/configure.ac 2009-04-17 14:36:01.000000000 -0500
|
||||
@@ -111,9 +111,9 @@ AC_ARG_ENABLE(visibility,
|
||||
GXX_VISIBILITY=$enableval, GXX_VISIBILITY=yes)
|
||||
AC_MSG_RESULT($GXX_VISIBILITY)
|
||||
if test "$GXX_VISIBILITY" = "yes"; then
|
||||
- AX_CXX_CHECK_FLAG(-fvisibility-inlines-hidden,[],[],[GXX_VISIBILITY=yes],[GXX_VISIBILITY=no])
|
||||
+ AX_CXX_CHECK_FLAG(-fvisibility=hidden,[],[],[GXX_VISIBILITY=yes],[GXX_VISIBILITY=no])
|
||||
if test "$GXX_VISIBILITY" = "yes"; then
|
||||
- CXXFLAGS="${CXXFLAGS} -fvisibility=hidden -fvisibility-inlines-hidden"
|
||||
+ CXXFLAGS="${CXXFLAGS} -fvisibility=hidden"
|
||||
AC_DEFINE(HAVE_GXXCLASSVISIBILITY,1)
|
||||
fi
|
||||
if test "$enable_shared" = "yes"; then
|
||||
diff -up exiv2-0.18.1/configure.visibility exiv2-0.18.1/configure
|
||||
--- exiv2-0.18.1/configure.visibility 2009-04-05 10:50:29.000000000 -0500
|
||||
+++ exiv2-0.18.1/configure 2009-04-17 14:48:51.000000000 -0500
|
||||
@@ -23905,7 +23905,7 @@ fi
|
||||
|
||||
|
||||
if test "$GXX_VISIBILITY" = "yes"; then
|
||||
- CXXFLAGS="${CXXFLAGS} -fvisibility=hidden -fvisibility-inlines-hidden"
|
||||
+ CXXFLAGS="${CXXFLAGS} -fvisibility=hidden"
|
||||
cat >>confdefs.h <<\_ACEOF
|
||||
#define HAVE_GXXCLASSVISIBILITY 1
|
||||
_ACEOF
|
14
exiv2.spec
14
exiv2.spec
@ -6,8 +6,8 @@
|
||||
|
||||
Summary: Exif and Iptc metadata manipulation library
|
||||
Name: exiv2
|
||||
Version: 0.18
|
||||
Release: 2%{?dist}
|
||||
Version: 0.18.1
|
||||
Release: 1%{?dist}
|
||||
|
||||
License: GPLv2+
|
||||
Group: Applications/Multimedia
|
||||
@ -24,7 +24,7 @@ BuildRequires: zlib-devel
|
||||
#BuildRequires: doxygen graphviz libxslt
|
||||
|
||||
Patch1: exiv2-0.18-deps.patch
|
||||
Patch2: exiv2-0.16-gcc43.patch
|
||||
Patch2: exiv2-0.18.1-visibility.patch
|
||||
|
||||
%if 0%{?libs}
|
||||
Requires: %{name}-libs = %{version}-%{release}
|
||||
@ -69,7 +69,7 @@ methods for Exif thumbnails, classes to access Ifd and so on.
|
||||
%setup -q -n %{name}-%{version}%{?pre:-%{pre}}
|
||||
|
||||
%patch1 -p1 -b .deps
|
||||
#patch2 -p1 -b .gcc43
|
||||
%patch2 -p1 -b .visibility
|
||||
|
||||
mkdir doc/html
|
||||
|
||||
@ -77,7 +77,7 @@ mkdir doc/html
|
||||
%build
|
||||
%configure \
|
||||
--disable-rpath \
|
||||
--disable-static
|
||||
--disable-static
|
||||
|
||||
make %{?_smp_mflags}
|
||||
|
||||
@ -130,6 +130,10 @@ rm -rf %{buildroot}
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Apr 17 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.18.1-1
|
||||
- exiv2-0.18.1
|
||||
- drop -fvisibility-inlines-hidden (#496050)
|
||||
|
||||
* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.18-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user