- exiv2-0.21
This commit is contained in:
parent
6a82818aaf
commit
f785d918d7
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
exiv2-0.20.tar.gz
|
/exiv2-0.21.tar.gz
|
||||||
|
@ -1,37 +0,0 @@
|
|||||||
diff -up exiv2-0.20/src/Makefile.deps exiv2-0.20/src/Makefile
|
|
||||||
--- exiv2-0.20/src/Makefile.deps 2010-05-25 10:25:02.000000000 -0500
|
|
||||||
+++ exiv2-0.20/src/Makefile 2010-05-30 13:33:38.181957187 -0500
|
|
||||||
@@ -195,11 +195,19 @@ $(CCOBJ): %.o: %.cpp
|
|
||||||
@$(LIBTOOL) --mode=compile $(COMPILE.cc) -DEXV_BUILDING_LIB=1 -o $@ $<
|
|
||||||
@$(MAKEDEPEND)
|
|
||||||
@$(POSTDEPEND)
|
|
||||||
+# The dependancies here are wrong. It generates .lo output,
|
|
||||||
+# so things are rebuilt *every* time 'make' is called.
|
|
||||||
+# Let's try a quick-n-dirty hack -- Rex
|
|
||||||
+ touch $@
|
|
||||||
|
|
||||||
$(COBJ): %.o: %.c
|
|
||||||
@$(LIBTOOL) --mode=compile $(COMPILE.c) -DEXV_BUILDING_LIB=1 -o $@ $<
|
|
||||||
@$(MAKEDEPEND)
|
|
||||||
@$(POSTDEPEND)
|
|
||||||
+# The dependancies here are wrong. It generates .lo output,
|
|
||||||
+# so things are rebuilt *every* time 'make' is called.
|
|
||||||
+# Let's try a quick-n-dirty hack -- Rex
|
|
||||||
+ touch $@
|
|
||||||
|
|
||||||
$(sort $(BINOBJ) $(EXIV2OBJ) $(MCOBJ) path-test.o): %.o: %.cpp
|
|
||||||
$(COMPILE.cc) -o $@ $<
|
|
||||||
diff -up exiv2-0.20/xmpsdk/src/Makefile.deps exiv2-0.20/xmpsdk/src/Makefile
|
|
||||||
--- exiv2-0.20/xmpsdk/src/Makefile.deps 2010-04-03 02:53:30.000000000 -0500
|
|
||||||
+++ exiv2-0.20/xmpsdk/src/Makefile 2010-05-30 13:36:16.004947131 -0500
|
|
||||||
@@ -108,6 +108,10 @@ $(CCOBJ): %.o: %.cpp
|
|
||||||
@$(LIBTOOL) --mode=compile $(COMPILE.cc) -o $@ $<
|
|
||||||
@$(MAKEDEPEND)
|
|
||||||
@$(POSTDEPEND)
|
|
||||||
+ # The dependancies here are wrong. It generates .lo output,
|
|
||||||
+ # so things are rebuilt *every* time 'make' is called.
|
|
||||||
+ # Let's try a quick-n-dirty hack -- Rex
|
|
||||||
+ @touch $@
|
|
||||||
|
|
||||||
%.ii: %.cpp
|
|
||||||
set -e; \
|
|
15
exiv2.spec
15
exiv2.spec
@ -1,7 +1,7 @@
|
|||||||
|
|
||||||
Summary: Exif and Iptc metadata manipulation library
|
Summary: Exif and Iptc metadata manipulation library
|
||||||
Name: exiv2
|
Name: exiv2
|
||||||
Version: 0.20
|
Version: 0.21
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
|
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
@ -18,8 +18,6 @@ BuildRequires: zlib-devel
|
|||||||
# docs
|
# docs
|
||||||
#BuildRequires: doxygen graphviz libxslt
|
#BuildRequires: doxygen graphviz libxslt
|
||||||
|
|
||||||
Patch1: exiv2-0.20-deps.patch
|
|
||||||
|
|
||||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||||
|
|
||||||
|
|
||||||
@ -55,8 +53,6 @@ methods for Exif thumbnails, classes to access Ifd and so on.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version}%{?pre:-%{pre}}
|
%setup -q -n %{name}-%{version}%{?pre:-%{pre}}
|
||||||
|
|
||||||
%patch1 -p1 -b .deps
|
|
||||||
|
|
||||||
mkdir doc/html
|
mkdir doc/html
|
||||||
|
|
||||||
|
|
||||||
@ -76,10 +72,10 @@ make install DESTDIR=%{buildroot}
|
|||||||
%find_lang exiv2
|
%find_lang exiv2
|
||||||
|
|
||||||
## Unpackaged files
|
## Unpackaged files
|
||||||
rm -f %{buildroot}%{_libdir}/lib*.la
|
rm -fv %{buildroot}%{_libdir}/libexiv2.la
|
||||||
|
|
||||||
## fix perms on installed lib
|
## fix perms on installed lib
|
||||||
chmod 755 %{buildroot}%{_libdir}/lib*.so*
|
chmod 755 %{buildroot}%{_libdir}/libexiv2.so.*
|
||||||
|
|
||||||
## nuke rpaths
|
## nuke rpaths
|
||||||
chrpath --list %{buildroot}%{_bindir}/exiv2 && \
|
chrpath --list %{buildroot}%{_bindir}/exiv2 && \
|
||||||
@ -108,7 +104,7 @@ rm -rf %{buildroot}
|
|||||||
|
|
||||||
%files libs -f exiv2.lang
|
%files libs -f exiv2.lang
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%{_libdir}/libexiv2.so.9*
|
%{_libdir}/libexiv2.so.10*
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
@ -119,6 +115,9 @@ rm -rf %{buildroot}
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Dec 01 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.21-1
|
||||||
|
- exiv2-0.21
|
||||||
|
|
||||||
* Sun May 30 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.20-1
|
* Sun May 30 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.20-1
|
||||||
- exiv2-0.20
|
- exiv2-0.20
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user