0.27.2-RC2 (#1720353)
This commit is contained in:
parent
0a59d55f7b
commit
f596f8af8b
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
|||||||
/exiv2-0.27.1-Source.tar.gz
|
/exiv2-0.27.1-Source.tar.gz
|
||||||
|
/v0.27.2-RC2.tar.gz
|
||||||
|
@ -1,28 +0,0 @@
|
|||||||
diff -up exiv2-0.27.1-Source/cmake/compilerFlags.cmake exiv2-0.27.1-Source/cmake/compilerFlags
|
|
||||||
diff -up exiv2-0.27.1-Source/cmake/compilerFlagsExiv2.cmake exiv2-0.27.1-Source/cmake/compilerFlagsExiv2
|
|
||||||
diff -up exiv2-0.27.1-Source/cmake/config.h.cmake exiv2-0.27.1-Source/cmake/config.h
|
|
||||||
diff -up exiv2-0.27.1-Source/cmake/exiv2_uninstall.cmake exiv2-0.27.1-Source/cmake/exiv2_uninstall
|
|
||||||
diff -up exiv2-0.27.1-Source/cmake/findDependencies.cmake exiv2-0.27.1-Source/cmake/findDependencies
|
|
||||||
diff -up exiv2-0.27.1-Source/cmake/FindIconv.cmake exiv2-0.27.1-Source/cmake/FindIconv
|
|
||||||
diff -up exiv2-0.27.1-Source/cmake/FindRegex.cmake exiv2-0.27.1-Source/cmake/FindRegex
|
|
||||||
diff -up exiv2-0.27.1-Source/cmake/FindSSH.cmake exiv2-0.27.1-Source/cmake/FindSSH
|
|
||||||
diff -up exiv2-0.27.1-Source/cmake/generateConfigFile.cmake exiv2-0.27.1-Source/cmake/generateConfigFile
|
|
||||||
diff -up exiv2-0.27.1-Source/cmake/generateDoc.cmake exiv2-0.27.1-Source/cmake/generateDoc
|
|
||||||
diff -up exiv2-0.27.1-Source/cmake/mainSetup.cmake exiv2-0.27.1-Source/cmake/mainSetup
|
|
||||||
diff -up exiv2-0.27.1-Source/cmake/packaging.cmake exiv2-0.27.1-Source/cmake/packaging
|
|
||||||
diff -up exiv2-0.27.1-Source/cmake/printSummary.cmake exiv2-0.27.1-Source/cmake/printSummary
|
|
||||||
diff -up exiv2-0.27.1-Source/src/CMakeLists.txt.cmake exiv2-0.27.1-Source/src/CMakeLists.txt
|
|
||||||
--- exiv2-0.27.1-Source/src/CMakeLists.txt.cmake 2019-04-26 04:31:16.000000000 -0500
|
|
||||||
+++ exiv2-0.27.1-Source/src/CMakeLists.txt 2019-04-26 13:33:33.913846741 -0500
|
|
||||||
@@ -239,9 +239,9 @@ install(FILES
|
|
||||||
${CMAKE_BINARY_DIR}/exiv2lib_export.h
|
|
||||||
DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/exiv2)
|
|
||||||
|
|
||||||
-install(EXPORT exiv2Config DESTINATION "${CMAKE_INSTALL_LIBDIR}/exiv2/cmake")
|
|
||||||
+install(EXPORT exiv2Config DESTINATION "${CMAKE_INSTALL_LIBDIR}/cmake/exiv2")
|
|
||||||
|
|
||||||
-install(FILES ${CMAKE_CURRENT_BINARY_DIR}/exiv2ConfigVersion.cmake DESTINATION "${CMAKE_INSTALL_LIBDIR}/exiv2/cmake")
|
|
||||||
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/exiv2ConfigVersion.cmake DESTINATION "${CMAKE_INSTALL_LIBDIR}/cmake/exiv2")
|
|
||||||
|
|
||||||
# ******************************************************************************
|
|
||||||
# exiv2 application
|
|
17
exiv2.spec
17
exiv2.spec
@ -1,18 +1,22 @@
|
|||||||
|
|
||||||
|
%global beta RC2
|
||||||
|
|
||||||
Summary: Exif and Iptc metadata manipulation library
|
Summary: Exif and Iptc metadata manipulation library
|
||||||
Name: exiv2
|
Name: exiv2
|
||||||
Version: 0.27.1
|
Version: 0.27.2
|
||||||
Release: 1%{?dist}
|
Release: 0.1.%{beta}%{?dist}
|
||||||
|
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: http://www.exiv2.org/
|
URL: http://www.exiv2.org/
|
||||||
#Source0: https://github.com/Exiv2/%{name}/archive/exiv2-%{version}.tar.gz
|
%if 0%{?beta:1}
|
||||||
|
Source0: https://github.com/Exiv2/%{name}/archive/v%{version}-%{beta}.tar.gz
|
||||||
|
%else
|
||||||
Source0: http://exiv2.org/builds/%{name}-%{version}-Source.tar.gz
|
Source0: http://exiv2.org/builds/%{name}-%{version}-Source.tar.gz
|
||||||
|
%endif
|
||||||
|
|
||||||
## upstream patches
|
## upstream patches
|
||||||
|
|
||||||
## upstreamable patches
|
## upstreamable patches
|
||||||
Patch100: exiv2-0.27.1-cmake_path.patch
|
|
||||||
|
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: expat-devel
|
BuildRequires: expat-devel
|
||||||
@ -69,7 +73,7 @@ BuildArch: noarch
|
|||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%autosetup -n %{name}-%{version}-Source -p1
|
%autosetup -n %{name}-%{version}-%{?beta}%{!?beta:Source} -p1
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -128,6 +132,9 @@ test -x %{buildroot}%{_libdir}/libexiv2.so
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jul 16 2019 Rex Dieter <rdieter@fedoraproject.org> - 0.27.2-0.1.RC2
|
||||||
|
- 0.27.2-RC2 (#1720353)
|
||||||
|
|
||||||
* Fri Apr 26 2019 Rex Dieter <rdieter@fedoraproject.org> - 0.27.1-1
|
* Fri Apr 26 2019 Rex Dieter <rdieter@fedoraproject.org> - 0.27.1-1
|
||||||
- exiv-0.27.1 (#1696117)
|
- exiv-0.27.1 (#1696117)
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (exiv2-0.27.1-Source.tar.gz) = 038b51241f5bfb323eb298695b5397a7d88d5c7d7303828e5e20b3f82c3df2615cee3e7e3426ea17438ca05d5abea10984cfd41f0649ddab72df1d1415bf3529
|
SHA512 (v0.27.2-RC2.tar.gz) = cf06d8bf25deff633a2780bfd345c9493db19f12dad559281279d6fea3a8dea384e4627e442d3bab3fb8fc79ba139a48de74471dd9dec8452adbcbf6723de1df
|
||||||
|
Loading…
Reference in New Issue
Block a user