backport pentax DNG crasher (#1585514, exiv2#201)
This commit is contained in:
parent
bc676732f4
commit
ca955494e2
20
exiv2-0.26-pentax_backport.patch
Normal file
20
exiv2-0.26-pentax_backport.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
diff -up exiv2-0.26/src/pentaxmn.cpp.pentax exiv2-0.26/src/pentaxmn.cpp
|
||||||
|
--- exiv2-0.26/src/pentaxmn.cpp.pentax 2017-04-26 14:16:21.000000000 -0500
|
||||||
|
+++ exiv2-0.26/src/pentaxmn.cpp 2019-01-10 14:21:00.342499581 -0600
|
||||||
|
@@ -1254,6 +1254,7 @@ namespace Exiv2 {
|
||||||
|
unsigned long lensID = 0x3ff;
|
||||||
|
unsigned long index = 0;
|
||||||
|
|
||||||
|
+ // http://www.sno.phy.queensu.ca/~phil/exiftool/TagNames/Pentax.html#LensData
|
||||||
|
const ExifData::const_iterator lensInfo = metadata->findKey(ExifKey("Exif.PentaxDng.LensInfo")) != metadata->end()
|
||||||
|
? metadata->findKey(ExifKey("Exif.PentaxDng.LensInfo"))
|
||||||
|
: metadata->findKey(ExifKey("Exif.Pentax.LensInfo"))
|
||||||
|
@@ -1268,8 +1269,6 @@ namespace Exiv2 {
|
||||||
|
// 0x0207 Pentax LensInfo Undefined 36 3 255 0 0 40 148 71 152 80 6 241 65 237 153 88 36 1 76 107 251 255 255 255 0 0 80 6 241 0 0 0 0 0 0 0 0
|
||||||
|
unsigned long base = 1;
|
||||||
|
|
||||||
|
- // http://www.sno.phy.queensu.ca/~phil/exiftool/TagNames/Pentax.html#LensData
|
||||||
|
- const ExifData::const_iterator lensInfo = metadata->findKey(ExifKey("Exif.Pentax.LensInfo"));
|
||||||
|
unsigned int autoAperture = lensInfo->toLong(base+1) & 0x01 ;
|
||||||
|
unsigned int minAperture = lensInfo->toLong(base+2) & 0x06 ;
|
||||||
|
unsigned int minFocusDistance = lensInfo->toLong(base+3) & 0xf8 ;
|
10
exiv2.spec
10
exiv2.spec
@ -6,7 +6,7 @@
|
|||||||
Summary: Exif and Iptc metadata manipulation library
|
Summary: Exif and Iptc metadata manipulation library
|
||||||
Name: exiv2
|
Name: exiv2
|
||||||
Version: 0.26
|
Version: 0.26
|
||||||
Release: 12%{?dist}
|
Release: 13%{?dist}
|
||||||
|
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: http://www.exiv2.org/
|
URL: http://www.exiv2.org/
|
||||||
@ -39,6 +39,11 @@ Patch25: exiv2-CVE-2018-8977.patch
|
|||||||
## upstreamable patches
|
## upstreamable patches
|
||||||
Patch100: exiv2-doxygen.patch
|
Patch100: exiv2-doxygen.patch
|
||||||
|
|
||||||
|
## upstream backports
|
||||||
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1585514
|
||||||
|
# https://github.com/Exiv2/exiv2/issues/201
|
||||||
|
Patch200: exiv2-0.26-pentax_backport.patch
|
||||||
|
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: expat-devel
|
BuildRequires: expat-devel
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
@ -148,6 +153,9 @@ test -x %{buildroot}%{_libdir}/libexiv2.so
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jan 10 2019 Rex Dieter <rdieter@fedoraproject.org> - 0.26-13
|
||||||
|
- backport pentax DNG crasher (#1585514, exiv2#201)
|
||||||
|
|
||||||
* Tue Jul 24 2018 Jan Grulich <jgrulich@redhat.com> - 0.26-12
|
* Tue Jul 24 2018 Jan Grulich <jgrulich@redhat.com> - 0.26-12
|
||||||
- Security fix for CVE-2017-17723, CVE-2017-17725, CVE-2018-10958, CVE-2018-10998,
|
- Security fix for CVE-2017-17723, CVE-2017-17725, CVE-2018-10958, CVE-2018-10998,
|
||||||
CVE-2018-11531, CVE-2018-12264, CVE-2018-12265, CVE-2018-14046, CVE-2018-5772,
|
CVE-2018-11531, CVE-2018-12264, CVE-2018-12265, CVE-2018-14046, CVE-2018-5772,
|
||||||
|
Loading…
Reference in New Issue
Block a user