auto-import exiv2-0.9.1-3 on branch devel from exiv2-0.9.1-3.src.rpm
This commit is contained in:
parent
d7e19dbe5f
commit
7852339184
@ -0,0 +1 @@
|
||||
exiv2-0.9.1.tar.gz
|
13
exiv2-0.9.1-deps.patch
Normal file
13
exiv2-0.9.1-deps.patch
Normal file
@ -0,0 +1,13 @@
|
||||
--- exiv2-0.9.1/src/Makefile.deps 2006-01-20 02:45:59.000000000 -0600
|
||||
+++ exiv2-0.9.1/src/Makefile 2006-05-18 09:10:11.000000000 -0500
|
||||
@@ -156,6 +156,10 @@
|
||||
@$(LIBTOOL) --mode=compile $(COMPILE.cc) -o $@ $<
|
||||
@$(MAKEDEPEND)
|
||||
@$(POSTDEPEND)
|
||||
+# The dependancies here are wrong. It generates .lo output,
|
||||
+# so things are rebuilt *every* time 'make' is called.
|
||||
+# Let's try a quick-n-dirty hack -- Rex
|
||||
+ touch $@
|
||||
|
||||
$(COBJ): %.o: %.c
|
||||
@$(LIBTOOL) --mode=compile $(COMPILE.c) -o $@ $<
|
20
exiv2-0.9.1-no_rpath.patch
Normal file
20
exiv2-0.9.1-no_rpath.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- exiv2-0.9.1/src/Makefile.no_rpath 2006-05-18 08:41:02.000000000 -0500
|
||||
+++ exiv2-0.9.1/src/Makefile 2006-05-18 09:10:11.000000000 -0500
|
||||
@@ -148,7 +148,7 @@
|
||||
# Compilation shortcuts
|
||||
COMPILE.cc = $(CXX) $(CXXFLAGS) $(CXXDEFS) $(CXXINCS) -c
|
||||
COMPILE.c = $(CC) $(CFLAGS) $(DEFS) $(INCS) -c
|
||||
-LINK.cc = $(CXX) $(CXXFLAGS) $(LDLIBS) $(LDFLAGS) -rpath $(libdir)
|
||||
+LINK.cc = $(CXX) $(CXXFLAGS) $(LDLIBS) $(LDFLAGS) #-rpath $(libdir)
|
||||
|
||||
# ******************************************************************************
|
||||
# Rules
|
||||
@@ -203,7 +203,7 @@
|
||||
bin: lib $(BINARY) $(EXIV2BIN) $(MCBIN) path-test
|
||||
|
||||
lib: $(OBJ)
|
||||
- $(LIBTOOL) --mode=link $(CXX) $(LDFLAGS) $(LOBJ) -o $(LIBRARY) -rpath $(libdir) -release $(EXIV2_VERSION)
|
||||
+ $(LIBTOOL) --mode=link $(CXX) $(LDFLAGS) $(LOBJ) -o $(LIBRARY) -release $(EXIV2_VERSION) -rpath $(libdir)
|
||||
@touch lib
|
||||
|
||||
path-test: path-test.o utils.o
|
102
exiv2.spec
Normal file
102
exiv2.spec
Normal file
@ -0,0 +1,102 @@
|
||||
|
||||
Summary: Exif and Iptc metadata manipulation library and tools
|
||||
Name: exiv2
|
||||
Version: 0.9.1
|
||||
Release: 3%{?dist}
|
||||
|
||||
License: GPL
|
||||
Group: Applications/Multimedia
|
||||
URL: http://home.arcor.de/ahuggel/exiv2/
|
||||
Source: http://home.arcor.de/ahuggel/exiv2/exiv2-%{version}.tar.gz
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
Patch1: exiv2-0.9.1-no_rpath.patch
|
||||
Patch2: exiv2-0.9.1-deps.patch
|
||||
|
||||
|
||||
|
||||
%description
|
||||
Exiv2 comprises of a C++ library and a command line utility to access image
|
||||
metadata. Exiv2 supports full read and write access to the Exif and Iptc
|
||||
metadata, Exif MakerNote support, extract and delete methods for Exif
|
||||
thumbnails, classes to access Ifd and so on.
|
||||
The command line utility allows you to:
|
||||
* print the Exif metadata of Jpeg images as summary info, interpreted values,
|
||||
or the plain data for each tag
|
||||
* print the Iptc metadata of Jpeg images
|
||||
* print the Jpeg comment of Jpeg images
|
||||
* set, add and delete Exif and Iptc metadata of Jpeg images
|
||||
* adjust the Exif timestamp (that's how it all started...)
|
||||
* rename Exif image files according to the Exif timestamp
|
||||
* extract, insert and delete Exif metadata (including thumbnails),
|
||||
Iptc metadata and Jpeg comments
|
||||
|
||||
%package devel
|
||||
Summary: Header files, libraries and development documentation for %{name}
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
%description devel
|
||||
%{summary}.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%patch1 -p1 -b .no_rpath
|
||||
%patch2 -p1 -b .deps
|
||||
|
||||
|
||||
%build
|
||||
%configure --disable-static
|
||||
|
||||
make -C src %{?_smp_mflags}
|
||||
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
make -C src install DESTDIR=$RPM_BUILD_ROOT
|
||||
|
||||
# Unpackaged files
|
||||
rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
|
||||
|
||||
# set eXecute bit on installed lib
|
||||
chmod a+x $RPM_BUILD_ROOT%{_libdir}/libexiv2-*.so
|
||||
|
||||
|
||||
%clean
|
||||
rm -rf $FPM_BUILD_ROOT
|
||||
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc COPYING README
|
||||
%{_bindir}/exiv2
|
||||
%{_libdir}/libexiv2-*.so
|
||||
%{_mandir}/man1/*
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root,-)
|
||||
%doc doc/html
|
||||
%{_bindir}/exiv2-config
|
||||
%{_includedir}/exiv2/
|
||||
%{_libdir}/libexiv2.so
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed May 17 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.9.1-3
|
||||
- cleanup %%description
|
||||
- set eXecute bit on installed lib.
|
||||
- no_rpath patch
|
||||
- deps patch (items get (re)compiled on *every* call to 'make')
|
||||
|
||||
* Wed May 17 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.9.1-2
|
||||
- %%post/%%postun: /sbin/ldconfig
|
||||
|
||||
* Tue May 16 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.9.1-1
|
||||
- first try
|
Loading…
Reference in New Issue
Block a user