exiv2-0.22
This commit is contained in:
parent
0076c9afbd
commit
63c47b6076
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
|||||||
/exiv2-0.21.1.tar.gz
|
/exiv2-0.21.1.tar.gz
|
||||||
|
/exiv2-0.22.tar.gz
|
||||||
|
@ -1,18 +0,0 @@
|
|||||||
--- a/src/canonmn.cpp 2011-02-13 15:39:15.000000000 +0100
|
|
||||||
+++ b/src/canonmn.cpp 2011-05-25 19:58:40.420111647 +0200
|
|
||||||
@@ -549,6 +549,7 @@
|
|
||||||
{ 154, "Canon EF 20mm f/2.8 USM" },
|
|
||||||
{ 155, "Canon EF 85mm f/1.8 USM" },
|
|
||||||
{ 156, "Canon EF 28-105mm f/3.5-4.5 USM" },
|
|
||||||
+ { 156, "Tamron SP AF 70-300mm F4-5.6 Di VC USD" }, // 1
|
|
||||||
{ 160, "Canon EF 20-35mm f/3.5-4.5 USM" }, // 0
|
|
||||||
{ 160, "Tamron AF 19-35mm f/3.5-4.5" }, // 1
|
|
||||||
{ 161, "Canon EF 28-70mm f/2.8L" }, // 0
|
|
||||||
@@ -671,6 +672,7 @@
|
|
||||||
{ 150, printCsLensByFocalLength },
|
|
||||||
{ 152, printCsLensByFocalLength },
|
|
||||||
{ 153, printCsLensByFocalLength },
|
|
||||||
+ { 156, printCsLensByFocalLength },
|
|
||||||
{ 161, printCsLensByFocalLength },
|
|
||||||
{ 169, printCsLensByFocalLength },
|
|
||||||
{ 173, printCsLensByFocalLength }, // works partly
|
|
@ -1,26 +0,0 @@
|
|||||||
Index: tiffcomposite.cpp
|
|
||||||
===================================================================
|
|
||||||
--- tiffcomposite.cpp (revision 2561)
|
|
||||||
+++ tiffcomposite.cpp (revision 2562)
|
|
||||||
@@ -1689,11 +1689,19 @@
|
|
||||||
|
|
||||||
if (elements_.empty()) return 0;
|
|
||||||
|
|
||||||
+ // Remaining assumptions:
|
|
||||||
+ // - array elements don't "overlap"
|
|
||||||
+ // - no duplicate tags in the array
|
|
||||||
uint32_t idx = 0;
|
|
||||||
+ uint32_t sz = cfg()->tagStep();
|
|
||||||
for (Components::const_iterator i = elements_.begin(); i != elements_.end(); ++i) {
|
|
||||||
- idx = EXV_MAX(idx, (*i)->tag() * cfg()->tagStep());
|
|
||||||
- idx += (*i)->size();
|
|
||||||
+ if ((*i)->tag() > idx) {
|
|
||||||
+ idx = (*i)->tag();
|
|
||||||
+ sz = (*i)->size();
|
|
||||||
+ }
|
|
||||||
}
|
|
||||||
+ idx = idx * cfg()->tagStep() + sz;
|
|
||||||
+
|
|
||||||
if (cfg()->hasFillers_ && def()) {
|
|
||||||
const ArrayDef* lastDef = def() + defSize() - 1;
|
|
||||||
uint16_t lastTag = static_cast<uint16_t>(lastDef->idx_ / cfg()->tagStep());
|
|
26
exiv2.spec
26
exiv2.spec
@ -1,8 +1,8 @@
|
|||||||
|
|
||||||
Summary: Exif and Iptc metadata manipulation library
|
Summary: Exif and Iptc metadata manipulation library
|
||||||
Name: exiv2
|
Name: exiv2
|
||||||
Version: 0.21.1
|
Version: 0.22
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
|
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: Applications/Multimedia
|
Group: Applications/Multimedia
|
||||||
@ -11,10 +11,6 @@ Source0: http://www.exiv2.org/exiv2-%{version}%{?pre:-%{pre}}.tar.gz
|
|||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
## upstream patches
|
## upstream patches
|
||||||
# http://dev.exiv2.org/issues/769
|
|
||||||
Patch100: exiv2-0.21.1-tiffcomposite.patch
|
|
||||||
# http://dev.exiv2.org/issues/772
|
|
||||||
Patch101: http://dev.exiv2.org/attachments/download/258/exiv2-0.21-Tamron70-300.patch
|
|
||||||
|
|
||||||
BuildRequires: chrpath
|
BuildRequires: chrpath
|
||||||
BuildRequires: expat-devel
|
BuildRequires: expat-devel
|
||||||
@ -59,11 +55,6 @@ methods for Exif thumbnails, classes to access Ifd and so on.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version}%{?pre:-%{pre}}
|
%setup -q -n %{name}-%{version}%{?pre:-%{pre}}
|
||||||
|
|
||||||
pushd src
|
|
||||||
%patch100 -p0 -b .tiffcomposite
|
|
||||||
popd
|
|
||||||
%patch101 -p1 -b .Tamron70-300
|
|
||||||
|
|
||||||
mkdir doc/html
|
mkdir doc/html
|
||||||
|
|
||||||
|
|
||||||
@ -103,20 +94,18 @@ test "$(pkg-config --modversion exiv2)" = "%{version}"
|
|||||||
rm -rf %{buildroot}
|
rm -rf %{buildroot}
|
||||||
|
|
||||||
|
|
||||||
%post libs -p /sbin/ldconfig
|
|
||||||
|
|
||||||
%postun libs -p /sbin/ldconfig
|
|
||||||
|
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%doc COPYING README
|
%doc COPYING README
|
||||||
%{_bindir}/exiv2
|
%{_bindir}/exiv2
|
||||||
%{_mandir}/man1/*
|
%{_mandir}/man1/*
|
||||||
|
|
||||||
|
%post libs -p /sbin/ldconfig
|
||||||
|
%postun libs -p /sbin/ldconfig
|
||||||
|
|
||||||
%files libs -f exiv2.lang
|
%files libs -f exiv2.lang
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%{_libdir}/libexiv2.so.10*
|
%{_libdir}/libexiv2.so.11*
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
@ -127,6 +116,9 @@ rm -rf %{buildroot}
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Oct 14 2011 Rex Dieter <rdieter@fedoraproject.org> 0.22-1
|
||||||
|
- exiv2-0.22
|
||||||
|
|
||||||
* Tue Sep 27 2011 Rex Dieter <rdieter@fedoraproject.org> 0.21.1-3
|
* Tue Sep 27 2011 Rex Dieter <rdieter@fedoraproject.org> 0.21.1-3
|
||||||
- New Tamron 70-300 mm lens improperly recognized (#708403)
|
- New Tamron 70-300 mm lens improperly recognized (#708403)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user