- exiv2-0.16-pre1
This commit is contained in:
parent
ef42e7f7f7
commit
475e5cf07b
@ -2,3 +2,4 @@ clog
|
|||||||
exiv2-0.12.tar.gz
|
exiv2-0.12.tar.gz
|
||||||
exiv2-0.14.tar.gz
|
exiv2-0.14.tar.gz
|
||||||
exiv2-0.15.tar.gz
|
exiv2-0.15.tar.gz
|
||||||
|
exiv2-0.16-pre1.tar.gz
|
||||||
|
@ -1,11 +0,0 @@
|
|||||||
--- exiv2-0.11/src/Makefile.no_rpath 2006-09-19 13:49:19.000000000 -0500
|
|
||||||
+++ exiv2-0.11/src/Makefile 2006-09-19 13:50:05.000000000 -0500
|
|
||||||
@@ -196,7 +196,7 @@
|
|
||||||
COMPILE.cc = $(CXX) $(CXXFLAGS) $(CXXDEFS) $(CXXINCS) -c
|
|
||||||
COMPILE.c = $(CC) $(CFLAGS) $(DEFS) $(INCS) -c
|
|
||||||
# LINK.cc does not need $(LIBS), libtool's dark magic takes care of that
|
|
||||||
-LINK.cc = $(CXX) $(CXXFLAGS) $(LIBRARY) $(LDFLAGS) -rpath $(libdir)
|
|
||||||
+LINK.cc = $(CXX) $(CXXFLAGS) $(LIBRARY) $(LDFLAGS) #-rpath $(libdir)
|
|
||||||
|
|
||||||
# ******************************************************************************
|
|
||||||
# Rules
|
|
42
exiv2.spec
42
exiv2.spec
@ -1,21 +1,24 @@
|
|||||||
|
|
||||||
|
%define pre pre1
|
||||||
|
|
||||||
Summary: Exif and Iptc metadata manipulation library
|
Summary: Exif and Iptc metadata manipulation library
|
||||||
Name: exiv2
|
Name: exiv2
|
||||||
Version: 0.15
|
Version: 0.16
|
||||||
Release: 4%{?dist}
|
Release: 0.1.%{?pre}%{?dist}
|
||||||
|
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: Applications/Multimedia
|
Group: Applications/Multimedia
|
||||||
URL: http://www.exiv2.org/
|
URL: http://www.exiv2.org/
|
||||||
Source0: http://www.exiv2.org/exiv2-%{version}.tar.gz
|
Source0: http://www.exiv2.org/exiv2-%{version}%{?pre:-%{pre}}.tar.gz
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
BuildRequires: zlib-devel
|
BuildRequires: chrpath
|
||||||
|
BuildRequires: expat-devel
|
||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
|
BuildRequires: zlib-devel
|
||||||
# docs
|
# docs
|
||||||
BuildRequires: doxygen graphviz libxslt
|
#BuildRequires: doxygen graphviz libxslt
|
||||||
|
|
||||||
Patch1: exiv2-0.11-no_rpath.patch
|
|
||||||
Patch2: exiv2-0.9.1-deps.patch
|
Patch2: exiv2-0.9.1-deps.patch
|
||||||
|
|
||||||
Requires: %{name}-libs = %{version}-%{release}
|
Requires: %{name}-libs = %{version}-%{release}
|
||||||
@ -53,41 +56,45 @@ methods for Exif thumbnails, classes to access Ifd and so on.
|
|||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q -n %{name}-%{version}%{?pre:-%{pre}}
|
||||||
|
|
||||||
%patch1 -p1 -b .no_rpath
|
|
||||||
%patch2 -p1 -b .deps
|
%patch2 -p1 -b .deps
|
||||||
|
|
||||||
mkdir doc/html
|
mkdir doc/html
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --disable-static
|
%configure \
|
||||||
|
--disable-rpath \
|
||||||
|
--disable-static
|
||||||
|
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf %{buildroot}
|
||||||
|
|
||||||
make install DESTDIR=$RPM_BUILD_ROOT
|
make install DESTDIR=%{buildroot}
|
||||||
|
|
||||||
%find_lang exiv2
|
%find_lang exiv2
|
||||||
|
|
||||||
# Unpackaged files
|
# Unpackaged files
|
||||||
rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
|
rm -f %{buildroot}%{_libdir}/lib*.la
|
||||||
|
|
||||||
# fix perms on installed lib
|
# fix perms on installed lib
|
||||||
chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so*
|
chmod 755 %{buildroot}%{_libdir}/lib*.so*
|
||||||
|
|
||||||
|
# nuke rpaths
|
||||||
|
chrpath --list %{buildroot}%{_bindir}/exiv2
|
||||||
|
chrpath --delete %{buildroot}%{_bindir}/exiv2
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
rm -rf $FPM_BUILD_ROOT
|
rm -rf %{buildroot}
|
||||||
|
|
||||||
|
|
||||||
%post -p /sbin/ldconfig
|
%post libs -p /sbin/ldconfig
|
||||||
|
|
||||||
%postun -p /sbin/ldconfig
|
%postun libs -p /sbin/ldconfig
|
||||||
|
|
||||||
|
|
||||||
%files
|
%files
|
||||||
@ -109,6 +116,9 @@ rm -rf $FPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Nov 13 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 0.16-0.1.pre1
|
||||||
|
- exiv2-0.16-pre1
|
||||||
|
|
||||||
* Tue Sep 18 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 0.15-4
|
* Tue Sep 18 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 0.15-4
|
||||||
- -libs: -Requires: %%name
|
- -libs: -Requires: %%name
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user