import exiv2-0.27.3-5.el8
This commit is contained in:
commit
3d93411f74
1
.exiv2.metadata
Normal file
1
.exiv2.metadata
Normal file
@ -0,0 +1 @@
|
||||
5f1b460b10171c3b12cd540d699e9b815f6f3058 SOURCES/exiv2-0.27.3.tar.gz
|
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/exiv2-0.27.3.tar.gz
|
12
SOURCES/exiv2-0.27.3-fcf-protection.patch
Normal file
12
SOURCES/exiv2-0.27.3-fcf-protection.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up exiv2-0.27.3-Source/cmake/compilerFlags.cmake.fcf-protection exiv2-0.27.3-Source/cmake/compilerFlags.cmake
|
||||
--- exiv2-0.27.3-Source/cmake/compilerFlags.cmake.fcf-protection 2020-06-30 08:33:22.000000000 -0500
|
||||
+++ exiv2-0.27.3-Source/cmake/compilerFlags.cmake 2020-06-30 18:03:38.197967648 -0500
|
||||
@@ -26,7 +26,7 @@ if ( MINGW OR UNIX OR MSYS ) # MINGW, Li
|
||||
# This fails under Fedora, MinGW GCC 8.3.0 and CYGWIN/MSYS 9.3.0
|
||||
if (NOT (MINGW OR CMAKE_HOST_SOLARIS OR CYGWIN OR MSYS) )
|
||||
if (COMPILER_IS_GCC AND CMAKE_CXX_COMPILER_VERSION VERSION_GREATER_EQUAL 8.0)
|
||||
- add_compile_options(-fstack-clash-protection -fcf-protection)
|
||||
+ add_compile_options(-fstack-clash-protection)
|
||||
endif()
|
||||
|
||||
if( (COMPILER_IS_GCC AND CMAKE_CXX_COMPILER_VERSION VERSION_GREATER_EQUAL 5.0) # Not in GCC 4.8
|
26
SOURCES/exiv2-CVE-2021-29457.patch
Normal file
26
SOURCES/exiv2-CVE-2021-29457.patch
Normal file
@ -0,0 +1,26 @@
|
||||
From 13e5a3e02339b746abcaee6408893ca2fd8e289d Mon Sep 17 00:00:00 2001
|
||||
From: Pydera <pydera@mailbox.org>
|
||||
Date: Thu, 8 Apr 2021 17:36:16 +0200
|
||||
Subject: [PATCH] Fix out of buffer access in #1529
|
||||
|
||||
---
|
||||
src/jp2image.cpp | 5 +++--
|
||||
1 file changed, 3 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/jp2image.cpp b/src/jp2image.cpp
|
||||
index 88ab9b2d6..12025f966 100644
|
||||
--- a/src/jp2image.cpp
|
||||
+++ b/src/jp2image.cpp
|
||||
@@ -776,9 +776,10 @@ static void boxes_check(size_t b,size_t m)
|
||||
#endif
|
||||
box.length = (uint32_t) (io_->size() - io_->tell() + 8);
|
||||
}
|
||||
- if (box.length == 1)
|
||||
+ if (box.length < 8)
|
||||
{
|
||||
- // FIXME. Special case. the real box size is given in another place.
|
||||
+ // box is broken, so there is nothing we can do here
|
||||
+ throw Error(kerCorruptedMetadata);
|
||||
}
|
||||
|
||||
// Read whole box : Box header + Box data (not fixed size - can be null).
|
49
SOURCES/exiv2-CVE-2021-29458.patch
Normal file
49
SOURCES/exiv2-CVE-2021-29458.patch
Normal file
@ -0,0 +1,49 @@
|
||||
From 0a91b56616404f7b29ca28deb01ce18b767d1871 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Backhouse <kevinbackhouse@github.com>
|
||||
Date: Fri, 9 Apr 2021 13:26:23 +0100
|
||||
Subject: [PATCH 1/5] Fix incorrect delete.
|
||||
|
||||
---
|
||||
src/crwimage_int.cpp | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/crwimage_int.cpp b/src/crwimage_int.cpp
|
||||
index a44a67e2c..6f89fa8b8 100644
|
||||
--- a/src/crwimage_int.cpp
|
||||
+++ b/src/crwimage_int.cpp
|
||||
@@ -579,7 +579,7 @@ namespace Exiv2 {
|
||||
void CiffComponent::setValue(DataBuf buf)
|
||||
{
|
||||
if (isAllocated_) {
|
||||
- delete pData_;
|
||||
+ delete[] pData_;
|
||||
pData_ = 0;
|
||||
size_ = 0;
|
||||
}
|
||||
|
||||
From 9b7a19f957af53304655ed1efe32253a1b11a8d0 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Backhouse <kevinbackhouse@github.com>
|
||||
Date: Fri, 9 Apr 2021 13:37:48 +0100
|
||||
Subject: [PATCH 3/5] Fix integer overflow.
|
||||
|
||||
---
|
||||
src/crwimage_int.cpp | 6 +++++-
|
||||
1 file changed, 5 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/crwimage_int.cpp b/src/crwimage_int.cpp
|
||||
index 6f89fa8b8..7b958c26f 100644
|
||||
--- a/src/crwimage_int.cpp
|
||||
+++ b/src/crwimage_int.cpp
|
||||
@@ -1187,7 +1187,11 @@ namespace Exiv2 {
|
||||
pCrwMapping->crwDir_);
|
||||
if (edX != edEnd || edY != edEnd || edO != edEnd) {
|
||||
uint32_t size = 28;
|
||||
- if (cc && cc->size() > size) size = cc->size();
|
||||
+ if (cc) {
|
||||
+ if (cc->size() < size)
|
||||
+ throw Error(kerCorruptedMetadata);
|
||||
+ size = cc->size();
|
||||
+ }
|
||||
DataBuf buf(size);
|
||||
std::memset(buf.pData_, 0x0, buf.size_);
|
||||
if (cc) std::memcpy(buf.pData_ + 8, cc->pData() + 8, cc->size() - 8);
|
21
SOURCES/exiv2-CVE-2021-29470.patch
Normal file
21
SOURCES/exiv2-CVE-2021-29470.patch
Normal file
@ -0,0 +1,21 @@
|
||||
diff --git a/src/jp2image.cpp b/src/jp2image.cpp
|
||||
index 0de088d..6310c08 100644
|
||||
--- a/src/jp2image.cpp
|
||||
+++ b/src/jp2image.cpp
|
||||
@@ -645,13 +645,16 @@ static void boxes_check(size_t b,size_t m)
|
||||
DataBuf output(boxBuf.size_ + iccProfile_.size_ + 100); // allocate sufficient space
|
||||
int outlen = sizeof(Jp2BoxHeader) ; // now many bytes have we written to output?
|
||||
int inlen = sizeof(Jp2BoxHeader) ; // how many bytes have we read from boxBuf?
|
||||
+ enforce(sizeof(Jp2BoxHeader) <= static_cast<size_t>(output.size_), Exiv2::kerCorruptedMetadata);
|
||||
Jp2BoxHeader* pBox = (Jp2BoxHeader*) boxBuf.pData_;
|
||||
int32_t length = getLong((byte*)&pBox->length, bigEndian);
|
||||
+ enforce(length <= static_cast<size_t>(output.size_), Exiv2::kerCorruptedMetadata);
|
||||
int32_t count = sizeof (Jp2BoxHeader);
|
||||
char* p = (char*) boxBuf.pData_;
|
||||
bool bWroteColor = false ;
|
||||
|
||||
while ( count < length || !bWroteColor ) {
|
||||
+ enforce(sizeof(Jp2BoxHeader) <= length - count, Exiv2::kerCorruptedMetadata);
|
||||
Jp2BoxHeader* pSubBox = (Jp2BoxHeader*) (p+count) ;
|
||||
|
||||
// copy data. pointer could be into a memory mapped file which we will decode!
|
21
SOURCES/exiv2-CVE-2021-29473.patch
Normal file
21
SOURCES/exiv2-CVE-2021-29473.patch
Normal file
@ -0,0 +1,21 @@
|
||||
From e6a0982f7cd9282052b6e3485a458d60629ffa0b Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Backhouse <kevinbackhouse@github.com>
|
||||
Date: Fri, 23 Apr 2021 11:44:44 +0100
|
||||
Subject: [PATCH 2/2] Add bounds check in Jp2Image::doWriteMetadata().
|
||||
|
||||
---
|
||||
src/jp2image.cpp | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/jp2image.cpp b/src/jp2image.cpp
|
||||
index 1694fed27..ca8c9ddbb 100644
|
||||
--- a/src/jp2image.cpp
|
||||
+++ b/src/jp2image.cpp
|
||||
@@ -908,6 +908,7 @@ static void boxes_check(size_t b,size_t m)
|
||||
|
||||
case kJp2BoxTypeUuid:
|
||||
{
|
||||
+ enforce(boxBuf.size_ >= 24, Exiv2::kerCorruptedMetadata);
|
||||
if(memcmp(boxBuf.pData_ + 8, kJp2UuidExif, 16) == 0)
|
||||
{
|
||||
#ifdef EXIV2_DEBUG_MESSAGES
|
55
SOURCES/exiv2-CVE-2021-3482.patch
Normal file
55
SOURCES/exiv2-CVE-2021-3482.patch
Normal file
@ -0,0 +1,55 @@
|
||||
From 22ea582c6b74ada30bec3a6b15de3c3e52f2b4da Mon Sep 17 00:00:00 2001
|
||||
From: Robin Mills <robin@clanmills.com>
|
||||
Date: Mon, 5 Apr 2021 20:33:25 +0100
|
||||
Subject: [PATCH] fix_1522_jp2image_exif_asan
|
||||
|
||||
---
|
||||
src/jp2image.cpp | 9 ++++++---
|
||||
1 file changed, 6 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/src/jp2image.cpp b/src/jp2image.cpp
|
||||
index eb31cea4a..88ab9b2d6 100644
|
||||
--- a/src/jp2image.cpp
|
||||
+++ b/src/jp2image.cpp
|
||||
@@ -28,6 +28,7 @@
|
||||
#include "image.hpp"
|
||||
#include "image_int.hpp"
|
||||
#include "basicio.hpp"
|
||||
+#include "enforce.hpp"
|
||||
#include "error.hpp"
|
||||
#include "futils.hpp"
|
||||
#include "types.hpp"
|
||||
@@ -353,7 +354,7 @@ static void boxes_check(size_t b,size_t m)
|
||||
if (io_->error()) throw Error(kerFailedToReadImageData);
|
||||
if (bufRead != rawData.size_) throw Error(kerInputDataReadFailed);
|
||||
|
||||
- if (rawData.size_ > 0)
|
||||
+ if (rawData.size_ > 8) // "II*\0long"
|
||||
{
|
||||
// Find the position of Exif header in bytes array.
|
||||
long pos = ( (rawData.pData_[0] == rawData.pData_[1])
|
||||
@@ -497,6 +498,7 @@ static void boxes_check(size_t b,size_t m)
|
||||
position = io_->tell();
|
||||
box.length = getLong((byte*)&box.length, bigEndian);
|
||||
box.type = getLong((byte*)&box.type, bigEndian);
|
||||
+ enforce(box.length <= io_->size()-io_->tell() , Exiv2::kerCorruptedMetadata);
|
||||
|
||||
if (bPrint) {
|
||||
out << Internal::stringFormat("%8ld | %8ld | ", (size_t)(position - sizeof(box)),
|
||||
@@ -581,12 +583,13 @@ static void boxes_check(size_t b,size_t m)
|
||||
throw Error(kerInputDataReadFailed);
|
||||
|
||||
if (bPrint) {
|
||||
- out << Internal::binaryToString(makeSlice(rawData, 0, 40));
|
||||
+ out << Internal::binaryToString(
|
||||
+ makeSlice(rawData, 0, rawData.size_>40?40:rawData.size_));
|
||||
out.flush();
|
||||
}
|
||||
lf(out, bLF);
|
||||
|
||||
- if (bIsExif && bRecursive && rawData.size_ > 0) {
|
||||
+ if (bIsExif && bRecursive && rawData.size_ > 8) { // "II*\0long"
|
||||
if ((rawData.pData_[0] == rawData.pData_[1]) &&
|
||||
(rawData.pData_[0] == 'I' || rawData.pData_[0] == 'M')) {
|
||||
BasicIo::AutoPtr p = BasicIo::AutoPtr(new MemIo(rawData.pData_, rawData.size_));
|
||||
|
388
SPECS/exiv2.spec
Normal file
388
SPECS/exiv2.spec
Normal file
@ -0,0 +1,388 @@
|
||||
|
||||
Summary: Exif and Iptc metadata manipulation library
|
||||
Name: exiv2
|
||||
Version: 0.27.3
|
||||
Release: 5%{?dist}
|
||||
|
||||
License: GPLv2+
|
||||
URL: http://www.exiv2.org/
|
||||
Source0: https://github.com/Exiv2/%{name}/archive/exiv2-%{version}.tar.gz
|
||||
|
||||
## upstream patches (lookaside cache)
|
||||
|
||||
# Security fixes
|
||||
Patch50: exiv2-CVE-2021-3482.patch
|
||||
Patch51: exiv2-CVE-2021-29458.patch
|
||||
Patch52: exiv2-CVE-2021-29457.patch
|
||||
Patch53: exiv2-CVE-2021-29470.patch
|
||||
Patch54: exiv2-CVE-2021-29473.patch
|
||||
|
||||
## upstreamable patches
|
||||
# don't unconditionally use -fcf-protection flag, not supported on all archs
|
||||
# fedora already includes this on archs that do support it
|
||||
Patch100: exiv2-0.27.3-fcf-protection.patch
|
||||
|
||||
|
||||
BuildRequires: cmake
|
||||
BuildRequires: expat-devel
|
||||
BuildRequires: gettext
|
||||
BuildRequires: pkgconfig
|
||||
BuildRequires: pkgconfig(libcurl)
|
||||
BuildRequires: pkgconfig(libssh)
|
||||
BuildRequires: zlib-devel
|
||||
# docs
|
||||
BuildRequires: doxygen graphviz libxslt
|
||||
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description
|
||||
A command line utility to access image metadata, allowing one to:
|
||||
* print the Exif metadata of Jpeg images as summary info, interpreted values,
|
||||
or the plain data for each tag
|
||||
* print the Iptc metadata of Jpeg images
|
||||
* print the Jpeg comment of Jpeg images
|
||||
* set, add and delete Exif and Iptc metadata of Jpeg images
|
||||
* adjust the Exif timestamp (that's how it all started...)
|
||||
* rename Exif image files according to the Exif timestamp
|
||||
* extract, insert and delete Exif metadata (including thumbnails),
|
||||
Iptc metadata and Jpeg comments
|
||||
|
||||
%package devel
|
||||
Summary: Header files, libraries and development documentation for %{name}
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
%description devel
|
||||
%{summary}.
|
||||
|
||||
%package libs
|
||||
Summary: Exif and Iptc metadata manipulation library
|
||||
# not strictly required, but convenient and expected
|
||||
%if 0%{?rhel} && 0%{?rhel} <= 7
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
%else
|
||||
Recommends: %{name} = %{version}-%{release}
|
||||
%endif
|
||||
%description libs
|
||||
A C++ library to access image metadata, supporting full read and write access
|
||||
to the Exif and Iptc metadata, Exif MakerNote support, extract and delete
|
||||
methods for Exif thumbnails, classes to access Ifd and so on.
|
||||
|
||||
%package doc
|
||||
Summary: Api documentation for %{name}
|
||||
BuildArch: noarch
|
||||
%description doc
|
||||
%{summary}.
|
||||
|
||||
|
||||
%prep
|
||||
%autosetup -n %{name}-%{version} -p1
|
||||
|
||||
|
||||
%build
|
||||
%{cmake} . \
|
||||
-DCMAKE_INSTALL_DOCDIR="%{_pkgdocdir}" \
|
||||
-DEXIV2_BUILD_DOC:BOOL=ON \
|
||||
-DEXIV2_ENABLE_NLS:BOOL=ON \
|
||||
-DEXIV2_BUILD_SAMPLES:BOOL=OFF
|
||||
|
||||
%make_build
|
||||
%make_build doc
|
||||
|
||||
%install
|
||||
make install/fast DESTDIR=%{buildroot}
|
||||
|
||||
%find_lang exiv2 --with-man
|
||||
|
||||
## unpackaged files
|
||||
rm -fv %{buildroot}%{_libdir}/libexiv2.la
|
||||
#rm -fv %{buildroot}%{_libdir}/pkgconfig/exiv2.lsm
|
||||
|
||||
%check
|
||||
export PKG_CONFIG_PATH="%{buildroot}%{_libdir}/pkgconfig${PKG_CONFIG_PATH:+:}${PKG_CONFIG_PATH}"
|
||||
test "$(pkg-config --modversion exiv2)" = "0.27.3"
|
||||
test "$(pkg-config --variable=libdir exiv2)" = "%{_libdir}"
|
||||
test -x %{buildroot}%{_libdir}/libexiv2.so
|
||||
|
||||
|
||||
%files -f exiv2.lang
|
||||
%license COPYING
|
||||
%doc doc/ChangeLog
|
||||
# README is mostly installation instructions
|
||||
#doc README.md
|
||||
%{_bindir}/exiv2
|
||||
%{_mandir}/man1/exiv2*.1*
|
||||
|
||||
%ldconfig_scriptlets libs
|
||||
|
||||
%files libs
|
||||
%{_libdir}/libexiv2.so.27*
|
||||
%{_libdir}/libexiv2.so.0.27.3
|
||||
|
||||
%files devel
|
||||
%{_includedir}/exiv2/
|
||||
%{_libdir}/libexiv2.so
|
||||
%{_libdir}/pkgconfig/exiv2.pc
|
||||
%{_libdir}/cmake/exiv2/
|
||||
%{_libdir}/libexiv2-xmp.a
|
||||
|
||||
%files doc
|
||||
%{_pkgdocdir}/
|
||||
%exclude %{_pkgdocdir}/ChangeLog
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Apr 29 2021 Jan Grulich <jgrulich@redhat.com> - 0.27.3-5
|
||||
- CVE-2021-29473 exiv2: out-of-bounds read in Exiv2::Jp2Image::doWriteMetadata
|
||||
Resolves: bz#1954065
|
||||
|
||||
- CVE-2021-29470 exiv2: out-of-bounds read in Exiv2::Jp2Image::encodeJp2Header
|
||||
Resolves: bz#1955014
|
||||
|
||||
* Wed Apr 28 2021 Jan Grulich <jgrulich@redhat.com> - 0.27.3-4
|
||||
- CVE-2021-29458 exiv2: out-of-bounds read in Exiv2::Internal::CrwMap::encode
|
||||
Resolves: bz#1953758
|
||||
|
||||
- CVE-2021-29457 exiv2: heap-based buffer overflow in Exiv2::Jp2Image::doWriteMetadata
|
||||
Resolves: bz#1953772
|
||||
|
||||
* Wed Apr 14 2021 Jan Grulich <jgrulich@redhat.com> - 0.27.3-3
|
||||
- CVE-2021-3482: Fix heap-based buffer overflow in Jp2Image::readMetadata()
|
||||
Resolves: bz#1947160
|
||||
|
||||
* Wed Oct 7 2020 Jan Grulich <jgrulich@redhat.com> - 0.27.3-2
|
||||
- Avoid duplicating Changelog file
|
||||
Resolves: bz#1880984
|
||||
|
||||
* Wed Oct 7 2020 Jan Grulich <jgrulich@redhat.com> - 0.27.3-1
|
||||
- Update to 0.27.3
|
||||
Resolves: bz#1880984
|
||||
|
||||
* Wed Mar 04 2020 Jan Grulich <jgrulich@redhat.com> - 0.27.2-5
|
||||
- Fix failing test
|
||||
Resolves: bz#1800472
|
||||
|
||||
* Wed Mar 04 2020 Jan Grulich <jgrulich@redhat.com> - 0.27.2-4
|
||||
- Drop test for the previous CVE as we test it manually and we don't have POC available
|
||||
Resolves: bz#1800472
|
||||
|
||||
* Wed Feb 26 2020 Jan Grulich <jgrulich@redhat.com> - 0.27.2-3
|
||||
- Fix infinite loop and hang in Jp2Image::readMetadata()
|
||||
Resolves: bz#1800472
|
||||
|
||||
* Tue Oct 29 2019 Jan Grulich <jgrulich@redhat.com> - 0.27.2-2
|
||||
Rebuild
|
||||
Resolves: bz#1651917
|
||||
|
||||
* Fri Sep 20 2019 Jan Grulich <jgrulich@redhat.com> - 0.27.2-1
|
||||
- Update to 0.27.2
|
||||
Resolves: bz#1651917
|
||||
|
||||
* Tue Sep 11 2018 Jan Grulich <jgrulich@redhat.com> - 0.26-10
|
||||
- Security fix for CVE-2018-16336
|
||||
|
||||
* Tue Jul 24 2018 Jan Grulich <jgrulich@redhat.com> - 0.26-9
|
||||
- Security fix for CVE-2017-17723, CVE-2017-17725, CVE-2018-10958, CVE-2018-10998,
|
||||
CVE-2018-11531, CVE-2018-12264, CVE-2018-12265, CVE-2018-14046, CVE-2018-5772,
|
||||
CVE-2018-8976, CVE-2018-8977, CVE-2018-9144
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.26-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Sat Feb 03 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.26-7
|
||||
- Switch to %%ldconfig_scriptlets
|
||||
|
||||
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.26-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.26-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Sun May 28 2017 Rex Dieter <rdieter@fedoraproject.org> - 0.26-4
|
||||
- Security fix for CVE-2017-9239 (#1455859,#1455860)
|
||||
|
||||
* Sat May 20 2017 Rex Dieter <rdieter@fedoraproject.org> - 0.26-3
|
||||
- -libs: use Recommends: instead (#1452938)
|
||||
|
||||
* Mon May 15 2017 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.26-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_27_Mass_Rebuild
|
||||
|
||||
* Tue May 02 2017 Rex Dieter <rdieter@fedoraproject.org> - 0.26-1
|
||||
- exiv2-0.26 (#1447129)
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.25-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Mon Feb 22 2016 Rex Dieter <rdieter@fedoraproject.org> 0.25-3
|
||||
- embedded copy of exempi should be compiled with BanAllEntityUsage (#888769)
|
||||
|
||||
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.25-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Mon Jun 22 2015 Rex Dieter <rdieter@fedoraproject.org> 0.25-1
|
||||
- exiv2-0.25 (#1234185)
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.24-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Tue Apr 14 2015 Rex Dieter <rdieter@fedoraproject.org> 0.24-6
|
||||
- rebuild (gcc5)
|
||||
|
||||
* Thu Feb 19 2015 Rex Dieter <rdieter@fedoraproject.org> 0.24-5
|
||||
- rebuild (gcc5)
|
||||
|
||||
* Mon Jan 05 2015 Rex Dieter <rdieter@fedoraproject.org> 0.24-4
|
||||
- CVE-2014-9449 exiv2: buffer overflow in RiffVideo::infoTagsHandler (#1178909)
|
||||
|
||||
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.24-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.24-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Mon Dec 02 2013 Rex Dieter <rdieter@fedoraproject.org> - 0.24-1
|
||||
- exiv2-0.24, abi bump
|
||||
- -doc subpkg
|
||||
- ready experimental cmake buildsystem support
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.23-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.23-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Tue Aug 14 2012 Rex Dieter <rdieter@fedoraproject.org> 0.23-3
|
||||
- empty html doc dir (#848025)
|
||||
|
||||
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.23-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Tue Apr 24 2012 Rex Dieter <rdieter@fedoraproject.org> 0.23-1
|
||||
- exiv2-0.23
|
||||
- abi bump
|
||||
|
||||
* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.22-5
|
||||
- Rebuilt for c++ ABI breakage
|
||||
|
||||
* Mon Jan 16 2012 Rex Dieter <rdieter@fedoraproject.org> 0.22-4
|
||||
- better rpath handling
|
||||
- revert locale change, move back to -libs
|
||||
|
||||
* Mon Jan 16 2012 Rex Dieter <rdieter@fedoraproject.org> 0.22-3
|
||||
- move locale files to main pkg (from -libs)
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.22-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Fri Oct 14 2011 Rex Dieter <rdieter@fedoraproject.org> 0.22-1
|
||||
- exiv2-0.22
|
||||
|
||||
* Tue Sep 27 2011 Rex Dieter <rdieter@fedoraproject.org> 0.21.1-3
|
||||
- New Tamron 70-300 mm lens improperly recognized (#708403)
|
||||
|
||||
* Mon Sep 26 2011 Rex Dieter <rdieter@fedoraproject.org> 0.21.1-2
|
||||
- gthumb crashes because of bug in exiv2 0.21.1 (#741429)
|
||||
|
||||
* Sat Feb 26 2011 Rex Dieter <rdieter@fedoraproject.org> 0.21.1-1
|
||||
- exiv2-0.21.1
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.21-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Wed Jan 26 2011 Rex Dieter <rdieter@fedoraproject.org> 0.21-2
|
||||
- Move ldconfig scriptlet calls to -libs (#672361)
|
||||
|
||||
* Wed Dec 01 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.21-1
|
||||
- exiv2-0.21
|
||||
|
||||
* Sun May 30 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.20-1
|
||||
- exiv2-0.20
|
||||
|
||||
* Wed Dec 30 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.19-1
|
||||
- exiv2-0.19 (#552275)
|
||||
|
||||
* Sun Dec 13 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.18.2-3
|
||||
- -libs unconditional
|
||||
- tighten deps using %%?_isa
|
||||
|
||||
* Fri Aug 07 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.18.2-2
|
||||
- (again) drop -fvisibility-inlines-hidden (#496050)
|
||||
|
||||
* Fri Jul 24 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.18.2-1
|
||||
- exiv2-0.18.2
|
||||
- drop visibility patch
|
||||
|
||||
* Fri Apr 17 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.18.1-1
|
||||
- exiv2-0.18.1
|
||||
- drop -fvisibility-inlines-hidden (#496050)
|
||||
|
||||
* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.18-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Thu Dec 18 2008 Rex Dieter <rdieter@fedoraproject.org> 0.18-1
|
||||
- exiv2-0.18
|
||||
|
||||
* Fri Dec 12 2008 Rex Dieter <rdieter@fedoraproject.org> 0.17.2-2
|
||||
- rebuild for pkgconfig deps
|
||||
|
||||
* Mon Jun 23 2008 Rex Dieter <rdieter@fedoraproject.org> 0.17.1-1
|
||||
- exiv2-0.17.1
|
||||
|
||||
* Mon Feb 11 2008 Rex Dieter <rdieter@fedoraproject.org> 0.16-2
|
||||
- respin (gcc43)
|
||||
- gcc43 patch
|
||||
|
||||
* Sun Jan 13 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 0.16-1
|
||||
- eviv2-0.16
|
||||
|
||||
* Mon Dec 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 0.16-0.3.pre1
|
||||
- CVE-2007-6353 (#425924)
|
||||
|
||||
* Mon Nov 26 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 0.16-0.2.pre1
|
||||
- -libs subpkg toggle (f8+)
|
||||
|
||||
* Tue Nov 13 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 0.16-0.1.pre1
|
||||
- exiv2-0.16-pre1
|
||||
|
||||
* Tue Sep 18 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 0.15-4
|
||||
- -libs: -Requires: %%name
|
||||
|
||||
* Tue Aug 21 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 0.15-3
|
||||
- -libs subpkg to be multilib-friendlier (f8+)
|
||||
|
||||
* Sat Aug 11 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 0.15-2
|
||||
- License: GPLv2+
|
||||
|
||||
* Thu Jul 12 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 0.15-1
|
||||
- exiv2-0.15
|
||||
|
||||
* Mon Apr 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 0.14-1
|
||||
- exiv2-0.14
|
||||
|
||||
* Tue Nov 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.12-1
|
||||
- exiv2-0.12
|
||||
|
||||
* Wed Oct 04 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.11-3
|
||||
- respin
|
||||
|
||||
* Tue Sep 19 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.11-2
|
||||
- BR: zlib-devel
|
||||
|
||||
* Tue Sep 19 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.11-1
|
||||
- exiv2-0.11
|
||||
|
||||
* Tue Aug 29 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.10-2
|
||||
- fc6 respin
|
||||
|
||||
* Sat Jun 03 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.10-1
|
||||
- 0.10
|
||||
|
||||
* Wed May 17 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.9.1-3
|
||||
- cleanup %%description
|
||||
- set eXecute bit on installed lib.
|
||||
- no_rpath patch
|
||||
- deps patch (items get (re)compiled on *every* call to 'make')
|
||||
|
||||
* Wed May 17 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.9.1-2
|
||||
- %%post/%%postun: /sbin/ldconfig
|
||||
|
||||
* Tue May 16 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.9.1-1
|
||||
- first try
|
Loading…
Reference in New Issue
Block a user