Merge branch 'master' into f26
This commit is contained in:
commit
00e309b52e
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
|||||||
/exiv2-0.25.tar.gz
|
/exiv2-0.25.tar.gz
|
||||||
|
/exiv2-0.26-trunk.tar.gz
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
diff -up exiv2-0.24/src/CMakeLists.txt.mandir exiv2-0.24/src/CMakeLists.txt
|
|
||||||
--- exiv2-0.24/src/CMakeLists.txt.mandir 2013-03-29 22:32:26.000000000 -0500
|
|
||||||
+++ exiv2-0.24/src/CMakeLists.txt 2013-12-02 12:14:04.264728159 -0600
|
|
||||||
@@ -284,7 +284,7 @@ INSTALL( FILES ${LIBEXIV2_HDR} DESTINATI
|
|
||||||
|
|
||||||
# ******************************************************************************
|
|
||||||
# Man page
|
|
||||||
-INSTALL( FILES exiv2.1 DESTINATION man/man1 )
|
|
||||||
+INSTALL( FILES exiv2.1 DESTINATION share/man/man1 )
|
|
||||||
|
|
||||||
# That's all Folks!
|
|
||||||
##
|
|
@ -1,21 +0,0 @@
|
|||||||
diff -up exiv2-0.24/config/Doxyfile.doxygen_config exiv2-0.24/config/Doxyfile
|
|
||||||
--- exiv2-0.24/config/Doxyfile.doxygen_config 2013-07-24 20:16:43.000000000 -0500
|
|
||||||
+++ exiv2-0.24/config/Doxyfile 2013-12-02 12:21:09.606260306 -0600
|
|
||||||
@@ -343,7 +343,7 @@ TYPEDEF_HIDES_STRUCT = NO
|
|
||||||
# 2^(16+SYMBOL_CACHE_SIZE). The valid range is 0..9, the default is 0,
|
|
||||||
# corresponding to a cache size of 2^16 = 65536 symbols.
|
|
||||||
|
|
||||||
-SYMBOL_CACHE_SIZE = 0
|
|
||||||
+#SYMBOL_CACHE_SIZE = 0
|
|
||||||
|
|
||||||
# Similar to the SYMBOL_CACHE_SIZE the size of the symbol lookup cache can be
|
|
||||||
# set using LOOKUP_CACHE_SIZE. This cache is used to resolve symbols given
|
|
||||||
@@ -1698,7 +1698,7 @@ DOT_NUM_THREADS = 0
|
|
||||||
# the DOTFONTPATH environment variable or by setting DOT_FONTPATH to the
|
|
||||||
# directory containing the font.
|
|
||||||
|
|
||||||
-DOT_FONTNAME = FreeSans
|
|
||||||
+#DOT_FONTNAME = FreeSans
|
|
||||||
|
|
||||||
# The DOT_FONTSIZE tag can be used to set the size of the font of dot graphs.
|
|
||||||
# The default size is 10pt.
|
|
@ -1,41 +0,0 @@
|
|||||||
diff -up exiv2-0.25/CMakeLists.txt.cmake_LIB_SUFFIX exiv2-0.25/CMakeLists.txt
|
|
||||||
--- exiv2-0.25/CMakeLists.txt.cmake_LIB_SUFFIX 2015-06-15 10:32:21.000000000 -0500
|
|
||||||
+++ exiv2-0.25/CMakeLists.txt 2015-06-22 08:48:19.486245765 -0500
|
|
||||||
@@ -25,7 +25,7 @@ if( POLICY CMP0042 )
|
|
||||||
else()
|
|
||||||
SET(CMAKE_MACOSX_RPATH 1)
|
|
||||||
endif()
|
|
||||||
-SET(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/lib")
|
|
||||||
+#SET(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}")
|
|
||||||
|
|
||||||
|
|
||||||
SET( PACKAGE_COPYRIGHT "Andreas Huggel" )
|
|
||||||
@@ -156,10 +156,10 @@ INCLUDE( config/CMakeChecks.txt )
|
|
||||||
|
|
||||||
SET( INSTALL_TARGET_STANDARD_ARGS
|
|
||||||
RUNTIME DESTINATION bin
|
|
||||||
- LIBRARY DESTINATION lib
|
|
||||||
- ARCHIVE DESTINATION lib
|
|
||||||
+ LIBRARY DESTINATION lib${LIB_SUFFIX}
|
|
||||||
+ ARCHIVE DESTINATION lib${LIB_SUFFIX}
|
|
||||||
)
|
|
||||||
-SET(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/lib")
|
|
||||||
+#SET(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}")
|
|
||||||
|
|
||||||
##
|
|
||||||
# add sources from XMPSDK directory
|
|
||||||
diff -up exiv2-0.25/config/CMakeChecks.txt.cmake_LIB_SUFFIX exiv2-0.25/config/CMakeChecks.txt
|
|
||||||
--- exiv2-0.25/config/CMakeChecks.txt.cmake_LIB_SUFFIX 2015-04-30 10:31:18.000000000 -0500
|
|
||||||
+++ exiv2-0.25/config/CMakeChecks.txt 2015-06-22 08:41:22.913094633 -0500
|
|
||||||
@@ -291,9 +291,9 @@ ADD_CUSTOM_TARGET(uninstall "${CMAKE_COM
|
|
||||||
|
|
||||||
IF( NOT MSVC )
|
|
||||||
CONFIGURE_FILE( config/exiv2.pc.cmake ${CMAKE_CURRENT_BINARY_DIR}/exiv2.pc @ONLY )
|
|
||||||
- INSTALL( FILES ${CMAKE_CURRENT_BINARY_DIR}/exiv2.pc DESTINATION lib/pkgconfig )
|
|
||||||
+ INSTALL( FILES ${CMAKE_CURRENT_BINARY_DIR}/exiv2.pc DESTINATION lib${LIB_SUFFIX}/pkgconfig )
|
|
||||||
CONFIGURE_FILE( config/exiv2.lsm.cmake ${CMAKE_CURRENT_BINARY_DIR}/exiv2.lsm)
|
|
||||||
- INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/exiv2.lsm DESTINATION lib/pkgconfig )
|
|
||||||
+ INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/exiv2.lsm DESTINATION lib${LIB_SUFFIX}/pkgconfig )
|
|
||||||
ENDIF( NOT MSVC )
|
|
||||||
|
|
||||||
# ******************************************************************************
|
|
21
exiv2-doxygen.patch
Normal file
21
exiv2-doxygen.patch
Normal file
@ -0,0 +1,21 @@
|
|||||||
|
diff -up exiv2-trunk/config/Doxyfile.doxygen exiv2-trunk/config/Doxyfile
|
||||||
|
--- exiv2-trunk/config/Doxyfile.doxygen 2017-05-02 09:17:33.631909015 -0500
|
||||||
|
+++ exiv2-trunk/config/Doxyfile 2017-05-02 09:18:03.019200824 -0500
|
||||||
|
@@ -1688,7 +1688,7 @@ HIDE_UNDOC_RELATIONS = YES
|
||||||
|
# toolkit from AT&T and Lucent Bell Labs. The other options in this section
|
||||||
|
# have no effect if this option is set to NO (the default)
|
||||||
|
|
||||||
|
-HAVE_DOT = YES
|
||||||
|
+#HAVE_DOT = YES
|
||||||
|
|
||||||
|
# The DOT_NUM_THREADS specifies the number of dot invocations doxygen is
|
||||||
|
# allowed to run in parallel. When set to 0 (the default) doxygen will
|
||||||
|
@@ -1705,7 +1705,7 @@ DOT_NUM_THREADS = 0
|
||||||
|
# the DOTFONTPATH environment variable or by setting DOT_FONTPATH to the
|
||||||
|
# directory containing the font.
|
||||||
|
|
||||||
|
-DOT_FONTNAME = Arial
|
||||||
|
+#DOT_FONTNAME = Arial
|
||||||
|
|
||||||
|
# The DOT_FONTSIZE tag can be used to set the size of the font of dot graphs.
|
||||||
|
# The default size is 10pt.
|
65
exiv2.spec
65
exiv2.spec
@ -1,24 +1,21 @@
|
|||||||
|
|
||||||
## enable experimental cmake build support (or not)
|
## enable experimental cmake build support (or not)
|
||||||
## still lacks some features, like visibility
|
# still a bit buggy (e.g. out-of-tree and translations broken)
|
||||||
#define cmake_build 1
|
#global cmake_build 1
|
||||||
|
|
||||||
Summary: Exif and Iptc metadata manipulation library
|
Summary: Exif and Iptc metadata manipulation library
|
||||||
Name: exiv2
|
Name: exiv2
|
||||||
Version: 0.25
|
Version: 0.26
|
||||||
Release: 4%{?dist}
|
Release: 3%{?dist}
|
||||||
|
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: http://www.exiv2.org/
|
URL: http://www.exiv2.org/
|
||||||
Source0: http://www.exiv2.org/exiv2-%{version}%{?pre:-%{pre}}.tar.gz
|
Source0: http://www.exiv2.org/builds/exiv2-%{version}-trunk.tar.gz
|
||||||
|
|
||||||
## upstream patches
|
## upstream patches
|
||||||
|
|
||||||
## upstreamable patches
|
## upstreamable patches
|
||||||
# support LIB_SUFFIX, and avoid hard-coded rpath while we're at it
|
Patch100: exiv2-doxygen.patch
|
||||||
Patch50: exiv2-0.25-cmake_LIB_SUFFIX.patch
|
|
||||||
Patch51: exiv2-0.24-cmake_mandir.patch
|
|
||||||
Patch52: exiv2-0.24-doxygen_config.patch
|
|
||||||
|
|
||||||
%if 0%{?cmake_build}
|
%if 0%{?cmake_build}
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
@ -26,6 +23,8 @@ BuildRequires: cmake
|
|||||||
BuildRequires: expat-devel
|
BuildRequires: expat-devel
|
||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
BuildRequires: pkgconfig
|
BuildRequires: pkgconfig
|
||||||
|
BuildRequires: pkgconfig(libcurl)
|
||||||
|
BuildRequires: pkgconfig(libssh)
|
||||||
BuildRequires: zlib-devel
|
BuildRequires: zlib-devel
|
||||||
# docs
|
# docs
|
||||||
BuildRequires: doxygen graphviz libxslt
|
BuildRequires: doxygen graphviz libxslt
|
||||||
@ -52,6 +51,8 @@ Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
|||||||
|
|
||||||
%package libs
|
%package libs
|
||||||
Summary: Exif and Iptc metadata manipulation library
|
Summary: Exif and Iptc metadata manipulation library
|
||||||
|
# not strictly required, but convenient and expected
|
||||||
|
Recommends: %{name} = %{version}-%{release}
|
||||||
%description libs
|
%description libs
|
||||||
A C++ library to access image metadata, supporting full read and write access
|
A C++ library to access image metadata, supporting full read and write access
|
||||||
to the Exif and Iptc metadata, Exif MakerNote support, extract and delete
|
to the Exif and Iptc metadata, Exif MakerNote support, extract and delete
|
||||||
@ -65,11 +66,7 @@ BuildArch: noarch
|
|||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version}%{?pre:-%{pre}}
|
%autosetup -n %{name}-trunk -p1
|
||||||
|
|
||||||
%patch50 -p1 -b .cmake_LIB_SUFFIX
|
|
||||||
%patch51 -p1 -b .cmake_mandir
|
|
||||||
%patch52 -p1 -b .doxygen_config
|
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -79,21 +76,24 @@ BuildArch: noarch
|
|||||||
export CPPFLAGS="-DBanAllEntityUsage=1"
|
export CPPFLAGS="-DBanAllEntityUsage=1"
|
||||||
|
|
||||||
%if 0%{?cmake_build}
|
%if 0%{?cmake_build}
|
||||||
mkdir -p %{_target_platform}
|
|
||||||
pushd %{_target_platform}
|
|
||||||
%{cmake} \
|
%{cmake} \
|
||||||
-DEXIV2_ENABLE_BUILD_PO:BOOL=ON \
|
-DEXIV2_ENABLE_BUILD_PO:BOOL=ON \
|
||||||
-DEXIV2_ENABLE_BUILD_SAMPLES:BOOL=OFF \
|
-DEXIV2_ENABLE_BUILD_SAMPLES:BOOL=OFF \
|
||||||
..
|
.
|
||||||
|
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
make doc -k ||:
|
make doc -k ||:
|
||||||
popd
|
|
||||||
%else
|
%else
|
||||||
%configure \
|
%configure \
|
||||||
--disable-rpath \
|
--disable-rpath \
|
||||||
--disable-static
|
--disable-static
|
||||||
|
|
||||||
|
## these options not enabled by default, find out why before considering
|
||||||
|
## manually enabling them
|
||||||
|
# --enable-video \
|
||||||
|
# --enable-webready
|
||||||
|
|
||||||
|
# rpath
|
||||||
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
|
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
|
||||||
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
||||||
|
|
||||||
@ -104,7 +104,7 @@ make doc -k ||:
|
|||||||
|
|
||||||
%install
|
%install
|
||||||
%if 0%{?cmake_build}
|
%if 0%{?cmake_build}
|
||||||
make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
|
make install/fast DESTDIR=%{buildroot}
|
||||||
%else
|
%else
|
||||||
make install DESTDIR=%{buildroot}
|
make install DESTDIR=%{buildroot}
|
||||||
|
|
||||||
@ -113,10 +113,9 @@ ls -l %{buildroot}%{_libdir}/libexiv2.so.*
|
|||||||
chmod 755 %{buildroot}%{_libdir}/libexiv2.so.*
|
chmod 755 %{buildroot}%{_libdir}/libexiv2.so.*
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%find_lang exiv2
|
%find_lang exiv2 --with-man
|
||||||
|
|
||||||
## unpackaged files
|
## unpackaged files
|
||||||
rm -fv %{buildroot}%{_libdir}/pkgconfig/exiv2.lsm
|
|
||||||
rm -fv %{buildroot}%{_libdir}/libexiv2.la
|
rm -fv %{buildroot}%{_libdir}/libexiv2.la
|
||||||
|
|
||||||
|
|
||||||
@ -126,16 +125,19 @@ test "$(pkg-config --modversion exiv2)" = "%{version}"
|
|||||||
test -x %{buildroot}%{_libdir}/libexiv2.so
|
test -x %{buildroot}%{_libdir}/libexiv2.so
|
||||||
|
|
||||||
|
|
||||||
%files
|
%files -f exiv2.lang
|
||||||
%doc COPYING README
|
%license COPYING
|
||||||
|
%doc doc/ChangeLog
|
||||||
|
# README is mostly installation instructions
|
||||||
|
#doc README
|
||||||
%{_bindir}/exiv2
|
%{_bindir}/exiv2
|
||||||
%{_mandir}/man1/*
|
%{_mandir}/man1/exiv2*.1*
|
||||||
|
|
||||||
%post libs -p /sbin/ldconfig
|
%post libs -p /sbin/ldconfig
|
||||||
%postun libs -p /sbin/ldconfig
|
%postun libs -p /sbin/ldconfig
|
||||||
|
|
||||||
%files libs -f exiv2.lang
|
%files libs
|
||||||
%{_libdir}/libexiv2.so.14*
|
%{_libdir}/libexiv2.so.26*
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%{_includedir}/exiv2/
|
%{_includedir}/exiv2/
|
||||||
@ -147,6 +149,15 @@ test -x %{buildroot}%{_libdir}/libexiv2.so
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat May 20 2017 Rex Dieter <rdieter@fedoraproject.org> - 0.26-3
|
||||||
|
- -libs: use Recommends: instead (#1452938)
|
||||||
|
|
||||||
|
* Mon May 15 2017 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.26-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue May 02 2017 Rex Dieter <rdieter@fedoraproject.org> - 0.26-1
|
||||||
|
- exiv2-0.26 (#1447129)
|
||||||
|
|
||||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.25-4
|
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.25-4
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user