import exempi-2.6.0-0.2.20211007gite23c213.el9
This commit is contained in:
commit
f37d060530
1
.exempi.metadata
Normal file
1
.exempi.metadata
Normal file
@ -0,0 +1 @@
|
||||
a4df1bc3f9c4ef14bbce6b97fb9e55408ef0c71b SOURCES/exempi-e23c21380f467f1f1c9dc397e0a08405fb4afa7a.tar.bz2
|
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/exempi-e23c21380f467f1f1c9dc397e0a08405fb4afa7a.tar.bz2
|
27
SOURCES/exempi-e23c213-typeinfos.patch
Normal file
27
SOURCES/exempi-e23c213-typeinfos.patch
Normal file
@ -0,0 +1,27 @@
|
||||
From d45c06270576493e1537080fa43c1af667c4337a Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Nikola=20Forr=C3=B3?= <nforro@redhat.com>
|
||||
Date: Tue, 12 Oct 2021 14:15:17 +0200
|
||||
Subject: [PATCH] Avoid multiple definitions of typeinfos
|
||||
|
||||
---
|
||||
XMPFiles/source/XMPFiles_Impl.cpp | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/XMPFiles/source/XMPFiles_Impl.cpp b/XMPFiles/source/XMPFiles_Impl.cpp
|
||||
index 2f918ac..ff45040 100644
|
||||
--- a/XMPFiles/source/XMPFiles_Impl.cpp
|
||||
+++ b/XMPFiles/source/XMPFiles_Impl.cpp
|
||||
@@ -47,7 +47,9 @@ using namespace std;
|
||||
/// This file ...
|
||||
///
|
||||
// =================================================================================================
|
||||
-#include "public/include/XMP.incl_cpp"
|
||||
+#if ! XMP_StaticBuild
|
||||
+ #include "public/include/XMP.incl_cpp"
|
||||
+#endif
|
||||
|
||||
#if XMP_WinBuild
|
||||
#pragma warning ( disable : 4290 ) // C++ exception specification ignored except to indicate a function is not __declspec(nothrow)
|
||||
--
|
||||
2.33.0
|
||||
|
292
SPECS/exempi.spec
Normal file
292
SPECS/exempi.spec
Normal file
@ -0,0 +1,292 @@
|
||||
%global commit e23c21380f467f1f1c9dc397e0a08405fb4afa7a
|
||||
%global shortcommit %%(c=%{commit}; echo ${c:0:7})
|
||||
%global date 20211007
|
||||
|
||||
Summary: Library for easy parsing of XMP metadata
|
||||
Name: exempi
|
||||
Version: 2.6.0
|
||||
Release: 0.2.%{date}git%{shortcommit}%{?dist}
|
||||
License: BSD
|
||||
URL: http://libopenraw.freedesktop.org/wiki/Exempi
|
||||
Source0: https://gitlab.freedesktop.org/libopenraw/%{name}/-/archive/%{commit}/%{name}-%{commit}.tar.bz2
|
||||
Patch0: exempi-e23c213-typeinfos.patch
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: boost-devel expat-devel zlib-devel pkgconfig
|
||||
# Work around for aarch64 support (https://bugzilla.redhat.com/show_bug.cgi?id=925327)
|
||||
BuildRequires: autoconf automake libtool
|
||||
BuildRequires: make
|
||||
Provides: bundled(md5-polstra)
|
||||
|
||||
%description
|
||||
Exempi provides a library for easy parsing of XMP metadata. It is a port of
|
||||
Adobe XMP SDK to work on UNIX and to be build with GNU automake.
|
||||
It includes XMPCore and XMPFiles.
|
||||
|
||||
%package devel
|
||||
Summary: Headers for developing programs that will use %{name}
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
Requires: pkgconfig
|
||||
|
||||
%description devel
|
||||
This package contains the libraries and header files needed for
|
||||
developing with exempi.
|
||||
|
||||
%prep
|
||||
%autosetup -p1 -n %{name}-%{commit}
|
||||
|
||||
%build
|
||||
libtoolize -vi
|
||||
NOCONFIGURE=1 ./autogen.sh
|
||||
# BanEntityUsage needed for #888765
|
||||
%configure CPPFLAGS="-I%{_includedir} -fno-strict-aliasing -DBanAllEntityUsage=1"
|
||||
|
||||
# Disable rpath
|
||||
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
|
||||
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
||||
|
||||
%make_build
|
||||
|
||||
%check
|
||||
%ifarch s390x
|
||||
# testcore test fails on big endian arches since exempi 2.5.2:
|
||||
# https://gitlab.freedesktop.org/libopenraw/exempi/-/issues/23
|
||||
make check || [ "$(grep '^FAIL:' exempi/test-suite.log)" = "FAIL: tests/testcore" ]
|
||||
%else
|
||||
make check
|
||||
%endif
|
||||
|
||||
%install
|
||||
%make_install
|
||||
|
||||
rm -rf %{buildroot}%{_libdir}/*.la
|
||||
rm -rf %{buildroot}%{_libdir}/*.a
|
||||
|
||||
%files
|
||||
%doc AUTHORS ChangeLog COPYING README
|
||||
%{_bindir}/exempi
|
||||
%{_libdir}/libexempi.so.8*
|
||||
%{_mandir}/man1/exempi.1*
|
||||
|
||||
%files devel
|
||||
%{_includedir}/exempi-2.0/
|
||||
%{_libdir}/libexempi.so
|
||||
%{_libdir}/pkgconfig/*.pc
|
||||
|
||||
%changelog
|
||||
* Wed Nov 03 2021 Nikola Forró <nforro@redhat.com> - 2.6.0-0.2.20211007gite23c213
|
||||
- Add modified upstream test suite as a gating test
|
||||
Related #1989405
|
||||
|
||||
* Wed Oct 20 2021 Nikola Forró <nforro@redhat.com> - 2.6.0-0.1.20211007gite23c213
|
||||
- Update to (unreleased) version 2.6.0 to resolve licensing issues
|
||||
Resolves #1989405
|
||||
|
||||
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 2.5.1-8
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
||||
* Thu Apr 15 2021 Mohan Boddu <mboddu@redhat.com> - 2.5.1-7
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.5.1-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Tue Jul 28 2020 Jeff Law <law@redhat.com> - 2.5.1-5
|
||||
- Force C++14 as this code is not C++17 ready
|
||||
|
||||
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.5.1-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Tue Jul 14 2020 Tom Stellard <tstellar@redhat.com> - 2.5.1-3
|
||||
- Use make macros
|
||||
- https://fedoraproject.org/wiki/Changes/UseMakeBuildInstallMacro
|
||||
|
||||
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.5.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Fri Aug 30 2019 Nikola Forró <nforro@redhat.com> - 2.5.1-1
|
||||
- Update to version 2.5.1
|
||||
Resolves #1747391
|
||||
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.5-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.5-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Tue Oct 9 2018 Owen Taylor <otaylor@redhat.com> - 2.4.5-5
|
||||
- Set NOCONFIGURE when running autogen.sh to avoid running configure twice
|
||||
|
||||
* Wed Sep 26 2018 Nikola Forró <nforro@redhat.com> - 2.4.5-4
|
||||
- Fix CVE-2018-12648
|
||||
Resolves #1594643
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.5-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Thu Jun 28 2018 Nikola Forró <nforro@redhat.com> - 2.4.5-2
|
||||
- Remove ldconfig from scriptlets
|
||||
|
||||
* Tue Mar 13 2018 Nikola Forró <nforro@redhat.com> - 2.4.5-1
|
||||
- Update to version 2.4.5
|
||||
Resolves #1553140
|
||||
|
||||
* Tue Feb 20 2018 Nikola Forró <nforro@redhat.com> - 2.4.4-2
|
||||
- Add missing gcc-c++ build dependency
|
||||
|
||||
* Tue Feb 06 2018 Nikola Forró <nforro@redhat.com> - 2.4.4-1
|
||||
- Update to version 2.4.4
|
||||
Resolves #1541818
|
||||
|
||||
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.2-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.2-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Mon Jul 03 2017 Jonathan Wakely <jwakely@redhat.com> - 2.4.2-5
|
||||
- Rebuilt for Boost 1.64
|
||||
|
||||
* Thu Jun 1 2017 Owen Taylor <otaylor@redhat.com> - 2.4.2-4
|
||||
- Make manpage installation agnostic of compression
|
||||
https://fedoraproject.org/wiki/Packaging:Guidelines#Manpages
|
||||
|
||||
* Mon May 15 2017 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.2-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_27_Mass_Rebuild
|
||||
|
||||
* Mon Feb 06 2017 Kalev Lember <klember@redhat.com> - 2.4.2-2
|
||||
- Rebuilt for Boost 1.63
|
||||
|
||||
* Mon Jan 30 2017 Nikola Forró <nforro@redhat.com> - 2.4.2-1
|
||||
- Update to version 2.4.2
|
||||
Resolves #1417497
|
||||
|
||||
* Fri Jan 27 2017 Jonathan Wakely <jwakely@redhat.com> - 2.4.1-3
|
||||
- Rebuilt for Boost 1.63
|
||||
|
||||
* Fri Jan 27 2017 Jonathan Wakely <jwakely@redhat.com> - 2.4.1-2
|
||||
- Rebuilt for Boost 1.63
|
||||
|
||||
* Tue Jan 24 2017 Nikola Forró <nforro@redhat.com> - 2.4.1-1
|
||||
- Update to version 2.4.1
|
||||
Resolves #1415672
|
||||
|
||||
* Mon Jan 09 2017 Nikola Forró <nforro@redhat.com> - 2.4.0-1
|
||||
- Update to version 2.4.0
|
||||
Resolves #1411059
|
||||
|
||||
* Thu Mar 17 2016 Nikola Forró <nforro@redhat.com> - 2.3.0-1
|
||||
- Update to version 2.3.0
|
||||
Resolves #1318279
|
||||
|
||||
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.1-15
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Fri Jan 15 2016 Jonathan Wakely <jwakely@redhat.com> - 2.2.1-14
|
||||
- Rebuilt for Boost 1.60
|
||||
|
||||
* Thu Aug 27 2015 Jonathan Wakely <jwakely@redhat.com> - 2.2.1-13
|
||||
- Rebuilt for Boost 1.59
|
||||
|
||||
* Wed Jul 29 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.1-12
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Changes/F23Boost159
|
||||
|
||||
* Wed Jul 22 2015 David Tardon <dtardon@redhat.com> - 2.2.1-11
|
||||
- rebuild for Boost 1.58
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.1-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 2.2.1-9
|
||||
- Rebuilt for GCC 5 C++11 ABI change
|
||||
|
||||
* Tue Jan 27 2015 Petr Machata <pmachata@redhat.com> - 2.2.1-8
|
||||
- Rebuild for boost 1.57.0
|
||||
|
||||
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.1-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.1-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Thu May 22 2014 Petr Machata <pmachata@redhat.com> - 2.2.1-5
|
||||
- Rebuild for boost 1.55.0
|
||||
|
||||
* Fri Jan 10 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 2.2.1-4
|
||||
- Run libtoolize before autogen.sh
|
||||
- Resolves: rhbz#1051186
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Tue Jul 30 2013 Petr Machata <pmachata@redhat.com> - 2.2.1-2
|
||||
- Rebuild for boost 1.54.0
|
||||
|
||||
* Mon Jul 22 2013 Deji Akingunola <dakingun@gmail.com> - 2.2.1-1
|
||||
- Update to version 2.2.1
|
||||
|
||||
* Wed Jan 30 2013 Stanislav Ochotnicky <sochotnicky@redhat.com> - 2.2.0-6
|
||||
- Get rid of unnecessary LDFLAGS definition overwriting RPM flags
|
||||
|
||||
* Wed Jan 02 2013 Stanislav Ochotnicky <sochotnicky@redhat.com> - 2.2.0-5
|
||||
- Make sure we respect RPM_OPT_FLAGS and simplify configure (#889554)
|
||||
|
||||
* Wed Dec 19 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> - 2.2.0-4
|
||||
- Add BanAllEntityUsage into macro definitions (#888765)
|
||||
|
||||
* Thu Aug 16 2012 Mikolaj Izdebski <mizdebsk@redhat.com> - 2.2.0-3
|
||||
- Add bundled(md5-polstra) provides
|
||||
- Update to current guidelines
|
||||
|
||||
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Wed Feb 22 2012 Deji Akingunola <dakingun@gmail.com> - 2.2.0-1
|
||||
- Update to version 2.2.0
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Mon May 3 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 2.1.1-1
|
||||
- Update to 2.1.1
|
||||
- Add testsuite execution
|
||||
- Removed build patch for gcc-4.4 (fixed in upstream)
|
||||
|
||||
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Wed Feb 04 2009 Deji Akingunola <dakingun@gmail.com> - 2.1.0-2
|
||||
- Add patch to build with gcc-4.4
|
||||
|
||||
* Tue Jan 06 2009 Deji Akingunola <dakingun@gmail.com> - 2.1.0-1
|
||||
- Update to 2.1.0
|
||||
|
||||
* Sat May 17 2008 Deji Akingunola <dakingun@gmail.com> - 2.0.1-1
|
||||
- Update to 2.0.1
|
||||
|
||||
* Wed Apr 02 2008 Deji Akingunola <dakingun@gmail.com> - 2.0.0-1
|
||||
- Update to 2.0.0
|
||||
|
||||
* Fri Feb 08 2008 Deji Akingunola <dakingun@gmail.com> - 1.99.9-1
|
||||
- Update to 1.99.9
|
||||
|
||||
* Sun Jan 13 2008 Deji Akingunola <dakingun@gmail.com> - 1.99.7-1
|
||||
- Update to 1.99.7
|
||||
|
||||
* Mon Dec 03 2007 Deji Akingunola <dakingun@gmail.com> - 1.99.5-1
|
||||
- Update to 1.99.5
|
||||
|
||||
* Wed Sep 05 2007 Deji Akingunola <dakingun@gmail.com> - 1.99.4-2
|
||||
- Rebuild for expat 2.0
|
||||
|
||||
* Wed Aug 22 2007 Deji Akingunola <dakingun@gmail.com> - 1.99.4-1
|
||||
- Update tp 1.99.4
|
||||
|
||||
* Tue Jul 10 2007 Deji Akingunola <dakingun@gmail.com> - 1.99.3-1
|
||||
- Initial packaging for Fedora
|
Loading…
Reference in New Issue
Block a user