Update to (unreleased) version 2.6.0 to resolve licensing issues
- resolves: #1989405
This commit is contained in:
parent
8183133700
commit
e144f4cc11
1
.gitignore
vendored
1
.gitignore
vendored
@ -8,3 +8,4 @@ exempi-2.1.1.tar.gz
|
|||||||
/exempi-2.4.4.tar.bz2
|
/exempi-2.4.4.tar.bz2
|
||||||
/exempi-2.4.5.tar.bz2
|
/exempi-2.4.5.tar.bz2
|
||||||
/exempi-2.5.1.tar.bz2
|
/exempi-2.5.1.tar.bz2
|
||||||
|
/exempi-e23c21380f467f1f1c9dc397e0a08405fb4afa7a.tar.bz2
|
||||||
|
27
exempi-e23c213-typeinfos.patch
Normal file
27
exempi-e23c213-typeinfos.patch
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
From d45c06270576493e1537080fa43c1af667c4337a Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Nikola=20Forr=C3=B3?= <nforro@redhat.com>
|
||||||
|
Date: Tue, 12 Oct 2021 14:15:17 +0200
|
||||||
|
Subject: [PATCH] Avoid multiple definitions of typeinfos
|
||||||
|
|
||||||
|
---
|
||||||
|
XMPFiles/source/XMPFiles_Impl.cpp | 4 +++-
|
||||||
|
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/XMPFiles/source/XMPFiles_Impl.cpp b/XMPFiles/source/XMPFiles_Impl.cpp
|
||||||
|
index 2f918ac..ff45040 100644
|
||||||
|
--- a/XMPFiles/source/XMPFiles_Impl.cpp
|
||||||
|
+++ b/XMPFiles/source/XMPFiles_Impl.cpp
|
||||||
|
@@ -47,7 +47,9 @@ using namespace std;
|
||||||
|
/// This file ...
|
||||||
|
///
|
||||||
|
// =================================================================================================
|
||||||
|
-#include "public/include/XMP.incl_cpp"
|
||||||
|
+#if ! XMP_StaticBuild
|
||||||
|
+ #include "public/include/XMP.incl_cpp"
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
#if XMP_WinBuild
|
||||||
|
#pragma warning ( disable : 4290 ) // C++ exception specification ignored except to indicate a function is not __declspec(nothrow)
|
||||||
|
--
|
||||||
|
2.33.0
|
||||||
|
|
25
exempi.spec
25
exempi.spec
@ -1,10 +1,15 @@
|
|||||||
|
%global commit e23c21380f467f1f1c9dc397e0a08405fb4afa7a
|
||||||
|
%global shortcommit %%(c=%{commit}; echo ${c:0:7})
|
||||||
|
%global date 20211007
|
||||||
|
|
||||||
Summary: Library for easy parsing of XMP metadata
|
Summary: Library for easy parsing of XMP metadata
|
||||||
Name: exempi
|
Name: exempi
|
||||||
Version: 2.5.1
|
Version: 2.6.0
|
||||||
Release: 8%{?dist}
|
Release: 0.1.%{date}git%{shortcommit}%{?dist}
|
||||||
License: BSD
|
License: BSD
|
||||||
URL: http://libopenraw.freedesktop.org/wiki/Exempi
|
URL: http://libopenraw.freedesktop.org/wiki/Exempi
|
||||||
Source0: http://libopenraw.freedesktop.org/download/%{name}-%{version}.tar.bz2
|
Source0: https://gitlab.freedesktop.org/libopenraw/%{name}/-/archive/%{commit}/%{name}-%{commit}.tar.bz2
|
||||||
|
Patch0: exempi-e23c213-typeinfos.patch
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
BuildRequires: boost-devel expat-devel zlib-devel pkgconfig
|
BuildRequires: boost-devel expat-devel zlib-devel pkgconfig
|
||||||
# Work around for aarch64 support (https://bugzilla.redhat.com/show_bug.cgi?id=925327)
|
# Work around for aarch64 support (https://bugzilla.redhat.com/show_bug.cgi?id=925327)
|
||||||
@ -27,13 +32,13 @@ This package contains the libraries and header files needed for
|
|||||||
developing with exempi.
|
developing with exempi.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%autosetup -p1 -n %{name}-%{commit}
|
||||||
|
|
||||||
%build
|
%build
|
||||||
libtoolize -vi
|
libtoolize -vi
|
||||||
NOCONFIGURE=1 ./autogen.sh
|
NOCONFIGURE=1 ./autogen.sh
|
||||||
# BanEntityUsage needed for #888765
|
# BanEntityUsage needed for #888765
|
||||||
%configure CPPFLAGS="-I%{_includedir} -fno-strict-aliasing -DBanAllEntityUsage=1 -std=c++14"
|
%configure CPPFLAGS="-I%{_includedir} -fno-strict-aliasing -DBanAllEntityUsage=1"
|
||||||
|
|
||||||
# Disable rpath
|
# Disable rpath
|
||||||
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
|
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
|
||||||
@ -42,7 +47,13 @@ sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
|||||||
%make_build
|
%make_build
|
||||||
|
|
||||||
%check
|
%check
|
||||||
|
%ifarch s390x
|
||||||
|
# testcore test fails on big endian arches since exempi 2.5.2:
|
||||||
|
# https://gitlab.freedesktop.org/libopenraw/exempi/-/issues/23
|
||||||
|
make check || [ "$(grep '^FAIL:' exempi/test-suite.log)" = "FAIL: tests/testcore" ]
|
||||||
|
%else
|
||||||
make check
|
make check
|
||||||
|
%endif
|
||||||
|
|
||||||
%install
|
%install
|
||||||
%make_install
|
%make_install
|
||||||
@ -62,6 +73,10 @@ rm -rf %{buildroot}%{_libdir}/*.a
|
|||||||
%{_libdir}/pkgconfig/*.pc
|
%{_libdir}/pkgconfig/*.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Oct 20 2021 Nikola Forró <nforro@redhat.com> - 2.6.0-0.1.20211007gite23c213
|
||||||
|
- Update to (unreleased) version 2.6.0 to resolve licensing issues
|
||||||
|
Resolves #1989405
|
||||||
|
|
||||||
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 2.5.1-8
|
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 2.5.1-8
|
||||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||||
Related: rhbz#1991688
|
Related: rhbz#1991688
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (exempi-2.5.1.tar.bz2) = 97f2a688e1f92e219d0b68b077608112373cf3e6cbfe4141bbb9c3d1f416926bfd568957c1d0a081b95b524cbd500da0b7bca0ce45e1e8611818f66bcb1b6518
|
SHA512 (exempi-e23c21380f467f1f1c9dc397e0a08405fb4afa7a.tar.bz2) = ad7142712c99bec02e1f119293e095b68db99d303f5c21d47b8658cf43b84f2aa48b78dd49565eb80dc1888e8c1bcfb376686ef690f2a052c415180fa1af13d4
|
||||||
|
Loading…
Reference in New Issue
Block a user