import execstack-0.5.0-15.el8

This commit is contained in:
CentOS Sources 2021-07-27 16:29:12 +00:00 committed by Andrew Lukoshko
commit 7ffcce8d53
5 changed files with 213 additions and 0 deletions

1
.execstack.metadata Normal file
View File

@ -0,0 +1 @@
2d9c4f3c410e4820587cf22d22091fb38f6bc43f SOURCES/prelink-4c79120.tar.gz

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
SOURCES/prelink-4c79120.tar.gz

View File

@ -0,0 +1,118 @@
From a33b23b9ec5c0733a0ff85dafc46b3df2a6d2249 Mon Sep 17 00:00:00 2001
From: Mark Salter <msalter@redhat.com>
Date: Fri, 21 Aug 2015 12:03:30 -0400
Subject: [PATCH] Add PL_ARCH for AArch64
Add a skeleton PL_ARCH for AArch64. Just enough to support
execstack.
Signed-off-by: Mark Salter <msalter@redhat.com>
---
src/Makefile.am | 3 ++-
src/Makefile.in | 9 ++++++---
src/arch-aarch64.c | 38 ++++++++++++++++++++++++++++++++++++++
3 files changed, 46 insertions(+), 4 deletions(-)
create mode 100644 src/arch-aarch64.c
diff --git a/src/Makefile.am b/src/Makefile.am
index d2265aa9c0..a4c65f2e65 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -12,7 +12,8 @@ bin_PROGRAMS = execstack
arch_SOURCES = arch-i386.c arch-alpha.c arch-ppc.c arch-ppc64.c \
arch-sparc.c arch-sparc64.c arch-x86_64.c arch-mips.c \
- arch-s390.c arch-s390x.c arch-arm.c arch-sh.c arch-ia64.c
+ arch-s390.c arch-s390x.c arch-arm.c arch-sh.c arch-ia64.c \
+ arch-aarch64.c
common_SOURCES = checksum.c data.c dso.c dwarf2.c dwarf2.h fptr.c fptr.h \
hashtab.c hashtab.h mdebug.c prelink.h stabs.c crc32.c
prelink_SOURCES = cache.c conflict.c cxx.c doit.c exec.c execle_open.c get.c \
diff --git a/src/Makefile.in b/src/Makefile.in
index 85cf84577f..863dc835a0 100644
--- a/src/Makefile.in
+++ b/src/Makefile.in
@@ -107,7 +107,8 @@ bin_PROGRAMS = execstack
arch_SOURCES = arch-i386.c arch-alpha.c arch-ppc.c arch-ppc64.c \
arch-sparc.c arch-sparc64.c arch-x86_64.c arch-mips.c \
- arch-s390.c arch-s390x.c arch-arm.c arch-sh.c arch-ia64.c
+ arch-s390.c arch-s390x.c arch-arm.c arch-sh.c arch-ia64.c \
+ arch-aarch64.c
common_SOURCES = checksum.c data.c dso.c dwarf2.c dwarf2.h fptr.c fptr.h \
hashtab.c hashtab.h mdebug.c prelink.h stabs.c crc32.c
@@ -139,7 +140,8 @@ am__objects_2 = arch-i386.$(OBJEXT) arch-alpha.$(OBJEXT) \
arch-ppc.$(OBJEXT) arch-ppc64.$(OBJEXT) arch-sparc.$(OBJEXT) \
arch-sparc64.$(OBJEXT) arch-x86_64.$(OBJEXT) \
arch-mips.$(OBJEXT) arch-s390.$(OBJEXT) arch-s390x.$(OBJEXT) \
- arch-arm.$(OBJEXT) arch-sh.$(OBJEXT) arch-ia64.$(OBJEXT)
+ arch-arm.$(OBJEXT) arch-sh.$(OBJEXT) arch-ia64.$(OBJEXT) \
+ arch-aarch64.$(OBJEXT)
am_execstack_OBJECTS = execstack.$(OBJEXT) $(am__objects_1) \
$(am__objects_2)
execstack_OBJECTS = $(am_execstack_OBJECTS)
@@ -162,7 +164,7 @@ LIBS = @LIBS@
depcomp = $(SHELL) $(top_srcdir)/depcomp
am__depfiles_maybe = depfiles
@AMDEP_TRUE@DEP_FILES = ./$(DEPDIR)/arch-alpha.Po \
-@AMDEP_TRUE@ ./$(DEPDIR)/arch-arm.Po ./$(DEPDIR)/arch-i386.Po \
+@AMDEP_TRUE@ ./$(DEPDIR)/arch-arm.Po ./$(DEPDIR)/arch-aarch64.Po ./$(DEPDIR)/arch-i386.Po \
@AMDEP_TRUE@ ./$(DEPDIR)/arch-ia64.Po ./$(DEPDIR)/arch-mips.Po \
@AMDEP_TRUE@ ./$(DEPDIR)/arch-ppc.Po ./$(DEPDIR)/arch-ppc64.Po \
@AMDEP_TRUE@ ./$(DEPDIR)/arch-s390.Po ./$(DEPDIR)/arch-s390x.Po \
@@ -277,6 +279,7 @@ distclean-compile:
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/arch-alpha.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/arch-arm.Po@am__quote@
+@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/arch-arch64.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/arch-i386.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/arch-ia64.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/arch-mips.Po@am__quote@
diff --git a/src/arch-aarch64.c b/src/arch-aarch64.c
new file mode 100644
index 0000000000..42eb2ececb
--- /dev/null
+++ b/src/arch-aarch64.c
@@ -0,0 +1,38 @@
+/* Copyright (C) 2015 Red Hat, Inc.
+ Written by Mark Salter <msalter@redhat.com>, 2015.
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2, or (at your option)
+ any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software Foundation,
+ Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. */
+
+#include <config.h>
+#include <assert.h>
+#include <errno.h>
+#include <fcntl.h>
+#include <stdio.h>
+#include <string.h>
+#include <locale.h>
+#include <error.h>
+#include <argp.h>
+#include <stdlib.h>
+
+#include "prelink.h"
+
+PL_ARCH = {
+ .name = "AArch64",
+ .class = ELFCLASS64,
+ .machine = EM_AARCH64,
+ .alternate_machine = { EM_NONE },
+ .max_page_size = 0x10000,
+ .page_size = 0x1000
+};
--
2.1.0

12
SOURCES/coverity.patch Normal file
View File

@ -0,0 +1,12 @@
diff --git a/src/fptr.c b/src/fptr.c
index cfe3aed..5d68c11 100644
--- a/src/fptr.c
+++ b/src/fptr.c
@@ -458,6 +458,7 @@ opd_size (struct prelink_info *info, GElf_Word entsize)
e->val = f->val;
e->gp = f->gp;
e->opd = ret | OPD_ENT_NEW;
+ f->ent = e;
ret += entsize;
}

81
SPECS/execstack.spec Normal file
View File

@ -0,0 +1,81 @@
Name: execstack
Version: 0.5.0
Release: 15%{?dist}
Summary: Utility to set/clear/query executable stack bit
%global commit 4c79120bcdbde0616f592458ccde7035e92ca3d8
%global shortcommit %(c=%{commit}; echo ${c:0:7})
License: GPLv2+
# work around for missing upstream tarball with latest checkin
Source0: https://github.com/keszybz/prelink/archive/%{commit}.tar.gz#/prelink-%{shortcommit}.tar.gz
Patch0: Add-PL_ARCH-for-AArch64.patch
Patch1: coverity.patch
BuildRequires: elfutils-libelf-devel
BuildRequires: libselinux-devel, libselinux-utils
BuildRequires: git
Requires: glibc >= 2.2.4-18, coreutils, findutils
Requires: util-linux, gawk, grep
Obsoletes: prelink < 0.5.0-8
%description
This package is built from prelink sources but contains just the
execstack binary. It can be used manipulate ELF binaries to run
with or without executable stack.
%prep
%autosetup -n prelink-%{commit} -p1 -Sgit
%build
sed -i -e '/^prelink_LDADD/s/$/ -lpthread/' src/Makefile.{am,in}
%configure
make %{?_smp_mflags} -C gelf
make %{?_smp_mflags} -C gelfx
make %{?_smp_mflags} -C gelfx32
make %{?_smp_mflags} -C src execstack
%check
cp src/execstack test
src/execstack -q test | grep '^-'
src/execstack -s test
src/execstack -q test | grep '^X'
src/execstack -c test
src/execstack -q test | grep '^-'
%install
install -D src/execstack %{buildroot}%{_bindir}/execstack
install -Dm0644 doc/execstack.8 %{buildroot}%{_mandir}/man8/execstack.8
%files
%license COPYING
%doc ChangeLog NEWS README TODO THANKS
%{_bindir}/execstack
%{_mandir}/man8/execstack.8.*
%changelog
* Thu Oct 18 2018 Nikola Forró <nforro@redhat.com> - 0.5.0-15
- Fix important Covscan defects (#1602488)
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.0-14
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.0-13
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.0-12
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.0-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.0-10
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Fri Aug 21 2015 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 0.5.0-9
- Add support for aarch64 (#1251165)
* Mon Jul 27 2015 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 0.5.0-8
- Kill off most of prelink package