- Update to 2.23.6
This commit is contained in:
parent
bd71c4e087
commit
fadf4915c5
@ -11,7 +11,7 @@ diff -up evolution-2.23.4/configure.experimental-plugins evolution-2.23.4/config
|
||||
plugins_standard="$plugins_standard_always"
|
||||
all_plugins_standard="$plugins_standard"
|
||||
|
||||
plugins_experimental_always="folder-unsubscribe mail-to-meeting save-attachments external-editor"
|
||||
plugins_experimental_always="folder-unsubscribe mail-to-meeting save-attachments external-editor hula-account-setup"
|
||||
-plugins_experimental="$plugins_experimental_always $IPOD_SYNC $TNEF_ATTACHMENTS $PYTHON_PLUGIN"
|
||||
+plugins_experimental="$plugins_experimental_always $IPOD_SYNC $TNEF_ATTACHMENTS $PYTHON_PLUGIN email-custom-header"
|
||||
all_plugins_experimental="$plugins_experimental_always ipod-sync tnef-attachments"
|
||||
@ -30,7 +30,7 @@ diff -up evolution-2.23.4/configure.in.experimental-plugins evolution-2.23.4/con
|
||||
plugins_standard="$plugins_standard_always"
|
||||
all_plugins_standard="$plugins_standard"
|
||||
|
||||
plugins_experimental_always="folder-unsubscribe mail-to-meeting save-attachments external-editor"
|
||||
plugins_experimental_always="folder-unsubscribe mail-to-meeting save-attachments external-editor hula-account-setup"
|
||||
-plugins_experimental="$plugins_experimental_always $IPOD_SYNC $TNEF_ATTACHMENTS $PYTHON_PLUGIN"
|
||||
+plugins_experimental="$plugins_experimental_always $IPOD_SYNC $TNEF_ATTACHMENTS $PYTHON_PLUGIN email-custom-header"
|
||||
all_plugins_experimental="$plugins_experimental_always ipod-sync tnef-attachments"
|
||||
|
84
evolution-2.23.6-deprecated-gnuc-pretty-function.patch
Normal file
84
evolution-2.23.6-deprecated-gnuc-pretty-function.patch
Normal file
@ -0,0 +1,84 @@
|
||||
diff -U0 evolution-2.23.6/mail/ChangeLog.deprecated-gnuc-pretty-function evolution-2.23.6/mail/ChangeLog
|
||||
diff -up evolution-2.23.6/mail/em-migrate.c.deprecated-gnuc-pretty-function evolution-2.23.6/mail/em-migrate.c
|
||||
--- evolution-2.23.6/mail/em-migrate.c.deprecated-gnuc-pretty-function 2008-08-01 02:37:53.000000000 -0400
|
||||
+++ evolution-2.23.6/mail/em-migrate.c 2008-08-04 14:53:29.000000000 -0400
|
||||
@@ -2934,7 +2934,7 @@ migrate_to_db()
|
||||
migrate_folders(store, info, account->name, &ex);
|
||||
|
||||
} else
|
||||
- printf("%s(%d):%s: failed to get folder infos \n", __FILE__, __LINE__, G_GNUC_PRETTY_FUNCTION);
|
||||
+ printf("%s:%s: failed to get folder infos \n", G_STRLOC, G_STRFUNC);
|
||||
camel_exception_clear(&ex);
|
||||
|
||||
}
|
||||
diff -up evolution-2.23.6/mail/em-network-prefs.c.deprecated-gnuc-pretty-function evolution-2.23.6/mail/em-network-prefs.c
|
||||
--- evolution-2.23.6/mail/em-network-prefs.c.deprecated-gnuc-pretty-function 2008-08-01 02:37:52.000000000 -0400
|
||||
+++ evolution-2.23.6/mail/em-network-prefs.c 2008-08-04 14:53:29.000000000 -0400
|
||||
@@ -323,8 +323,7 @@ notify_proxy_type_changed (GtkWidget *wi
|
||||
emnp_set_sensitiveness (prefs, NETWORK_PROXY_MANUAL, FALSE);
|
||||
emnp_set_sensitiveness (prefs, NETWORK_PROXY_AUTOCONFIG, FALSE);
|
||||
if (type == NETWORK_PROXY_SYS_SETTINGS) {
|
||||
- d(g_print ("%s:%s:%d: Loading sys settings... \n",
|
||||
- __FILE__,G_GNUC_PRETTY_FUNCTION, __LINE__));
|
||||
+ d(g_print ("%s:%s: Loading sys settings... \n", G_STRLOC, G_STRFUNC));
|
||||
emnp_load_sys_settings (prefs->gconf);
|
||||
}
|
||||
|
||||
@@ -357,11 +356,11 @@ widget_entry_changed_cb (GtkWidget *widg
|
||||
if (GTK_IS_SPIN_BUTTON (widget)) {
|
||||
port = gtk_spin_button_get_value_as_int (GTK_SPIN_BUTTON (widget));
|
||||
gconf_client_set_int (gconf, (const char *)data, port, NULL);
|
||||
- d(g_print ("%s:%s:%d: %s is SpinButton: value = [%d]\n", __FILE__,G_GNUC_PRETTY_FUNCTION, __LINE__, (const char *)data, port));
|
||||
+ d(g_print ("%s:%s: %s is SpinButton: value = [%d]\n", G_STRLOC, G_STRFUNC, (const char *)data, port));
|
||||
} else if (GTK_IS_ENTRY (widget)) {
|
||||
value = gtk_entry_get_text (GTK_ENTRY (widget));
|
||||
gconf_client_set_string (gconf, (const char *)data, value, NULL);
|
||||
- d(g_print ("%s:%s:%d: %s is Entry: value = [%s]\n", __FILE__,G_GNUC_PRETTY_FUNCTION, __LINE__, (const char *)data, value));
|
||||
+ d(g_print ("%s:%s: %s is Entry: value = [%s]\n", G_STRLOC, G_STRFUNC, (const char *)data, value));
|
||||
}
|
||||
|
||||
}
|
||||
diff -up evolution-2.23.6/mail/em-subscribe-editor.c.deprecated-gnuc-pretty-function evolution-2.23.6/mail/em-subscribe-editor.c
|
||||
--- evolution-2.23.6/mail/em-subscribe-editor.c.deprecated-gnuc-pretty-function 2008-07-18 02:19:05.000000000 -0400
|
||||
+++ evolution-2.23.6/mail/em-subscribe-editor.c 2008-08-04 14:53:29.000000000 -0400
|
||||
@@ -312,8 +312,8 @@ sub_fill_level(EMSubscribe *sub, CamelFo
|
||||
e_dlist_addtail(&sub->pending, (EDListNode *)node);
|
||||
}
|
||||
} else {
|
||||
- d(printf("%s:%d:%s: fi->flags & CAMEL_FOLDER_NOINFERIORS=%d\t node->path=[%p]\n",
|
||||
- __FILE__, __LINE__, __GNUC_PRETTY_FUNCTION__, fi->flags & CAMEL_FOLDER_NOINFERIORS,
|
||||
+ d(printf("%s:%s: fi->flags & CAMEL_FOLDER_NOINFERIORS=%d\t node->path=[%p]\n",
|
||||
+ G_STRLOC, G_STRFUNC, fi->flags & CAMEL_FOLDER_NOINFERIORS,
|
||||
node->path));
|
||||
}
|
||||
|
||||
@@ -408,7 +408,7 @@ sub_queue_fill_level(EMSubscribe *sub, E
|
||||
struct _emse_folderinfo_msg *m;
|
||||
int id;
|
||||
|
||||
- d(printf("%s:%d:%s: Starting get folderinfo of '%s'\n", __FILE__, __LINE__, __GNUC_PRETTY_FUNCTION__,
|
||||
+ d(printf("%s:%s: Starting get folderinfo of '%s'\n", G_STRLOC, G_STRFUNC,
|
||||
node?node->info->full_name:"<root>"));
|
||||
|
||||
m = mail_msg_new (&sub_folderinfo_info);
|
||||
@@ -501,7 +501,7 @@ sub_row_expanded(GtkTreeView *tree, GtkT
|
||||
char *row_name;
|
||||
|
||||
gtk_tree_model_get(model, iter, 1, &row_name, -1);
|
||||
- d(printf("%s:%d:%s: row-expanded '%s'\n", __FILE__, __LINE__, __GNUC_PRETTY_FUNCTION__,
|
||||
+ d(printf("%s:%s: row-expanded '%s'\n", G_STRLOC, G_STRFUNC,
|
||||
row_name?row_name:"<root>"));
|
||||
|
||||
/* Do we really need to fetch the children for this row? */
|
||||
diff -up evolution-2.23.6/mail/mail-vfolder.c.deprecated-gnuc-pretty-function evolution-2.23.6/mail/mail-vfolder.c
|
||||
--- evolution-2.23.6/mail/mail-vfolder.c.deprecated-gnuc-pretty-function 2008-07-18 02:19:05.000000000 -0400
|
||||
+++ evolution-2.23.6/mail/mail-vfolder.c 2008-08-04 14:53:29.000000000 -0400
|
||||
@@ -50,7 +50,7 @@
|
||||
#include "mail-tools.h"
|
||||
#include "mail-vfolder.h"
|
||||
|
||||
-#define d(x) /* (printf("%s(%d):%s: ", __FILE__, __LINE__, __PRETTY_FUNCTION__), (x))*/
|
||||
+#define d(x) /* (printf("%s:%s: ", G_STRLOC, G_STRFUNC), (x))*/
|
||||
|
||||
static EMVFolderContext *context; /* context remains open all time */
|
||||
CamelStore *vfolder_store; /* the 1 static vfolder store */
|
@ -80,6 +80,9 @@ Patch14: evolution-2.9.1-im-context-reset.patch
|
||||
# Don't ship broken plugins as stable
|
||||
Patch15: evolution-2.23.4-experimental-plugins.patch
|
||||
|
||||
# The usual regressions...
|
||||
Patch16: evolution-2.23.6-deprecated-gnuc-pretty-function.patch
|
||||
|
||||
## Dependencies ###
|
||||
|
||||
Requires(post): GConf2
|
||||
@ -224,6 +227,7 @@ This package contains the plugin to filter junk mail using SpamAssassin.
|
||||
%patch13 -p1 -b .no-gnome-common
|
||||
%patch14 -p1 -b .im-context-reset
|
||||
%patch15 -p1 -b .experimental-plugins
|
||||
%patch16 -p1 -b .deprecated-gnuc-pretty-function
|
||||
|
||||
mkdir -p krb5-fakeprefix/include
|
||||
mkdir -p krb5-fakeprefix/lib
|
||||
@ -492,6 +496,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{evo_plugin_dir}/org-gnome-backup-restore.xml
|
||||
%{evo_plugin_dir}/liborg-gnome-backup-restore.so
|
||||
|
||||
%{evo_plugin_dir}/org-gnome-evolution-caldav.eplug
|
||||
%{evo_plugin_dir}/liborg-gnome-evolution-caldav.so
|
||||
|
||||
%{evo_plugin_dir}/org-gnome-calendar-file.eplug
|
||||
%{evo_plugin_dir}/liborg-gnome-calendar-file.so
|
||||
|
||||
@ -540,6 +547,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{evo_plugin_dir}/org-gnome-imap-features.eplug
|
||||
%{evo_plugin_dir}/liborg-gnome-imap-features.so
|
||||
|
||||
%{evo_plugin_dir}/org-gnome-evolution-mail-attachments-import-ics.eplug
|
||||
%{evo_plugin_dir}/liborg-gnome-evolution-mail-attachments-import-ics.so
|
||||
|
||||
%{evo_plugin_dir}/org-gnome-itip-formatter.eplug
|
||||
%{evo_plugin_dir}/liborg-gnome-itip-formatter.so
|
||||
|
||||
@ -567,6 +577,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{evo_plugin_dir}/org-gnome-prefer-plain.eplug
|
||||
%{evo_plugin_dir}/liborg-gnome-prefer-plain.so
|
||||
|
||||
%{evo_plugin_dir}/org-gnome-publish-calendar.eplug
|
||||
%{evo_plugin_dir}/liborg-gnome-publish-calendar.so
|
||||
%{evo_plugin_dir}/org-gnome-publish-calendar.xml
|
||||
|
||||
%{evo_plugin_dir}/org-gnome-save-calendar.eplug
|
||||
%{evo_plugin_dir}/liborg-gnome-save-calendar.so
|
||||
|
||||
@ -580,18 +594,8 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{evo_plugin_dir}/org-gnome-templates.eplug
|
||||
%{evo_plugin_dir}/liborg-gnome-templates.so
|
||||
|
||||
%{evo_plugin_dir}/org-gnome-evolution-hula-account-setup.eplug
|
||||
%{evo_plugin_dir}/liborg-gnome-evolution-hula-account-setup.so
|
||||
|
||||
%{evo_plugin_dir}/org-gnome-publish-calendar.eplug
|
||||
%{evo_plugin_dir}/liborg-gnome-publish-calendar.so
|
||||
%{evo_plugin_dir}/org-gnome-publish-calendar.xml
|
||||
|
||||
%{evo_plugin_dir}/org-gnome-evolution-caldav.eplug
|
||||
%{evo_plugin_dir}/liborg-gnome-evolution-caldav.so
|
||||
|
||||
%{evo_plugin_dir}/org-gnome-evolution-mail-attachments-import-ics.eplug
|
||||
%{evo_plugin_dir}/liborg-gnome-evolution-mail-attachments-import-ics.so
|
||||
%{evo_plugin_dir}/org-gnome-evolution-webdav.eplug
|
||||
%{evo_plugin_dir}/liborg-gnome-evolution-webdav.so
|
||||
|
||||
%files devel
|
||||
%defattr(-, root, root)
|
||||
|
Loading…
Reference in New Issue
Block a user