- Update to 2.25.3.1

- New BR: libgweather-devel
- Remove patch for GNOME bug #552583 (fixed upstream).
- Bump the gtkhtml and gtk2 minimum versions.
This commit is contained in:
Matthew Barnes 2008-12-15 17:50:24 +00:00
parent 42aa128ab8
commit fada318095
4 changed files with 92 additions and 9 deletions

View File

@ -1 +1 @@
evolution-2.25.2.tar.bz2
evolution-2.25.3.1.tar.bz2

View File

@ -0,0 +1,73 @@
diff -up evolution-2.25.3.1/configure.in.libgweather evolution-2.25.3.1/configure.in
--- evolution-2.25.3.1/configure.in.libgweather 2008-12-15 11:50:21.000000000 -0500
+++ evolution-2.25.3.1/configure.in 2008-12-15 11:50:57.000000000 -0500
@@ -43,7 +43,7 @@ m4_define([dbus_minimum_version], [1.0.0
m4_define([hal_minimum_version], [0.5.4])
m4_define([libnotify_minimum_version], [0.3.0])
m4_define([gnome_pilot_minimum_version], [2.0.15])
-m4_define([gweather_minimum_version], [2.25.3])
+m4_define([gweather_minimum_version], [2.25.2])
# GNOME Documentation
GNOME_DOC_INIT
diff -up evolution-2.25.3.1/configure.libgweather evolution-2.25.3.1/configure
--- evolution-2.25.3.1/configure.libgweather 2008-12-15 11:50:26.000000000 -0500
+++ evolution-2.25.3.1/configure 2008-12-15 11:52:43.000000000 -0500
@@ -32935,11 +32935,11 @@ if test -n "$LIBGWEATHER_CFLAGS"; then
elif test -n "$PKG_CONFIG"; then
if test -n "$PKG_CONFIG" && \
{ ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"gweather >= 2.25.3\"") >&5
- ($PKG_CONFIG --exists --print-errors "gweather >= 2.25.3") 2>&5
+ ($PKG_CONFIG --exists --print-errors "gweather >= 2.25.2") 2>&5
ac_status=$?
$as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
(exit $ac_status); }; then
- pkg_cv_LIBGWEATHER_CFLAGS=`$PKG_CONFIG --cflags "gweather >= 2.25.3" 2>/dev/null`
+ pkg_cv_LIBGWEATHER_CFLAGS=`$PKG_CONFIG --cflags "gweather >= 2.25.2" 2>/dev/null`
else
pkg_failed=yes
fi
@@ -32950,12 +32950,12 @@ if test -n "$LIBGWEATHER_LIBS"; then
pkg_cv_LIBGWEATHER_LIBS="$LIBGWEATHER_LIBS"
elif test -n "$PKG_CONFIG"; then
if test -n "$PKG_CONFIG" && \
- { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"gweather >= 2.25.3\"") >&5
- ($PKG_CONFIG --exists --print-errors "gweather >= 2.25.3") 2>&5
+ { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"gweather >= 2.25.2\"") >&5
+ ($PKG_CONFIG --exists --print-errors "gweather >= 2.25.2") 2>&5
ac_status=$?
$as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
(exit $ac_status); }; then
- pkg_cv_LIBGWEATHER_LIBS=`$PKG_CONFIG --libs "gweather >= 2.25.3" 2>/dev/null`
+ pkg_cv_LIBGWEATHER_LIBS=`$PKG_CONFIG --libs "gweather >= 2.25.2" 2>/dev/null`
else
pkg_failed=yes
fi
@@ -32973,21 +32973,21 @@ else
_pkg_short_errors_supported=no
fi
if test $_pkg_short_errors_supported = yes; then
- LIBGWEATHER_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "gweather >= 2.25.3" 2>&1`
+ LIBGWEATHER_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "gweather >= 2.25.2" 2>&1`
else
- LIBGWEATHER_PKG_ERRORS=`$PKG_CONFIG --print-errors "gweather >= 2.25.3" 2>&1`
+ LIBGWEATHER_PKG_ERRORS=`$PKG_CONFIG --print-errors "gweather >= 2.25.2" 2>&1`
fi
# Put the nasty error message in config.log where it belongs
echo "$LIBGWEATHER_PKG_ERRORS" >&5
{ $as_echo "$as_me:$LINENO: result: no" >&5
$as_echo "no" >&6; }
- { { $as_echo "$as_me:$LINENO: error: The weather calendar setup plugin requires GWeather >= 2.25.3. Alternatively, you may specify --without-weather as a configure option to avoid building the plugin." >&5
-$as_echo "$as_me: error: The weather calendar setup plugin requires GWeather >= 2.25.3. Alternatively, you may specify --without-weather as a configure option to avoid building the plugin." >&2;}
+ { { $as_echo "$as_me:$LINENO: error: The weather calendar setup plugin requires GWeather >= 2.25.2. Alternatively, you may specify --without-weather as a configure option to avoid building the plugin." >&5
+$as_echo "$as_me: error: The weather calendar setup plugin requires GWeather >= 2.25.2. Alternatively, you may specify --without-weather as a configure option to avoid building the plugin." >&2;}
{ (exit 1); exit 1; }; }
elif test $pkg_failed = untried; then
- { { $as_echo "$as_me:$LINENO: error: The weather calendar setup plugin requires GWeather >= 2.25.3. Alternatively, you may specify --without-weather as a configure option to avoid building the plugin." >&5
-$as_echo "$as_me: error: The weather calendar setup plugin requires GWeather >= 2.25.3. Alternatively, you may specify --without-weather as a configure option to avoid building the plugin." >&2;}
+ { { $as_echo "$as_me:$LINENO: error: The weather calendar setup plugin requires GWeather >= 2.25.2. Alternatively, you may specify --without-weather as a configure option to avoid building the plugin." >&5
+$as_echo "$as_me: error: The weather calendar setup plugin requires GWeather >= 2.25.2. Alternatively, you may specify --without-weather as a configure option to avoid building the plugin." >&2;}
{ (exit 1); exit 1; }; }
else
LIBGWEATHER_CFLAGS=$pkg_cv_LIBGWEATHER_CFLAGS

View File

@ -5,12 +5,13 @@
%define gnome_doc_utils_version 0.8.0
%define gnome_icon_theme_version 2.19.91
%define gnome_pilot_version 2.0.15
%define gtk2_version 2.12.0
%define gtkhtml_version 3.23.5
%define gtk2_version 2.14.0
%define gtkhtml_version 3.25.3
%define intltool_version 0.35.5
%define last_libgal2_version 2:2.5.3-2
%define libbonobo_version 2.20.3
%define libbonoboui_version 2.4.2
%define libgweather_version 2.25.2
%define orbit2_version 2.9.8
%define pilot_link_version 2:0.12.1
%define scrollkeeper_version 0.1.4
@ -44,8 +45,8 @@
### Abstract ###
Name: evolution
Version: 2.25.2
Release: 2%{?dist}
Version: 2.25.3.1
Release: 1%{?dist}
License: GPLv2 and GFDL
Group: Applications/Productivity
Summary: Mail and calendar client for GNOME
@ -77,8 +78,9 @@ Patch13: evolution-2.7.1-no-gnome-common.patch
# RH bug #176400
Patch14: evolution-2.9.1-im-context-reset.patch
# GNOME bug #552583
Patch15: evolution-2.25.2-broken-account-uris.patch
# Back off the bleeding edge libgweather requirement.
# We can get by with libgweather-2.25.2 for now.
Patch15: evolution-2.25.3.1-libgweather.patch
## Dependencies ###
@ -119,6 +121,7 @@ BuildRequires: libbonobo-devel >= %{libbonobo_version}
BuildRequires: libbonoboui-devel >= %{libbonoboui_version}
BuildRequires: libgnomecanvas-devel >= 2.0
BuildRequires: libgnomeui-devel >= 2.0
BuildRequires: libgweather-devel >= %{libgweather_version}
BuildRequires: libsoup-devel >= %{soup_version}
BuildRequires: libtool >= 1.5
BuildRequires: libxml2-devel
@ -173,6 +176,7 @@ Requires: evolution-data-server-devel >= %{eds_version}
Requires: gtk2-devel >= %{gtk2_version}
Requires: gtkhtml3-devel >= %{gtkhtml_version}
Requires: libbonobo-devel >= %{libbonobo_version}
Requires: libgweather-devel >= %{libgweather_version}
Requires: libsoup-devel >= %{soup_version}
Requires: libxml2-devel
Obsoletes: libgal2-devel <= %{last_libgal2_version}
@ -233,7 +237,7 @@ This package contains supplemental utilities for %{name} that require Perl.
%patch12 -p1 -b .fix-conduit-dir
%patch13 -p1 -b .no-gnome-common
%patch14 -p1 -b .im-context-reset
%patch15 -p1 -b .broken-account-uris
%patch15 -p1 -b .libgweather
mkdir -p krb5-fakeprefix/include
mkdir -p krb5-fakeprefix/lib
@ -700,6 +704,12 @@ rm -rf $RPM_BUILD_ROOT
%{_libexecdir}/evolution/%{evo_major}/evolution-addressbook-clean
%changelog
* Mon Dec 15 2008 Matthew Barnes <mbarnes@redhat.com> - 2.25.3.1-1.fc11
- Update to 2.25.3.1
- New BR: libgweather-devel
- Remove patch for GNOME bug #552583 (fixed upstream).
- Bump the gtkhtml and gtk2 minimum versions.
* Tue Dec 09 2008 Matthew Barnes <mbarnes@redhat.com> - 2.25.2-2.fc11
- Add patch for GNOME bug #552583 (fix account URI comparisons).

View File

@ -1 +1 @@
4f86cfd53102d673edc52643eb86c94c evolution-2.25.2.tar.bz2
2d74ba6cf6dfca0cbe208c82f5726de9 evolution-2.25.3.1.tar.bz2