This commit is contained in:
Matthew Barnes 2011-07-04 20:34:08 -04:00
parent 080ecd47c3
commit eb8425bdb9
4 changed files with 12 additions and 66 deletions

1
.gitignore vendored
View File

@ -16,3 +16,4 @@ evolution-2.31.5.tar.bz2
/evolution-3.0.0.tar.bz2
/evolution-3.1.1.tar.bz2
/evolution-3.1.2.tar.bz2
/evolution-3.1.3.tar.bz2

View File

@ -1,59 +0,0 @@
diff --git a/configure.ac b/configure.ac
index 1078197..903e50e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1283,10 +1283,14 @@ EVO_SET_COMPILE_FLAGS(LIBSOUP, libsoup-gnome-2.4 >= libsoup_minimum_version)
AC_SUBST(LIBSOUP_CFLAGS)
AC_SUBST(LIBSOUP_LIBS)
-EVO_SET_COMPILE_FLAGS(GDATA, libgdata >= 0.4.0)
+EVO_SET_COMPILE_FLAGS(GDATA, libgdata >= 0.7.0)
AC_SUBST(GDATA_CFLAGS)
AC_SUBST(GDATA_LIBS)
+if `$PKG_CONFIG --atleast-version=0.9 libgdata`; then
+ AC_DEFINE(HAVE_LIBGDATA_0_9,1,[libgdata is 0.9 or higher])
+fi
+
EVO_SET_COMPILE_FLAGS(EVOLUTION_CALENDAR, libgtkhtml-4.0 libebook-1.2 libecal-1.2 libedataserverui-3.0 libebackend-1.2 $libnotify gtkhtml-editor-4.0)
AC_SUBST(EVOLUTION_CALENDAR_CFLAGS)
AC_SUBST(EVOLUTION_CALENDAR_LIBS)
diff --git a/plugins/google-account-setup/google-source.c b/plugins/google-account-setup/google-source.c
index 1fce985..1e54362 100644
--- a/plugins/google-account-setup/google-source.c
+++ b/plugins/google-account-setup/google-source.c
@@ -418,6 +418,9 @@ static void
retrieve_list_clicked (GtkButton *button, GtkComboBox *combo)
{
ESource *source;
+ #ifdef HAVE_LIBGDATA_0_9
+ GDataClientLoginAuthorizer *authorizer;
+ #endif
GDataCalendarService *service;
GDataFeed *feed;
gchar *user, *password, *tmp;
@@ -448,8 +451,14 @@ retrieve_list_clicked (GtkButton *button, GtkComboBox *combo)
return;
}
+ #ifdef HAVE_LIBGDATA_0_9
+ authorizer = gdata_client_login_authorizer_new ("evolution-client-0.1.0", GDATA_TYPE_CALENDAR_SERVICE);
+ service = gdata_calendar_service_new (GDATA_AUTHORIZER (authorizer));
+ if (!gdata_client_login_authorizer_authenticate (authorizer, user, password, NULL, &error)) {
+ #else
service = gdata_calendar_service_new ("evolution-client-0.1.0");
if (!gdata_service_authenticate (GDATA_SERVICE (service), user, password, NULL, &error)) {
+ #endif
/* Error! */
claim_error (parent, error->message);
g_error_free (error);
@@ -559,6 +568,9 @@ retrieve_list_clicked (GtkButton *button, GtkComboBox *combo)
}
g_object_unref (service);
+ #ifdef HAVE_LIBGDATA_0_9
+ g_object_unref (authorizer);
+ #endif
g_free (user);
}

View File

@ -27,8 +27,8 @@
### Abstract ###
Name: evolution
Version: 3.1.2
Release: 2%{?dist}
Version: 3.1.3
Release: 1%{?dist}
Group: Applications/Productivity
Summary: Mail and calendar client for GNOME
License: GPLv2+ and GFDL
@ -47,8 +47,7 @@ Patch10: evolution-1.4.4-ldap-x86_64-hack.patch
# RH bug #589555
Patch13: evolution-2.30.1-help-contents.patch
Patch14: evolution-3.1.2-libgdata_0_9.patch
Patch15: evolution-3.1.2-g_const_return.patch
Patch14: evolution-3.1.2-g_const_return.patch
## Dependencies ###
@ -78,6 +77,7 @@ BuildRequires: glib2-devel >= %{glib2_version}
BuildRequires: gnome-common
BuildRequires: gnome-desktop3-devel >= %{gnome_desktop_version}
BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
BuildRequires: gnome-online-accounts
BuildRequires: gnutls-devel
BuildRequires: gtk-doc
BuildRequires: gtk3-devel >= %{gtk3_version}
@ -205,8 +205,7 @@ This package contains the plugin to import Microsoft Personal Storage Table
%setup -q -n evolution-%{version}
%patch10 -p1 -b .ldaphack
%patch13 -p1 -b .help-contents
%patch14 -p1 -b .libgdata_0_9
%patch15 -p1 -b .g_const_return
%patch14 -p1 -b .g_const_return
mkdir -p krb5-fakeprefix/include
mkdir -p krb5-fakeprefix/lib
@ -444,6 +443,7 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/evolution/%{evo_base_version}/modules/libevolution-module-mail.so
%{_libdir}/evolution/%{evo_base_version}/modules/libevolution-module-mailto-handler.so
%{_libdir}/evolution/%{evo_base_version}/modules/libevolution-module-offline-alert.so
%{_libdir}/evolution/%{evo_base_version}/modules/libevolution-module-online-accounts.so
%{_libdir}/evolution/%{evo_base_version}/modules/libevolution-module-plugin-lib.so
%{_libdir}/evolution/%{evo_base_version}/modules/libevolution-module-plugin-manager.so
%{_libdir}/evolution/%{evo_base_version}/modules/libevolution-module-startup-wizard.so
@ -637,6 +637,10 @@ rm -rf $RPM_BUILD_ROOT
%endif
%changelog
* Mon Jul 04 2011 Matthew Barnes <mbarnes@redhat.com> - 3.1.3-1
- Update to 3.1.3
- Remove patch for building against libgdata-0.9.0 (fixed upstream).
* Wed Jun 15 2011 Milan Crha <mcrha@redhat.com> - 3.1.2-2
- Rebuild against newer gnome-desktop3

View File

@ -1 +1 @@
88a2f03c2b89b6085edce87ea4220702 evolution-3.1.2.tar.bz2
50d890b7ed7d431f68a5756b9e1be14e evolution-3.1.3.tar.bz2