Rebuild against newer libxml2; Add patch for libnotify 0.7

This commit is contained in:
Milan Crha 2010-11-05 15:25:44 +01:00
parent fa242d827a
commit e18922eb77
2 changed files with 111 additions and 1 deletions

View File

@ -0,0 +1,103 @@
commit 8854c727c1c05bc22a7757ffa93bc9533286525f
Author: Flo Gravo <flo.gravo@gmail.com>
Date: Fri Oct 22 18:54:27 2010 -0400
Bug 632903 - Support libnotify-0.7
diff --git a/calendar/gui/alarm-notify/alarm-queue.c b/calendar/gui/alarm-notify/alarm-queue.c
index 7145a22..752ce37 100644
--- a/calendar/gui/alarm-notify/alarm-queue.c
+++ b/calendar/gui/alarm-notify/alarm-queue.c
@@ -1606,7 +1606,11 @@ popup_notification (time_t trigger, CompQueuedAlarms *cqa,
body = g_strdup_printf ("%s %s", start_str, time_str);
}
+#ifdef HAVE_LIBNOTIFY_07
+ n = notify_notification_new (summary, body, "stock_appointment-reminder");
+#else
n = notify_notification_new (summary, body, "stock_appointment-reminder", NULL);
+#endif /* HAVE_LIBNOTIFY_07 */
if (!notify_notification_show (n, NULL))
g_warning ("Could not send notification to daemon\n");
diff --git a/configure.ac b/configure.ac
index d7c2abe..133161e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1340,7 +1340,7 @@ LIBNOTIFY_CFLAGS=
LIBNOTIFY_LIBS=
PKG_CHECK_MODULES([LIBNOTIFY], [libnotify >= $libnotify_minimum_version], [HAVE_LIBNOTIFY="yes"], [HAVE_LIBNOTIFY="no"])
if test "x$HAVE_LIBNOTIFY" = "xyes"; then
- AC_DEFINE(HAVE_LIBNOTIFY, 1, [libnotify available])
+ AC_DEFINE(HAVE_LIBNOTIFY, 1, [Define if you have libnotify])
libnotify="libnotify"
else
libnotify=""
@@ -1348,6 +1348,10 @@ fi
AC_SUBST(LIBNOTIFY_CFLAGS)
AC_SUBST(LIBNOTIFY_LIBS)
+if $PKG_CONFIG --atleast-version=0.7 libnotify; then
+ AC_DEFINE(HAVE_LIBNOTIFY_07, 1, [Define if you have libnotify >= 0.7])
+fi
+
dnl **************
dnl Calendar Flags
dnl **************
diff --git a/plugins/mail-notification/mail-notification.c b/plugins/mail-notification/mail-notification.c
index f8fd766..961868a 100644
--- a/plugins/mail-notification/mail-notification.c
+++ b/plugins/mail-notification/mail-notification.c
@@ -562,11 +562,15 @@ new_notify_status (EMEventTargetFolder *t)
if (!notify_init ("evolution-mail-notification"))
fprintf (stderr,"notify init error");
+#ifdef HAVE_LIBNOTIFY_07
notify = notify_notification_new (
- _("New email"), safetext,
- "mail-unread", NULL);
+ _("New email"), safetext, "mail-unread");
+#else
+ notify = notify_notification_new (
+ _("New email"), safetext, "mail-unread", NULL);
notify_notification_attach_to_status_icon (
notify, status_icon);
+#endif /* HAVE_LIBNOTIFY_07 */
/* Check if actions are supported */
if (can_support_actions ()) {
diff --git a/plugins/publish-calendar/publish-calendar.c b/plugins/publish-calendar/publish-calendar.c
index d30a9b1..da93063 100644
--- a/plugins/publish-calendar/publish-calendar.c
+++ b/plugins/publish-calendar/publish-calendar.c
@@ -140,7 +140,7 @@ update_publish_notification (GtkMessageType msg_type, const gchar *msg_text)
gtk_status_icon_set_from_stock (status_icon, stock_name);
gtk_status_icon_set_tooltip_text (status_icon, actual_msg->str);
- #ifdef HAVE_LIBNOTIFY
+#ifdef HAVE_LIBNOTIFY
if (can_notify) {
if (notify) {
notify_notification_update (notify, _("Calendar Publishing"), actual_msg->str, stock_name);
@@ -150,8 +150,12 @@ update_publish_notification (GtkMessageType msg_type, const gchar *msg_text)
return;
}
+#ifdef HAVE_LIBNOTIFY_07
+ notify = notify_notification_new (_("Calendar Publishing"), actual_msg->str, stock_name);
+#else
notify = notify_notification_new (_("Calendar Publishing"), actual_msg->str, stock_name, NULL);
notify_notification_attach_to_status_icon (notify, status_icon);
+#endif /* HAVE_LIBNOTIFY_07 */
notify_notification_set_urgency (notify, NOTIFY_URGENCY_NORMAL);
notify_notification_set_timeout (notify, NOTIFY_EXPIRES_DEFAULT);
g_timeout_add (500, show_notify_cb, NULL);
@@ -159,7 +163,7 @@ update_publish_notification (GtkMessageType msg_type, const gchar *msg_text)
g_signal_connect (notify, "closed", G_CALLBACK (remove_notification), NULL);
}
}
- #endif
+#endif
status_icon_timeout_id = g_timeout_add_seconds (15, remove_notification, NULL);

View File

@ -29,7 +29,7 @@
Name: evolution
Version: 2.91.1
Release: 2%{?dist}
Release: 3%{?dist}
Group: Applications/Productivity
Summary: Mail and calendar client for GNOME
License: GPLv2+ and GFDL
@ -51,6 +51,8 @@ Patch12: evolution-2.9.1-im-context-reset.patch
# RH bug #589555
Patch13: evolution-2.30.1-help-contents.patch
Patch14: evolution-2.91.1-libnotify07.patch
## Dependencies ###
Requires(pre): GConf2
@ -204,6 +206,7 @@ This package contains the plugin to import Microsoft Personal Storage Table
%patch10 -p1 -b .ldaphack
%patch12 -p1 -b .im-context-reset
%patch13 -p1 -b .help-contents
%patch14 -p1 -b .libnotify07
mkdir -p krb5-fakeprefix/include
mkdir -p krb5-fakeprefix/lib
@ -606,6 +609,10 @@ rm -rf $RPM_BUILD_ROOT
%endif
%changelog
* Fri Nov 05 2010 Milan Crha <mcrha@redhat.com> - 2.91.1-3
- Rebuild against newer libxml2
- Add patch for libnotify 0.7
* Wed Nov 3 2010 Matthias Clasen <mclasen@redhat.com> - 2.91.1-2
- Rebuild against new libnotify