- Update to 2.27.2

- Patch broken libevolution-mail-shared library.
- Remove strict_build_settings since the settings are used upstream now.
This commit is contained in:
Matthew Barnes 2009-05-29 14:31:18 +00:00
parent 5f8d20c34c
commit e1407d0876
2 changed files with 55 additions and 1 deletions

View File

@ -0,0 +1,44 @@
diff -up evolution-2.27.2/mail/Makefile.am.fix-shared-mail evolution-2.27.2/mail/Makefile.am
--- evolution-2.27.2/mail/Makefile.am.fix-shared-mail 2009-05-24 13:35:00.000000000 -0400
+++ evolution-2.27.2/mail/Makefile.am 2009-05-29 10:23:51.000000000 -0400
@@ -31,9 +31,8 @@ INCLUDES = \
-DPREFIX=\""$(prefix)"\" \
-DG_LOG_DOMAIN=\"evolution-mail\"
-component_LTLIBRARIES = libevolution-mail-shared.la \
- libevolution-mail.la
-
+privsolib_LTLIBRARIES = libevolution-mail-shared.la
+component_LTLIBRARIES = libevolution-mail.la
# Mail.idl
MAIL_IDL = Evolution-Mail.idl
@@ -172,9 +171,9 @@ libevolution_mail_la_LIBADD = \
libevolution_mail_la_LDFLAGS = \
-avoid-version -module $(NO_UNDEFINED)
-libevolution_mail_la_DEPENDENCIES = em-filter-i18n.h
-
-# .server files
+libevolution_mail_la_DEPENDENCIES = \
+ em-filter-i18n.h \
+ libevolution-mail-shared.la
libevolution_mail_shared_la_SOURCES = \
em-account-editor.c \
@@ -252,10 +251,13 @@ libevolution_mail_shared_la_LIBADD =
$(SMIME_LIBS) \
$(THREADS_LIBS)
-libevolution_mail_shared_la_LDFLAGS = \
- -avoid-version -module $(NO_UNDEFINED)
+libevolution_mail_shared_la_LDFLAGS = $(NO_UNDEFINED)
+# This forces the shared library to be installed before
+# the component library, so libtool relinking will work.
+install-componentLTLIBRARIES: install-privsolibLTLIBRARIES
+# .server files
server_in_files = GNOME_Evolution_Mail.server.in.in
server_DATA = $(server_in_files:.server.in.in=.server)

View File

@ -65,6 +65,9 @@ Patch11: evolution-2.5.4-fix-conduit-dir.patch
# RH bug #176400
Patch12: evolution-2.9.1-im-context-reset.patch
# Fix broken libevolution-mail-shared.
Patch13: evolution-2.27.2-fix-shared-mail.patch
## Dependencies ###
Requires(post): GConf2
@ -222,6 +225,7 @@ This package contains supplemental utilities for %{name} that require Perl.
%patch10 -p1 -b .ldaphack
%patch11 -p1 -b .fix-conduit-dir
%patch12 -p1 -b .im-context-reset
%patch13 -p1 -b .fix-shared-mail
mkdir -p krb5-fakeprefix/include
mkdir -p krb5-fakeprefix/lib
@ -286,6 +290,9 @@ if pkg-config openssl ; then
fi
%endif
# Regenerate mail/Makefile.in (this is temporary).
automake
%configure \
--enable-gtk-doc \
--enable-ipv6 \
@ -462,6 +469,7 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/evolution/%{evo_major}/libevolution-calendar-a11y.so.*
%{_libdir}/evolution/%{evo_major}/libevolution-calendar-importers.so.*
%{_libdir}/evolution/%{evo_major}/libevolution-mail-importers.so.*
%{_libdir}/evolution/%{evo_major}/libevolution-mail-shared.so.*
%{_libdir}/evolution/%{evo_major}/libevolution-smime.so.*
%{_libdir}/evolution/%{evo_major}/libevolution-widgets-a11y.so.*
%{_libdir}/evolution/%{evo_major}/libfilter.so.*
@ -623,6 +631,7 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/evolution/%{evo_major}/libevolution-calendar-a11y.so
%{_libdir}/evolution/%{evo_major}/libevolution-calendar-importers.so
%{_libdir}/evolution/%{evo_major}/libevolution-mail-importers.so
%{_libdir}/evolution/%{evo_major}/libevolution-mail-shared.so
%{_libdir}/evolution/%{evo_major}/libevolution-smime.so
%{_libdir}/evolution/%{evo_major}/libevolution-widgets-a11y.so
%{_libdir}/evolution/%{evo_major}/libfilter.so
@ -666,8 +675,9 @@ rm -rf $RPM_BUILD_ROOT
%{_libexecdir}/evolution/%{evo_major}/evolution-addressbook-clean
%changelog
* Mon May 25 2009 Matthew Barnes <mbarnes@redhat.com> - 2.27.2-1.fc12
* Mon May 29 2009 Matthew Barnes <mbarnes@redhat.com> - 2.27.2-1.fc12
- Update to 2.27.2
- Patch broken libevolution-mail-shared library.
- Remove strict_build_settings since the settings are used upstream now.
* Mon May 04 2009 Matthew Barnes <mbarnes@redhat.com> - 2.27.1-1.fc12