diff --git a/evolution-2.7.1-notification-cleanups.patch b/evolution-2.7.1-notification-cleanups.patch
index adad881..1fb6841 100644
--- a/evolution-2.7.1-notification-cleanups.patch
+++ b/evolution-2.7.1-notification-cleanups.patch
@@ -1,5 +1,5 @@
---- evolution-2.7.1/calendar/gui/alarm-notify/alarm-queue.c.notification-cleanups 2006-04-22 00:39:20.000000000 -0400
-+++ evolution-2.7.1/calendar/gui/alarm-notify/alarm-queue.c 2006-05-12 14:52:43.000000000 -0400
+--- evolution-2.7.2.1/calendar/gui/alarm-notify/alarm-queue.c.notification-cleanups 2006-04-22 00:39:20.000000000 -0400
++++ evolution-2.7.2.1/calendar/gui/alarm-notify/alarm-queue.c 2006-05-23 16:04:23.000000000 -0400
@@ -1566,10 +1566,11 @@
const char *summary, *location;
GtkTooltips *tooltips;
@@ -23,7 +23,7 @@
if (organiser.cn) {
if (location)
body = g_strdup_printf ("%s\n%s %s\n%s %s", organiser.cn, _("Location:"), location, start_str, time_str);
-@@ -1617,16 +1615,19 @@
+@@ -1617,16 +1615,21 @@
body = g_strdup_printf ("%s %s", start_str, time_str);
}
@@ -32,12 +32,14 @@
+ n = notify_notification_new (summary, body, "stock_appointment-reminder", NULL);
+
+ /* Notifications don't timeout: require explicit user action: */
-+ notify_notification_set_timeout (n, NOTIFY_TIMEOUT_NEVER);
++ notify_notification_set_timeout (n, NOTIFY_EXPIRES_NEVER);
+
-+ if (!notify_notification_show_and_forget (n, NULL))
++ if (!notify_notification_show (n, NULL))
g_warning ("Could not send notification to daemon\n");
- /* create the private structure */
++ g_object_unref (n);
++
+ g_free (body);
g_free (start_str);
g_free (end_str);
diff --git a/evolution.spec b/evolution.spec
index a9d42d4..61b3827 100644
--- a/evolution.spec
+++ b/evolution.spec
@@ -129,7 +129,7 @@ Requires: libgnomeprint22 >= %{libgnomeprint22_version}
Requires: gnome-vfs2 >= %{gnomevfs2_version}
%if %{libnotify_support}
-Requires: libnotify
+Requires: libnotify >= 0.4
%endif
Obsoletes: libgal2 <= %{last_libgal2_version}
@@ -653,6 +653,10 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/evolution/%{evo_major}/libmenus.so
%changelog
+* Tue May 23 2006 Matthew Barnes 2.7.2.1-3
+- Port evolution-2.7.1-notification-cleanups.patch to new libnotify API.
+- Require libnotify >= 0.4.
+
* Fri May 19 2006 Matthew Barnes - 2.7.2.1-2
- Require specific versions of GNU Autotools packages for building.
- Add evolution-2.7.2-preedit-gnome.bz-264485.patch (Mayank Jain).