- Update to 2.12.1

- Add files for the new backup-restore plugin.
This commit is contained in:
Milan Crha 2007-10-15 18:26:48 +00:00
parent 97eab24f36
commit d8dd82c49f
5 changed files with 46 additions and 47 deletions

View File

@ -1 +1 @@
evolution-2.12.0.tar.bz2 evolution-2.12.1.tar.bz2

View File

@ -1,6 +1,20 @@
--- evolution-2.10.1/configure.no-gnome-common 2007-04-09 12:32:23.000000000 -0400 diff -up evolution-2.12.1/configure.in.no-gnome-common evolution-2.12.1/configure.in
+++ evolution-2.10.1/configure 2007-04-09 12:33:02.000000000 -0400 --- evolution-2.12.1/configure.in.no-gnome-common 2007-10-15 08:30:42.000000000 +0200
@@ -33161,154 +33161,6 @@ +++ evolution-2.12.1/configure.in 2007-10-15 17:54:01.000000000 +0200
@@ -1282,9 +1282,6 @@ AC_SUBST_FILE(EVO_MARSHAL_RULE)
dnl *************************
dnl CFLAGS and LIBS and stuff
dnl *************************
-
-GNOME_COMPILE_WARNINGS(yes)
-CFLAGS="$CFLAGS $WARN_CFLAGS"
case $CFLAGS in
*-Wall*)
# Turn off the annoying "comparison between signed and unsigned"
diff -up evolution-2.12.1/configure.no-gnome-common evolution-2.12.1/configure
--- evolution-2.12.1/configure.no-gnome-common 2007-10-15 17:54:01.000000000 +0200
+++ evolution-2.12.1/configure 2007-10-15 18:47:03.000000000 +0200
@@ -31564,137 +31564,6 @@ EVO_MARSHAL_RULE=$srcdir/marshal.mk
@ -66,27 +80,10 @@
- rm -f conftest.er1 - rm -f conftest.er1
- cat conftest.err >&5 - cat conftest.err >&5
- echo "$as_me:$LINENO: \$? = $ac_status" >&5 - echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); } && - (exit $ac_status); } && {
- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err' - test -z "$ac_c_werror_flag" ||
- { (case "(($ac_try" in - test ! -s conftest.err
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;; - } && test -s conftest.$ac_objext; then
- *) ac_try_echo=$ac_try;;
-esac
-eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
- (eval "$ac_try") 2>&5
- ac_status=$?
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; } &&
- { ac_try='test -s conftest.$ac_objext'
- { (case "(($ac_try" in
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
- *) ac_try_echo=$ac_try;;
-esac
-eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
- (eval "$ac_try") 2>&5
- ac_status=$?
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; }; then
- has_option=yes - has_option=yes
-else -else
- echo "$as_me: failed program was:" >&5 - echo "$as_me: failed program was:" >&5
@ -155,15 +152,3 @@
case $CFLAGS in case $CFLAGS in
*-Wall*) *-Wall*)
# Turn off the annoying "comparison between signed and unsigned" # Turn off the annoying "comparison between signed and unsigned"
--- evolution-2.10.1/configure.in.no-gnome-common 2007-04-09 09:11:47.000000000 -0400
+++ evolution-2.10.1/configure.in 2007-04-09 12:32:23.000000000 -0400
@@ -1136,9 +1136,6 @@
dnl *************************
dnl CFLAGS and LIBS and stuff
dnl *************************
-
-GNOME_COMPILE_WARNINGS(yes)
-CFLAGS="$CFLAGS $WARN_CFLAGS"
case $CFLAGS in
*-Wall*)
# Turn off the annoying "comparison between signed and unsigned"

View File

@ -927,7 +927,7 @@
} }
/** alarm_queue_remove_client /** alarm_queue_remove_client
@@ -2155,22 +2141,16 @@ @@ -2155,24 +2141,16 @@ alarm_queue_remove_async (EThread *e, Al
void void
alarm_queue_remove_client (ECal *client, gboolean immediately) alarm_queue_remove_client (ECal *client, gboolean immediately)
{ {
@ -942,16 +942,21 @@
- list = malloc (sizeof (struct _alarm_client_msg)); - list = malloc (sizeof (struct _alarm_client_msg));
- list->client = client; - list->client = client;
- msg->data = list; - msg->data = list;
-
- d(printf("%s:%d (alarm_queue_remove_client) - Posting a task\n",__FILE__, __LINE__));
- if (immediately) {
- alarm_queue_remove_async (NULL, msg, NULL);
- g_free (list);
- g_free (msg);
- } else
- e_thread_put(alarm_operation_thread, (EMsg *)msg);
+ msg = g_slice_new (struct _alarm_client_msg); + msg = g_slice_new (struct _alarm_client_msg);
+ msg->header.func = (MessageFunc) alarm_queue_remove_async; + msg->header.func = (MessageFunc) alarm_queue_remove_async;
+ msg->client = client; + msg->client = client;
+
- d(printf("%s:%d (alarm_queue_remove_client) - Posting a task\n",__FILE__, __LINE__)); + if (immediately)
if (immediately)
- alarm_queue_remove_async (NULL, msg, NULL);
+ alarm_queue_remove_async (msg); + alarm_queue_remove_async (msg);
else + else
- e_thread_put(alarm_operation_thread, (EMsg *)msg);
+ message_push ((Message *) msg); + message_push ((Message *) msg);
} }

View File

@ -45,8 +45,8 @@
### Abstract ### ### Abstract ###
Name: evolution Name: evolution
Version: 2.12.0 Version: 2.12.1
Release: 8%{?dist} Release: 1%{?dist}
License: GPLv2 and GFDL+ License: GPLv2 and GFDL+
Group: Applications/Productivity Group: Applications/Productivity
Summary: GNOME's next-generation groupware suite Summary: GNOME's next-generation groupware suite
@ -531,6 +531,7 @@ rm -rf $RPM_BUILD_ROOT
%{_libexecdir}/evolution/%{evo_major}/evolution-addressbook-export %{_libexecdir}/evolution/%{evo_major}/evolution-addressbook-export
%{_libexecdir}/evolution/%{evo_major}/evolution-alarm-notify %{_libexecdir}/evolution/%{evo_major}/evolution-alarm-notify
%{_libexecdir}/evolution/%{evo_major}/killev %{_libexecdir}/evolution/%{evo_major}/killev
%{_libexecdir}/evolution/%{evo_major}/evolution-backup
# Various conduits for gnome-pilot: # Various conduits for gnome-pilot:
%if %{pilot_support} %if %{pilot_support}
@ -681,6 +682,10 @@ rm -rf $RPM_BUILD_ROOT
%{evo_plugin_dir}/org-gnome-evolution-mail-attachments-import-ics.eplug %{evo_plugin_dir}/org-gnome-evolution-mail-attachments-import-ics.eplug
%{evo_plugin_dir}/liborg-gnome-evolution-mail-attachments-import-ics.so %{evo_plugin_dir}/liborg-gnome-evolution-mail-attachments-import-ics.so
%{evo_plugin_dir}/liborg-gnome-backup-restore.so
%{evo_plugin_dir}/org-gnome-backup-restore.eplug
%{evo_plugin_dir}/org-gnome-backup-restore.xml
%files devel %files devel
%defattr(-, root, root) %defattr(-, root, root)
%{_includedir}/evolution-%{evo_major} %{_includedir}/evolution-%{evo_major}
@ -713,6 +718,10 @@ rm -rf $RPM_BUILD_ROOT
%dir %{_datadir}/omf/evolution %dir %{_datadir}/omf/evolution
%changelog %changelog
* Mon Oct 15 2007 Milan Crha <mcrha@redhat.com> - 2.12.1-1.fc8
- Update to 2.12.1
- Add files for the new backup-restore plugin.
* Tue Oct 09 2007 Matthew Barnes <mbarnes@redhat.com. - 2.12.0-8.fc8 * Tue Oct 09 2007 Matthew Barnes <mbarnes@redhat.com. - 2.12.0-8.fc8
- Sync version requirements up with configure.in. - Sync version requirements up with configure.in.

View File

@ -1 +1 @@
aaa378a63477b56de214ea9eaa7f8560 evolution-2.12.0.tar.bz2 392623efa9b79ede17ce90512f2c3c0a evolution-2.12.1.tar.bz2